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(o) Legal noti
. 0 /Legal notice

Copyright and trademark information relating to this product release.
Copyright © 2000-2024 RWS Holdings plc. All rights reserved.

This legal notice applies to RWS Holdings plc and its subsidiaries and affiliates. All intellectual
property rights contained herein are the sole and exclusive rights of RWS. All references to
RWS shall mean RWS Holdings plc and its subsidiaries and affiliates details of which can be
obtained upon written request.

All rights reserved. Unless explicitly stated otherwise, all intellectual property rights including
those in copyright in the content of this website and documentation are owned by or
controlled for these purposes by RWS. Except as otherwise expressly permitted hereunder
or in accordance with copyright legislation, the content of this site, and/or the documentation
may not be copied, reproduced, republished, downloaded, posted, broadcast or transmitted
in any way without the express written permission of RWS.

Trados Studio is a registered trademark of RWS. All other trademarks are the property of
their respective owners. The names of other companies and products mentioned herein may
be the trademarks of their respective owners. Unless stated to the contrary, no association
with any other company or product is intended or should be inferred.

This product may include open source or similar third-party software, details of which can
be found by clicking the following link: “Acknowledgments” on page 241 .

Although RWS takes all reasonable measures to provide accurate and comprehensive
information about the product, this information is provided as-is and all warranties,
conditions or other terms concerning the documentation whether express or implied by
statute, common law or otherwise (including those relating to satisfactory quality and fitness
for purposes) are excluded to the extent permitted by law.

To the maximum extent permitted by law, RWS shall not be liable in contract, tort (including
negligence or breach of statutory duty) or otherwise for any loss, injury, claim liability or
damage of any kind or arising out of, or in connection with, the use or performance of the
Software Documentation even if such losses and/or damages were foreseen, foreseeable or
known, for: (a) loss of, damage to or corruption of data, (b) economic loss, (c) loss of actual
or anticipated profits, (d) loss of business revenue, (e) loss of anticipated savings, (f) loss of
business, (g) loss of opportunity, (h) loss of goodwill, or (i) any indirect, special, incidental or
consequential loss or damage howsoever caused.

All Third Party Software is licensed "as is." RWS makes no warranties, express, implied,
statutory or otherwise with respect to the Third Party Software, and expressly disclaims all
implied warranties of non-infringement, merchantability and fitness for a particular purpose.
In no event will Licensor be liable for any damages, including loss of data, lost profits,
cost of cover or other special, incidental, consequential, direct, actual, general or
indirect damages arising from the use of the Third Party Software or accompanying
materials, however caused and on any theory of liability. This limitation will apply even
if Licensor has been advised of the possibility of such damage. The parties acknowledge
that this is a reasonable allocation of risk.

Information in this documentation, including any URL and other Internet website references,
is subject to change without notice. Without limiting the rights under copyright, no part of
this may be reproduced, stored in or introduced into a retrieval system, or transmitted in any
form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or
for any purpose, without the express written permission of RWS.
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(1) . .
) About this guide

This guide describes the differences between the way that Trados Studio 2024 works
compared to SDL Trados 2007 and SDLX.

The purpose of this guide is to help the experienced SDL Trados 2007 and SDLX 2007 users
understand the differences and adapt to them quickly. For a more complete introduction to
working with Trados Studio, see the Trados Studio Online Help .

This guide is split into two sections. The first half of the guide describes the differences
between conceptual information and standard user procedure in Trados Studio compared
to SDL Trados 2007 and SDLX 2007. The second half of the guide provides instructions on how
to migrate data from SDL Trados 2007 and SDLX 2007 to Trados Studio 2024.

Part 1: User Chapter 2- “Introduction to Trados Studio for SDL Trados 2007 Users”
Tasks on page 11

Chapter 3 - “Introduction to Trados Studio for SDLX Users” on page 61
Part 2: Data Chapter 4 - “About Data Migration” on page 113
Migration

Chapter 5 - “Upgrading Legacy Translation Memories” on page 117

Chapter 6 - “Populating Translation Memories from TMX Files” on page
143

Chapter 7 - “Populating Translation Memories from Bilingual
Documents” on page 167

Chapter 8 - “Populating Translation Memories from Alignment Result
Files” on page 177

Chapter 9 - “Reuse Translations From Bilingual Documents in
PerfectMatch ” on page 183

Chapter 10- “Migrating INI and ANL Tag Settings Files” on page 197

Chapter 11- “How to work with the Translation Supply Chain with
Trados Studio (TTX and Bilingual Doc Files)” on page 219

Before you begin

¢ Install the Trados Compatibility and Migration Power Pack to add support for the
following common compatibility and migration scenarios:

® Open legacy SDLX/ITD-based TMS and TeamWorks project packages

® OpenITD, TTX and Bilingual Workbench file types created in SDLX, Trados 2007 and
Translator's Workbench. Official support for these products has ended in 2012.
RWS recommends that you consider converting these legacy file types to the
.SDLXLIFF format.

® Add the Upgrade Migration Wizard to Trados Studio. This wizard was available
out-of-the box with previous Trados Studio versions, but has now moved to this
dedicated app in order to declutter the Trados Studio user interface. This powerful
wizard enables the following batch-oriented use cases:

® Combine multiple Trados Studio translation memories (TMs) into one
® Upgrade Translator's Workbench and SDLX TMs to Trados Studio translation
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memory format: TMW and .MDB format to .SDLTM
® Migrate TMs from TMX to Trados Studio format in batch mode

® Migrate file-based to server-based TMs in Trados GroupShare and vice versa To
install the app, go to the Add-Ins tab > RWS AppStore or visit AppStore Web version .

Upgrade your TMs. To benefit from all the features introduced since Trados Studio
2009 (for example, upLIFT), you will need to upgrade file-based translation memories in
Trados Studio 2024. This is not mandatory as the translation memories have the same
format, but it is recommended. To upgrade TMs, use the Upgrade Migration Wizard
that comes with the Trados Compatibility and Migration Power Pack app. For
information on how to upgrade server-based translation memories from Trados Studio
2009 to Trados Studio 2024 format, see the Trados GroupShare 2020 SR1 Installation
Guide .

Related documentation

Trados Studio 2024 Installation Guide - contains information about installing Trados
Studio 2024.

Trados GroupShare Installation Guide - contains information about installing the server
components of Trados Studio 2024 and upgrading server-based translation memories
from Trados Studio 2009 to the 2024 format.

Trados Studio 2024 Online Help - contains information about using Trados Studio 2024.

Translating and Reviewing Documents Quick Start Guide - contains information for
translators and reviewers. It focuses on how to translate and review files.

Project Management Quick Start Guide - contains information for project managers. It
focuses on the project lifecycle.

Translation Memory Management Quick Start Guide - contains information for users
who create and maintain translation memories.

Introducing Trados Studio

Trados Studio provides one integrated environment for all your translation, review and
project management needs. It is a project-based translation management system and
translation editor tool.

It enables you to create projects, centralize data management, manage and create
translation memories, and translate and review documents. Trados Studio also enables
translation teams to share translation tools, translation memories and project files across
an organization. This setup enables both individual and team working. The audience for this
tool are project managers, translators and reviewers. Using Trados Studio you can:

Translate a single file.
Automate the process of project creation.
Apply translation memories to project files and produce translation analysis figures.

Allow translators to connect directly to translation memories and termbases using the
intranet or Internet, ensuring maximum leverage and consistency.

Manage and create translation memories (local and server-based).
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® Translate and review documents.
® Align existing translated documents to generate translation memory content.

Trados Studio can also be a single-user tool. In this setup the Trados Studio application and
translation memories are located on your computer and there is no interaction with
translation memories or projects over an intranet or the Internet. You can translate and
manage files as part of a project or you can perform a single file translation where a project
is automatically created when you open the file for translation. A project may contain a
single file or many files for translation into one language or several languages. It may also
contain reference material, translation memories and instructions for translators.

Profiles

Preferences are stored in your user profile. You can export your user profile to a file for
sharing with other users or for you to take with you when you use Trados Studio on a
different computer. You could also create profiles for use with different customers. There are
three types of profiles that are shipped with Trados Studio:

Default RWS recommends that new users select this profile.

SDL Trados RWS recommends that users upgrading from SDL Trados
2007 select this profile. This profile contains keyboard
shortcuts and translation settings from SDL Trados 2007
software. For more information, see “Defining Default
Settings " on page 69.

SDLX RWS recommends that users migrating from SDLX select this
profile. This profile contains keyboard shortcuts and
translation settings from SDLX software. For more informa-
tion, see “Defining Default Settings " on page 69.

You are prompted to select which user profile you want to use when you first open the
application. You can also select a different profile by selecting File Menu > Setup > Manage
User Profiles.

Terminology

Some terminology may differ from the terminology used in SDL Trados 2007 and SDLX:
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Project

Project

Project

All files in Trados Studio are
translated and managed as part of
a project. A project can contain a
single file or many files for
translation into one language or
several languages. It may also
contain reference material,
translation memories, termbases
and instructions for translators.

Packages

Packages

n/a

A project package contains all of the
files that need to be sent to a
project team member in order for
them to commence work on the
project. A project package is a
simple file structure containing:

® Project files: target language
files and reference files

® The project translation memory
® Project settings.

Once the project package is
created, you send it by email or
another transport method to the
team member who will be working
on the project files.

Views

Synergy Views

n/a

Each view represents a different
area of functionality in the
application.

Analyze

Analyze

SDL Analyze

Analyzes files against the
translation memory, producing
statistics on the leverage to be
expected during translation. This
task works with project translation
memories if they are available

Pre-translate

Translate

SDL Apply

When you create a project, it
pretranslates project files by
applying translations from
translation memories, terminology
databases (termbases) and
previously translated files.
Pre-translation refers to the
automatic translation of segments
in the source file(s).

Finalize

Clean Up

Create
Translations
Wizard

Update Translation Memory
Convert to Generated Format

Migration Guide
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Structure
Tags

External Tags

Tags

They typically represent structural
information. These tags and their
content are completely ignored
during translation and can only
appear outside sentences. You
rarely need to move or delete
structure tags during translation.

Inline Tags

Internal Tags

Tags

These tags may represent
formatting information (such as
bold), surround hyperlinks or other
markers, and may appear inside the
text.

Print Preview

Bilingual Preview

n/a

Previews the source and target
segments of the document
side-by-side in a web browser.

External
Preview

n/a

View Source
Translation
Preview

Previews the document in its native
application.

Real-time
Preview

n/a

n/a

The translation preview is updated
to reflect the changes as you type.
This update occurs every time you
confirm a segment

Trados Studio actions

The following actions can be performed in Trados Studio. If you have selected a SDLX or SDL
Trados user profile, you can continue to use SDLX and SDL Trados 2007 keyboard shortcuts
for these actions. The keyboard shortcuts listed below are for the default user profile.

Translating Documents (Editor View)

A
¥

Translate Single Document

File > Open > Translate
Single Document

[cTRL]+[sHIFT] +[0]

Home tab > Project Settings |n/a
"'\
Project Settings
@ Home tab > Translation [cTrRL]+[T]
> Memory group > Apply
Translation
Apply a Translation
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a8 Home tab > Translation [F3]
& Memory > Concordance
Search
Concordance Search
['—‘i Home tab > Project Settings |n/a
j > Termbases
Open a Termbase
Term Recognition window or |n/a

3

Insert Term Translation

Termbase Search window >
Insert term translation

Home tab > Segment [cTRL] +[ENTER]
/¢ ) .
v Actions group > Confirm
Confirm a Translation
9 Home tab > Segment [cTRL] +[ENTER]

Approve a Translation

Actions group > Confirm
and Move to Next
Unconfirmed Segment

Y

Sign-off a Translation

Home tab > Segment
Actions group > Confirm
and Move to Next
Unconfirmed Segment

[cTRL] +[ENTER]

Insert Tags Home tab > Formatting or |[cTRL]+[,]
QuickInsert group

Preview Translation in n/a [cTRL]+[K]
Preview Window
Preview Translation in its File > Print & View In n/a
Native Application

= Review tab > Comments [cTRL]+[SHIFT]+[N]
=4 group > Add Comment
Add Comment

= Review tab > Quality [Fs]

~ Assurance group > Verify
Verify Document

— File > Save Target As [sHIFT]+[F12]

Generate Translated
Document

Creating and Managing TMs (Translation Memories View)

Migration Guide
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4 Home tab > Tasks group > [ALT]+[sHIFT]+[N]
New > New Translation
Memory
Create a New File-based
Translation Memory
= Home tab > Tasks group > n/a
b New > New Server-based
Translation Memory
Create a New Server-based
Translation Memory
Home tab > Tasks group > [aLT]+[sHIFT]+[O]
= | Open Translation Memory
Open a Translation
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(2) Introduction to Trados Studio for SDL Trados 2007 users

Overview

There are some differences between the way Trados Studio works compared with SDL Trados
2007. The purpose of this chapter is to help experienced SDL Trados 2007 users understand
the differences and adapt to them quickly.

Note: The chapter is based on settings in the SDL Trados profile. If you have not selected
the SDL Trados profile, the behavior described in this chapter may vary.

SDL Trados 2007 was made up of several components:

SDL Trados Synergy
SDL Trados Synergy was the project management tool for people using SDL Trados 2007.
It enabled you to automate project creation, centralize data management and track
projects.

SDL Trados Translator's Workbench
SDL Trados Translator's Workbench was a translation memory management system in
SDL Trados 2007. It also supported interactive translation through the interface with
Microsoft Word and SDL Trados Tag Editor. This interface provided direct access to the
translation memory database whilst translation was in progress.

Trados Studio has incorporated the translation memory management system, project
management and both editor tools into one application. It enables you to create projects,
centralize data management, manage and create translation memories, and translate and
review documents.

Note: For the purposes of this guide, users of SDL Trados 2007 will be referred to as SDL
Trados Translator's Workbench users.

This chapter goes through the difference between projects in SDL Trados Translator's
Workbench and Trados Studio, how the translating environment has changed and where to
go to perform translation memory maintenance.

For a more complete introduction to working with Trados Studio, see the online help
installed with Trados Studio.

Workflows

These are some of the potential workflows that you can follow in Trados Studio. These are
workflows that you control and can be changed to suit your needs.

® Single-File Translation Workflow

® Project Package Translation: Offline Workflow

® Cloud Project Translation: Online Workflow

® GroupShare Project Translation: Online Workflow
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Single-File Translation Workflow

The following diagram shows a typical workflow if you are translating a single file in Trados

Studio:

Translator

Specify Settings
and Resources
(File > Options)

Open File

Translate File

Verify File

Mo Erors

L

Mesds
Comactions

Generate
Translated
Document
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Project Package Translation: Offline Workflow

This is an example of one way in which you can work with projects through the use of project
packages:
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Project Manager
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Create Project
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Recommended package use

There are two recommendations about how you work with packages in your workflow:
® Always create a package for every task you want to be completed
® Always create a return package for every task you have completed and send to the
person who gave you the task.

For detailed information about what a package is, see “Packages” on page 23.

Alternative workflows

Alternative package workflow

This example describes another way in which you can work with packages in a workflow.
® The project manager creates a project.

® The project manager creates a project package and sends to the translator for
translation.

® The translator opens the package and translates the files.

® The translator creates a return package and sends it to the project manager
® The project manager creates a project package and sends it to the reviewer
® The reviewer opens the package and reviews the files.

® The reviewer creates a return package and sends it to the project manager.

Alternative project workflow

This workflow example shows how an individual translator can benefit from using projects.

® The translator creates a project for each customer and never runs the Finalize batch
task.

® When the translator receives new files for a project, they add the new files to the project
source language then prepare them with the Prepare batch task.

® The translator saves the finished target files using the File > Save Target As instead of
running the Finalize batch task on the files.

® If the translator is using a project TM, they can run the Update Main Translation
Memories batch task.
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GroupShare project translation: Online
workflow

This workflow stores the Trados GroupShare project on the Project Server and assumes that
all team members in the workflow have access to the Project Server. It eliminates the need
for using project packages as all team members can simply open the Trados GroupShare
server-based project to access their work from the server.

GroupShare Project Server

s T
SDL Trados Studio
{Project Manager) SOL Trados Studio (Translator)
Create Project Translate Files.
{Publish to GroupShare & Op;ﬂ (Automatic Check ChecklIn
Praoject Server duting r;up_ are Out and Get Latest Translated files
creation) roject “ersion)
SDL Trados Studio (Reviewer)
Finalize Files Review Files Open
(Autoratic Check out Check In (Autormnatic Check GroupShare
and Get Latest Reviewed Files out and Get Latest Prg'ect
“arsion) Warsion) !
. _J

Note: For more information about using Trados Studio in an Trados GroupShare
environment, see the Trados Studio Help .

Views

The layout of SDL Trados Synergy was similar to Trados Studio with the functionality being
accessed through views. To display a view, you clicked the button that bears the name of the
view or the icon for that view. The view navigation buttons appeared at the bottom of the

navigation pane.
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Project

i new Project... T O | Project & v @

SDL Trados Synergy

View  Help

Tutarial:

u SOL Trados Sunergy

3 Translation in SOL Tradas
SDL Trados windlign

User Guides

i
d

Synergy User Guide

Translator's wWorkbench Guide
i
i

Shortcuts

Windlign User Guide

File Formats Fieference Guide

E Translator's Workbench
E TagEditor
B windlign
E] MUl T erm
E S-T agger for Framehdaker

q
3 Start

K
Lo

Today

u Projects

a Reports

.\‘.;[ Files

/

\_‘_—/

i¥

2 Files {)

Start T ——
T 1 Create Wew Project a@ Open Package @
“ Create a new translation project using the Open a project or return package received
Create Project Wizard, from a keam member,
Project: Project A More Projects...
Start Translation =] i == (Create Project Package =]
Start Translator's Workbench and open the I Create a package cantaining the praject files
First file in the appropriate translation editar, to be sent for kranslation.
Translation Memory Terminology
Create Translation Memory @ 5 (3 Create New Termbase @
Create a new file-based translation memary - Create new termbase using MulkiTerm
using Translator's Workbench, Deskkap.
Open Translation Memory @ ﬁ\ Open Termbase @
Cpen a translation memory using Translator's Open a termbase using MultiTerm Deskkop,
‘workbench,
Aligh Translated Files @ Extract Terminology @
Align previously translated files to create Extract terminalogy from existing documents,
translation memary content.
File Types Tools
—_ ] Manage Tag Settings =] Glue Source Files =]
Manage settings for processing markup Glue mulkiple small translatable files into ane
= language file Farmats. large file to imprave efficiency.,
@ ) Manage Filter Settings @ m Convert XLIFF Files @
\ Manage settings for processing other file Canwvert XLIFF Files ko TradosTag Format,
Farmats,
e.— Project &

Like SDL Trados Synergy, Trados Studio also has a Projects, Reports and Files view. In
addition, Trados Studio has a Welcome, Editor and Translation Memories view. After
aligning existing translated documents, Trados Studio opens an extra Alignment view where
you can review and correct the alignment result file (».sd1align).

B
T ore | View  Acdins Help
»
Project Feature
Settings. Toggle
Configuration  Feature Toggle Open
Files < | Neme
Filter Files. @) SamplePhotoPrinter.doc sdl.
File name: [3 SemplePresentation.ppix.d.
‘ ] [) SampleXML_DITA xml sdixi
doo sdiit
Language: #) TryPerfectMatch. doc.sdixiiff
Project folders

= Sample Project

) My Tasks.

™ Sent Tasks

File Details

[ inciude subfolders

& Welcome
- Projects
N2 Files

3 Reports
/ Editor

g Translation Me...

Trados Studio - Sample Project

= B AddFiles~ B o]
B 4 Add Folders B ®
Batch
Tasks + & Add New Folder [ B
File Actions
Words  FileStatus  Progress  Size Usage File Type ldent..  Path
219 In Translation 0% 34KB Transiatable DOCV2000  \
9 InTranslation [l 22% 56 KB Translatable PresentationML.. |
2491 Unspecified 100KB Translatable  XML:DITA13v.

183
224

InTranslation [l
In Translation

12%

65KB Translatable
46KB Trenslatable

Wordprocessing
DOCv2000 1\

No files selected

[ File Details §1 Analysis Statistics [ Confirmation Statistics & Task History [ File Attributes

Trados GroupShare

Cloud Task

Cloud Projects

Due date

[none]
[none]
[none]
[none]
[none]

#a - & x
@ Tell me what you want to do.. 2
¥ @ File details layout -
® @ L'
Packages Layout Bookma
Assigned To
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The Trados Studio views function in the following way:

Welcome This is where you can:

® Access popular Help videos and documentation

® Read the latest Trados Studio news
You can also access commands to do the following:

® New Project

® Translate Single Document

® Open Package

® Open GroupShare Project

® Access your cloud account information and manage

subscriptions to cloud machine translation engines

Selecting any of these commands will switch you to the
appropriate view in Trados Studio or open another application
where you can perform the action.

Projects This is where you view and work with projects. You can select a
project to view detailed project and file information and track
project and file status.

Files This is where you work with project files. From here you can:

® Open files for translation, review or sign-off.

® Perform batch processing on files.

® Create packages from the project files.
You can also view word counts and translation progress for
these files.

Reports This is where you view project reports. The reports provide
detailed translation analysis figures which feed directly into the
project planning and budgeting process.

Editor This is where documents are translated and reviewed.

Translation Memories

This is where you create and manage translation memories.

Alignment

This is where you review and correct the result of the alignment
that Trados Studio performs automatically when you align
existing translated documents.

This view is only available when you open an alignment result
file (*.sdlalign).
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Defining default settings

You can define default settings for use in your translation in the Options dialog box. These
settings are used if you open a single file for translation and are stored in the default project
template when you create a project. Select File > Options to display the Options dialog

box.

»- 4" Editor Termbases

- @ AutoSuggest E Add termbases to the project and order them. Set a default termbase and check the language mapping.
>-@ File Types

p@ Embedded Content Processars + TreiE o E s < | Settings... | ‘ Remove Set Default

b@ Verification

{ | 4 EX Language Pairs

| 4 Al Language Pairs Mo termbase added yet
4 Bl Translation Memory and Auto
p
" Search Settings
b.}’ Match Repair

: b@ Batch Processing

b--E1 English (United States)-> Portugue

[E] Default Task Sequence

3 Translation Quality Assessment

B Translation Memories View

@ Colars

-E& Keyboard Shortcuts

| | b-& Automatic Updates

|| v @ welcome View

Termbase Name Filter Enabled

b
)
,
b
b

Project Language = Mapped Language in the Selected Termbase
BE ¢)ish (United States) Mo termbase selected yet.

&3 rortuguese Brazily No termbase selected yet.

Reset to Defaults Cancel Help

SDL Trados profile settings

If you selected the SDL Trados profile, similar settings that were selected by default in SDL
Trados are selected in Trados Studio. These are some of the settings.

Select Language Pairs > All Language Pairs > Batch Processing > Pre-translate Files
from the navigation tree in the Options dialog box.

® The Minimum Match Score is set to 100%. This means that only 100% matches will be
pre-translated

® The Copy source to target if no match found check box is not selected. This means
that the source segment text is not automatically copied into the target segments if no
translation memory match was found.

These settings allow you to see 100% matches and work interactively through the remainder
of the document, pulling fuzzy matches from the translation memory as required during
the interactive translation process.
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Creating and managing projects

Like SDL Trados 2007 projects, Trados Studio is also a project-based translation management
system. All files are translated and managed as part of a project. A project may contain a
single file or many files for translation into one language or several languages. It may also
contain reference material, translation memories, termbases and instructions for translators.

Click the New Project button in any view in Trados Studio to create a new project. This is
the same button that you use in SDL Trados Synergy to create projects.

€ SDL Trados Synergy

Project
O Settings
O Configuration

Tasks »

SDL Trados Synergy gave you an option to create a project from scratch with default settings.
Trados Studio however, provides you with a default template on which to base your project.
This can significantly speed up the time it takes to create a project. The default template
stores your default settings specified in the application. You can specify these default settings
and file filters in the Options dialog box. The default template is automatically selected
when you create a new project. These settings can be modified as required when you create
a project.
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ww Create a New Project

One Step General

Use Settings from 0

Project Name
Project 3

Location Path [/ Autofill

Translation Resources

5 Default (Default project template for new users)

C:\Users\hhopirtean\OneDrive - SDL\Desktop'Project 3

Project Files (1 total, 1 translatable, 0 reference)

4 5 6 7

Termbases PerfectMatch

Trados GroupShare

ard page.
d go through all t

Source Language

LS English (United States)

- Browse

Target Languages

B German (Germany)

Browse

Batch Tasks

- m} X

Summary Preparation

3 of 9 completed

-

Clear all (1 Selected)

7

[] Include subfolders

BERO® &

= Project3 (1)

Help

[]  Filesin Selected Folder v

D new 1.txt

Size Usage

1KB Translatable

File Type  File Type Identifier [3]

v Text Plain Text v 1.0.0.0

Next

coneel

Trados Studio provides you with the same ability to specify translation memory,
pre-translation and batch processing settings that SDL Trados Synergy provided when you

create a project.

Note: In Trados Studio, you can modify the project settings you specified after the project
is created. You modify these settings in the Project Settings dialog.

Project Settings - Sample Project

>[4 File Types

4 @ Embedded Content Processars
DE Verification

E’ -IEl Language Pairs

:D- ? Translation Quality Assessment

Reset to Defaults
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Location:

Due Date:

Customer:

Sample Project

Sample project included with SDL Trados Studio.

‘C:\Users\sur\:ariu\Documents\Studm 201%\Projects\Samples\SampleProject

Browse...

D Allow source editing

D Users assigned to a project package must run verification before returning the package
D Use word-based tokenization for Asian source text
O 06-Aug-18 18:00:00 s

<nones

~ | | Customers...

Cancel Help
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Packages

Trados Studio packages follow a similar approach to SDL Trados Synergy packages. A project
package is a single zipped file that contains all of the files that need to be sent to a project
team member in order for them to commence work on the project. It can contain:

® Project files: target language files and reference files

® The project translation memory

® Connection details for a server-based translation memory

® Project settings.
Once the project package is created, you can click the Send Packages by Email button at
the end of the Create Project Package wizard to email to the team member who will be

working on the project files. You can create packages in the Projects and Files view by
selecting the Create Project Package option from the Packages group.

Note: If you are working with a GroupShare project, you can access work that is assigned
to you by opening the project in Trados Studio. For more information, see the Trados Studio
2024 Help .
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| E Create Project Package U
Check the files to be included in project packages:
MName L Usage Words Status Progress Sent Task Path
] samplePhotoPrinter.... B Tranclatable 219 In Transla... 53% n/a \
i2f] SamplePresentation... M@ Translatable 9 InTransla.. [ 22% nfa \
[o] SampleXML_DITAxm... M@ Translatable 2491 In Transla... 0% nia \
[iw SecondSample.doc.... B Transiatable 206 In Transla... I 10% nia \
IE] TryPerfectMatch.doc. ... B Trancistable 224 In Transla... n/a \
|
|
|
| <
| Select All Deselect All
Help Next Cancel

Translating files

There are some major differences in how you translate a file in SDL Trados Translator's

Workbench to how you translate a file in Trados Studio. However, some of the basic actions
have stayed the same. For example, you still confirm a translation once it is complete. The

following are the areas of functionality in which the differences between SDL Trados

Translator's Workbench and Trados Studio are described:

® Open a File for Translation. See “Opening a File for Translation” on page 25.

® Bilingual Files. See “TTX Files, Bilingual Microsoft Word Files vs. SDL XLIFF Files” on

page 30.

® Translating Environment. See “Translating Environment” on page 30.
® Retrieving translations from the translation memory. See “Working with Translation

Memories” on page 84.

® Looking up Terminology. See “Working with Terminology ” on page 89.

® Working with Tags. See “Working with Tags " on page 40.
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® Preview translations. See “Previewing a Document” on page 44.
® Confirming translations. See “Confirming a Segment” on page 99.

Opening a file for translation

When using SDL Trados Translator's Workbench, you opened a file for translation in SDL
Trados Tag Editor or Microsoft Word. Alternatively, you could have opened a file from a
project in SDL Trados Synergy for translation in SDL Trados Tag Editor or Microsoft Word.

In Trados Studio, you can open a single file for translation or open a file for translation from
within a project.

B®e- Trados Studio - Sample Project - & x
I vome | view  Addins  Help @ Tell me what you want to do... [
@ 7 b Open For Review Explore Containing Folder B Add Files ~ B Delete Files ® B~ =8~ @ G’ﬂ File details layout - /fﬁ
w f 4 ) e N
# Open For Sign-off B % Add Folders B ® ] © d
Project Feature Open For Batch b Create Project
Settings. Toggle Translation Tasks - @ Open File With Add New Folder B, B -4 @ Package
Config Feature Toggle Open File Actions Trados GroupShare  Cloud Projects Packages Layout Bookma | a
Files < | Name = Words  File Status  Progress Size Usage File Type Ident..  Path Cloud Task Due date Assigned To 2
Fiter Files [ S Samp 215 in Transiation 0% 34KB Translatable  DOCv2000 | none Tnone] a g
File name: [ SemplePresentation. pptx sd 9 InTranslation [0 22% 56 KB Translatable PresentationML.. \ none. [none] nla g
‘ ] [3) SampleXML_DITA xml sdbd. 2491 Unspecified 100KB Trenslateble XML DITA13v.. \ none Tnone] e s
3] docx sdixiff 183 InTranslation | 12% 65KB Translatable Wordprocessing... \ none [none] na =
Language: ) TryPerfectMatch. doc. sdixiiff 224 In Translation 46KB Translatable DOCv2000  \ none. [none] nla T
[ German (Gen g
Project folders =
= Sample Project
My Tasks
7 Sent Tasks
File Details 3 x
[ inciude subfoiders | Name SamplePhotoPrinter doc sdbiff
Path c Drive - SDLID 202 i P doc sdiiff
Usage Translatable
# Welcome LastModified /1612021 9:31:50 AM
Size 34K8
Projects.
- Original Name | SamplePhatoPrinter.doc
Files File Type Identifier DOC v 2.0.0.0
G Reports Words
/ Editor

g Translation Me...

File Details 4% Analysis Statistics = Confirmation Statistics £ Task History [ File Attributes

Alternatively, you can open a file for translation by drag-and-dropping it from your computer
into the Welcome page.
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Bfe-
Home | View Add-Ins  Help @ Tell me what you want to do... 2

- 4 ® o EE m & T

Project. Feature Align Create AutoSuggest Open Terminology Software Show Useful Tips
Settings Toggle Documents ~ Dictionary RetrofitFile Management Localization ~Shortcuts  Collection
Configuration_ Feature Toggle Translation Memory -
a
<

Welcome Home Get Started More Resources Latest News Z
R RWS AppStore B
~ . . T
B Drag files for translation or browse your computer g

AN\, Open Project Package
Open a project package sent to you for translation or revision. The project is automatically added to your list in the Projects view. You can work with packages from Trados Studio, WorldServer, TMS and other systems.

Watch Video

AN Open Trados GroupShare Project
'@ Open a project shared on Trados for Trados projects are based and enable you to work with fellow translators and reviewers in a more efficient and centralized way. Watch
Video

a Working with Cloud Projects

Create cloud projects right from within Studio to benefit from new flexible ways of working and hamess the power of the cloud. Watch Video

< >

& Welcome
- Projects
Files

4 Reports
/' Editor

g Translation Me...

Single-File translation
Before you open a single file for translation in Trados Studio, RWS recommends that you
define your default:

® Translation Memories and Termbases

® Settings

Note: You can also connect to automated translation providers (Machine Translation) and
add AutoSuggest dictionaries which offer text suggestions while you translate. For more
information, refer to the online help in Trados Studio .

Translation memories, termbases and settings are defined in the Language Pairs section
of the Options dialog box.
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All Language Pairs Level
|

Project Settings - Sampleth(oPlinter.duc_en-US_de-DE EI@
b Project I| All Language Pairs
b~ [E4 File Types II Select one of the following settings:
b [E3 Embedded ContentFrooessors & Translation Memory and Automated Translation
v [Z} Verification f (31 Termbases
b- 2 Translation Quality Assessment 1% Batch Frocessing
AE Language Pairs |I

Fa All Language Pairs
. b Bl Translation Memary and Aute
b [l Termbases
: b - £} Batch Processing
P-)l English (United States)->German | |

[ ok || cancel || Hep

I
Individual Language Pairs Level

Typically, you edit settings, and select translation memories and termbases at the All
Language Pairs level. These settings apply to all of the language pairs and then individual
exceptions to these settings can be defined for each language pair.

For example, you can change the default fuzzy matching threshold setting to 65% at the All
Language Pairs level and it will apply to all translation memories for all language pairs.
However, if you want English to German to use a different fuzzy matching threshold, you can
change it at the individual language pairs level to 75%.

The default translation memories and termbases that you define here are automatically
opened and your default settings applied when you start a new translation.
Setting up your translation defaults

For example, if you want to set up default translation memories, termbases and translation
settings for English (United States) to German (Germany) follow these instructions:
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Procedure
1. Select File > options. The Options dialog box is displayed.
2. To set up your default translation memory:

® Select Language Pairs > All Language Pairs > Translation Memory and
Automated Translation from the navigation tree. The Translation Memory and
Automated Translation page is displayed on the right.

® Click Add and select File-based Translation Memory from the drop-down list to
add a local translation memory. The Open Translation Memory dialog box is
displayed.

® Select an English (United States) - German (Germany) translation memory and click
Open. The translation memory is added to the list. Only * . sd1tm translation
memories are supported.

Note: For information on migrating your translation memories to *.sd1tm format,
see Chapter 5 - “Upgrading Legacy Translation Memories” on page 117.

¢ If your setup does not include the language pairs specified in the selected translation
memory, English (United States) - German (Germany), the Add Supported Language
Pairs dialog box is displayed where you can select the language pair and click OK to
add it to the setup.

3. To set up your default termbase:

® Select Language Pairs > All Language Pairs > Termbases from the navigation
tree. The Termbases page is displayed on the right.

® Click Add. The Select Termbases dialog box is displayed. If the termbase that you
want to use is not displayed, click Browse to locate a local termbase. The termbase
is added to the list in the Select Termbases dialog box.

® (Click OK. The termbase is added to the list.

Opening a single file for translation

Procedure

1. Click the File > Translate Single Document iCON in any view. The Open Document
dialog is displayed.

2. Select the file which you want to translate and click Open.

The Open Document dialog is displayed.
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| Source Language: = English (United States) *1 g
Target Language: | @ German (Germany) . | loptional)
E Create Translation Memory... v| B Use.. - ﬁ Settings... | | ¢ Remove | & Import... Bk, Export... | Upgrade

|
MName Enabled Langusges Lookup Penalty Concordance Update
E English-German.sditm v E - s | v v

0 Set up different translation memories or automated translation providers for a specific language pair from its settings node.

| Do not show this dialog again if the language pair settings for the document are known.

Advanced... Cancel Help

3. Select English (United States) as your Source Language and German (Germany) as your
Target Language.

4. Ifyou already defined your default translation memories for this language pair in the
previous section, the default translation memories are displayed under Translation
Memory and Automated Translation. Add and remove translation memories as
required

5. Click OK. The translatable content of the source language document is identified,
segmented and placed in an *.sd1x1iff file. The file is opened in the Editor window in
the Editor view for translating.

When you use the Translate Single Document command, a project is automatically
created for the opened file. Your default translation memories and termbases (that you
defined in the Options dialog box) are automatically opened. Any settings that you
specified in the Options dialog box are also automatically applied. If you want to change
these settings for this file, select Project Settings from the Home tab of any view to
display the Project Settings dialog.

Open a file for translation from a project

If you are working with projects in Trados Studio, you can open a file for translation from
the Files view. In the Files view, right-click on a file and select Open for Translation from the
shortcut menu. The file is opened in the Editor view. The translation memories and
termbases defined in the project are automatically opened. Any settings that you specified
in the project are also automatically applied.

If you want to change the settings, select Project Settings from the Home tab of any view
to display the Project Settings dialog box.
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TTX Files, Bilingual Microsoft Word files vs. SDL
XLIFF files

When you created a project in SDL Trados Synergy or when you opened a file for translation
in SDL Trados Tag Editor, the file was converted to a bilingual format TTX for translation. If
you were using SDL Trados Translator's Workbench with Microsoft Word, files were converted
to a Bilingual Rich Text Format (RTF).

In Trados Studio when you create a project or open a document for translation it is converted
to SDL XLIFF, a bilingual format used by Trados Studio. SDL XLIFF stands for SDL XML
Localization Interchange File Format. It is an XML based bilingual file format, specially
developed for use in localization. It is bilingual because it contains both the source document
and the document translation in a single file. When an SDLXLIFF file is displayed in the
Editor window in the Editor view, the source document text is displayed on the left of the
editor window and the target version of the text is displayed on the right.

When you save an SDL XLIFF file, the *.sd1x1iff extension is added to the name of the
source language document being translated. For example, a source document named
Sample.doc would be saved as sample.doc.sdlx1iff. For more information on XLIFF files,
refer to http://xml.coverpages.org/xliff.html

Note: Bilingual Rich Text Format (RTF) files created when translating in Microsoft Word

with SDL Trados Translator's Workbench and cannot be processed or opened in Trados
Studio. To leverage information from these files, they must first be cleaned up in SDL Trados
Translator's Workbench to create a legacy translation memory and then upgraded to the
new translation memory format. For more information, see “Importing Bilingual Files to a
Legacy Translation Memory and Upgrading the Translation Memory " on page 175.

Translating environment

In SDL Trados Translator's Workbench the editing environment was made up of two
applications. The translatable content was displayed within the file in bilingual mode in SDL
Trados TagEditor. SDL Trados Translator's Workbench was displayed on the top and showed
the match from the translation memory.

If you had terminology recognition enabled, SDL Trados Translator's Workbench displayed
recognized terms from the currently selected segment.
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In Trados Studio, documents are reviewed and translated in the Editor view. This view
contains the following components:

® Navigation pane, where you can see the documents that are currently open and navigate
between them.

® Tabs and groups on the Ribbon.
® Editor window where you perform translation or review.

® Aset of tabbed windows that appear above the Editor window. These include a
translation results window, a term recognition window, a concordance window, a
comments window and a messages window.
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navigation pane

view specific windows
side-by-side editor
menus and toolbars

Editor Window

The

Editor window in the Editor view is where you translate documents. The bilingual SDL

XLIFF document containing the text to be translated and the translation are displayed in the
window, side by side. The source language text appears on the left and the target language
version on the right. The content of the document is broken down into segments (typically
sentences). The target language segments can be edited.

The first column displays segment numbers. Only one number is displayed for each
segment pair as the source and target segments are aligned with each other by default.
You can choose not to display segment numbers. The source and target segments can
also be worked with as two separate lists.

Between the source and target segment columns is the segment status column. This
column indicates the current translation status of the segment and its translation origin.
For example, if the translation is approved and if a 100% match was found in the
translation memory for this segment.

To the right of the target language segments is the document structure column. It
displays a code that tells you where in the original document the segment text appears.
Hover over the code or click on the code in this column to display a description telling
you where the segment appears in the source document.
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Translating in SDL TradTranslating in SDL Trados
Translator’s Workbench vs. Translating in

Trados Studio

In SDL Trados Translator's Workbench, to start translating a segment you first clicked the

Open/Get button to edit the target segment.

To start translating inTrados Studio, click inside one of the target segments in the document
and simply start typing. You can use standard windows text editing functionality when

working in Trados Studio.

When you place your cursor in a segment, it automatically becomes the active segment
which allows you to edit that segment. You can choose to turn off the option that makes it
the active segment automatically and instead manually make it the active segment by
selecting Home tab > Navigation group > Activate Row.

Working with translation memories

When you worked with a translation memory in SDL Trados Translator's Workbench, you
could retrieve translations from your translation memory and update the translation
memory. In Trados Studio, the process of retrieving the translations works in a similar way,
however, updating the translation memory uses different logic.
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Retrieving translations from the Translation Memory

When you clicked the Open/Get button in SDL Trados Translator's Workbench, a lookup in
the translation memory was performed.

Q) SDL Trados Translator's Workbench - manuals_en-de |Z||E|E|
Filz Settings “iew Options Tools Help
Created on: 18/11/2008, . .
15:53 [¢] Association for Road Safety — Conference
Created by EMOUNT
Changed an:
Changed by _
Last Used: 0841 2/2008, Ealid Association for Road Safety — Caonference
Usage: 131'28 = Tagung der Gesellschatft fiir Yerkehrssicherheit
(o
Exact Match \\ o=+ | 1datch 1 of 2

Pe r[:\entage Match

In Trados Studio, translations found by the lookup are displayed in the Translation Results
window where you can then choose one to apply to the current segment. Lookups are
performed on source language segments only.

A translation memory lookup is performed when a segment becomes the active segment.
This happens when you place your cursor in a new segment or when your cursor is
automatically placed in a segment after confirming a previous segment. If you have
automatic row activation turned off, select Home tab > Navigation group > Activate Row
to make it the active segment. When a lookup is performed:

® The best translation memory match is automatically placed in the target segment and
the match is also displayed in the Translation Results window.

® In the example below, a 100% translation memory match has been found and

automatically confirmed. The percentage match [[iigl] is displayed in the segment
status column and the &£, symbol indicates that the segment is confirmed.
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Updating the Translation Memory

In SDL Trados Translator's Workbench, the Project and Filter Settings dialog box was where
you could specify how to filter your translation memory matches and specify what field values
would be assigned to the new translation units when updating the translation memory.

The logic used to update the translation memory was based on metadata. If you changed a
translation in the document that was from the translation memory, the translation unit
was not updated but instead a new translation unit was created.
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In Trados Studio, you specify your project and filter settings for the active document in the
Project Settings dialog box on the following two pages:

® Filters - These settings determine what filters applied to the contents of the translation
memory. These filters are applied to translations retrieved from the translation memory
when lookups are performed.

® Update - These settings determine what field values are assigned to new translation
units when updating the translation memory.

By default, a new translation is automatically added to the translation memory and assigned
the field values specified in your Update settings when you confirm a translation during
editing. If you change a translation in your document that was taken from the translation
memory and then confirm the translation, the translation unit in the document replaces the
translation unit in the translation memory. The values that are assigned to the translation
unit are merged with the new ones specified in your Update settings. If you want to add the
changed translation as a new translation unit, before you confirm the segment select
Advanced tab > Translation Memory group > Add as New Translation from the Ribbon.
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Working with Terminology

How you work with terminology in Trados Studio is similar to the way you worked with
terminology in SDL Trados Translator's Workbench. Like SDL Trados Translator's Workbench,
you can only work with MultiTerm termbases in Trados Studio. and you can perform the
following actions:

® Retrieve terms from the termbase
® Browse the termbase
® Add terms to the termbase.

Retrieving terms from the MultiTerm Termbase

When you clicked the Open/Get button in SDL Trados Translator's Workbench, a search in
the MultiTerm termbase was performed.

About this task
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Terminology Match

In Trados Studio, terms found by the search are displayed in the Term Recognition window
where you can then choose which one to insert into the current segment. Searches are
performed on source language terms only.

A search in the termbase is performed when a segment becomes the active segment. This
happens when you place your cursor in a new segment or when your cursor is automatically
placed in a segment after confirming a previous segment. If you have automatic row
activation turned off, select Home tab > Navigation group > Activate Row to make it the
active segment. When a search is performed:

® The term that has been found is highlighted by a red bracket in the source segment and
the term translations are displayed in the Term Recognition window.

® In the example below, the term, Road Safety has been found in the termbase with one
translation. To insert the term translation into the target segment, select the translation,
Verkehrssicherheit, in the Term Recognition window and click (7.
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You can also manually search for a term in the Termbase Search window.

Procedure

1.

Click the Termbase Search tab to display the Termbase Search window.

Termbase Search -« 0 X

road safety  Sample CJK

Insert term
~ translation
into the
target
segment or
wview term
details

Type the term you want to search for in the box at the top of the window and press
[ENTER]. In the example above, photo printer was entered and one translation has been
found.

You can then do the following:

® Select the term translation, Fotodrucker and click (% to insert the term into the
source segment.

® Click & and the term entry is displayed in the Termbase Viewer window.

Browsing and adding terms

You can browse terms and add terms in the Termbase Viewer window. To display this window,
do one of the following:

Select View tab > Information group > Termbase Viewer. The terms from the default
termbase are listed here in alphabetical order.

Select a term in the Term Recognition or Termbase Search window and click & .

Highlight a term in the Editor window and right-click and select Add Term from the
shortcut menu. A new entry is displayed in the Termbase Viewer window.
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Working with tags

In SDL Trados TagEditor, you were able to choose whether tag text was displayed fully,
partially or not at all by clicking the tag text buttons on the TagEditor toolbar.

(¢]o @

By default, Trados Studio settings specify that recognized formatting tags are hidden,
therefore when you insert commonly used tags from the QuickInsert group on the Home
tab or by another method, the tags remain hidden and instead the text is formatted in the
style in the Editor window. For example, text that is tagged as bold is displayed in bold

with no tags.

For more information, contact your local branch of the
Teachers Edueation Pragrakuime Fawhdation.

You can set the Formatting display style option in the Options dialog box to show or hide
commonly recognized tags, such as bold and italics, for example.

The same tag display options that were in SDL Trados TagEditor are available from the
Editor view > View tab > Options group. By default, tag text is only partially displayed.
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Translatable attribute tags

The way that translatable attribute tags are treated in Trados Studio is different than how
they were treated in SDL Trados TagEditor. In SDL Trados TagEditor, a translatable attribute
tag was split into three parts and was displayed in a segment that contained other text. For
example, an image with tooltip text (ALT Attribute) appeared in the following way.

Part 2: Translatable
Text

Part1: Tag IT?DHIP] Part 3: Tag

b / L~
limg...alt=4Create Project F'ackage[:]ﬂick this to
rmermber in arder for them to commence work on 2

In Trados Studio, a translatable attribute tag is split into a separate segment from other text
in the document. The new way of segmenting this tag allows you to reuse the translation

no matter where it occurs. This has an impact on leverage against upgraded translation
memories because it segments differently. For more information on segmentation, see
“Upgrading Segmentation Rules” on page 122.

Part 2: Translatable Text
(Tooltip)
!

Once the ﬁackage iz created, you send ™
9 it by email to the team member who wil \

!
1 Create Project Package & TAG I

Create Retum ﬁackagem P+

Click thiz to create a returh
11 package containing project files for
which a specific manual tazk has been
completed.

Inserting tags

In SDL Trados TagEditor, tags were classified as placeables. You inserted them from the Tags
toolbar or used the placeable buttons on the Workbench toolbar.
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In Trados Studio tags are classified as a type of placeables (recognized tokens). There are a
variety of ways to apply the correct tag formatting to your translations in Trados Studio. You
can insert tags using your mouse or your keyboard. The following instructions describe
how to apply italic formatting to text in your target language segment using your mouse or
by using keyboard shortcuts.

Inserting italic tags using your mouse

Procedure
1. Click inside the target segment where you want the italics formatting to be applied.

2. Place the cursor over the source segment text that has the italics formatting and press
[cTrL]. The formatted text is highlighted in gold.

e e e & dLic <iiun programme el

3. With the [cTrL] key depressed, mouse-click on the formatted text in the source segment
text. The formatting tag pair is inserted into the target segment at the point where the
cursor is located. Click inside the tag pair and start typing.

Note: You can also insert tags from the QuickInsert group in the Home tab of the
Editor view and copy and paste tags from the source and target segments. In addition,
you can create custom QuickInsert tags.

SDL Trados Studio - Sample Project

Help
— - - 10 & £ 5
©@® ™
Concor
A Sear
QuickInsert M | Translatio

Inserting italic tags using your keyboard and the QuickPlace drop-down
list

Procedure

1. When the cursor is at the point where you want to type text formatted in italics in the
target segment, press [cTRL]+[, ]. The QuickPlace drop-down list is displayed below the
target segment. Depending on your settings, this list shows sample text with formatting
applied or a list of tags from the source segment.

® The example of the QuickPlace drop-down list on the left shows sample text
formatted in italics and in bold. The second example of the QuickPlace drop-down
list on the right, shows how the bold and italic tags may display if you change your
default tag display settings. There is more than one choice on the lists because the
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2.

source segment has text formatted in both of these styles.

[zampile faxt!

[zample text]

<of italic="on"">

| <cf Bald="on"> J

® The first type of formatting from the source segment is selected automatically. In
the source segment, the text formatted by the tag is highlighted.

Press [ENTER] or [TaB] to start applying the formatting or to insert the italics tag into the
target segment. If you selected an italics tag, a ghost tag is also inserted.

Note: A ghost tag is a marker tag that is automatically added to a segment when the
segment contains an incomplete tag pair. For example, if you delete a tag that is one half
of a pair, the system will automatically display a ghost tag until you replace the missing
tag. Ghost tags only occur in tag pairs, as only tag pairs require a beginning and an end
tag to function correctly. A ghost tag looks like a grayed-out version of an ordinary tag.
You cannot edit ghost tags but you can restore a ghost tag to a real tag.

A real tag A ghost tag
\ /
: /
éE rZiehungsprogramm

vam Bildungsminister vorgestellt

Continue typing. The italics formatting is applied to the text.

When you want the formatting to stop being applied, click [cTrL]+[.] to select the
formatted text from the drop-down list again or insert the closing tag of the pair.

For more information on working with tags, refer to the online help in Trados Studio.

Working with placeables

Placeables are source document content that has been recognized as:

content not requiring translation, or

content which can be automatically localized by applying a translation memory. For
example, some dates can automatically be converted to the correct format by applying
a translation memory.

Similarly to Trados Translator's Workbench, placeables are identified by a blue square-
bracket underline in the Translation Memory window:

Reqgizter today L=

el =nd obtain a w discuuntﬂ!
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The previous section described how to insert tags which are a type of placeables. To insert
other placeables, such as numbers, variables and dates you can follow the same procedure.
The following instructions describe how to insert 20% in to your target segment by using
your mouse or by using keyboard shortcuts.

Inserting placeables using your mouse

Procedure
1. Click inside the target segment where you want to insert 20%.

2. Place the cursor over 20% in the source segment text and press [cTRL]. The 20% text is
highlighted in gold. 2o%,

3. With the [cTrL] key depressed, mouse-click the 20% in the source segment text. 20% is
inserted into the target segment at the point where the cursor is located.

Inserting placeables using your keyboard and the QuickPlace
drop-down list

Procedure

1. When the cursor is at the point where you want to insert 20% in the target segment,
press [cTRL]+[, ]. The QuickPlace drop-down list of the placeable from the source
segment is displayed below the target segment.

2. Press [ENTER] or [TAB] to insert the 20% into the target segment.

Previewing a document

In SDL Trados TagEditor there are various previews available that allow you to look at how
the text will appear when you generate the translated document. You have three preview
modes: bilingual, source and target.
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There are three types of preview in Trados Studio:

® Preview in the Preview Window - Displays the document in the Preview window in the
Editor view.

® Preview in the Native Application - Displays the document in the application in which is
was originally created. The applications available to preview the document depend on
what settings are specified in your file filters and what applications are installed on
your machine.

® Print Preview - Displays the document as a bilingual SDL XLIFF file in a web browser.
The source and target text is displayed side-by-side. When you preview the document you
can also print it from your web browser.

Like SDL Trados TagEditor, you can choose to preview the document source or target text or
you can display source and target text side-by-side

Real-time preview

You can also select to preview in real time. If you select this option, the translation preview
is updated to reflect the changes as you type. This update occurs every time you confirm a
segment. The currently active segment is highlighted in the Preview window. If you click on
the active segment in the preview, your cursor is automatically placed in the active segment
in the document.

For more information, refer to the online help in Trados Studio.
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Note: Real-time preview may not be available for all file types .
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Confirming a segment

When you have finished translating a segment you should confirm the segment to indicate
that the translation is complete. To confirm the translation, place your cursor in the
translated segment and select Confirm from the Home tab > Segment Actions group or
press [cTRL] + [ENTER]. When you confirm a translation:

® The segment status is changed to Translated and the £ icon is displayed in the segment
status column.

® The translation is automatically added to the translation memory. If you are using a
project translation memory, the translation is added to the project translation memory
and not the main translation memory.

® The translation can be viewed in the Preview window.

® Segment verification is performed. Segment verification errors are displayed in the
Messages window.

® Trados Studio automatically places your cursor in the next segment, skipping all locked
segments.

Note: By default, when the system applies a 100% translation memory match to a segment,
the segment is automatically confirmed. This is an optional setting which is controlled from
the Options dialog box.
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When the status of every segment in a document is changed to Translated, the status of
the document changes to Translated.

Opening a file for review

In Trados Studio you can also open a file for review. When you open a file for review the
screen layout in the Editor view changes to the review layout and the list of statuses available
to apply to segments changes to show review statuses only.

In the Editor window, the source language segments are displayed on the left and target
language segments on the right. The segment status column in between the source and
target segments contains information about the target segment status, for example whether
the translation has been confirmed.

Editor <« | SemplePhotoPrinter doc sdbxiff [Review] =g
A~z
+ [ SemplePhotoPier. q 5 H
isaed 1 Getting Started <HIW  [Erste Schritte :
2 Finding a location for your photo printer 4 igneten A t fiir Ihren Fotodrucker finden B -
Place the photo printer on a flat, clean and dust-free surface, in a dry location, and out of direct i Platzieren Sie den Fotodrucker auf einer flachen, sauberen und staubfreien Oberfléche, und u g
jaht. stellen Sie ihn an einem trockenen Ort auf, der keinem direkten Sonnenlicht ausgesetzt ist. <
4 Allow at least 12 cm clearance from the back of the photo printer for the paper to travel D u Z
5 When connecting power or USB cables, keep the cables clear of the paper path to the frontand [} 8
rear of the photo printer.
6 For proper ventilationf#l]], make sure the top and back of the photo printer are not blocked. n u +
Allow enough space on all sides of the photo printer to let you connect and disconnect cables, [} Ne S
change the color cartridge, and add paper. g
s Connecting and turning on the power D N
9 EXSNote: D P
10 Use only the AC power adapter included with your photo printer. D
11 Other adapters can damage your camera, photo printer, or computer. (]
12 To connect and tum on the power, follow these steps: D P
13 Step (] TC+
14 Notes 0 Tcr
15 Connect the AC power cord to the AC power adapter, then to the back of the photo printer. D us
16 e AC pover cable included with your photo priner may not require assembly, and may be different [} Tcr
from the one shown.
17 Plug the AC power cable into a power outlet. n] us
18 Press the On / Off button to tur the power on. D (T
Comments(0) x
P Welcome z © Errors + Wamings o Information [} Show Comments for Active Document Only | Show Source and Target Comment v
Proje Severi S/ Comment Document Scope Segm  User Date Version D
- Projects
Files
4 Reports
/ Editor
g Translation Me...
= Comments(0) | % TQAs (0) @ g ple Project ¢ - ple Project_Engl

Y All segments INS [186.76% ¢ 12.33% £0.91% 50.00% /30.00% B Chars: 14 2 0/1001 " ->=

Verification

SDL Trados Translator's Workbench had a series of verification plug-ins that allowed you to
verify or validate the tag content of your target files and run quality assurance checks.

These verifications have been enhanced for Trados Studio. Some of the verifiers can be
configured for each individual file type and some can be configured at language pair level.
To perform verification on:

® asegment, confirm the segment.

® anindividual file when you have finished translating a file, go to Review tab > Quality
Assurance group > Verify in the Editor view.

® agroup of project files, select Home tab > Batch Tasks in the Projects or the Files view
and select Verify Files from the Batch Tasks drop-down menu.

Verification errors for segments or individual files are displayed in the Messages window in
the Editor view of Trados Studio.
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Mes=sages (3) -« 0 X
@ € 0Emors 3 Warnings (1) 0 Motes ”

41

Severity | Message * Qrigin
e End punctuation difference detected. QA Checker 3.0
i End punctuation difference detected. (Message 1z outdated,.. QA Checker 3.0
End punctuation difference detected. QA Checker 3.0

The following verification types are included in Trados Studio:

Tag Verification Tag verification compares the tag content of target
material with the tag content of the original source
material and identifies any changes that were made.
Changes in the target material are acceptable
provided that the syntax of tags remains intact and
that the translated document can be converted back
to its original format. Tag verification helps to ensure
that only acceptable changes are made.

The settings for this verifier are defined for each
individual file type.

QA Check 3.0 QA Checker 3.0 incorporates a suite of quality
assurance checks. The checks are broken down into
the following areas: Segment Verification, Segments
to Exclude, Punctuation, Numbers, Regular Expres-
sions, Word List, Inconsistencies, Trademark Check
and Advanced.

Terminology Verifier Terminology Verifier checks your current document to
ensure that the target terms contained in the
MultiTerm termbase have been used during
translation or to verify whether forbidden terms have
been used.

Global verification settings for verification are defined under File > Options > Verification.

Language specific verification settings are defined under File > Options > Language Pairs >
<language pair> > Verification
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Options EI@

b Editor WVerfication

W _ Verffication is applied across all file types.
i’ l_EI .-A.!JtoSuggc—,at You can enable/disable individual verifiers in the list below.
v~ [E} File Types

¥~ [E} Embedded Content Processors

b4 QA Checker 3.0 QA Checker 3.0

b ¥ Tag Verifier Tag verfication

b Terminclogy Verifier Teminclogy Verfier
% Translation Quality Assessment
A Language Pairs
£ Default Task Sequence
B Translation Memories View

&) Colors

Keyboard Shortcuts
P ’-3' Automatic Updates
b @ Welcome View

v T T W W

(o) [oome ) [

Clean up vs. finalize

When you have finished translating a document, the source and target segments are still
stored together in the document. In SDL Trados Translator's Workbench you used the Clean
Up command to generate target translation of the files in their native format and to update
the translation memory. Alternatively, you could have used the Save Target As command in
SDL Trados TagEditor which does not update the translation memory.

In SDL Trados Synergy, you used the Finalize command to generate the target translations
and update the translation memory for one or more files at the same time.

In Trados Studio, you can:

Finalize Generates the target translations and updates the translation
memory for one or more files at the same time.

Ri?ht-click on the project in Projects or right click on the
selected files in Files view select Batch Tasks > Finalize rom
the shortcut menu

Save Target As Generates a target translation for a single file in the Editor
view.

Select File > Save Target As from the menu.
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Export Files Generates a target translation for a group of files at any point
in the project life cycle.

Ri?ht-click on the project in Projects or right click on the
selected files in Files view select Batch Tasks > Finalize from
the shortcut menu.

Home View Add-Ins Help

(D About SDL Trados Studio (@) About SDL Trados Studio ) @ v OB G(‘:’ 1 | File details layout -
>
{7 Add Files S @ 3 " BeE ]
Project Open For Batch _ Create Project
Settings Translaticn Tasks » [ B i) .8 - Package
Cata group Configuration Open File Actions GroupShare Packages Layout
Files < || Hame Words  Status Progress Size Usage File Type Iden.  Path Local ¢
] SamplePhotoPrinter.doc.sd... 219 InTranslat.. 52KB Translatable Word 2000-200.. 4 nla
B German (Germany) - 1] TryPerfectMatch.doc sdlxdiff 224 In Review E3KB Translatable \ord 2000-200.. 4 nla
Project folders S e emton 2% KB T Powerfoint 200\ 2
= Somple Project fiw SecondSampledocs # Open FerDensiation 1% TEKB Transiatable | ord 2007 v20. nia
1 Wy Tasks [2] SampleXML_DITAx e Open For Review 130 KB Translatable XML DITA 11w b nla
" Sent Tasks % Open For Sign-off
() Translate (to yghnt;
() Translat (to yghnt) BatchJasks » Cfmahzg _)
[ Create EI'CJEC': Package Analyze Files
3  Create Studio 2009 Package Translation Quality Assessment
e Export files
] *:  Explore Containing Folder Generate Target Translations
File Details 24 Apply Perfecthatch
Files 5 [&  Open File With Populate Project Translation Memories
[ Include subfolders Size 3KB | Pseudo-translate
\niords 332 E Update from Reviewed Target File (Retrofit)
&, Welcome Export for Bilingual Review
Update from Bilingual Review
wy Projects Pre-translate Files
[ Files Change Phase ¥ Translation Count
- 48  Assign to Users in Phase ¥ Update Main Translation Memecries

Creating and managing translation
memories

In SDL Trados Translator's Workbench, you created and maintained translation memories.
In Trados Studio, you create and maintain translation memories in the Translation
Memories view. This view contains the following components:

® Navigation pane, where you can see the file and server-based translation memories
that are currently open and navigate between them. You also see language resource
templates.

® Tabs and groups containing maintenance tools.

® TM side-by-side editor window, where you perform maintenance on your translation
memories.

® Search Details window, where you create and apply filters to your translation memories.

® Field Values window, where you view and edit field values for the selected translation
unit.
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. Navigation pane
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Search Details window
TM side-by-side editor

. Field Values window
Ribbon tabs and groups

Creating a Translation Memory

In SDL Trados Translator's Workbench when you created translation memories, you specified
the language, system fields and general details.
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Create Translation Memory

Source languages: Target languages:
English [Caribbean) » English [Canada) -~ Create. .
Engligh (Ireland)] B Englizh [Canbbean)
English [Jamaica) 3 E nglish [Ireland)
English [Mew Zealand) Englizh [Jamaica)
English [South Africa) English [Mew Zealand)
English [Trinidad] English [South &frica) =
English [United Kingdam E nglish [T rinidad
English [United States) English [Urited Kingdonm] Ry

Syztem fields

e Creation date Change date [ Used date

< » Creation uger Charmge Lizer [ Usage counter

Multiple tranzlations

I—_"; [] &sllow multiple translations for identical source segments =

—

General

M ame:

Copyright notice:

Drezcnphion:

In Trados Studio, to create a translation memory in the Translation Memories view:

® Select File > New > Translation Memory or click Create and select File-based
Translation Memory on the Translation Memory and Automated Translation page to
create a file-based translation memory. The New Translation Memory wizard is displayed.

® Select File > New > Server-based Translation Memory or click Create and select
Server-based Translation Memory on the Translation Memory and Automated
Translation page to create a server-based translation memory. The New Server-based
Translation Memory wizard is displayed.

52 Migration Guide



Introduction to Trados Studio for SDL Trados 2007 users @

@ New Translation Memory — a X
@ 2 3 4
General Fields Language Resources Finish

1 of 4 completed

Name: * ™

Description:

Copyright:

Location: * C\Users\hhopirtean\OneDrive - SDL\Documents\Studio 2021\Translation Memories

Source Language: * B English (United States) -

Target Language: © | ™® German (Germany) -
Enable character-based concordance search

Help Back Next Cancel

Settings that you defined after creating a translation memory in SDL Trados Translator's
Workbench are now included in the creation process in Trados Studio. You can specify the
following in the New Translation Memory/New Server-based Translation Memory wizard:

® The name, location and languages of the translation memory.

® The fields for the translation units in the translation memory, and translation memory
settings.

® The language resource template. You can create or modify language resource lists.
These lists are used in conjunction with the segmentation rules in translation memory
processing and to identify untranslatable content.

Editing a Translation Memory setup

In SDL Trados Translator's Workbench you edited translation memory settings in the Setup
dialog:
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Setup C:\Documents and SettingslemountiMy DocumentskTiM1 . trmar
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Hare System fiekd
Tr--11 | watem |§ z
Creation date
Copyright notice; ]
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e Change date
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Change uzer
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|lzage counter

T arget languages:
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Created by: EMOUNT Egg::zﬂ Egz'f;dla] W
Ereated an: DE."I-I 2.‘"2["]8 15|:||:| English [Earil:ul:-ean]
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Walid until English [J amaica)
English [ Zea!and]
kultiple tranzlations: ez Engl!sh [Sl:-'u-th Altica]

Enlsh Tnldad

[ K H Cancel H Help

In Trados Studio you edit translation memory settings in the Translation Memory Settings
dialog. To display this dialog, select the translation memory that you want to edit settings for
from the navigation tree in the Translation Memories view, go to the Home tab and select
Settings.
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| 4| English-German

Mame: English-German
Fields and Settings ame &

Language Resources Description: Sample English-German translation memaory

Access Rights

Performance and Tuning
Fragment Alignment Copyright: |[C] 2008 5DL

Location: |C:\Do(uments\TMs

|
|
Source Language: |Eng|ish {United States) |
|

Target Language: |German (Germany}

Created By: |STU'ITGART\dbro(kmann |

Created At [18-Feb-0s |

Translation Units: |109’90 |

You can edit and view the following sections:

[TM Name] - This is where you can view general details of the translation memory, for
example, name and source language. You can also modify the translation memory
description.

Language Pairs - This is where you can view which language pairs are in the translation
memory. This page is only displayed for server-based translation memories that are
multilingual and can contain more than one language pair.

Fields and Settings - This is where you can view existing fields and create additional
fields in the translation memory. You can also specify translation memory settings.

Language Resources - This is where you can modify language resource lists in your
translation memory. These lists are used in conjunction with the segmentation rules in
translation memory processing and are also used to identify untranslatable content.

Access Rights - This is where you can protect file-based translation memories by defining
passwords that are linked to translation memory maintenance or a users rights.

Performance and Tuning - This is where you can use different tools to improve the
performance of server-based translation memories searches (on the selected translation
memory). This does not apply to file-based translation memories.

Importing and exporting

In SDL Trados Translator's Workbench you imported and exported translation memory data
from the File menu.
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Import

Irmpart mode
(*) Small import file [no recrganisation) b

) Large import file [with recrganization]

E sizting tranglation unitz I e figlds Help
) Leave unchanged ) Ignare

) Keep most recent (%) Add to setup

) Keep oldest

) Merge

) Ovenwrite

[ ] Check matching sub-languages

In Trados Studio, you can import translation memory data using the Import wizard. To
display this wizard, select the translation memory for which you want to import data from
the navigation tree in the Translation Memories view and then selecting Home tab > Tasks
group > Import.

& Import - O X
o ()
v L4 g -
Import Files Bilingual Document Import Options General Import Options Import

3 of 4 completed

Apply Field Values: Edit...

[ Import translation units as plain text

[] Exclude language variants

[ Export invalid translation units

Export Location: Browse...

If target segments differ:

@ Add new translation units

O Overwrite existing translation units

(O Leave existing translation units unchanged

O Keep most recent translation units

Use information from bilingual file to update TU system fields

Help Back Next Cancel
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You can assign field values to newly imported translation units. For example, you may want
to indicate the type of document the imported translations are for, such as, Software or
Online Help.

B Import — ] b4
v ©) 3 s
Import Files TMX Import Options General Import Options Import

2 of 4 completed

Filter: NOT Created on != "10/7/2021 7:23:19 PM" | | Edit.. |

Unknown Fields: | Add to translation memory i

Please select the scenario that applies best to you:

@ The imported data will be primarily used with new, native source files or files processed only with Trados Studio
() The imported data will be primarily used with presegmented legacy Trados ITD or TTX files

(O The imported data will be primarily used in mixed scenarios

Help Back Next Finish Cancel

Depending on the source you import data from, you can apply a filter so that only translation
units that match the conditions of the filter are imported. Filters are based on the field
values assigned to the translation units that are being imported.

If imported translation units have fields associated with them that are not part of the
translation memory, there are several different options on how to import those translation
units. For example, you could specify to only import translation units that contain the same
fields as the translation memory you are importing into or you could add the fields from the
imported translation units to the translation memory.

Translation Memory maintenance

In SDL Trados Translator's Workbench you performed maintenance on your translation
units in your translation memory in the following ways:

® A spot-editing feature allowed you to edit and delete individual translation units. You
accessed this feature from the maintenance, concordance and translation memory
windows in SDL Trados Translator's Workbench.

® The Maintenance command provided access to the Translation Memory Maintenance
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dialog box where you edited and deleted the contents of your translation memory at
translation unit and global level.

Translation Memory Maintenance - TU Mo. 1-5
[ Filter... ] Translation unitz proceszed at a time

[ Find and Replace. . ] Dizplay tranzlation unit information

Help

[ ] Resume search from last position

[ Feszet Search l [ << Previous ] [ et > -

Delete -

Bl Association for Road Safety — Confarence ~

=8 Tagung der Gesellschaft fir Yerkehrssicherheit

Created ong 18/01/2000, 1218 Created by CAROL-AMM  Changed on: Chanoed by Last
dzed: Uszage: O

Efes Hoad Safety Education in our Schools
= /erkehrserziehung an Schulen

In Trados Studio, you can perform maintenance directly in the Translation Memories view.
You can use the Search Details window to find the translation units that you want to edit.
The translation units are displayed in the TM side-by-side editor.

TM Window Name Source Language Target Language
\ 1ab Segments . Segments
\ P
Englizh-German [en-U5->de-DE] /f / ¥ X |Field Values «( 1 X
1 Association for Road”  Tagung der Gesellschaft || custom Fields
Safety Conference flr Verkehrssicherheit [ Field Value
Road Safety Verkehrserziehung an
2 Education in our Schulen
Schools
& Road Safety Verkehrserziehung in der
3 Education in our Sekundarstufe
Secondary Schools System Fields
Road Safety Verkehrserziehung in der Field “ Value -
4 Education in our Grundschule Created by CAROL-ANM
Primary Schools Created on 11872000 315
This conference Auf dieser Tagung wird Document st.
| nresants the new b Aas neie bk i S | ast modifie - STUTTGART T
| I I
Translation Unit Document ! Field
Status Column Structure Values
Column
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To change the segment text, simply click in the segment and start typing. Use the Save
group on the Home tab in the Translation Memories view to:

® Mark a translation unit for deletion.

® Save (Commit) changes to the translation memory or discard or undo your changes as
required.

Use the Field Values window to assign custom field values to the translation unit selected in
the TM side-by-side Editor.
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Overview

There are some differences between the way that SDLX worked compared to Trados Studio.
The purpose of this chapter is to help the experienced SDLX users understand the differences
and adapt to them quickly. .

For a more complete introduction to working with Trados Studio, see the online help
installed with Trados Studio

SDLX is a translation management tool. It is made up of multiple modules which allow you
to translate a document, create a project, align files, analyze files, track projects, split files and
create and manage termbases.

Trados Studio is an integrated project-based translation management system and translation
editor tool. It enables you to create projects, centralize data management, manage and
create translation memories, and translate and review documents.

This chapter goes through the difference between projects in SDLX and Trados Studio, how
the translating environment has changed and where to go to perform translation memory
maintenance.

Note: This chapter is based on settings in the SDLX profile. If you have not selected the
SDLX profile, the behavior described in this chapter may vary. For more information about
the default settings selected in the SDLX profile, see “SDLX Profile Settings ” on page 70.

Workflows

These are some of the potential workflows that you can follow in Trados Studio. These are
workflows that you control and can be changed to suit your needs.

® Single-file Translation Workflow
® Project Package Translation: Offline Workflow
® GroupShare Project Translation: Online Workflow

Single-File Translation Workflow

The following diagram shows a typical workflow if you are translating a single file in Trados
Studio:
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Project Package Translation: Offline Workflow

This is an example of one way in which you can work with projects through the use of project

packages:

Migration Guide 63



N\
‘1\3/1‘ Introduction to Trados Studio for SDLX users

i - N
Project Manager
Specify
Settings and
Resources Finalize Files
(File =
Options)
Create Project
. '
Craate
Package Open Package
.

9 ‘ o
Send Project Send Retum
FPackage Package

[ ] o
- ™y
l Translator
~ )
Onen Package Create Return
¥ 4 Package
b r
Translate Files
i b
Create
Open Package
> Package P g
e A
\ 4 )
|
Send Project Send Retum
Package Package
1
REIECTED: [ . A
Sent back b Trard slor 4‘ Reviewer
for comedions i h
Create Returh
Open Package Package
Review Files (= APPROWVED
—
\, .

64 Migration Guide




Introduction to Trados Studio for SDLX users @

Recommended package use

There are two recommendations about how you work with packages in your workflow:
® Always create a package for every task you want to be completed
® Always create a return package for every task you have completed and send to the
person who gave you the task.

See “Assigning Work to Project Participants ” on page 75 for detailed information about
packages.

Alternative workflows

Alternative package workflow

This example describes another way in which you can work with packages in a workflow.
® The project manager creates a project.

® The project manager creates a project package and sends to the translator for
translation.

® The translator opens the package and translates the files.

® The translator creates a return package and sends it to the project manager
® The project manager creates a project package and sends it to the reviewer
® The reviewer opens the package and reviews the files.

® The reviewer creates a return package and sends it to the project manager.

Alternative project workflow

This workflow example shows how an individual translator can benefit from using projects.

® The translator creates a project for each customer and never runs the Finalize batch
task.

® When the translator receives new files for a project, they add the new files to the project
source language then prepare them with the Prepare batch task.

® The translator saves the finished target files using the File > Save Target As instead of
running the Finalize batch task on the files.

® If the translator is using a project TM, they can run the Update Main Translation
Memories batch task.
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Cloud translation workflow

In Trados Studio 2021 and later you can upload your projects, translation memories and
termbases into your own secure cloud space and use them in Trados Studio, along with
neural machine translation. With cloud projects, you enjoy the security of knowing that your
work is synced to the cloud all the time and your projects are backed up in a secure
environment.

The following diagram shows the workflow for translating a cloud project file when using a
Trados Studio's cloud capabilities subscription type. Trados Team and Trados Enterprise
subscriptions give you access to more complex workflows and more account resources.

Sign in to your Language Provision account with .
9 y guag _— _— Create cloud project
Cloud account cloud resources
RWS Language Cloud RWS Language Cloud
Translation requires
changes
Revert task back to . . )
. 4+ Complete project 44— Translate cloud project file
Translation stage
RWS Language Cloud RWS Language Cloud RWS Language Cloud

GroupShare project translation: Online
workflow

This workflow stores the Trados GroupShare project on the Project Server and assumes that
all team members in the workflow have access to the Project Server. It eliminates the need
for using project packages as all team members can simply open the Trados GroupShare
server-based project to access their work from the server.

66 Migration Guide



Introduction to Trados Studio for SDLX users 3

GroupShare Project Server

-

SDL Trados Studio |

{Project Manager) SOL Trados Studio (Translator)
Create Project Translate Files.
{Publish to GroupShare s - Op;r; (Automatic Check ChecklIn
Project Server during rouR.aNare Outand Get Latest Translated files
creation) Rikoject “ersion)

SDL Trados Studio (Reviewer)
Finalize Fileg Review Files Open
Automatic Check out Check In Automatic Check P
2§ GroupShare
and Get Latest = Rewewed Files out and Get Latest F'rg'ect
“arsion) Warsion) !

Note: For more information about using Trados Studio in an Trados GroupShare
environment, see the Trados Studio Help .

Switchboard vs. Views

SDLX was split in into different areas of functionality that were accessed through the SDLX
Switchboard. To display a area of functionality, you clicked a button on the Switchboard.
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£, 5DLX : [no server]

Projeck  TM Translate Align TermBase Tools Help

Project Wizard

QA Check Exchange

In Trados Studio the functionality is accessed through views. To display a view, click the
button that bears the name of the view or the icon for that view. The view navigation buttons
appear at the bottom of the navigation pane.

Trados Studio has a Welcome, Projects, Files, Editor and Translation Memories view.

B&R - Trados Studio - Sample Project @ - & x
B vome | view  Addins  Help @ Tell me what you want to do. 2
) » Q0 o B Add Files - B B B~ B 2 @ File details layout -
- of s Eallie s ® @ |[edbbiowt 0
2 Open F B Ope e % Add Folders [ eF e - ©R
Project Feature Batch g
Settings Toggle Tasks + @ Add New Folder 2. B el k [ ] e e
Configuration Feature Toggle Open File Actions Trados GroupShare  Cloud Projects Packages Layout Bookma | &
Files < | Name ~ Words  FileStatus  Progress  Size Usage File Type Ident..  Path Cloud Task Due date Assigned To ;
Fiter Fles ) SamplePhotoPrinter.doc sdl. 219 In Translation 0% 34KB Trensieteble DOCv2000 1\ none [none] e g
P £ e o nTransiotion [l 2% S6KB Transietable  PreseniationL.. | o Jonel s 3
) SempleXML_DITA xm.sdbx 2491 Unspecified 100KB Trenslatable XML DITA13v.. | none [none] e 5
docx sdixiff 183 InTranslation [l 12% 65KB Translatable Wordprocessing... | none [none] nla =
Language: ) TryPerfeciatch doc st 224 InTranslation 46KB Trnsitoble DOCv2000  \ ey i i +
]
Project folders. 2
= Sample Project
) My Tasks
2 Sent Tasks
File Details 7 x

[ include subfolders

& Welcome

- Projects

N E) Files

14 Reports

/ Editor

& Translation Me...

No files selected

File Details &1 Analysis Statistics [£ Confirmation Statistics £ Tesk History [ File Attributes

The Trados Studio views function in the following way:
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Welcome This is where you can:
® Access popular Help videos and documentation
® Read the latest Trados Studio news
You can also access commands to do the following:
® Translate Single Document
® Open Project Package
® Open Trados GroupShare Project
® Access your Language Cloud account information and
manage subscriptions to Language Cloud machine
translation engines
Selecting any of these commands will switch you to the
appropriate view in Trados Studio or open another application
where you can perform the action.

Projects This is where you view and work with projects. You can select a
project to view detailed project and file information and track
project and file status.

Files This is where you work with project files. From here you can:

® Open files for translation, review or sign-off.

® Perform batch processing on files.

® Create packages from the project files.
You can also view word counts and translation progress for
these files.

Reports This is where you view project reports. The reports provide
detailed translation analysis figures which feed directly into the
project planning and budgeting process.

Editor This is where documents are translated and reviewed.

Translation Memories

This is where you create and manage translation memories.

Alignment

This is where you review and correct the result of the alignment
that Trados Studio performs automatically when you align
existing translated documents.

This view is only available when you open an alignment result
file (*.sdlalign).

Defining default settings

You can define default settings for use in your translation in the Options dialog box. These
settings are used if you open a single file for translation and are stored in the default project
template when you create a project. Select File > Options to display the Options dialog

box.
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1 Language Pairs
4 Al Language Pairs Mo termbase added yet

b-B Translation Memory and Auto

y

Search Settings

b /&~ Match Repair

b -[F] Batch Processing
b--E1 English (United States)-> Portugue
[E] Default Task Sequence

- X
|5 # Editor Termbases
- @ AutoSuggest E Add termbases to the project and order them. Set a default termbase and check the language mapping.
b @ File Types
»[#] Embedded Content Processars o= Create ~ [ Use ~ | Settings... | ‘ Remove Set Default
»
Pl

Termbase Name Filter Enabled

%/ Translation Quality Assessment

@ Colars
3 Keyboard Shortcuts
b-& Automatic Updates

b
b
b B Translation Memories View
b
13

s & Welcome View Project Language = Mapped Language in the Selected Termbase
BE ¢)ish (United States) Mo termbase selected yet.
&3 rortuguese Brazily No termbase selected yet.
Reset to Defaults Cancel Help

SDLX profile settings

If you selected the SDLX profile, similar settings that were selected by default in SDLX are
selected in Trados Studio. Below are some of the key settings included in the profile. If you
prefer to manually define these settings, complete the steps below:

Procedure
1. Select File > options from the Ribbon. The Options dialog box is displayed.
2. Select Editor from the navigation tree.

® Under Opening Files, select Automatically copy source content to target cells
when opening document. When this option is selected, the content of source
segments is automatically copied to target segments when you open a document
for the first time. This is useful if you are performing a single file translation and have
not pre-translated the file.

3. Select Language Pairs > All Language Pairs > Batch Processing > Pre-translate
Files from the navigation tree.

® Under After Applying Translations, select Copy source to target if no match
found. This is useful if you have pre-translated a document and want the source
text where matches were not found to be copied to the target cells.

4. Click OK to save your changes and close the Options dialog box.

Note: For information on how to set up your default translation memories and
termbases before starting a new translation, see “Single File Translation” on page 26.
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Creating and managing projects

In SDLX you could create a project with a group of files. The action of creating a project was
used primarily to pre-translate files and convert them to ITDs in a batch. The project was
also used for creating project translation memories and merging translations.

Trados Studio is a project-based translation management system. All files in Trados Studio
are translated and managed as part of a project. A project may contain a single file or many
files for translation into one language or several languages. It may also contain reference
material, translation memories, termbases and instructions for translators.

Note: When you open a single file for translation using the Translate Single Document
command in Trados Studio, a project is automatically created.

In SDLX you clicked the Project Wizard button on the SDLX switchboard to create a new
project. In Trados Studio click the New Project button in any view to create a new project.

SDLX Project Wizard Button

Project Wizard

SDL Trados Studio New Project Button

“ Home Wiew Add-Ins
—.

Project Mew Cpen Batch
Settings Project § Project  Tasks =
Configuration — e—

SDLX gave you an option to automate the process of creating projects using a template
called a Project Profile.
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‘@' S5DL Project Wizard : Create Project Z”Elb__q

File types ] Languages ] Source files ] Options ] Thiz ] Analysis ] Reporing ] Tracking ]

Prafile Profile contains:

| S []1 File types

Profile description |:| 3 Languages

[]4 Target folder

|:| 5 Tranzlation Metmory seftings
[ sutamatch settings

[]7 &eneral options

[]& Translation Memaries

[]49 Analysiz settings

[]10 Reporting options

[111 Tracking option=

Open... Save as.. ] [ Create neww profile

Mo target languages have been selected

0%

Trados Studio however, provides you with a default template on which to base your project.
This can significantly speed up the time it takes to create a project. The default template
stores your default settings specified in the application. You can specify these default settings
and file filters in the Options dialog box. The default template is automatically selected
when you create a new project. These settings can be modified as required when you create
a project.
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ww Create a New Project - ] X
G———@ a z g g g g
One Step General Translation Resources Termbases Trados GroupShare PerfectMatch Batch Tasks Summary Preparation

3 of 9 completed

One Step

‘ou can create 2 proj sing just the opticns on this wizard page.
If you want to manually configur vanced options, select Next and go through all the steps.
Use Settings from [i ] Source Language
5 Default (Default project template for new users) - LS English (United States) -
Project Name Target Languages Clear all (1 Selected)
Project 3 B German (Germany)
y
Location Path [/ Autofill
C:\Users\hhopirtean\OneDrive - SDL\Desktop'Project 3
Project Files (1 total, 1 translatable, 0 reference) D Include subfolders
BEM - (] Files in Selected Folder v Size Usage File Type  File Type Identifier [3]
== Project3 (1) 1 new 1.ixt 1KB Translatable v Text Plain Text v 1.0.0.0

Help Back Next Cancel

Trados Studio provides you with the same ability to specify translation memory,
pre-translation and batch processing settings that SDLX provided when you created a project.
In SDLX this information was specified in the SDL Project Wizard. In Trados Studio this
information is specified in the New Project wizard.

Note: In Trados Studio, you can modify project settings you specified after the project is
created. You modify these settings in the Project Settings dialog box.

Project Settings - Sample Project — m} =

H Mame: Sample Project | |
v [8] File Types

D@ Embedded Content Pracessars
DE Verification

Eb -IE Language Pairs

Description: | Sample project included with SDL Tradas Studio.

:; -|3| Translation Quality Assessment Location: ChUsers\suricariv\DocumentstStudio 2019\Projects\Samples\SampleProject Browse...
D Allow source editing
D Users assigned to a project package must run verification before returning the package
D Use word-based tokenization for Asian source text
DueDate: [ ] |06-Aug-13 18:00:00 2
Customer: <nonex ~ | | Customers...

Reset to Defaults Cancel Help
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Create project Translation Memory

In SDLX you could create a project translation memory using the Create Project TM wizard.
The project translation memory contains only the translation memory entries that are
relevant to the project ITD files in SDLX.

Create Project TM

Files | Tranzlation Memories || I:Ipticuns|

Filez to check

AddITD

ils

Add Project
Remove
Clear

Filez Selected

e

Start | | Cloze

In Trados Studio the process of creating a project translation memory is included in the
Create a New Project wizard.

Note: When a translator updates the translation memory during translation, the project
translation memory is updated when a segment is confirmed. The project manager can then
decide if those translations are updated to the main translation memory at the end of the
project.
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ww Create a New Project - Batch Tasks - ] X
&) &) &)
O—Oo0—¢C L4 L4 L4 @ g S
One Step General Translation Resources Termbases Trados GroupShare PerfectMatch Batch Tasks Summary Preparation
7 of 9 completed
Task Sequence Prepare without project TM - Task Sequences

Convert, analyze and pre-translate files without creating project translation memories.

Tasks: Convert to Translatable Format, Copy to Target Languages, Apply PerfectMatch, Pre-translate Files, Analyze Files

Language Pairs
4-E All Language Pairs Batch Processing
o= -

T Select one of the following settings:
Analyze Files
Pre-translate Files Analyze Files
Fuzzy Bands Pre-translate Files
PerfectMatch Fuzzy Bands

b [ English (United States)- PerfectMatch

Help Back Next Cancel

Assigning work to project participants

In SDLX if you wanted to send files to another person in the workflow, you had to email the
files and associated information. In Trados Studio you can send project packages to exchange
this information. A project package is a single zipped file that contains all of the files that
need to be sent to a project team member in order for them to commence work on the
project. It can contain:

® Project files: target language files and reference files

® The project translation memory

® Connection details for a server-based translation memory

® Project settings.
Once the project package is created, you can click the Send Packages by Email button at
the end of the Create Project Package wizard to email to the team member who will be

working on the project files. You can create packages in the Projects and Files view by
selecting the Create Project Package option from the ribbon.

Note: If you are working with a Trados GroupShare project, you can access work that is
assigned to you by opening the project in Trados Studio. For more information, see the Trados
Studio Documentation .
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|E:;_-:;-; oject Package O
Check the files to be included in project packages:
MName L Usage Words Status Progress Sent Task Path
I@] SamplePhotoPrinter.... B Tznsiatable 219 In Transla... 53% n/a \
ksl] SamplePresentation. ... B Tanclatable 9 In Transla.. . 22% n/a \
[ SampleXML_DITAxm... ™™ Translatable 2491 In Transla... 0% nia \
@' SecondSample.doc.... B Trznsiatable 206 In Transla... I 10% n/a \
I@] TryPerfectMatch.doc. ... B Tranclatsble 224 In Transla... n/a Y
£
Select All Deselect All
Help Next Cancel

Translating files

There are some major differences in how you translated a file in SDLX to how you translate
afilein Trados Studio. However, some of the basic actions have stayed the same. For example,
you still confirm a translation once it is complete. The following are the areas of functionality

in which the differences between SDLX and Trados Studio are described:

Open a File for Translation. See “Opening a File for Translation” on page 77.
Bilingual Files. See “ITD Files vs. SDL XLIFF Files " on page 81.

Translating Environment. See “Translating Environment” on page 81.
Retrieving translations from the translation memory. See “Working with Translation

Memories ” on page 33.

Looking up Terminology. See “Working with Terminology ” on page 37.

Working with Tags. See “Working with Tags ” on page 92.

Preview translations. See “Previewing a Document” on page 97.

Confirming translations. See “Confirming a Segment” on page 46.
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Opening a file for translation

When using SDLX, you opened a file from a project in SDL Edit or started a new translation.

In Trados Studio, you can open a single file for translation or open a file for translation from
within a project.

B®R- Trados Studio - Sample Project @ - & x
B vome | view  Addins  Help @ Tell me what you want to do... [
@ f. Open For Review Explore Containing Folder B Add Files ~ B Delete Files ® B- [=#-Y @ @ File details layout -
w . Z = i @ 'S
2 Open For Sign-off B % Add Folders B B I~ ©R
Project Feature Open For Batch Create Project
Settings. Toggle Translation Tasks - [ Open File With Add New Folder B, B -4 @ Package
Feature Toggle Open File Actions Trados GroupShare Cloud Projects Packages Layout Bookma | a
Files < | Name Words  File Status _Progress _ Size Usage File Type ldent..  Path Cloud Task Due date Assigned To 4
Filter Files = pl 219 _In Translation 0% 34 KB Translatable DOCv20.0.0 \ none [none] nia 2
File name: [ SemplePresentation. pptx sd 9 InTranslation [l 22% 56 KB Translatable PresentationML.. | none. [none] nla g
‘ ] [ SempleXML_DITA xml.sdix! 2491 Unspecified 100KB Translatable XML:DITA13v.. \ none. [none] nla g
3] docx sdixiff 183 InTranslation | 12% 65KB Translatable ~Wordprocessing... \ none [none] na .
Language: ) TryPerfectMatch doc sdixiiff 224 In Translation 46KB Translatable DOCv2000  \ none. [none] nla T
[ German (Gen g
Project folders =

- Sample Project
9 My Tasks
 Sent Tasks

File Details  x
[ Include subfolders Neme SamplePhotoPrinter doc.sdixiff
Path C:\L Drive - SDL\D 202 je Pl doc sdixiiff
Usage Trensietable
{ﬁ\ Welcome Last Modified 6/16/2021 9:31:50 AM
size 34K8
Projects
- Original Name ‘SamplePhotoPrinter doc
Files File Type Identifier DOC v 2.0.0.0
ﬁ Reports Words. 219
# Editor

g Translation Me...

[ File Details &9 Analysis Statistics [= Confirmation Statistics 43 Task History [3] File Attributes.

Alternatively, you can open a file for translation by drag-and-dropping it from your computer
into the Welcome screen.

Note: In Trados Studio, the rules used to segment your document are stored in the
translation memory that you selected when opening your document or when creating your
project. For more information, see “Translation Memory Segmentation ” on page 107.

Single-File translation
Before you open a single file for translation in Trados Studio, RWS recommends that you
define your default:

® Translation Memories and Termbases

® Settings

Note: You can also connect to automated translation providers (Machine Translation) and
add AutoSuggest dictionaries which offer text suggestions while you translate. For more
information, refer to the online help in Trados Studio .

Translation memories, termbases and settings are defined in the Language Pairs section
of the Options dialog box.
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All Language Pairs Level
|

Project Settings - Sampleth(oPlinter.duc_en-US_de-DE EI@

All Language Pairs

* w Project II

b~ [E4 File Types II Select one of the following settings:

b [E3 Embedded ContentFrooessors F' Translation Memory and Automated Translation
b |5 Verification f (31 Termbases

b [ Translation Quality Assessment 1% Batch Frocessing

4-[@ Language Pairs |I

Fa All Language Pairs
. b Bl Translation Memary and Aute
b [l Termbases
: b - £} Batch Processing
P-)l English (United States)->German | |

[ ok || cancel || Hep

I
Individual Language Pairs Level

Typically, you edit settings, and select translation memories and termbases at the All
Language Pairs level. These settings apply to all of the language pairs and then individual
exceptions to these settings can be defined for each language pair.

For example, you can change the default fuzzy matching threshold setting to 65% at the All
Language Pairs level and it will apply to all translation memories for all language pairs.
However, if you want English to German to use a different fuzzy matching threshold, you can
change it at the individual language pairs level to 75%.

The default translation memories and termbases that you define here are automatically
opened and your default settings applied when you start a new translation.
Setting up your translation defaults

For example, if you want to set up default translation memories, termbases and translation
settings for English (United States) to German (Germany) follow these instructions:
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Procedure

1.

Select File > options. The Options dialog box is displayed.

2. To set up your default translation memory:

® Select Language Pairs > All Language Pairs > Translation Memory and
Automated Translation from the navigation tree. The Translation Memory and
Automated Translation page is displayed on the right.

® Click Add and select File-based Translation Memory from the drop-down list to
add a local translation memory. The Open Translation Memory dialog box is
displayed.

® Select an English (United States) - German (Germany) translation memory and click
Open. The translation memory is added to the list. Only * . sd1tm translation
memories are supported.

Note: For information on migrating your translation memories to *.sd1tm format,
see Chapter 5 - “Upgrading Legacy Translation Memories” on page 117.

¢ If your setup does not include the language pairs specified in the selected translation
memory, English (United States) - German (Germany), the Add Supported Language
Pairs dialog box is displayed where you can select the language pair and click OK to
add it to the setup.

3. To set up your default termbase:

® Select Language Pairs > All Language Pairs > Termbases from the navigation
tree. The Termbases page is displayed on the right.

® Click Add. The Select Termbases dialog box is displayed. If the termbase that you
want to use is not displayed, click Browse to locate a local termbase. The termbase
is added to the list in the Select Termbases dialog box.

® (Click OK. The termbase is added to the list.

Opening a single file for translation

Procedure

1.

Click the File > Translate Single Document iCON in any view. The Open Document
dialog is displayed.

Select the file which you want to translate and click Open.

The Open Document dialog is displayed.
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| Source Language: = English (United States) *1 g
Target Language: | @ German (Germany) . | loptional)
E Create Translation Memory... v| B Use.. - ﬁ Settings... | | ¢ Remove | & Import... Bk, Export... | Upgrade

|
MName Enabled Langusges Lookup Penalty Concordance Update
E English-German.sditm v E - s | v v

0 Set up different translation memories or automated translation providers for a specific language pair from its settings node.

| Do not show this dialog again if the language pair settings for the document are known.

Advanced... Cancel Help

3. Select English (United States) as your Source Language and German (Germany) as your
Target Language.

4. Ifyou already defined your default translation memories for this language pair in the
previous section, the default translation memories are displayed under Translation
Memory and Automated Translation. Add and remove translation memories as
required

5. Click OK. The translatable content of the source language document is identified,
segmented and placed in an *.sd1x1iff file. The file is opened in the Editor window in
the Editor view for translating.

When you use the Translate Single Document command, a project is automatically
created for the opened file. Your default translation memories and termbases (that you
defined in the Options dialog box) are automatically opened. Any settings that you
specified in the Options dialog box are also automatically applied. If you want to change
these settings for this file, select Project Settings from the Home tab of any view to
display the Project Settings dialog.

Open a file for translation from a project

If you are working with projects in Trados Studio, you can open a file for translation from
the Files view. In the Files view, right-click on a file and select Open for Translation from the
shortcut menu. The file is opened in the Editor view. The translation memories and
termbases defined in the project are automatically opened. Any settings that you specified
in the project are also automatically applied.

If you want to change the settings, select Project Settings from the Home tab of any view
to display the Project Settings dialog box.
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ITD files vs. SDLXLIFF files

When you created a project in SDLX or when you started a new translation, the file was
converted to a bilingual format ITD for translation.

In Trados Studio when you create a project or open a document for translation it is converted
to SDL XLIFF, a bilingual format used by Trados Studio. SDL XLIFF stands for SDL XML
Localization Interchange File Format. It is an XML based bilingual file format, specially
developed for use in localization. It is bilingual because it contains both the source document
and the document translation in a single file. When an SDL XLIFF file is displayed in the
Editor window in the Editor view, the source document text is displayed on the left of the
editor window and the target version of the text is displayed on the right.

When you save an SDL XLIFF file, the *.sd1x1iff extension is added to the name of the
source language document being translated. For example, a source document named
Sample.doc would be saved as sample.doc.sdlx1iff. For more information on XLIFF files,
refer to http://xml.coverpages.org/xliff.html

Translating ITD files in Trados Studio

To open and work with ITD files in Trados Studio, first install the Trados Compatibility and
Migration Power Pack. This is a free Trados Studio app available from the RWS AppStore. To
install and enable support for ITD and other legacy files, go to Help tab > Add-ins or visit
AppStore Web version .

Translating Environment

To translate or review documents in SDLX you used SDL Edit which you accessed by clicking
Edit on the SDLX switchboard. When you opened the document in SDL Edit:

® The translatable document was displayed in the top portion of the application.

® The match for of the translation memory was displayed in the bottom half of the
application.

® Recognized terms from the currently selected segment are displayed in the TermBase
Results window.
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In Trados Studio, documents are reviewed and translated in the Editor view. This view
contains the following components:

® Navigation pane, where you can see the documents that are currently open and navigate
between them.

® Tabs and groups containing editing tools.
® Editor window where you perform translation or review.

® Aset of tabbed windows that appear above the Editor window. These include a
translation results window, a term recognition window, a concordance window, a
comments window and a messages window.
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SamplePhotoPrinter. doc.sdbiff [Transktion)

1 Getting Started

2 Finding a location for your photo printer
Place the photo printer on a flat, clean and dust-free surface, in a dry location, and out of
direct sunlight.

4| Allow at least 12 cm clearance from the back of the photo printer for the paper to travel.
When connecting power or USB cables, keep the cables clear of the paper path to the front and
rear of the photo printer.

6 For proper ventilationfB, make sure the top and back of the photo printer are not blocked.

> Allow enough space on all sides of the photo printer to let you connect and disconnect
cables, change the color cartridge, and add paper.

& Connecting and turning on the power

9 [EXENote:

10| Use only the AC power adapter included with your photo printer.

11 Other adapters can damage your camera, photo printer, or computer.

12 To connect and turn on the power, follow these steps:

13 Step

14 Notes

15 Connect the AC power cord to the AC power adapter, then to the back of the photo printer.

1, The AC power cable included with your photo printer may not require assembly, and may be different

from the one shown.

17 Plug the AC power cable into a power outlet.

18 Press the On / Off button to tur the power on.

19 The photo printer initializes and the On/Off button glows steady green.

<HTW  [Erste Schritte
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navigation pane

view specific windows
side-by-side editor
menus and toolbars

Editor Window

The Editor window in the Editor view is where you translate documents. The bilingual SDL
XLIFF document containing the text to be translated and the translation are displayed in the
window, side by side. The source language text appears on the left and the target language
version on the right. The content of the document is broken down into segments (typically
sentences). The target language segments can be edited.

® The first column displays segment numbers. Only one number is displayed for each
segment pair as the source and target segments are aligned with each other by default.
You can choose not to display segment numbers. The source and target segments can
also be worked with as two separate lists.

® Between the source and target segment columns is the segment status column. This
column indicates the current translation status of the segment and its translation origin.
For example, if the translation is approved and if a 100% match was found in the
translation memory for this segment.

® To the right of the target language segments is the document structure column. It
displays a code that tells you where in the original document the segment text appears.
Hover over the code or click on the code in this column to display a description telling
you where the segment appears in the source document.

Migration Guide 83



@ Introduction to Trados Studio for SDLX users

Source Language
Segments

’
—— - —
SanpleFhoioPinier docsdixliff [Translation]”

1 Getting Started %
Finding a location for your O
photo printer

Flace the photo printer on a flat, clean and
dust-free surface, in a dry location, and out
3 | of direct suniight.

Allow at least 12 cm clearance from the back of oA 100%
. 'the photo printer for the paper to travel.

\ -
Segment Status

Document ¥Window
Nanee Tah

2

/EA

Segment
Numbers

Target Language

Segments
] f v X
Messages Window "‘l o
Erste Schritte -‘

Flatzieren Sie den Fotodrucker auf einer LI
flachen, sauberen und staubfreien

Oberflache, und stellen Sie ihn an einem

trockenen Ort auf, der fkeimem dirckten

Sonnenlicht ausgesetzt ist.

Ihuf der Riickseite des Eptodruckers LI
sollte fiir problemlosen Papiertransoort / v

Document
Structure

Translating in SDLX vs. Translating in Trados

Studio

In SDLX, you clicked in a segment and started to type to start translating a segment.

To start translating in Trados Studio, click inside one of the target segments in the document
and simply start typing. This segment becomes the active segment. You can use standard
windows text editing functionality when working in Trados Studio.

Working with translation memories

When you worked with a translation memory in SDL Trados Translator's Workbench, you
could retrieve translations from your translation memory and update the translation
memory. In Trados Studio, the process of retrieving the translations works in a similar way,
however, updating the translation memory uses different logic.

Retrieving translations from the translation memory

When you clicked in a segment in SDLX, a lookup in the translation memory was optionally
performed. The translation memory match for the segment was displayed in the bottom

pane of the application.
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N |
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IFor Help, press F1 1‘\ English {United States) - = German (Germany)

\
Percentage Match

In Trados Studio, translations found by the lookup are displayed in the Translation Results
window where you can then choose one to apply to the current segment. Lookups are
performed on source language segments only.

A translation memory lookup is performed when a segment becomes the active segment.
This happens when you place your cursor in a new segment or when your cursor is
automatically placed in a segment after confirming a previous segment. If you have
automatic row activation turned off, select Home tab > Navigation group > Activate Row
to make it the active segment. When a lookup is performed:

® The best translation memory match is automatically placed in the target segment and
the match is also displayed in the Translation Results window.

® In the example below, a 100% translation memory match [Jilifl has been found and
automatically confirmed. The percentage match is displayed in the segment status
column and the &, symbol indicates that the segment is confirmed.
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\ Segment
Status
Column

Updating the Translation Memory

In SDLX, the TM Filters dialog box was where you could specify how to filter your translation

memory matches.
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In SDLX, the TM Default Field Values dialog box was where you could specify what field
values would be assigned to the new translation units when updating the translation

memory.

“* TM Default Field Values

Walues

Field Yalue Add

Qlire;

Caontent Type

E dit
Remove

Clear

]9

[ Cancel

In Trados Studio, you specify your project and filter settings for the active document in the
Project Settings dialog box on the following two pages:

® Filters - These settings determine what filters are applied to the contents of the
translation memory. These filters are applied to translations retrieved from the
translation memory when lookups are performed.

® Update - These settings determine what field values are assigned to new translation
units when updating the translation memory.

By default, a new translation is automatically added to the translation memory and assigned
the field values specified in your Update settings when you confirm a translation during
editing.
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In Trados Studio, updating a translation memory uses the same method that was used in
SDLX. If you change a translation in your document that was taken from the translation
memory and then confirm the translation, the translation unit in the document replaces the
translation unit in the translation memory. The values that are assigned to the translation
unit are merged with the new ones specified in your Update settings in Trados Studio.

However, in Trados Studio, you can also choose to add a changed translation as a new
translation unit. Before you confirm the changed translation segment, select Advanced tab
> Translation Memory group > Add as New Translation from the Ribbon to add it as a
new translation unit.

Project Settings - Sample Project IEI@

e Project Field Values

"[E# File Types - The fellowing field values will be associated with new translation units added to
- |4 Embedded Content Processors Ei—_l the translation memary:

= erification

<0 ] 4]

Translation Quality Assessment Field Value

P.
P.
P.
P.
P.
4~ Language Pairs
4= Al Language Pairs

4B} Translation Memory and Auto
: - Search

- Penalties

- Filters

- Language Resources

b [§l Termbases

¥ £} Batch Processing

b= English (United States)->German (
b= English (United States)->French (F
p-=# English (United States)->Japanese

(o) [oome ) [

Viewing differences in the source segments

In SDLX if you wanted to view the differences between the source segment text in the
document and the source segment match in the translation memory, you had to display the
TM Difference View window.
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In Trados Studio the difference between source segments is automatically displayed in the
Translation Memory window along with the translation memory match. The blue font
indicates that the text appears in the document and not in the translation memory match.
The red font indicates that the text appears in the translation memory source segment and
not in the source segment of the document.

English-German - Translation Results -« 01 X

wy ProjectSettings Hy B B »
Road Safety Education in our Maticnal Schools

Source |
Seqgment
Text Road Safety Educaticn in our Verkehrserziehung in der Grundschule
__~TPrimaryNational Schools |
Translation 5 Road Safety Education in our Werkehrserziehung in der Sekundarstufe
Memory Secondaryhlational Schools
Match

Road Safety Education in our_ Werkehrserziehung an Schulen
MNational Schools

English-Geman 1/18/2000 3:19:47 PM  STUTTGART wdbrockmann

Working with Terminology

How you work with terminology in Trados Studio is similar to the way you worked with
terminology in SDL Trados Translator's Workbench. Like SDL Trados Translator's Workbench,

you can only work with MultiTerm termbases in Trados Studio. and you can perform the
following actions:

® Retrieve terms from the termbase
® Browse the termbase

® Add terms to the termbase.
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Retrieving terms from the MultiTerm termbase

When you clicked the Open/Get button in SDL Trados Translator's Workbench, a search in
the MultiTerm Desktop termbase was performed.

About this task

e —
Terroase Results X

1Associgtion for Road # 1Tagung der A _ :
Safety - Conference = Gesellschaft fur tRoad SafeMVerkeW
erkehrssicherheit 7
2\Road Safety 2 Road Safety Education '
Education in our in our National Schools /
Mational Schools v v /

Terminology Match

In Trados Studio, terms found by the search are displayed in the Term Recognition window
where you can then choose which one to insert into the current segment. Searches are
performed on source language terms only.

A search in the termbase is performed when a segment becomes the active segment. This
happens when you place your cursor in a new segment or when your cursor is automatically
placed in a segment after confirming a previous segment. If you have automatic row
activation turned off, select Home tab > Navigation group > Activate Row to make it the
active segment. When a search is performed:

® The term that has been found is highlighted by a red bracket in the source segment and
the term translations are displayed in the Term Recognition window.

® In the example below, the term, Road Safety has been found in the termbase with one
translation. To insert the term translation into the target segment, select the translation,
Verkehrssicherheit, in the Term Recognition window and click 7 .
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You can also manually search for a term in the Termbase Search window.

Procedure
1. Click the Termbase Search tab to display the Termbase Search window.

Termbase Search -~ 1 X
road ® 3 Z

road zafety  Sample CJK

\ Insert term
translation
into the

target
segment or

view term
details.

2. Type the term you want to search for in the box at the top of the window and press
[ExTER]. In the example above, photo printer was entered and one translation has been
found.

3. You can then do the following:

® Select the term translation, Fotodrucker and click (% to insert the term into the
source segment.

® (lick [@ and the term entry is displayed in the Termbase Viewer window.
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Browsing and adding terms

You can browse terms and add terms in the Termbase Viewer window. To display this window,
do one of the following:

® Select View tab > Information group > Termbase Viewer. The terms from the default
termbase are listed here in alphabetical order.

® Select a term in the Term Recognition or Termbase Search window and click & .

® Highlight a term in the Editor window and right-click and select Add Term from the
shortcut menu. A new entry is displayed in the Termbase Viewer window.

Choose a Choose an input Edit and save
layout for the model adding terml:rase
Entry Pane terms Entr:es

\ |
— K\_
[@,|| Termbask Viewer |I
2 Flags layout - (Mo input model) [ 0
3
£ || AC Entry number: 10
2 || AC power cable Hiustration:
7 || AC power cord

1=

i || alternating current X
AP Entry
Browse | A7 Pane
API Audio Products r—— 4

Pane™. T .
Application Prograrmming Interface
Automated Processes, Inc.

color cartridge 5= English

color cartridge ribbon photo printer
ContraPLUS Status: Preferred
fﬂBt photo-printer
interface Status: Forbidden
LED

Light-emitting dicde |== German

matrix mistjet printers

Matrix Mistjet Printers Fotodrucker

Working with tags

In SDLX, standard recognized formatting tags were hidden. For example, text that was
tagged as bold was displayed in bold with no tags. For other types of tags in SDLX, you were
able to choose whether text with tags was highlighted or if the tag text was displayed with

a marker, partial text or full text. You could change this setting in the Display Tags dialog box.
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Display Tags...

Dizplay farmatting information uzing
{(*) Colours [Standard colour formatting]

() Tags [Display tag az marker]
() Shart Tags [Display tag name only]
) Long Tags [Displays tag name and info.]

By default, Trados Studio settings specify that recognized formatting tags are hidden,
therefore when you insert commonly used tags from the QuickInsert group on the Home
tab or by another method, the tags remain hidden and instead the text is formatted in the
style in the Editor window. For example, text that is tagged as bold is displayed in bold

with no tags.

For more information, contact your local branch of the
Teachers Education Programme Foundation.

In Trados Studio you can choose to show recognized tags, by selecting a different option
from the Formatting display style drop-down list in the Options dialog box.

Trados Studio has similar tag display options to the ones that were available in SDLX. In
Trados Studio you can change the tag display from the Editor view using the View tab >
Options group. By default, tag text is only partially displayed.

& MNoTag Text & Tagld
& Partial Tag Text G Toggle formatting tag display
& Full Tag Text

Opticns

Translatable attribute tags

The way that translatable attribute tags are treated in Trados Studio is similar to how they
were treated in SDLX. In most cases in SDLX, translatable attributes were put into a separate
segment to help to reuse the translation of attributes in other segments. However, this
varies depending on what filter was used

In Trados Studio, a translatable attribute tag is split into a separate segment from other text
in the document. The new way of segmenting this tag allows you to reuse the translation
no matter where it occurs.

For example an image with tooltip text (ALT Attribute) is displayed in the following way in
Trados Studio:
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Part 2: Translatable
Text
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Inserting tags

In SDLX, there were three ways to insert tags. You could:
® Select a word in the target segment containing formatting and type over that word,
® Select standard formatting tags from the toolbar, or
® Use format painting to copy formatting from the source segment to the target segment.

B I 0O

C2En et (-1, Edcation in our National
Schools

In Trados Studio there are a variety of ways to apply the correct tag formatting to your
translations. Like SDLX, in Trados Studio you can still select a word in the target segment
containing formatting and type over that word.

You can also insert tags using your mouse or your keyboard. The following instructions
describe how to apply italic formatting to text in your target language segment using your
mouse or by using keyboard shortcuts.

Inserting tags using your mouse

Inserting tags in Trados Studio using your mouse is similar to format painting in SDLX.
However, in Trados Studio you do not need to be in Format Paint Mode.

Procedure
1. Click inside the target segment where you want the italics formatting to be applied.

2. Place the cursor over the source segment text that has the italics formatting and press
[cTrL]. The formatted text is highlighted in gold.

e e e = ducaiiun programme dETiE el

3. With the [cTrL] key depressed, mouse-click on the formatted text in the source segment
text. The formatting tag pair is inserted into the target segment at the point where the
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cursor is located. Click inside the tag pair and start typing.

Note: In Trados Studio you can insert tags from the QuickInsert group in the Home
tab of the Editor view and copy and paste tags from the source and target segments. In
addition, you can create custom QuickInsert tags.

SDL Trades Studio - Sample Project

Help
— - - -0« £ .@i
@@ m
Concor
v Sear
QuickInsert M | Translatic

Inserting tags using your keyboard and the QuickPlace drop-down list

Procedure

1.

When the cursor is at the point where you want to type text formatted in italics in the
target segment, press [cTrRL]+[, ]. The QuickPlace drop-down list is displayed below the
target segment. Depending on your settings, this list shows sample text with formatting
applied or a list of tags from the source segment.

® The example of the QuickPlace drop-down list on the left shows sample text
formatted in italics and in bold. The second example of the QuickPlace drop-down
list on the right, shows how the bold and italic tags may display if you change your
default tag display settings. There is more than one choice on the lists because the
source segment has text formatted in both of these styles.

[zample faxt!

[zample text]

<of italic="on"">

| <ch Bold="on"> J

® The first type of formatting from the source segment is selected automatically. In
the source segment, the text formatted by the tag is highlighted.

Press [ENTER] or [TaB] to start applying the formatting or to insert the italics tag into the
target segment. If you selected an italics tag, a ghost tag is also inserted.

Note: A ghost tag is a marker tag that is automatically added to a segment when the
segment contains an incomplete tag pair. For example, if you delete a tag that is one half
of a pair, the system will automatically display a ghost tag until you replace the missing
tag. Ghost tags only occur in tag pairs, as only tag pairs require a beginning and an end
tag to function correctly. A ghost tag looks like a grayed-out version of an ordinary tag.
You cannot edit ghost tags but you can restore a ghost tag to a real tag.
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Areal tag Aghost tag

EW Erzichungsprogramm
vom Bildungsminister vorgestellt

3. Continue typing. The italics formatting is applied to the text.

When you want the formatting to stop being applied, click [cTrL]+[.] to select the
formatted text from the drop-down list again or insert the closing tag of the pair.

For more information on working with tags, refer to the online help in Trados Studio .

Working with placeables

Placeables are source document content that has been recognized as:

® content not requiring translation, or

® content which can be automatically localized by applying a translation memory. For
example, some dates can automatically be converted to the correct format by applying
a translation memory.

Similarly to Trados Translator's Workbench, placeables are identified by a blue square-
bracket underline in the Translation Memory window:

Fiegister today EAEERENTEEREEENEEEN and obtain a M discuuntﬂ!

The previous section described how to insert tags which are a type of placeables. To insert
other placeables, such as numbers, variables and dates you can follow the same procedure.
The following instructions describe how to insert 20% in to your target segment by using
your mouse or by using keyboard shortcuts.

Inserting placeables using your mouse

Procedure
1. Click inside the target segment where you want to insert 20%.

2. Place the cursor over 20% in the source segment text and press [cTRL]. The 20% text is
highlighted in gold. 2o%,

3. With the [cTrL] key depressed, mouse-click the 20% in the source segment text. 20% is
inserted into the target segment at the point where the cursor is located.
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Inserting placeables using your keyboard and the QuickPlace
drop-down list

Procedure

1. When the cursor is at the point where you want to insert 20% in the target segment,
press [cTrRL]+[, ]. The QuickPlace drop-down list of the placeable from the source
segment is displayed below the target segment.

2. Press [ENTER] or [TAB] to insert the 20% into the target segment.

Previewing a document

In SDLX there were two types of previews available. These previews were accessed by clicking
one of the following buttons on the toolbar:

® View Source & - Preview the source language document

® Translation Preview & - Preview how the text will appear when you generate the
translated document.

@i SampleStudio_DE. doc - Microsoft Word

File Edit Wiew Insert Format  Tools Table Window Help  Trados  adobe PDF
! Acrobat Comments =
—1
El'l' 'I'IEI'Z'I'3'I'4'I'5'I'E'I'?'I'8'I'E!'I'1I:I'I'11'I'12'I'13'I'14'I'15'I'1E~'c,'1?'l ~
; Tagung der Gesellschaft flir Verkehrssicherheait
. Werkehr=erziehung in der Sekundarstufe 1
" Fark Hatel, Crublin &, Ireland -
. The Mational Aszociation for Road Safety (AR S invites all pimany school teachers to padicipate
. inadaylong conference on Foad Safety education for four to eleven year old children. This
> conference presents the newedvoation pmg@asare unwveiled by the Minister for Education last
R year.
" Far more information, contactyour local branch of the Teaohers Educafion Pogamae
z Fowmd o
- ’ Lv2
o —
. Callect the conference motor car mascots faryour schoal, +
~ Register todayand obtain 32012522009 o discount! &
- ¥
=eE@]=w< | »
Page 1 Sec 1 11 Endlish (.5

There are three types of preview in Trados Studio:

® Preview in the Preview Window- Displays the document in the Preview window in the
Editor view.

® Preview in the Native Application - Displays the document in the application in which is
was originally created. The applications available to preview the document depend on
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what settings are specified in your file filters and what applications are installed on your
machine.

® Print Preview - Displays the document as a bilingual SDL XLIFF file in a web browser. The
source and target text is displayed side-by-side. When you preview the document you
can also print it from your web browser.

Like SDLX, you can choose to preview the document source or target text or you can display
source and target text side-by-side.

Real-time preview

You can also select to preview in real time. If you select this option, the translation preview
is updated to reflect the changes as you type. This update occurs every time you confirm a
segment. The currently active segment is highlighted in the Preview window. If you click on
the active segment in the preview, your cursor is automatically placed in the active segment
in the document.

Note: For more information, refer to the online help in Trados Studio. Real-time preview
may not be available for all file types .
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Confirming a segment

When you have finished translating a segment you should confirm the segment to indicate
that the translation is complete. To confirm the translation, place your cursor in the
translated segment and select Confirm from the Home tab > Segment Actions group or
press [cTRL] + [ENTER]. When you confirm a translation:

® The segment status is changed to Translated and the £ icon is displayed in the segment
status column.

® The translation is automatically added to the translation memory. If you are using a
project translation memory, the translation is added to the project translation memory
and not the main translation memory.

® The translation can be viewed in the Preview window.

® Segment verification is performed. Segment verification errors are displayed in the
Messages window.

® Trados Studio automatically places your cursor in the next segment, skipping all locked
segments.

Note: By default, when the system applies a 100% translation memory match to a segment,
the segment is automatically confirmed. This is an optional setting which is controlled from
the Options dialog box.

When the status of every segment in a document is changed to Translated, the status of
the document changes to Translated.

Opening a file for review

In Trados Studio you can also open a file for review. When you open a file for review the
screen layout in the Editor view changes to the review layout and the list of statuses available
to apply to segments changes to show review statuses only.

In the Editor window, the source language segments are displayed on the left and target
language segments on the right. The segment status column in between the source and
target segments contains information about the target segment status, for example whether
the translation has been confirmed.
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Editor
[ SamplePhotoPrinter

» [Getting Started|

& Welcome
w Projects
Files

4 Reports
/ Editor

g Translation Me...

SamplePhotoPrinter.doc sdiiif [Review]

' Getting Started
2 Finding a location for your photo printer
Place the photo printer on a flat, clean and dust-free surface, in a dry location, and out of direct
sunlight.
4 Allow at least 12 cm clearance from the back of the photo printer for the paper to travel.
5 When connecting power or USB cables, keep the cables clear of the paper path to the front and
rear of the photo printer.
6 For proper ventilationfBl, make sure the top and back of the photo printer are not blocked.
Allow enough space on all sides of the photo printer to let you connect and disconnect cables,
change the color cartridge, and add paper.
8 Connecting and turning on the power
9 EFAINote:
10 Use only the AC power adapter included with your photo printer.
11 Other adapters can damage your camera, photo printer, or computer.
12 To connect and turn on the power, follow these steps:
13 Step
14 Notes
15 Connect the AC power cord to the AC power adapter, then to the back of the photo printer.
16 TheAC power cable included with your photo printer may not require assembly, and may be different
fiom the one shown.
17 Plug the AC power cable into a power outlet.
18 Press the On / Off button to turn the power on.
Comments(0)
© Errors
Severi S/ Comment Segm  User

Document Scope

Comments(0) | % TQAs (0) @ a4

<l |Ersbe Schritte

DD DODDODD0OD 00D DD SN

Platzieren Sie den Fotodrucker auf einer flachen, sauberen und staubfreien Oberflache, und u
stellen Sie ihn an einem trockenen Ort auf, der keinem direkten Sonnenlicht ausgesetzt ist.

4 Wamings @ Information [ Show Comments for Active Document Only | Show Source and Target Comment v

Date Version D

Sample Project | -

ple Project_E

enpy <

sdiL Injesn =4 | 00N Aeidsi] peo

Y All segments INS [186.76% ¢ 12.33% £0.91% 50.00% /30.00% B Chars: 14 2 0/1001 ™ ->==

Verification

SDL Trados Translator's Workbench had a series of verification plug-ins that allowed you to

verify or validate the tag content of your target files and run quality assurance checks.

These verifications have been enhanced for Trados Studio. Some of the verifiers can be

configured for each individual file type and some can be configured at language pair level.

To perform verification on:

® asegment, confirm the segment.

® anindividual file when you have finished translating a file, go to Review tab > Quality
Assurance group > Verify in the Editor view.

® agroup of project files, select Home tab > Batch Tasks in the Projects or the Files view
and select Verify Files from the Batch Tasks drop-down menu.

Verification errors for segments or individual files are displayed in the Messages window in

the Editor view of Trados Studio.

Messages (3)

Q
L

Severity
A

Y
i

€) OFErrors £\ 3 Wamings (1) 0 Notes
Message
End punctuation difference detected.

End punctuation difference detected. (Message is outdated. ..

End punctuation difference detected.

~ 01 X

4l

* Origin

@A Checker 3.0
@A Checker 3.0
QA Checker 3.0

The following verification types are included in Trados Studio:
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Tag Verification Tag verification compares the tag content of target
material with the tag content of the original source
material and identifies any changes that were made.
Changes in the target material are acceptable
provided that the syntax of tags remains intact and
that the translated document can be converted back
to its original format. Tag verification helps to ensure
that only acceptable changes are made.

The settin%s for this verifier are defined for each
individual file type.

QA Check 3.0 QA Checker 3.0 incorporates a suite of quality
assurance checks. The checks are broken down into
the following areas: Segment Verification, Segments
to Exclude, Punctuation, Numbers, Regular Expres-
sions, Word List, Inconsistencies, Trademark Check
and Advanced.

Terminology Verifier Terminology Verifier checks your current document to
ensure that the target terms contained in the
MultiTerm termbase have been used during
translation or to verify whether forbidden terms have
been used.

Global verification settings for verification are defined under File > Options > Verification.

Language specific verification settings are defined under File > Options > Language Pairs >
<language pair> > Verification

Options oo )
b g Editor Verffication
’ l_EI .-':‘\.!.ItOSLIggest ¥§rulfIE:T‘:Oenn:bEII;EE!IIizgbﬁgﬁzsiv?g:!:P;pri.;:ﬁ in the list below.
v~ [E} File Types
¥~ [E} Embedded Content Processors
b4 QA Checker 3.0 QA Checker 3.0
b ¥ Tag Verifier Tag verfication
b (& Terminclogy Verifier Terminclogy Verifier
% Translation Quality Assessment

A Language Pairs

15 Default Task Sequence

B Tranzlation Memories View
&) Colors

Keyboard Shortcuts

@ Automatic Updates

& Welcome View

v T T W T T W

o) (ol ) [
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Create translation vs. Finalize

When you have finished translating a document, the source and target segments are still
stored together in the document. In SDLX you used the:

® SDL Project Wizard: Create Translations wizard to generate target translation of the
files in their native format for files from a project or individual files.

® Create Translation command in SDL Edit for an individual file.

In Trados Studio, there are three different commands you can use to create target
translations for one individual file or a group of files. In addition, you can also choose to
update the translation memory at the same time.

Finalize

Generates the target translations and updates the translation
memory for one or more files at the same time. Right-click on
the project in Projects or right click on the selected files in
Files view select Batch Tasks > Finalize from the shortcut
menu.

Save Target As

Generates a target translation for a single file in the Editor
view. Select File > Save Target As from the Ribbon in any
view.

Export Files

Generates a target translation for a group of files at any point
in the project life cycle. Right-click on the project in Projects
or right click on the selected files in Files view select Batch
Tasks > Finalize from the shortcut menu.

Home | View  Add-ns
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Project Cpen For Batch Create Project
Settings Translaticn Tasks » [ 2y 230 Package
Cata group Configuration Open File Actions GroupShare Packages Layout
Files < Name Words Status Progress Size Usage File Type Iden.  Path Local ¢
] SamplePhotoPrinter.doc sd... 219 InTranslat.. 52KB Translatable Word 2000-200.. % nla
= German (Germany) - ] TryPerfectMatch doc. sdldiff 224 In Review E3KB Translatable Word 2000-200. 4 nla
Project folders h?__l_] SamplePresentation " T 4 E5KE T PowerPoint 200.. % na
= Sample Praject fiw, SecondSampledocy # OPen FerTrensiation 23 TEKE Translstable  Word 2007 v 20 | wa
1 Wy Tasks [2] SampleXML_DITAx “a  Open For Review 130 KB Translatable XML DITA 11w b nla
W Sent Tasks % Open For Sign-off
(BT late (to yghnb!
(®) Translate (to yghnt) Batch Jasks 3
= CIEEZE%ICJEEZ Package Analyze Files
B  Create Studio 2009 Package Translation Quality Assessment
‘
4 *:  Explore Containing Folder Generate Target Translations
File Details =3 Apply PerfectMatch
e 5 B! Open File With Populate Project Translation Memories
[] Include subfolders Size 384 KB Pseudo-translate
_________ \niords 32 ) Update from Reviewed Target File (Retrofit)
& Welcome i} Export for Bilingual Review
e Update from Bilingual Review
- Projects =) Pre-translate Files
= Files 8 Change Phase ¥ Translation Count
- w&  Assign to Users in Phase v Update Main Translation Memecries
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Creating and managing translation
memories

In SDL Trados Translator's Workbench, you created and maintained translation memories.
In Trados Studio, you create and maintain translation memories in the Translation
Memories view. This view contains the following components:

® Navigation pane, where you can see the file and server-based translation memories
that are currently open and navigate between them. You also see language resource
templates.

memories.

unit.

Tabs and groups containing maintenance tools.

TM side-by-side editor window, where you perform maintenance on your translation

Search Details window, where you create and apply filters to your translation memories.
Field Values window, where you view and edit field values for the selected translation

B®®rRoc-o-- Trados Studio - Sample Project @ - & x
I vome | view  Addns  Help @ Tell me what you want to do... [
X% [ Batch Edit < TUs per Page: | 50 - % Y. o & MarkTU for Deletion & Fin
w g 4 2 & 23 ® m K & 85
[R Batch Delete > Next Page Y. Add B Import & R Rep
Project  _ Open New Import Export Migrate Local Align Create AutoSuggest Page: | 1 | outof314 Perform __ »
Settings - - £ Settings TMsto Cloud ~ Documents ~ Dictionary 1 Last Page 5 Search ¥ B
Configu... Clipboa. Tasks 5 Cloud Resour. Tools Navigation Pagination Filters Save Editi | a
Translation... < |[Feerch Detais lx|e
=z
TR TM Filter: [ <no filter> VRRRTNRR £
B ClupWed-0T-file-ba || ko Name — [<no filter> ] o
8, English-German 2 3
Language Resource T || Source Text [ ]
Target Text | |
Search Type | Search entire TM -]
v
English-German [en"US->deDE]_CluWed-01-file-bosed [en US >de DE] X Field Values 2 x
If you receive the message pCannot Confinue the Hardware Update Wizard4, contact the Intel _Wenn Sie die Meldung Fortsetzung nicht mogichd ernalten, besuchen Sie die Intel | ~ FomomFode

Corporation Support Web site at pwww.intel.com/support/4.

If you selected Use saved usemame and password, enter the password in the pPasswordq
field, up to 256 characters.

Specifies that identity privacy protection is enabled.

Adapter Settings

Back to Contents

An administrator can configure the Intel(R) PROSet/Wireless Application Settings to control how
the application behaves on the user's computer, and to select what level of control users have
over various aspects of their wireless connections.

™

e

>

To configure Adapter Settings:
Click PpInclude Adapter Settings in this packaged.

=

in the

Corporation Support-Website unter pwww.intel.com/support/4.

Wenn Sie "Gespeicherten Benutzernamen und Kennwort” gewéhit haben, geben Sie
das Kennwort im Feld pKennwort{ ein (maximal 256 Zeichen).

Legt fest, dass der Identitats-Datenschutz akiiviert ist.

Adaptereinstellungen

Zuriick zum Inhaltsverzeichnis
Benutzers verhélt, und um auszuwahlen, wie viel Kontrolle Benutzer iiber die
Kiicken Sie auf pAdaptereinstellungen in dieses Paket einschiiefend. 3

Infrastructure networks are identified with an access point image (P
Wireless Networks and Profiles list.4

5

Ein kann die von Intel(R) PROSet/Wireless
konfigurieren, um zu steuern, wie sich die Anwendung auf dem Computer eines.
verschiedenen Aspekte ihrer drahtiosen Verbindung haben.
So konfigurieren Sie die Adaptereinstellungen:
werden in der Liste der drahtiosen Netzwerke und in der
i angezeigt (P p?

Profiiste mit einem

Field Value

ystem Fields

. Navi

ua oA W =

gation pane

Search Details window
TM side-by-side editor
Field Values window

. Ribbon tabs and groups

o For each seting listed in the table below, select one of the following optons: Wihlen Sie fiir jede in der unten stehenden Tabelle aufgefiinrte Einstellung eine der Fc‘i‘:‘ed o V‘::“e
# Welcome foiganden Optoner: Created on 11/16/2007 11:40
11 Provides a space for you to enter the outer identity, up to 256 characters. Stellt Ihnen einen Platz fiir die Eingabe der externen Identitét mit bis zu 256 Zeichen e
= Projects 2ur Verfiigung Lost modifed by | serviceintel
Files 12 The default is "anonymous”. Der Standard ist "anonym". Last modified o 7/11/2008 3:44:35.
- — 13 Server vaiidation settings. Servervalidierungseinstellung. Lestusedby BN
14 Specifies whether your computer connects to a server only if it resides within a particular Legt fest, ob Ihr Computer nur zu einem Server verbindet, wenn er sich innerhalb einer Last used on 7/17/20099:03:34,
/ Editor domain or has a specific name. bestimmten Domain befindet oder dber einen bestimmten Namen verfigt. Usage count 2
& Transiation Me.. Provides a space for you to type the name of the required server or domain that the server Sieht einen Platz fiir Sie vor, um den Namen des erforderiichen Servers oder der
5 Must reside in. For example, if you only want to connect to servers that reside in example.com,  Domain einzutippen, in der sich der Server befinden muss. Wenn Sie beispieisweise
| —— T ]
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Creating a Translation Memory

In SDLX when you created translation memories, you specified the name of the translation
memory and which user was creating the translation memory. The languages contained in
the translation memory were not specified until it contained translation units. You created
translation memories in SDL Edit and SDL Maintain.

“ New Translation Memory

Login
User [ETETTMMMMIIIINN | [ new |
Optionz

Stare Context Information

[ ok, l [ Cancel

In Trados Studio, to create a translation memory in the Translation Memories view:

® You can select File > New > Translation Memory to create a file-based translation
memory. The New Translation Memory wizard is displayed.

® You can select File > New > Server-based Translation Memory to create a server-based
translation memory. The New Server-based Translation Memory wizard is displayed.

@ New Translation Memory — a X
@ 2 3 4
General Fields Language Resources Finish

1 of 4 completed

Name: * ™

Description:

Copyright:

Location: * C\Users\hhopirtean\OneDrive - SDL\Documents\Studio 2021\Translation Memories

Source Language: * E English {(United States) -

Target Language: * | ™® German (Germany) -
Enable character-based concordance search

Help Back Next Cancel
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Settings that you defined after creating a translation memory in SDLX are now included in
the creation process in Trados Studio. You can specify the following in the New Translation
Memory/New Server-based Translation Memory wizard:

® The name, location and languages of the translation memory.

® The fields for the translation units in the translation memory, and translation memory
settings.

® The language resource template. You can create or modify language resource lists.
These lists are used in conjunction with the segmentation rules in translation memory
processing and to identify untranslatable content.

Editing a translation memory setup

In SDLX you edited translation memory settings in several different locations. Custom
translation memory fields and their values were created and edited in the TM Fields &
Attributes dialog box which was accessed from SDL Maintain, SDL Edit and SDL Apply.

“ TM Fields & Attributes

Fieldz

Mame Type b ultiple Add

Document Type Aftribute '

Custarmer Test Mo
Field Definition Alttributes
Mame | Add
|D|:n:ument Type Orline

Print Femove
|.ﬁ.ttribute w |
Al multiple selection
[ (] l [ Cancel

Segmentation rules in SDLX were stored in a segmentation file that could be edited from
SDL Apply, SDL Edit, SDL Analyse and the Project Wizard.

In Trados Studio the segmentation rules are stored with the translation memory. The
segmentation rules used in the translation memory are automatically applied when you
open a document and have the default translation memory specified for that language pair.
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In Trados Studio, both custom fields and segmentation rules can be edited in the Translation
Memory Settings dialog box. To display this dialog box, select the translation memory that
you want to edit settings for from the navigation tree in the Translation Memories view and
then select Home tab > Tasks group > Settings.

| Translation Memory Settings - English-German — ] X

| 4 [ English-German

i Fields and Settings
| Language Resources Description: sample English-German translation memary

Mame: English-German

Access Rights

Performance and Tuning

Fragment Alignment Copyright: |[C] 2008 5DL

Location: |C:\.Documants\.TMs

Source Language: |Eng|ish {United States)

Target Language: |German (Germany}

Created By: |STU1TGART\dbrockmann |

Created At: [18-Feb-09 |

Translation Units: |1099D |

You can edit and view the following sections:

® [t™ Name] - This is where you can view general details of the translation memory, for
example, name and source language. You can also modify the translation memory
description.

® Language Pairs - This is where you can view which language pairs are in the translation
memory. This page is only displayed for server-based translation memories that are
multilingual and can contain more than one language pair.

® Fields and Settings - This is where you can view existing fields and create additional
fields in the translation memory. You can also specify translation memory settings.

® Language Resources - This is where you can modify language resource lists in your
translation memory. These lists are used to specify segmentation rules in translation
memory processing and are also used to identify untranslatable content. The language
resource lists can be shared between multiple users.

® Access Rights - This is where you can protect file-based translation memories by defining
passwords that are linked to translation memory maintenance or a users rights.

® Performance and Tuning - This is where you can use different tools to improve the
performance of server-based translation memories searches (on the selected translation
memory). This does not apply to file-based translation memories.
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Translation Memory segmentation

In SDLX, the segmentation rules that were used in your document could be specified when

you created a

new translation.

Mew Translation

Sounce

Filenarne: |N:'xTeu:hniu:aI PublicationzAEmma temp folders R ivelin test ilez\Rivelin | [ Browse... ]

Language: | Englizh [Urited States) b | |Western European [windows) b |

File Type: | Microzaoft Waord w | [ Optiohs. .. ]

Tranzlation

Language: | German [Germany) L | |'W'estern Evropean [Windows] w |

Se

Active Rules: | Default Edit Rules...

st | (e

5 (ova ]

In Trados Studio, the rules used to segment your document are stored in the translation
memory that you selected when opening your document or when creating your project.
These rules can be edited in the Translation Memory Settings dialog box under Language
Resources or when you create the translation memory.
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-

4-8 English-German

Translation Memory Settings - English-German

Language: % English (United States)

Resources:  Tupe

Importing and exporting

In SDLX you imported and exported translation memory data in SDL Maintain.

Import Wizard - Files E|

SD

Select the files to be imported:

Segmentation Rules
(7 Paragraph based segmentation
@ Sentence based segmentation
Rules
Cther terminating punctuation (question mark, exclamation mark)
o
Reset to Defaults
[ ok ][ cancel | [ Heb
[ ok

] [ Cancel | [ Hep

=4 |
=3 Documents and Settings
= emaunt
= Desktop
=7 Rivelin test files
ENUS_DE i

unl
i
=
o
=
o

Filez Selected

&dd

Clear

I

< Back Mest »

l [ Cancel ] [

Help
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In Trados Studio, you can import translation memory data using the Import wizard. To
display this wizard, select the translation memory for which you want to import data from
the navigation tree in the Translation Memories view and then select Home tab > Tasks
group > Import.

B Import — ] b4
P
@ o ® 4
Import Files Bilingual Document Import Options General Import Options Import

3 of 4 completed

Apply Field Values: Edit...

[ Import translation units as plain text
[ Exclude language variants
1 Export invalid translation units
Export Location: Browse...
If target seaments differ:
@ Add new translation units
(O Overwrite existing translation units
(O Leave existing translation units unchanged

(O Keep most recent translation units

Use information from bilingual file to update TU system fields

Help Back Next Cancel

You can assign field values to newly imported translation units. For example, you may want
to indicate the type of document the imported translations are for, such as, software or online
help.
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B Import - O X
o @ 3 4
Import Files TMX Import Options General Import Options Import

2 of 4 completed

Filter: NOT Created on != "10/7/2021 7:23:19 PM" | | Edit.. |

Unknown Fields: | Add to translation memory ~

Please select the scenario that applies best to you:

@ The imported data will be primarily used with new, native source files or files processed only with Trados Studio
(O) The imported data will be primarily used with presegmented legacy Trados ITD or TTX files

() The imported data will be primarily used in mixed scenarios

Help Back Mext Cancel

Depending on the source you import data from, you can apply a filter so that only translation
units that match the conditions of the filter are imported. Filters are based on the field
values assigned to the translation units that are being imported.

If imported translation units have fields associated with them that are not part of the
translation memory, there are several different options on how to import those translation
units. For example, you could specify to only import translation units that contain the same
fields as the translation memory you are importing into or you could add the fields from the
imported translation units to the translation memory.

Translation Memory maintenance

In SDLX you performed maintenance on your translation units in SDL Maintain. You could
use filters to search for the translation units you wanted to edit. You could delete and edit the
text of a translation unit.
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test.mdb - SDL Maintain

TM Edit Format Wiew Tools Help
e o X 2 on| ? N2
Filker |<n|:| filker actives V| S 141
1Tagung der Gesellschaft fur A ssociation for Road Safety - 4
Yerkehrssicherheit
2erkehrserziehung in der 2 Eoad Safety Education in our
Sekundarstufe Secondary Schools
3 Tagesordnung: _Agenda:
14 dieser Tagung wird das neue | 1This conference presents the new |
3 Schnelle Anmeldung wird empfohlen, S Hurry, as places are limited!
da die Teilnehmerzahl begrenzt ist.
6 | sich anzumelden, wenden Sie 6 To register, contact your local branch
sich bitte an die ortliche Yerretung of the Road Safety
der Gesellschaft fur i Association adfads  [Madified By=emount Context

In Trados Studio, you can perform maintenance directly in the Translation Memories view.
You can use the Search Details window to find the translation units that you want to edit.
The translation units are displayed in the TM side-by-side editor.

TM Window Name Source Language Target Language
. Tab Segments . Segments
\ ;
English-German [en-US-»de-DE] j,ff / ¥ X |Field Values -« 0 X
1 Association for Road”  Tagung der Gesellschaft “ | custom Fields
Safety Conference fiir Verkehrssicherheit L Fiold Valoe
Road Safety Verkehrserziehung an
2 Education in our Schulen
Schools
i Road Safety Verkehrserziehung in der
3 Education in our Sekundarstufe
Secondary Schools System Fields
Road Safety Verkehrserziehung in der Field “ Value =
4 Education in our Grundschule Created by CAROL-AMN
Frimary Schools Created on 11872000 3:15..
This conference AUF dieser Tagung wird Document st.
|| nrecents the new [ Y das neus b ) T || 1A=t modifis . STITTGARTA | ™
Tranlslatiun Unit Document ' Field
Status Column structure Yalues
Column

To change the segment text, simply click in the segment and start typing. Use the Save
group on the Home tab in the Translation Memories view to:

® Mark a translation unit for deletion.

® Save (Commit) changes to the translation memory or discard or undo your changes as
required.
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Use the Field Values window to assign custom field values to the translation unit selected in
the TM side-by-side Editor.
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@ About Data Migration

Overview

You can upgrade and migrate the following data from SDL Trados, SDLX and other translation
memory software to Trados Studio 2024.

SDL Trados Studio 2009 Translation Memories (Server-based)
SDL Trados (2007/Pre-2007) Translation Memories (Server-based)
SDLX Translation Memories (File and server-based)

TMX Files (Version 1.4b)

SDL Trados INI Tag Settings Files (SDL Trados 7.x, SDL Trados 2006 and SDL Trados 2007
versions)

SDLX ANL Tag Settings Files (SDLX 2007).

Depending on what you are upgrading or migrating different associated data can be also
upgraded.

Note:

For information on how to upgrade server-based translation memories from SDL Trados
Studio 2009 to TM Server 2020 SR2 format, refer to the Trados GroupShare 2020 SR1
Installation Guide .

File-based translation memories from SDL Trados Studio 2009 and SDL Trados Studio
2011 do not need upgrading and are the same format as translation memories in Trados
Studio 2024.

Make sure you have installed the Trados Legacy Compatibility Pack app from the RWS
AppStore before you start working with ITD, TTX and BilingualWorkbench TMs in Trados
Studio.

Upgrading translation memories

You can upgrade translation memories from SDLX, SDL Trados and other translation memory
software. There are several upgrade methods from which you can choose. To determine
which method to use you should consider the following:

® What files are available to upgrade.

® What files are supported for upgrade.

® What associated data you want to migrate alongside the translation memory.
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Method 1: Upgrade Translation Memories

Use this method to upgrade your legacy translation memories from SDL Trados 2007 and
SDLX 2007. See “Upgrading Legacy Translation Memories ” on page 117.

Method 2: Upgrade using TMX Files

Use this method to upgrade or import TMX files from SDL Trados 2007 and SDLX 2007 and
other translation memory software. See “Populating Translation Memories from TMX
Files” on page 143.

Method 3: Upgrade using bilingual files

Use this method to upgrade using bilingual files TradosTag (TTX) and SDL Edit (ITD) Files
from SDL Trados 2007 and SDLX 2007. See “Populating Translation Memories from
Bilingual Documents ” on page 167.

Method 4: Upgrade using alignment tools

Use this method to upgrade using translated files that are aligned with their source in SDL
Trados WinAlign or SDL Align. See “Populating Translation Memories from Alignment
Result Files " on page 177.

Supported upgrade translation memory file
formats

The following table describes what support is offered for using the different methods of
upgrading your translation memories from different products. Make sure you have installed
the Trados Legacy Compatibility Pack app from the RWS AppStore before you start working
with ITD, TDX and BilingualWorkbench TMs in Trados Studio.

@ Supported

~ Limited Support

Upgrade | Upgrade Upgrade Upgrade Upgrade  Upgrade

Using Segmentatiamsing TMX using TMX using Using
Upgrade  Rules (version (pre 1.4B) Bilingual | Bilingual
TMs 1.4b) TTX ITD
Wizard

Trados o [ [ o

2007 Suite

Trados o [ [

2007 SP2

Trados [ o o

2006
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Product Upgrade | Upgrade Upgrade Upgrade Upgrade  Upgrade

Using Segmentatioamsing TMX using TMX using Using
Upgrade  Rules (version (pre 1.4B) Bilingual | Bilingual
TMs 1.4b) TTX ITD
Wizard

Trados7.x |@ o

Earlier o

Versions of

Trados

SDLX

SDLX 2007 |@ [ o o

SDLX 2006 |@ [ ] o

SDLX 2005 |@ o ®

Miscellaneous

3rd-party ~ ~

Translation plain text |plain text

Memory only only

Software

Reusing translations from bilingual files in
PerfectMatch

You can extract translations from previously translated bilingual documents from SDL Trados
2007 and SDLX 2007 and transfer them to Trados Studio project files. This is accomplished
by applying PerfectMatch to your project in Trados Studio. It allows you to leverage
information from previous translations and apply them to new translations. You can do this
with the following bilingual formats:

® SDL Trados 2007 TTX
® SPLX 2007 ITD

For more information, see “Reuse Translations From Bilingual Documents in PerfectMatch ”
on page 183.

Migrating INI and ANL files to Trados Studio

You can migrate the tag settings you use for XML and HTML translation. The settings identify
what content is translatable or not translatable in a file. You can migrate the following tag
settings files:

® SDLX (ANL)
® SDL Trados (INI)

For more information, see “Migrating INI and ANL Tag Settings Files ” on page 197.
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@ Upgrading legacy translation memories

Overview

The purpose of this chapter is to give instructions on how to upgrade your translation
memories from SDL Trados 2007 and SDLX 2007 to the Trados Studio 2024 format (* . sd1ltm)
using the Upgrade Translation Memories wizard in Trados Studio.
You can upgrade the following translation memories:

® SDLX 2007, SDLX 2006 and SDLX 2005 File-based Translation Memories (* .mdb)

® SDLX 2007, SDLX 2006 and SDLX 2005 SQL Server-based Translation Memories

® SDL Trados Studio 2009 Translation Memories (Server-based)

® SDL Trados 2007, SDL Trados 2006 and SDL Trados 7.x File-based Translation Memories
(* . tmw)

® SDL Trados 2007, SDL Trados 2006 and SDL Trados 7.x Server-based Translation
Memories.

Note:

® For information on how to upgrade server-based translation memories from Trados
Studio 2009 to TM Server 2020 SR2 format, refer to the Trados GroupShare 2020 SR1
Installation Guide .

® File-based translation memories from Trados Studio 2009 and Trados Studio 2011 do
not need upgrading and are the same format as translation memories in Trados Studio
2024.

You can also upgrade SDL Trados 2007 or SDLX 2007 translation memory created from
translated legacy files using SDL Trados WinAlign and SDL Align. For more information, see
“Populating Translation Memories from Alignment Result Files ” on page 177.

For information on how to upgrade translation memories using TMX files and bilingual
documents, see “Populating Translation Memories from TMX Files " on page 143 and see
“Populating Translation Memories from Bilingual Documents” on page 167.

Why upgrade your Translation Memories?

Upgrading your translation memories allows you to continue to leverage matches from
your previous translations. Depending on what type of translation memory and what aspects
of the translation memory are user-defined you can choose to upgrade the following
information alongside the translation units in the translation memory:

® Data inside a segment pair (For example, leading and trailing tags)
® Custom fields and assigned values

® Language Resources (Including Segmentation Rules, Abbreviation Lists, Variable Lists
and Ordinal Follower Lists).
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Hints and tips

Complete the following instructions to help find the best upgrade strategy for your
translation memories:

® Upgrade your translation memory and make it a read-only translation memory that is
not updated during translation.

® Create a new Trados Studio translation memory that you can update during translation.
® Open both translation memories at the same time when translating in Trados Studio.
You can specify the update settings when you open a document in the Open Document

dialog. Alternatively, if you already have a document open or have created a project, you can
specify the update settings in the Project Settings dialog:

Translation Memory and Document Settings x
Source Language: | M= English (United States) ¢« &
Target Language: M German (Germany) ~ | |optional)

Translation Memaory and Automated Translation

Create a translation memaory, select an existing translation memory or connect to automated translation providers or other resources,
g Specify whether to include the selected providers in lookup, concordance search and whether to update them,

+ Create Translation Memory... v| B Use. - 'f::l' Settings... | f | Remaove |§._lmport... B, Export... | Upgrade
Name Enabled Languages Lockup Penalty Concordance Update
B Legacy_Trades_2007 sdltm v E->ER [v] 0 v

‘gh My_New_TM sdlm i J Emm [ o v v

Do not show this dialog again if the language pair settings for the document are known.

Advanced... Canicel Help

This approach enables you to leverage the data from the old translation memory while
creating new translation units in the new translation memory that have the updated
segmentation and tag handling that is in Trados Studio.

Upgrade Translation Memory process

The following diagram shows the steps you need to take to upgrade your translation
memories in Trados Studio:
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Translation Memory
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/

Prepare
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Language resource
file created
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Upgrade Custom
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Compatibility
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—

S0L Trados Studio
format *. sditm

/

Software required for upgrade

When upgrading your translation memories, some types of TMs require you to have the
application where the translation memory was created and Trados Studio installed on your

computer.

Make sure you have installed the Trados Compatibility and Migration Power Pack from
the RWS AppStore before you start working with data created in SDLX, Trados 2007 and

Translator's Workbench.
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SDLX 2007 file-based and |Trados Compatibility and Migration Power Pack
server-based TMs

SDL Trados 2007 Trados Compatibility and Migration Power Pack
file-based TMs

SDL Trados 2007

server-based TMs ® SDL Trados Server Manager 2007

® Trados Compatibility and Migration Power Pack

Install the Trados Compatibility and Migration Power Pack

Before you begin

Install this free app to add the Upgrade Migration Wizard in the Translation Memories

view > Tools group on the ribbon. This app also adds support for legacy ITD, TTX and Bilingual
Workbench file types created in SDLX, Trados 2007 and Translator's Workbench. The import

functionality is enabled for any Trados Studio license. However, the Upgrade Migration

Wizard is only enabled if you have an active Trados Studio subscription or a perpetual license

for the Professional, Freelance or Express edition.

Procedure
1. Open the Add-ins tab Trados Studio and select RWS AppStore.
This opens the RWS AppStore on the Installed Plug-ins page.

2. Type Trados Compatibility and Migration Power Pack in the search box and press
Enter.

3. Select the app and click the Download icon in the app description on the right-hand
side of the RWS AppStore page.

4. When Trados Studio finishes downloading the app, the following confirmation message

is displayed: Download complete. Restart Trados Studio to finish installing
the plug-ins. Click this confirmation message to go to your specified Downloads
location and run the app installer.

5. Double-click on the downloaded Trados Compatibility and Migration Power Pack app

and run the installer.
The following message is displayed when the app is successfully installed:

SDL Trados Compatibility and Migration Power Pack 2021 Beta %

o Setup has completed successtully.

6. Restart Trados Studio after closing all active sessions.

7. Go to the Translation Memories view check that the Upgrade Translation Memories
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option has been added to the Tools group. You can now also start opening and importing
the following legacy file types:

® SDL Edit Documents (.ITD)

® TRADOStag Documents (.TTx)

® Translation Memory Exchange Documents (. TMX, .TMX.GZ)
® S-tagger

® Bilingual Workbench

° TMW

¢ .MDB

Upgrading segmentation rules

Segmentation rules can be upgraded along with your translation memories. They are
converted to a language resources file which includes segmentation rules, abbreviation
lists, ordinal follower lists and variable lists. Segmentation has a significant impact on
leverage from legacy resources. If the translation memories you are upgrading are
segmented differently, matching against the translation memory will lead to fuzzy matches
or return no matches at all.

When segmentation rules are migrated, tag and filter settings are not taken into account as
they are not part of the segmentation rules but are part of the corresponding file format
filter. Adjustments to tag and filter settings will need to be done manually. For more
information about tag and filter settings, see “Migrating INI and ANL Tag Settings File ” on
page 197.

The following tables shows what segmentation lists can be upgraded from SDL Trados and
SDLX:

Segmentation Rules Yes Only SDL Trados 2007 Suite
Abbreviations List No Yes, only userdefined lists
Ordinal Followers List No Yes, only userdefined lists
Variables List No Yes, only userdefined lists
Note:

® If you want to upgrade your segmentation rules from SDL Trados 2006 or SDL Trados
7.x, you must first install SDL Trados 2007 Suite.

¢ If you migrate your user-defined abbreviation lists, ordinal follower lists and variable
lists, they are merged with the defaults lists in Trados Studio.
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Should you migrate your segmentation rules?

When you upgrade your translation memories you should decide whether to upgrade your
segmentation rules or to use Trados Studio's default rules.

® If you are working in a supply chain where both SDL Trados 2007 and Trados Studio are
used together or a supply chain where SDLX 2007 and Trados Studio are used together,
RWS recommends that you upgrade your segmentation rules. However, you can also
migrate custom rules that would take too much time to recreate.

® If you are only going to be using Trados Studio, RWS recommends that you select the
default segmentation rules in Trados Studio and modify them as needed. This will
provide cleaner rules and better default segmentation.

Note: If you are unsure of whether to migrate your segmentation rules, contact Professional
Services.

SDLX Segmentation

It is optional to upgrade the SDLX segmentation rules to a language resource that is
contained within the translation memory when you upgrade the translation memory. You
may find that SDLX rules representation formalism (SRX) may be a bit harder to read and
understand. Therefore, you may find it easier to accept the default segmentation rules
(Language Resources) in Trados Studio which provide cleaner rules and an improved user
interface for modifying and reading the rules.

Segmentation rules are not stored within the SDLX translation memories but in a separate
SRX file. They are stored locally on a user's machine in their installation folders. Therefore, if
you want to upgrade your segmentation rules in your translation memory, the translation
memory must be upgraded on the computer where the customized segmentation rules are
stored and you must have administrative permission rights on that computer to migrate
those rules.

Note: If you migrate your segmentation rules, they replace the rules in Trados Studio.

There are some key differences between the rules in Trados Studio and SDLX:

® In SDLX, abbreviations and ordinal followers are stored as exceptions, therefore when
they are upgraded to Trados Studio, each abbreviation and ordinal follower on the list
appears as a separate exception instead of displaying on the abbreviations or ordinal
follower lists in Trados Studio. RWS recommends that you remove these exceptions and
add them to the appropriate list in Trados Studio.

® SDLX has language-specific rule sets which capture language-specific abbreviations.

® SDLX may not break if the break character is followed by closing punctuation (for
example, a closing double quote, or closing parentheses).
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SDL Trados 2007 segmentation

It is optional to upgrade the SDL Trados 2007 segmentation rules and lists to a language
resource that is contained within the translation memory when you upgrade the translation
memory. Most segmentation rules used in Trados Studio are based on the rules that were
used in SDL Trados 2007. If you did not customize your rules in SDL Trados 2007, RWS
recommends that you do not migrate your rules and use the defaults in Trados Studio
instead.

If you choose to migrate your user-defined segmentation rules and lists the following
happens:
® If you migrate your segmentation rules fully, they replace the rules in Trados Studio.

® If you migrate your user-defined abbreviation list, it is merged with the default list in
Trados Studio.

® If you migrate your user-defined ordinal follower list and there is a default list for that
language in Trados Studio, it is merged with the default list.

® If you migrate your user-defined variable list and there is no default variable list in
Trados Studio, the list is not merged but just copied across to the new translation
memory.

Note: If you heavily customized your SDL Trados 2007 rules, you may not be able to fully
migrate the rules. In this case, RWS recommends you contact Professional Services for more
information.

Some constraints defined in SDL Trados 2007 (for example, minimum number of words or
characters in a segment) are not migrated, so any customization of such settings will have no
effect on segmentation in Trados Studio.

These are some key differences between the rules in Trados Studio and SDL Trados 2007
that could effect leverage in your translation memory during upgrade:

® SDL Trados 2007 did not segment number-only segments and Trados Studio does.

® SDL Trados 2007 abbreviation lists are not case sensitive and Trados Studio's abbreviation
lists are.

® For some languages (such as German), SDL Trados 2007 did not always segment
correctly after numbers followed by a full stop, independent of the ordinal followers list.
Trados Studio does segment correctly for these languages.

® In SDL Trados 2007, numbers in a segment-initial position were not always included in
the segment. In Trados Studio, these numbers are included in the segment but not if they
are, for example, a numbered list.

® SDL Trados 2007 has an 'End of Paragraph' rule that by design no longer exists in Trados
Studio since content is always segmented at paragraph breaks.
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Comparison of default rules

This following table summarizes segmentation differences for the default Western

languages.

Full Stop

Breaks:

- unless followed by
lower case letter.

- unless preceding
word including the
full stop is in the
abbreviations list.

- unless full stop is
preceded by a
sequence of digits
and the word
following the full stop
is in the ordinal
followers list.

Breaks,

- unless full stop
follows a digit
sequence in
segment-initial
position.

- unless full stop is
part of an ellipsis
(llu.ll)

The same as SDL
Trados 2007.

Question and
Exclamation Mark

Breaks,

- unless followed by
lower case letter.

Breaks

The same as SDL
Trados 2007.

Colon Breaks by default. Does not break. Breaks,
- unless followed by
lower case letter.
Semicolon Does not break by Does not break. The same as SDL
default. Trados 2007.
Tabulator Breaks by default. Does not. break. No break by default.

Additional Trados Studio segmentation rules

® When Trados Studio segments your document, it includes punctuation following the
break character in the segment in some cases. For example, an exclamation mark that
appears within double quotes. The quote marks are included in the segment for

translation.

"double quotes!"

® Trados Studio supports the same type of segment and paragraph-based segmentation
that was supported in SDL Trados and SDLX.
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Compatibility with SDL Trados 2007 and SDLX
2007 data

The legacy translation memory engines, SDL Trados Translator's Workbench and SDLX,
applied and stored data associated with a translation unit differently to Trados Studio. In
addition, the file format filters worked differently. When you upgrade a translation memory
you can specify what data inside a segment pair is removed or retained in your translation
memory in order to optimize the leverage from your new upgraded translation memory. This
process makes the content of the translation units in your upgraded translation memory
closer to what the file format filters in Trados Studio are likely to produce.

For example, depending on your settings, Microsoft Word's heading numbers and bullet
point characters are stored in an SDLX translation memory. In the Trados Studio Microsoft
Word file type, it does not allow you to include the heading numbers or bullet point
characters in the translation memory. This means that heading information is stored but
not the heading number. If you upgrade your translation memory without removing this
information from the translation memory, a difference will occur when the translation unit is
reused, resulting in penalty or fuzzy match. Eliminating those pieces of data associated

with the translation memory should now allow it to result in an 100% match. Although in
some situations you may want to retain that data.

For more details about the different options, see the Compatibility options.

Upgrading fields

Fields and their values can be upgraded along with your translation memories. The
translation memories are scanned for their fields and values. If you have multiple translation
memories upgrading to the new translation memory, you may find that there are field
clashes.

The examples below explain different scenarios that may occur when you have field clashes.
Field clashes occur when you have a field with the same name in two different translation
memories that are being upgraded to one new translation memory. The clash only occurs if
these fields are using the same capitalization.

Example A
If you have two fields with the same name from different translation memories and they are

different types (for example, Text and Picklist), one of the fields is renamed automatically
when the translation memories are upgraded.
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Scenario

® Translation Memory A has a field called Project which is a Text field.
® Translation Memory B has a field called Project which is an Picklist field.

Upgrade Result

® Trados Studio automatically renames the field from Translation Memory B to Project_
SinglePicklist. You can change this field name as needed.

Example B

If you have two fields with the same name from different translation memories and they are
the same type of field (Text or Picklist) but only allow single values assigned to translation
units, only one value will remain assigned to a translation units that are merged in the new
translation memory unless you change the field to allow multiple values to be assigned.

Scenario

® Translation Memory A has a field called Project which is a Picklist field that only allows
single values assigned to translation units.

® Translation Memory B has a field called Project which is a Picklist field that only allows
single values assigned to translation units.

® In Translation Memory A and B, there is an identical translation unit. In Translation
Memory A it has the value, Project A assigned to it. In Translation Memory B it has the
value, Project B assigned to it.

Upgrade Result

® Trados Studio merges the translation units from Translation Memory A and Translation
Memory B, and the value from Translation Memory B, Project B, is the only value that
remains assigned to the merged translation unit.

¢ If you want both values to remain assigned to the translation unit so that it has Project
A and Project B assigned to it, you must select the Multiple check box when you upgrade
your translation memories. This changes the field allowing for multiple values to be
assigned to translation units.

Example C

If you have two fields with the same name from different translation memories and they are
the same type of field (Text or Picklist) but one allows single values assigned to translation
units and the other one allows multiple values assigned to translation units, both values will
remain assigned to translation units that are merged in the new translation memory.
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Scenario

® Translation Memory A has a field called Project which is a Picklist field that only allows
single values assigned to translation units.

® Translation Memory B has a field called Project which is a Picklist field that allows multiple
values assigned to translation units.

® In Translation Memory A and B, there is an identical translation unit. In Translation
Memory A it has the value, Project A assigned to it. In Translation Memory B it has the
value, Project B assigned to it.

Upgrade Result

® Trados Studio merges the translation units from Translation Memory A and Translation
Memory B, and the values from Translation Memory A and B, Project A and Project B,
remain assigned to the merged translation unit.

Upgrading your legacy translation
memories

This section describes how to upgrade your SDLX 2007 and SDL Trados 2007 translation
memories to the Trados Studio format (*. sd1tm) using the Upgrade Translation Memories
wizard in Trados Studio.

In Trados Studio,

® File-based translation memories are bilingual and can only have one source language
and one target language.

® Server-based translation memories are multilingual and can have multiple source
languages and target languages.

Therefore, if you are upgrading a translation memory that is multilingual with more than
one target language, you would have to create an Trados Studio server-based translation
memory or create multiple Trados Studio file-based translation memories (one for each
language direction).

Before you start

Before you upgrade your translation memories, you may want to do the following:

® Perform maintenance on your translation memories in SDL Trados Translator's
Workbench or in SDL Maintain in SDLX 2007 to ensure you are upgrading quality data.

® Ensure that the correct software is installed on the computer. See “Software Required
for Upgrade” on page 120.

® Decide if you want to upgrade your segmentation rules. See “Upgrading Segmentation
Rules” on page 122.
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Upgrading your legacy translation memories

To upgrade your legacy translation memories:

Before you begin

Make sure that you have installed the Trados Compatibility and Migration Power Pack as
described in the section “Software required for upgrade ” on page 120.

Procedure

1. Select Home tab > Tools group > Upgrade Translation Memories in the Translation
Memories group. This is only available after you install the Trados Compatibility and
Migration Power Pack.

The Upgrade Translation Memories wizard is displayed on the Input Translation
Memories page.

| BB Upgrade Translation Memories — O W

@ 2 3 4

Input Translation Memories Output Translation Memories Output Translation Memories Settings Upgrading Translation
Memories

1 of 4 completed
+ Add File-based TMs from Folder... + Add File-based TMs... + Add Server-based TM - 3¢ Remove |

Id Name Location Translation Units
T™- le.mdb @ TM™- le.mdb CiUsersisuricariuiDesktopiTM-sample.mdb 38

Specify the location to store temporary files created during the conversion process:

|C:\Users\sun:ariu\DUcuments\Studiu 2019\ Upgrade Translation Memories | Browse...

| Help Next Cancel

2. If you want to add file-based legacy translation memories:

add a folder containing a group of SDLX  |...Add File-based TMs from Folder. The
2007 or SDL Trados translation memories, |Browse for Folder dialog is displayed.
Select the folder and click OK to add the
contents of the folder.

add an individual SDLX 2007 or SDL Trados |...Add File-based TMs. The Select Input
translation memory, Translation Memories dialog is displayed.
Select the translation memories and click
Open to add them.

3. Ifyouwant to add an SDL Trados server-based legacy translation memory:

® Click Add Server-based TM and select SDL Trados 2007 server-based translation
memory from the drop-down list. The Log On dialog is displayed.
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o "y

Log on @
Server: YOO1EN-53E-03

E ? (® UseWindows authertication

() Uze Trados authentication

Optiong

[ ] Fiemember lagin infarmation

OK | [ Ccancel

® Select the appropriate authentication method and enter your Login ID and
Password if required. Click OK. The Open Server-based Translation Memory dialog
box is displayed.

o -

Open Server-based Translation Memory @

TH Server: "-.-"I_'.J_ MEM-53

Tranzlation Memarnes:

=L APC_TMM @Lescar
i AC_EN_DE
E AC_EMca_FReza
=0 aPC_TMD2@ELescar
B CCTV Master ENUS_EN-US_DE
8 EM -IT - Product Comparisan
=0 APC_TMJD @Lescar
id us_FR
=0 APC_TMPIELescar
if Gams
=" APC_TMMc@ELescar
i EMus FRca
I EMus_FRi
B EMus ITit
=0 PC_TMTP@Lescar
8 EmmaTest

Cancel ] [ Help

® Expand a database to load the translation memories it contains into the window for
selection. To expand a database, double-click the database or click the plus icon
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preceding the database name. If you are not currently logged in to a TM server, the
window remains empty. Select a translation memory and click OK.

4. If you wantto add an SDLX 2007 server-based legacy translation memory:

® Click Add Server-based TM and select SDLX 2007 server-based translation
memory from the drop-down list. The Select Data Source dialog box is displayed.

’n Select Data Source @

Data Sources

-

D ezcription Add

Configure

Remove

Clear

[ Ok J [ Cancel

® If the server from which you want to retrieve the translation memories is not
displayed, click Add. Alternatively, if the server from which you want to retrieve
translations memories is displayed, select the server and click Configure. The
Add/Configure SQL Server Data Source dialog box is displayed.
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(a Add SQL Server Data Source @

Mame SOl Semver
Dezcription

Server

HIGHCLIFFE -

Connection
@ |Jze Windows authentication

(7 Use Data Source authentication

Uszer D
Pazzword
Prarmpt for pazsward when
acceszzing databasze
D atabaze
DET -

Ok, ” Canicel ]

® Enter a Name that you want to use to refer to the server.
® Select the server from the Server drop-down list.

® Select the appropriate authentication method and enter your User ID and Password
if required.

® Select the translation memory that you want to upgrade from the Database
drop-down list and click OK. The Select Data Source dialog box is displayed. Click OK
again to add the translation memory.

® Click Next on the Input Translation Memories page.
The Output Translation Memories page is displayed.
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BB Upgrade Transla - [m] X
[ ey
LV 4 {2) 3 4
Input Translation Memories Output Translation Memories Output Translation Memories Settings Upgrading Translation

Memories

2 of 4 completed
(@ Create output translation memory for each input translation memory

(O Create output translation memery for each language pair

(O Custom

Output translation memaries:

H' TM-sample_en-GB_de-DE

& TM-sample.mdb EE = |

Help Back Next Cancel

5. Click Next on the Input Translation Memories page.

The Output Translation Memories page is displayed.

Upg - [m] X

) )

L4 \2) 8 =

Input Translation Memories Qutput Translation Memories Qutput Translation Memories Settings Upgrading Translation
Memories

2 of 4 completed
(@) Create output translation memory for each input translation memeory |

() Create output translation memory for each language pair

() Custom

OQutput translation memories:

H TM-sample_en-GB_de-DE

8 TM-sample. mdb

‘ Help Back Next Cancel

6. Specify how the translation memories will be created:

® Create output translation memory for each input translation memory - When
this option is selected, an Trados Studio translation memory is created for each

translation memory that was added on the Input Translation Memories page. Click
Next and go to step 8.

Create output translation memory for each language pair - When this option is
selected, an Trados Studio translation memory is created for each language pair that
exists in the translation memories that were added on the Input Translation
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Memories page. Click Next and go to step 8.

® Custom - When this option is selected, additional options are displayed where you
can customize how the Trados Studio translation memories are created. If you want
to change the language direction of the translation memory that you are upgrading,
select this option.

|& Upgrade Translation Memories — [m] x|

@ @ 3 s

Input Translation Memories Output Translation Memories Output Translation Memories Settings Upgrading Translation
Memories

2 of 4 completed

(O Create output translation memory for each input translation memory

() Create output translation memery for each language pair
® Custom
Input translation memeories: Qutput translation memories:
Input Source  Target B New Output Translation Memary Create
& TM-sample mdb E - Rename
& Th-sample mdb - ==

Delete

Add =

€ Remove

Help Back Next m Cancel

Note:

® If you are upgrading to a server-based translation memory, they can contain
multiple language pairs. If you are upgrading to a file-based translation memory,
they can only contain one language pair.

Each translation memory file is displayed twice in Output translation memories
box. Once for each language direction. For example, the translation memory
master_en_de.tmw file is displayed twice with the language direction as English
to German and German to English.

7. Specify your custom built translation memories:

® Select the translation memory with the language direction for which you want to
create the translation memory in the Output translation memories box.

® Select the new translation memory in the Output translation memories box. Use
the Rename and Create buttons to create the new translation memories in this box
as needed.

Click Add. The translation memory is added to the new selected translation memory.
Repeat these steps until you have all of the translation memories in the Output
translation memories box that you want to create.

Click Next. The Output Translation Memories Settings page is displayed.
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BB Upgrade Translation Memories - [m] X
(Y & )
LV L 3) &
Input Translation Memories Output Translation Memories OQutput Translation Memories Settings Upgrading Translation
Memories

3 of 4 completed

Output Translation Memories: TM-sample_en-GB_de-DE |

B TM-sample_en-GB_de-DE Location Settings Language Pairs Compatibility Fields  Language Resources

@ lemdb m - @) File-based translation memory
-sample.

Location: | C\Users\suricariutDesktop Browse...

() Server-based translation memory

Server: Servers...
Location:  (MNone) Browse..,

Container: | (Mone) Browse...

| Help Back Cancel

8. Select the translation memory for which you want to specify settings. The settings for
the translation memory are displayed on the right-hand side on the Location tab:

® If you want the new upgraded translation memory to be created locally, select
File-based translation memory. Go to step 10.

Note: If you selected more than one language pair in your new upgraded translation
memory, the option to create a file-based translation memory is disabled because
file-based translation memories are bilingual and can only contain one language pair.

¢ If you want the new upgraded translation memory to be created on a server, select
Server-based translation memory. Go to step 9.

9. Ifyou selected Server-based translation memory, specify the following:
® Server - Select the server where you want to create the new translation memory. If

the required server does not appear in the list for selection, click Servers to display
the Servers dialog box where you can add the server.

® Location - Click Location to display the Select Location dialog box. This dialog box
is where you select the organization or resource library to which you want the new
translation memory to belong.

® Container - Click Containers to display the Select Translation Memory Container
dialog box. This dialog box is where you select the container where you want the
translation memory to be created.

10. Click the Settings tab:
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Mew Dutput Tranzlation kMemory

Location | Settingz | Language Pairz | Compatibility | Fields | Language Resources

Dezcrption: e
Copyright:
[] Enable character-based concordance search
S ettingz
Recoghize dates Recognize acronyms Recognize alphanumeric

Recoghize times Recognize variables

Recoghize numbers Recoghize measurements

Count az one if words:
Are hpphenated
Are joined by dazhes

Contain formatting tags

[mport

[] Import translation units as plain text

IF target zegmentz differ:
@ Add new tranzlation unitz
71 Owenarite existing tranglation units
71 Leave existing translation units unchanged

I K.eep most recent tranglation units

Specify the following:

® If you want to add a description, enter a description in the Description box. This

will be displayed in the translation memory settings after the translation memory is
created.

Import translation units a plain text - When this option is selected, all formatting
in the import file is ignored and the translation unit content is imported as plain
text. This may be useful if you are importing translation units from an application
that handles tags differently to Trados Studio as the imported tag information would
not display correctly in Trados Studio.

If target segments differ - The source segments of some translation units for import
may be identical to those of the translation units in the translation memory although the
target segments differ. In this case, you can ask Trados Studio to:

® Add new translation units - This option imports the new translation units as

additional entries. The TM fields of the new translation units are merged with those
of the existing TUs.

® Overwrite existing translation units - This imports the new translation units and
overwrites the existing translation units. The TM fields of the existing TUs are also
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11.

12.

replaced with the TM fields of the new TUs. The only fields that Trados Studio keeps
from the existing TUs are those fields that do not have a correspondent in the new
TUs.

® Leave existing translation units unchanged - This keeps the existing translation
units and their TM fields and does not import the new ones. For server-based TMs,
this option is only available for translation memories created in SDL Studio
GroupShare 2019 SP2 and later.

® Keep most recent translation units - This keeps the most recently changed
translation unit and its fields. Trados Studio imports a translation unit whose source
segment is identical to that of an existing translation unit only if the imported unit
is newer than the existing one. If the change date of the translation unit for import is
older than the change date of the existing one, Trados Studio does not replace the
existing translation unit. For server-based TMs, this option is only available for
translation memories created in Studio GroupShare 2019 SP2 and later.

® Existing translation units - Translation units that match both the source and target
segment of existing TUs, are not added as duplicates to the translation memory.
Instead, Trados Studio merges the system and custom fields available for the two
translation units. This ensures that the information about both translation units is
recorded in your translation memory.

Specify your Recognition Settings - These settings are used to identify elements that
do not change during translation. These elements include variables, dates, times,
numbers, measurements and acronyms. These elements can either be transferred
directly from the current source segment to the new target segment or automatically
converted to the correct target language format. For example, you can auto-localize date
and time elements to the correct target language format.

Which settings are selected varies based on what type of translation memory you are
upgrading and what settings were selected in the translation memories you are
upgrading. Select or clear the check boxes as needed.

® If you are upgrading an SDLX translation memory, all of the recognition settings are
selected.

® Ifyouare upgrading an SDL Trados translation memory, only the recognition settings
that were selected in the translation memory you are upgrading from are selected.

® If you are upgrading multiple translation memories to one new translation memory,
only the recognition settings that are selected in all of the translation memories
are selected.

Note: For more detailed information on these settings, see the Trados Studio Help that
is launched from Trados Studio.

Click the Language Pairs tab:

TM_sample._en-US_de-DE
| Location | Settings | Language Pairs | Compatibility | Fields | Languar

Source Language Target Language
E=] English (United States) B Cerman (Germany)

This is where you can view the source language and target languages in the translation
memory. Each row indicates one language pair.
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® Server-based translation memories in Trados Studio are multilingual and may have
multiple language pairs listed on this page.

® File-based translation memories in Trados Studio are bilingual and can only contain
one language pair.

13. Click the Compatibility tab:

TM_sample._en-US_de-DE
| Location I Settings I Language Pairs | Compatibility | Fields | Language Rﬁsourc:es|

Please select the scenario that applies best to you:
@ The upgraded TM will be primarily used with new, native source files or files processed only with SOL Trados Studio
() The upgraded TM will be primarily used with presegmented legacy SOL Trados ITD or TTX files

() The upgraded TM will be primarily used in mixed scenaros

When you upgrade a translation memory you can specify what data inside a segment
pair is removed or retained in your translation memory in order to optimize the leverage
from your new upgraded translation memory. This process makes the content of the
translation units in your upgraded translation memory closer to what the file format
filters in Trados Studio are likely to produce. For example, you can remove or leave
leading and trailing tags. For more information, see “Compatibility with SDL Trados 2007
and SDLX 2007 Data” on page 126.

Select from one of the following compatibility options:

The upgraded TM will be primarily |Imports a version of the translation memory
used with new, native source files |that has had some formatting-related data

or files processed only with Trados | removed. You might want to do this, for

Studio example, if you are a translator and you receive
files in their original (native) format with a
legacy translation memory. In this case,
removing the formatting related data associated
with the translation unit will increase the
leverage because you are more likely to get a
match if the translation units in the translation
memory are using the same type of formatting-
related data as the document you are
translating.

The upgraded TM will be primarily [Imports a version of the translation memory
used with presegmented legacy |that retains the legacy translation unit data. You
SDL Trados ITD files and TTX files | might want to do this, for example, if you are a
translator and you receive a pre-segmented
legacy bilingual file with a legacy translation
memory. In this case, retaining the data
associated with the translation unit will increase
leverage.
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The upgraded TM will primarily
used in mixed scenarios

Imports two versions of the translation unit, one
where the data associated with the translation
unit will be removed and another one where it
retains the data. You might want to do this if:

® you want to permanently upgrade the
translation memory and

® you are using legacy bilingual files and
using bilingual files from Trados Studio.

Selecting this option will maximize the
translation memory leverage in all situations,
however, it may also increase the number of
multiple 100% matches, causing a penalty to be
applied.

14. Click the Fields tab:

MNew Output Translation Memory

| Location | Settings | Language Pairs Eﬂmpatibil'rtﬂ Fields | Language Resources

MName
General
Contest
Source File
w1050
w050
Project D
projectD_2

Type
List
Ligt
List
List
Ligt
Text
Teut

Picklist
OperatorLetter

transindes. marke...
W SHEP_CHIOA)..,

docurmentation

TrainerMedey. ..

Allow Multiple \Values Remove

FEEEEEE

The existing custom fields from the translation memories you are upgrading are listed
here. If you have multiple translation memories upgrading to a new translation memory,
you may find that there are field clashes. For information about field clashes and what

to do, see Upgrading Fields .

You can perform the followings actions on this tab:
® Click Add to add a new field. When you click Add a new row is added to this tab.
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Click in the Name column for this row and type the name. Select the type of field
from the drop down list in the Type column. Enter values in the Picklist column if
you selected List as the type of field.

® Click Remove to delete a field and all of its corresponding fields values that are
assigned to translation units in the translation memory.

® To rename a field, click in the field you want to change in the Name column. Type
the new name. The corresponding fields values that are assigned to translation units
stay assigned to those translation units but with a new field name.

Note: For more information about fields and the different types of fields, see the
Trados Studio Help . You can access the help from the Help tab in Trados Studio.

15. Click the Language Resources tab:

Mew Output Translation Memaony
| Location | Settings I Language Pairs | Compatibility | Fields | Language Resources |

The language resources are associated with the segmentation rules. You can use the default
language resources or use the existing language resources. f you are not sure, it is recommended
that you use the default language resources.

Source Language Language Resources
#= English (United States) (Default Language Resources) -
E German (Germany) [Default Language Resources) -

Language resources control the process of segmenting source document text so that it
is ready for a translation memory to be applied to the segments. Language resources are
stored in the form of lists and rules. Your input translation memories are scanned and
any segmentation rules are copied. For details of what segmentation rules are upgraded,
see “Upgrading Segmentation Rules” on page 122.

Select one of the following from the drop-down list in the Language Resources column
for each language pair:

¢ Default Language Resources - Select this to use the default Trados Studio
segmentation rules.
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® Upgraded Language Resources - Select this to use the segmentation rules from
your existing translation memories.

Note: You can change language resources after the translation memory is created in
the Translation Memories view.

Click Finish to upgrade your translation memories.

The Upgrading Translation Memories page is displayed. A progress bar is displayed as
each task is run.

16. When the translation memory has been upgraded, you can do the following:

® Click the Details link to display the Import Results dialog box which contains
statistics about what translation units were imported.

Import Results @

Status:  Completed

-

Import Statistics
Frocessed: 3399
Added: 393
Merged:

]
Replaced: 0O
Errors: ]

® Click the Open link to open the translation memory in the Translation Memories
view where you can view the imported data and modify the segmentation rules.
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<6> Populating translation memories from .TMX files

Overview

The purpose of this chapter is to give instructions on how to upgrade your translation
memories to the Trados Studio format (. sd1tm) using Translation Memory Exchange
Documents (TMX) files. RWS provides support for upgrading the following TMX files:

® Limited support for TMX files generated from a software other than SDL Trados or
SDLX. You can upgrade TMX version 1.4b or pre-1.4b.

® SDL Trados TMX (Only version 1.4b).
® SDLX 1.4b TMX (Only version 1.4b).

Who should do this?

Primarily, the users who should upgrade TMX files are ones where the TMX file was
third-party generated. That is TMX files generated from software other than SDL Trados or
SDLX.

Software required

To import and upgrade TMX files in Trados Studio 2022 and later, first install the Trados
Compatibility and Migration Power Pack app from the RWS AppStore.

To install the app, go to the Add-Ins tab > RWS AppStore or visit https://appstore.rws.com .

Note: RWS AppStore recommends that if you have a legacy translation memory in SDLX
2007 or SDL Trados 2007, you use this to upgrade to the new format in Trados Studio.
However, if you do not want the setup information to be extracted from the translation
memory you may want to upgrade using a TMX file (Only version 1.4b). For more information,
see “Upgrading Legacy Translation Memories ” on page 117.

Hints and tips

Users who have third-party generated TMX files that are version 1.4b or below should select
the option to Import translation units as plain text. When this option is selected, all
formatting in the import file is ignored and the translation unit content is imported as plain
text. This may be useful if you are importing translation units from an application that
handles tags differently to Trados Studio as the imported tag information would not display
correctly in Trados Studio.

® Use the Import wizard to import the 3d party generated TMX files:
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B Import - O X
::!-j 2 3

Import Files General Import Options Import

1 of 3 completed

Files:
Ch\Users\suricariu’\DesktophEN-US_DE-DE.tmx Adld Files...
Add Folder...
Remaove
Help Back Next Finish Cancel

® Select the Import translation units as plain text check box on the General Import
Options page:
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B Import

@ <

Import Files TMX Import Options

:_‘..E.::
General Import Options

- O X

4

Import

3 of 4 completed

Apply Field Values:

Edit...

Import translation units as plain text I

[ Exclude language variants
[ Export invalid translation units
Export Location:

If target segments differ:
(® Add new translaticn units

) Overwrite existing translation units
() Leave existing translation units unchanged

] Keep most recent translation units

Use information from bilingual file to update TU system fields

| Help

Benefits and limitations

Back ext

Browse...

Depending on the type of TMX file, different information can be extracted. TMX files contain
limited information (if any) about the setup of the translation memory. For example, it does
not contain segmentation rules, abbreviations, recognition settings, ordinal follower lists or

variable lists.

If you are upgrading a TMX file that is version 1.4b from SDLX 2007 or SDL Trados 2007 then
some setup information can be extracted. If you are upgrading a TMX file from a third party
software then there are further limits on what can be upgraded.

The following table shows details of the components that make up a TMX file and what can
be extracted from those files during the upgrade process.

Translation Units Yes Yes Yes
Context Match No No No
Information

Custom Fields and Yes but with some Yes but with some No

their Values

restrictions

restrictions
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System Fields Yes Yes Yes

Tags Yes Yes See Note

Note: If you are upgrading a third party generated TMX file, contact professional services
to determine if tags from your TMX file can be extracted.

Two methods

There are two methods you can use to upgrade your TMX file to a translation memory in
Trados Studio format (* . sd1tm).

Upgrading TMX files using the upgrade Translation Memories
wizard

This method creates a new upgraded translation memory with the data extracted from the
TMX file. The TMX file is scanned to obtain all relevant information:

® Translation Units

® Custom fields and their values (You can only import these from TMX files created by SDL
Trados and SDLX)

® System Fields
® Tags
You can then choose which information is included in the new upgraded translation memory

and what settings are used. You also have more control over the custom fields and correcting
them if they are not imported correctly.

Note: Third party TMX files have a limited amount of data that is imported. Contact
professional services to determine if tags from your TMX file can be extracted.

The following diagram shows the steps you need to take to upgrade your TMX files using
the Upgrade Translation Memories wizard in Trados Studio:

The following diagram shows the steps you need to take to upgrade your TMX files using
the Upgrade Translation Memories wizard in Trados Studio.
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Upgrade Translation
Memories Wizard

'

Input TMX Files

!

For third party TMX files
Upgrade Custom —I'/ S0L Professional Services /

Fields should be consulted

New Upgraded _
Translation Memory 47/ fu?;;rﬂggjﬁbfmmﬂ /
Created

Importing TMX files into an existing Translation Memory

This method imports the TMX file into a translation memory that already exists in Trados
Studio. The imported TMX file is not scanned for custom fields but you can optionally choose
to import the custom fields or choose to ignore them. The main difference between using
this method as opposed to using the Upgrade Translation Memories wizard is that in this
method the translation memory already exists and it may already contain data. This method
also allows you to filter out unwanted translation units and apply new field values to the
translation units you are importing.

The following diagram shows the steps you need to take to import your TMX files into an
existing translation memory in Trados Studio:
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Existing Translation TM View in SDL Trados
Memory Studio 2009

Import Wizard

" Specify Status of
Translation Units to
be Imported

l

Apply Field Values Create a Filter

l

Successful Import

Upgrading fields

SDLX and SDL Trados fields

Fields and their values can be upgraded along with your TMX files.

However, the field values are treated differently than when you upgrade using a translation
memory. The custom field information is extracted from the TMX file by extracting the fields
and their values from the translation units and not by reading the setup information.
Therefore, field values are only retrieved from the translation units as they occur and are
not necessarily complete. For example, a TMX file has a picklist field Content Type with
values Online, Print, Tutorial. If one or more of the values is never assigned to any of the
translation units, those values not be included in the new translation memory.

If you are upgrading multiple TMX files to the new translation memory, you may find that
there are field clashes. Field clashes occur when you have a field with the same names in two
different TMX files that are being upgraded to one new translation memory. For examples
of different scenarios that might occur, see “Upgrading Fields ” on page 126.
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Other Translation Memory software fields

If you are importing your TMX files from another translation memory software, other than
SDLX and SDL Trados, then you may not be able to upgrade any custom field information to
the new Trados Studio translation memory.

The reason for this is that the setup of the fields, field types and their values in TMX files is
not standardized and may differ from the setup in SDL Trados and SDLX. Contact professional
services to determine if you can upgrade any of your custom fields.

Tag information

If you are importing your TMX files from another translation memory software other than
SDLX and SDL Trados, then you may not be able to upgrade any tag information to the new
Trados Studio translation memory. Contact professional services to determine if you can
upgrade any of your tag information.

Upgrading the tmx files using the
upgrade Translation Memories wizard

This section describes how to upgrade TMX files to an Trados Studio translation memory
format (* . sd1tm) using the Upgrade Translation Memories wizard in Trados Studio.

Before you start

If you want to import a number of TMX files, place them all in a single folder so that you can
import the folder.

Make sure that you have installed the Trados Compatibility and Migration Power Pack as
described in the section “Software required for upgrade ” on page 120.

Upgrading TMX files using the upgrade
Translation Memories wizard

To upgrade your TMX files:

Procedure

1. Go to the Home tab and select Upgrade Translation Memories. The Upgrade
Translation Memories wizard is displayed on the Input Translation Memories page.
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BB Upgrade Translation Memories — O X
@ 5 3 4
Input Translation Memories Qutput Translation Memories Qutput Translation Memories Settings Upgrading Translation

Memories

1 of 4 completed

4+ Add File-based TMs from Folder... == Add File-based TMs... =j= Add Server-based TM -~ 3§ Remove |

Id Name Location Translation Units
EN-US_DE-DE tmx & EN-US_DE-DE.tmx CUsers'suricariuiDesktoplEN-LIS_DE-DE tmx Unknown

Specify the location to store temporary files created during the conversion process:

|C:\Users\suncariu\Documents\Studio 201%\Upgrade Translation Memories | Browse...

Help Bad Next Cancel

2. Addyour TMX file:

® Click Add File-based TMs. The Select Input Translation Memories dialog box is
displayed.

® Select the TMX file you want to add and click Open.
The TMXfile is added to the Input Translation Memories page.

® Click Next. The Output Translation Memories page is displayed.

| B8 Upgrade Translation Memories — O x |
<@ @ 3 s
Input Translation Memories Output Translation Memories Qutput Translation Memories Settings Upgrading Translation
Memories

2 of 4 completed

(@ Create output translation memery for each input translation memaory
(O Create output translation memory for each language pair

(O Custom

Qutput translation memories:

H' EN-US_DE-DE_en-US_de-DE

EN-US_DE-DE tmx

Help Back Next Cancel

3. Specify how the translation memories will be created:

® Create output translation memory for each input translation memory - When
selected, an Trados Studio translation memory is created for each TMX file that was
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added on the Input Translation Memories page. Click Next and go to step 5.

® Create output translation memory for each language pair - When selected, an
Trados Studio translation memory is created for each language pair that exists in the
TMX files that were added on the Input Translation Memories page. Click Next and
go to step 5.

® Custom - When selected, additional options are displayed where you can customize
how the Trados Studio translation memories are created. If you want to change
the language direction of the TMX file that you are upgrading, select this option.

Upgrade Translation Memories =3
Output Translation Memories
Specify how the output translation memaries will be created from the input translation memories. EQ
() Create output translation memary for each input ranslation memary
() Create output translation memory for each language pair
@ Custom
Input translation memaries: Output translation memaries:
Input Source  Tanget B Mew Output Translation Memary
1 Third_Party tms - e 1 Third_Party tmx B m- _
Add =
< Back ] [ Hesxt » ] [ Finizh ] [ Cancel
Note:
.

® If you are upgrading to a server-based translation memory, they can contain
multiple language pairs. If you are upgrading to a file-based translation memory,
they can only contain one language pair.

® Each TMXfile is displayed twice in Output translation memories box. Once for
each language direction. For example, the TMX file ENUS_DE.tmx file is displayed
twice with the language direction as English to German and German to English.

4. Create your custom built translation memories:

® Select the TMX file with the language direction for which you want to create the
translation memory in the Output translation memories box.

® Select the new translation memory in the Output translation memories box. Use
the Rename and Create buttons to create the new translation memories in this box
as needed.

® Select Add. The TMX file is added to the selected translation memory. Repeat these
steps until you have all of the translation memories in the Output translation
memories box that you want to create.

Click Next. The Output Translation Memories Settings page is displayed.
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BB Upgrade Translation Memories - [m] X
o 3 ’
Input Translation Memories Output Translation Memories Output Translation Memories Settings Upgrading Translation

Memories
2 of 4 completed
(O Create output translation memoary for each input translation memory |
(O Create output translation memery for each language pair
(® Custom
Input translation memaries: Output translation memaries:
Input Source  Target 3 New Qutput Translation Memory Create

EN-US_DE-DE tmx

Rename

EN-US_DE-DE tmx ]

Delete

Add =

€ Remove

| Help Back Next Cancel

5. Select the translation memory for which you want to specify settings. The settings for
the translation memory are displayed on the right-hand side on the Location tab:

® If you want the new upgraded translation memory to be created locally, select
File-based translation memory. Go to step 7.

Note: If you selected more than one language pair in your new upgraded translation
memory, the option to create a file-based translation memory is disabled because
file-based translation memories are bilingual and can only contain one language pair.

® If you want the new upgraded translation memory to be created on a server, select
Server-based translation memory.

6. Ifyou selected Server-based translation memory, specify the following:

® Server - Select the server where you want to create the new translation memory. If
the required server does not appear in the list for selection, click Servers to display
the Servers dialog box where you can add the server.

® Location - Click Location to display the Select Location dialog box. This dialog box
is where you select the organization or resource library to which you want the new
translation memory to belong.

® Container - Click Containers to display the Select Translation Memory Container
dialog box. This dialog box is where you select the container where you want the
translation memory to be created.

7. Click the Settings tab:
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Mew Dutput Tranzlation kMemory

Location | Settingz | Language Pairz | Compatibility | Fields | Language Resources

Dezcrption:

Copyright:
[] Enable character-based concordance search
S ettingz

Recoghize dates Recognize acronyms Recognize alphanumeric
Recoghize times Recognize variables

Recoghize numbers Recoghize measurements

Count az one if words:
Are hpphenated
Are joined by dazhes

Contain formatting tags

[mport

[] Import translation units as plain text

IF target zegmentz differ:
@ Add new tranzlation unitz
71 Owenarite existing tranglation units
71 Leave existing translation units unchanged

I K.eep most recent tranglation units

Specify the following:

® If you want to add a description, enter a description in the Description box. This
will be displayed in the translation memory settings after the translation memory is
created.

¢ Import translation units a plain text - When this option is selected, all formatting
in the import file is ignored and the translation unit content is imported as plain
text. This may be useful if you are importing translation units from an application
that handles tags differently to Trados Studio as the imported tag information would
not display correctly in Trados Studio. It is also useful if you are importing a TMX
file that is from a 3rd party software that is version 1.4B or earlier

Note: If you are unsure about whether to import your TMX file as plain text, contact
Professional Services.

8. Specify your Recognition Settings - These settings are used to identify elements that
do not change during translation. These elements include variables, dates, times,
numbers, measurements and acronyms. These elements can either be transferred
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10.

directly from the current source segment to the new target segment or automatically
converted to the correct target language format. For example, you can auto-localize date
and time elements to the correct target language format.

By default all of these settings are selected when you upgrade a TMX file. Select or clear
the check boxes as needed.

Note: For more detailed information on these settings, see the Trados Studio Help that
is launched from Trados Studio.

Click the Language Pairs tab:

TM_sample._en-US_de-DE
| Location | Settings | Language Pairs | Compatibility | Fields | Languar

Source Language Target Language
E=] English (United States) B Cerman (Germany)

This is where you can view the source language and target languages in the translation
memory. Each row indicates one language pair. Server-based translation memories in
Trados Studio are multilingual and may have multiple language pairs listed on this page.

Click the Compatibility tab:

TM_sample._en-U5_de-DE
| Location I Settings I Language Pairs | Compatibility | Fields | Language Hﬁsources|

Please select the scenario that applies best to you:
@ The upgraded TM will be primarily used with new, native source files or files processed only with SOL Trados Studio

() The upgraded TM will be primarily used with presegmented legacy SOL Trados ITD or TTX files

() The upgraded TM will be primarily used in mixed scenarios

When you upgrade a TMX file you can specify what data inside a segment pair is removed
or retained in your translation memory in order to optimize the leverage from your

new upgraded translation memory. This process makes the content of the translation
units in your new translation memory closer to what the file format filters in Trados
Studio are likely to produce. For example, you can remove or leave leading and trailing
tags. For more information, see “Compatibility with SDL Trados'2007 and SDLX 2007 Data
" on page 126.

Select from one of the following compatibility options:
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The upgraded TM will be primarily
used with new, native source files or
files processed only with Trados
Studio

Imports a version of the TMX file that has had
some formatting-related data removed. You
might want to do this, for example, if you are
a translator and you receive files in their
original (native) format with a legacy TMX file.
In this case, removing the formatting-related
data associated with the translation unit will
increase the leverage because you are more
likely to get a matcﬂ if the translation units in
the translation memory are using the same
type of formattingrelated data as the
ocument you are translating.

The upgraded TM will be primarily
used with presegmented legacy SDL
Trados ITD files and TTX files

Imports a version of the TMX file that retains
the legacy translation unit data. You might
want to do this, for example, if you are a
translator and you receive a pre-segmented
legacy bilingual file with a legacy TMX file. In
this case, retaining the data associated with
the translation unit will increase leverage.

The upgraded TM will primarily used
in mixed scenarios

Imports two versions of the translation unit,
one where the data associated with the
translation unit will be removed and another
one where it retains the data. You might want
to do this if:

® you want to permanently upgrade the
translation memory and

® you are using Iegiacy bilingual files and
using bilingual files from Trados Studio

Selecting this option will maximize the
translation memory leverage in all situations,
however, it may also increase the number of
multiple 100% matches, causing a penalty to
be applied.

11. Click the Fields tab:
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Mew Output Translation Memony

Location | Settings | Language Pairs Eﬂmpatibil'rtﬂ Fields | Language Resources
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Source File
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OperatorLetter
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documentation
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Allow Multiple Values

EEEEEEE

Remove

The existing custom fields from the TMX files you are upgrading are listed here. If you
have multiple TMX files that you are upgrading to this new translation memory, you may
find that there may be field clashes. For information about field clashes and what to
do, see “Upgrading Field” on page 126.
You can perform the followings actions on this tab:
® Click Add to add a new field. When you click Add a new row is added to this tab.
Click in the Name column for this row and type the name. Select the type of field

from the drop down list in the Type column. Enter values in the Picklist column if you
selected List as the type of field.

® Click Remove to delete a field and all of its corresponding fields values that are

assigned to translation units in the translation memory.

® To rename a field, click in the field you want to change in the Name column. Type
the new name. The corresponding fields values that are assigned to translation units
stay assigned to those translation units but with a new field name.

Note: For more information about fields and the different types of fields, see the
Trados Studio Help . You can access this help from the Help tab in the Trados Studio.

12. Click the Language Resources tab:
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MNew Output Translation Memony
| Location | Settings | Language Pairs | Compatibilty | Fields | Language Resources |

The language resources are associated with the segmentation rules. You can use the default
language resources or use the existing language resources. f you are not sure, it is recommended
that you use the default language resources.

Source Language Language Resources
English (United States) (Default Language Resources) -

E German (Germany) (Default Language Resources) -

Language resources control the process of segmenting source document text so that it
is ready for a translation memory to be applied to the segments. Language resources are
stored in the form of lists and rules. TMX files do not contain segmentation rules. If

you are upgrading a TMX file, default segmentation rules for Trados Studio are
automatically selected.

Note: You can change language resources after the translation memory is created in
the Translation Memories view.

Click Finish to upgrade your TMX files to a new translation memory.

The Upgrading Translation Memories page is displayed. A progress bar is displayed as
each task is run.
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B8 Upgrade Translation Memories — [m} #
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Input Translation Memories Qutput Translation Memories Qutput Translation Memories Settings Upgrading Translation

Memories
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QCreate translation memary ‘Mew Output Translation Complete Open Restart
Memorysditm’

@ Impaort EM-US_DE-DEtmx into "Mew Output Translation [imported 22767/68701 errars: 3]
Memorysditm’

® Build Translation Model "New Output Translation

® Align Translation Units "New Output Translation

View Log File

Help Back Next Cancel

13. When the new translation memory is created, you can do the following:

® Click the Details link to display the Import Results dialog which contains statistics
about what translation units were imported.

-

[ Import Results @

Status:  Completed
Import Statistics
Frocessed: 3399
Added: 393
Merged: ]
Replaced: 0O
Errors: ]

Close

® Click the Open link to open the translation memory in the Translation Memories
view where you can view the imported data and modify the segmentation rules.

Importing TMX files into an existing
translation memory

This section describes how to import TMX files into an existing Trados Studio translation
memory (*.sdltm) in Trados Studio.
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Before you start

® To import a number of TMX files, place them all in a single folder so that you can import
the folder.

® Make sure that the translation memory you want to import data into, appears in the
navigation tree in the Translation Memories view. If the translation memory is not in
the navigation tree:

® select File > Open > Open Translation Memory to open a file-based translation
memory.

® select File > Open > Server-based Translation Memory to open a server-based
translation memory.

Importing TMX files into an existing Translation
Memory

About this task
To import a TMX file:

If you want to import a number of files, place them all in a single folder so that you can
import the folder.
Procedure

1. Ifyou are not currently working in the Translation Memories view, click the Translation
Memories button in the navigation pane to display the Translation Memories view.

2. Inthe navigation tree, select the translation memory you want to import data into.

¢ If the translation memory does not appear in the navigation tree, select File > Open
> Open Translation Memory or select File > Open > Server-based Translation
Memory from the Ribbon.

3. Select Home tab > Filters group > Import (or you can right-click the translation memory
and select Import from the shortcut menu).

Note: If it is a multilingual server-based translation memory, the option to import is
only available if you select the language pair to which you want to import underneath
the translation memory name on the navigation tree.

The Import wizard is displayed on the Import Files page.
4. Complete the Import Files page by selecting the files to be imported:
® If you want to select a single file, click Add Files.
¢ If you want to select a folder, click Add Folder.

® Continue selecting files until the list of files to be imported is complete.
Click Next.

® The TMX Import Options page is displayed:
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Impaort

TMX Import Options
Specify import options for the TMX files you have selected.
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~  Studio

(7) The imported data will be primarily used with presegmented legacy SOL Trados ITD or TTX files

(71 The imported data will be primarily used in mixed scenarios

Help <Back | [ Ned> |
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%]

L

5. Ifyou want to filter out unwanted translation units from the import, click Edit to display
the Filter dialog box where you create a filter to exclude the unwanted TUs. Only
translation units that match the filter are imported.

6. Specify how you want the import to handle fields that exist in the translation unit being
imported, but not in the translation memory you are importing to. Select one of the
following options from the Unknown Fields drop-down list:

® Add to translation memory - When this option is selected, the translation unit and
the unknown fields are added to the translation memory. The field is added to the
translation memory settings and becomes available for all translation units in the
translation memory.

¢ Ignore - When this option is selected, the translation unit is added to the translation
memory but the unknown fields are not imported.

¢ Skip translation unit - When this option is selected, translation units containing
unknown fields are not imported. Skipped translation units are not counted as errors
in the import statistics.

® Fail translation unit import - When this option is selected, translation units that
have unknown fields are not imported. Failed translation units are counted as errors
in the import statistics. You can also choose to export these translation units to a
separate TMX file, on the General Import Options page. See step 8.

7. When you upgrade a translation memory you can specify what data associated with the
translation unit is removed or retained in your translation memory in order to optimize
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the leverage from your new upgraded translation memory. For more information, see
“Compatibility with SDL Trados 2007 and SDLX 2007 Data " on page 126.

The upgraded TM will be primarily
used with new, native source files or
files processed only with Trados
Studio

Imports a version of the translation memory
that has had the associated data from a
translation unit removed. You might want to
do this, for example, if you are a translator
and you receive files in their original (native)
format with a legacy translation memory. In
this case, removing the data associated with
the translation unit will increase the leverage.

The upgraded TM will be primarily
used with presegmented legacy SDL
Trados ITD files and SDLX TTX files

Imports a version of the translation memory
that retains the legacy translation unit data.
You might want to do this, for example, if you
are a translator and you receive a
re-segmented legacy bilingual file with a
egacy translation memory. In this case,
retaining the data associated with the
translation unit will increase leverage.

The upgraded TM will primarily used
in mixed scenarios

Imports two versions of the translation unit,
one where the data associated with the
translation unit will be removed and another
one where it retains the data. You might want
to do this if:

® you want to permanently upgrade the
translation memory and

® you are using legacy bilingual files and
using bilingual files from Trados Studio

Selecting this option will maximize the
translation memory leverage in all situations.

The General Import Options page is displayed.
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-
Impaort T T-_—— r—r

General Import Options
Specify general import options and click Finish to start importing.

Spply Field Values:  Content Output = "Onling”

[] Import translation units as plain texd
[ Bxclude language varants

[] Export invalid translation units

Export Location:

If target segments differ:
@ Add new translation units
(7 Owenwrite existing translation units
() Leave existing translation units unchanged
(7 Keep most recent translation units

e

8. Complete the General Import Options page:

b

¢ Apply Field Values - If the translation memory you are importing into has custom
fields, you can specify what values should be placed in these fields for the imported
translation units. Click Edit to display the Field Values dialog box. For each field,
specify or select a value and click OK.
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Field values ﬁ
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Cottent Output Online
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[ ak. l[ Cancel ][ Help

L

¢ Import translation units as plain text - When this option is selected, all formatting
in the import file is ignored and the translation unit content is imported as plain
text. This may be useful if you are importing translation units from an application
that handles tags differently to Trados Studio as the imported tag information would
not display correctly in Trados Studio. It is also useful if you are importing a TMX
file that is from a third-party software that is version 1.4B or earlier.

® Exclude language variants - When this option is selected, translation units for
variants of the selected source and target language will not be imported. For
example if you are importing into an English (United Kingdom) / German (Germany)
translation memory and you select this option, any English (US) / German (Germany)
translation units in the import file will not be imported.

¢ Export invalid translation units - When this option is selected, translation units
that do not match the selections you have made on this page are not imported; they
are saved to a *.tmx file. The TMX file can be imported later if you want. Click
Browse to specify a location and name for the file.

If target segments differ - The source segments of some translation units for
import may be identical to those of the translation units in the translation memory
although the target segments differ. In this case, you can ask Trados Studio to:

® Add new translation units - This option imports the new translation units as
additional entries. The TM fields of the new translation units are merged with those
of the existing TUs.

® Overwrite existing translation units - This imports the new translation units and
overwrites the existing translation units. The TM fields of the existing TUs are also
replaced with the TM fields of the new TUs. The only fields that Trados Studio keeps
from the existing TUs are those fields that do not have a correspondent in the new
TUs.

® Leave existing translation units unhanged - This keeps the existing translation
units and their TM fields and does not import the new ones. For server-based TMs,
this option is only available for translation memories created in SDL Studio
GroupShare 2019 SP2 and later.

® Keep most recent translation units - This keeps the most recently changed
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translation unit and its fields. Trados Studio imports a translation unit whose source
segment is identical to that of an existing translation unit only if the imported unit
is newer than the existing one. If the change date of the translation unit for import is
older than the change date of the existing one, Trados Studio does not replace the
existing translation unit. For server-based TMs, this option is only available for
translation memories created in Studio GroupShare 2019 SP2 and later.

Existing translation units - Translation units that match both the source and target
segment of existing TUs, are not added as duplicates to the translation memory.
Instead, Trados Studio merges the system and custom fields available for the two
translation units. This ensures that the information about both translation units is
recorded in your translation memory.

Click Finish to display the Importing page. A progress bar is displayed as each task
is run.

9. When data has finished importing into the translation memory. Click Close.
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<7> Populating translation memories from bilingual documents

Overview

This chapter gives instructions on how to populate Trados Studio translation memories with
content from bilingual documents from SDL Trados 2007 and SDLX 2007.

You may want to do this in order to update your translation memory with previous
translations to extract context information. It allows you to leverage information from
previous translations and apply them to new translations. This chapter describes how to do
this with the following bilingual formats:

® SDL Trados 2007 TTX

® SDLX 2007 ITD

® SDL Trados 2007 Bilingual Rich Text Format (RTF) - created when translating in Microsoft
Word with SDL Trados Translator's Workbench.

Make sure you have installed the Trados Legacy Compatibility Pack app from the RWS
AppStore before you start working with ITD, TTX files in Trados Studio.

Why do this?
There are two reasons why you may want to do this:

® You can extract context information from the bilingual documents because of the
sequence of the translation units. This can then be used in your translation memory for
context matches.

Note: You can also use reuse the translations from bilingual documents by applying
PerfectMatch. For more information, see “Reuse Translations From Bilingual Documents in
PerfectMatch " on page 183.

® SDL Trados 2007 Bilingual Rich Text Format documents are created when translating in
Microsoft Word with SDL Trados Translator's Workbench and cannot be processed or
opened in Trados Studio. These files must first be cleaned up in SDL Trados Translator's
Workbench to create a legacy translation memory and then upgraded to the new
translation memory format.

Benefits and limitations

The key difference between importing bilingual files as opposed to TMX files is that bilingual
files do not contain custom fields.

However, a benefit to importing them is that you can extract context information which
cannot be migrated in any other way than with bilingual files. This may lead to higher-
quality matches. Also, tags and formatting can be extracted from bilingual files much more
reliably than from TMX files.

The following table shows details what can be extracted from a bilingual file when populating
a translation memory:
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Translation Units Yes Yes Yes
Context Match Yes Yes No
Information

Custom Fields and n/a n/a n/a
their Values

System Fields n/a n/a n/a
Tags Yes Yes Yes
Segmentation Rules [n/a n/a n/a

Two methods

There are two different methods you can use to migrate your bilingual files to the Trados
Studio translation memory format (* . sdltm).

Importing bilingual files to an existing Translation Memory

This method creates a new upgraded translation memory with the data extracted from the
TMX file. The TMX file is scanned to obtain all relevant information:

® Translation Units

® Custom fields and their values (You can only import these from TMX files created by SDL
Trados and SDLX)

® System Fields
® Tags
You can then choose which information is included in the new upgraded translation memory

and what settings are used. You also have more control over the custom fields and correcting
them if they are not imported correctly.

Note: Third party TMX files have a limited amount of data that is imported. Contact
professional services to determine if tags from your TMX file can be extracted.

The following diagram shows the steps you need to take to upgrade your TMX files using
the Upgrade Translation Memories wizard in Trados Studio:

The following diagram shows the steps you need to take to upgrade your TMX files using
the Upgrade Translation Memories wizard in Trados Studio:

Migration Guide 169



@ Populating translation memories from bilingual documents

Upgrade Translation
Memories Wizard

'

Input TMX Files

!

For third party TMX files
Upgradle Custom |————— S0L Professional Services
Fields should be consulted

New Upgraded _
Translation Memory 47/ fu?;;rﬂggjﬁbfmmﬂ /
Created

Importing bilingual files to a legacy translation memory and
upgrading the Translation Memory

This method is used for bilingual word documents from SDL Trados Translator's Workbench
that cannot be opened in Trados Studio. Bilingual Rich Text Format (RTF) documents are
created when translating in Microsoft Word with SDL Trados Translator's Workbench and
cannot be processed or opened directly in Trados Studio.

These files must first be cleaned up in SDL Trados Translator's Workbench to create a legacy
translation memory and then upgraded to the new translation memory format.

The following diagram shows the steps you need to take to import bilingual files to a legacy
translation memory and upgrade the translation memory:

Use Clean Up S Thdes T
" rados Iranslalors
Trados 2007
Upgrade Translation See Upgrading
i N Legacy Translation
Memories Wizard Memories
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Importing bilingual files to an existing
translation memory

This section describes how to import bilingual files to an existing translation memory in
Trados Studio translation memory format (* . sd1tm) using the Import wizard in Trados Studio.
You can import the following bilingual file formats:

® SDL Trados 2007 TTX
® SDLX 2007 ITD

Before you start

® If you want to import a number of files, place them all in a single folder so that you can
import the folder

® Make sure that the translation memory you want to import data into, appears in the
navigation tree in the Translation Memories view. If the translation memory is not in
the navigation tree:

® Select File > Open > Open Translation Memory to open a file-based translation
memory.

® Select File > Open > Server-based Translation Memory to open a server-based
translation memory.

Importing bilingual files to an existing
Translation Memory

To import a bilingual file:

Procedure

1. Ifyou are not currently working in the Translation Memories view, click the Translation
Memories button in the navigation pane to display the Translation Memories view.

2. Inthe navigation tree, select the translation memory you want to import data into.

® If the translation memory does not appear in the navigation tree, select File > Open
> Open Translation Memory or select File > Open > Server-based Translation
Memory.

3. Select Home tab > Filters group > Import (or you can right-click the translation memory
and select Import from the shortcut menu).

Note: If it is @ multilingual server-based translation memory, the option to import is
only available if you select the language pair to which you want to import underneath
the translation memory name on the navigation tree.

The Import wizard is displayed on the Import Files page.
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4. Complete the Import Files page by selecting the files to be imported.
® If you want to select a single file, click Add Files.
¢ If you want to select a folder, click Add Folder.

® Continue selecting files until the list of files to be imported is complete.
Click Next.

The Bilingual Document Import Options are displayed:

5. Complete the Bilingual Document Import Options page by identifying the segments you
want to import. You do this by selecting the segment confirmation level (status). You
can select multiple statuses. The following tables describes what the Trados Studio
statuses correspond to in SDL Trados TTX files and SDLX ITD files.

Draft Fuzzy Match, Machine n/a
Translated

Translated 100% Match, Manually Confirmed
Translated

Translation Approved Context Match, Unconfirmed
PerfectMatch

Click Next.
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Note:

® If there is no origin attribute associated with a translation unit in a TTX file and the
source and target text are the same, the status is set to Draft.

® For more information about the statuses in Trados Studio, refer to the online help in
Trados Studio .

The General Import Options page is displayed.

-

anpor Al i A

General Import Options
Specify general import options and click Finish to start importing.

Apply Field Values:  Content Cutput = "Onling’

[] Import translation units as plain text
[] Exclude language vanants

[7] Export invalid translation units

Export Location:

ff target segments differ:
@ Add new translation units
(71 Owenwrite existing translation units
() Leave existing translation units unchanged
() Keep most recent translation units

e

6. Complete the General Import Options page:

® Apply Field Values - If the translation memory you are importing into has custom
fields, you can specify what values should be placed in these fields for the imported
translation units. Click Edit to display the Field Values dialog box. For each field,
specify or select a value and click OK.
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¢ Import translation units as plain text - When this option is selected, all formatting
in the import file is ignored and the translation unit content is imported as plain
text. This may be useful if you are importing translation units from an application
that handles tags differently to Trados Studio as the imported tag information would
not display correctly in Trados Studio. It is also useful if you are importing a TMX
file that is from a third-party software that is version 1.4B or earlier.

® Exclude language variants - When this option is selected, translation units for
variants of the selected source and target language will not be imported. For
example if you are importing into an English (United Kingdom) / German (Germany)
translation memory and you select this option, any English (US) / German (Germany)
translation units in the import file will not be imported.

¢ Export invalid translation units - When this option is selected, translation units
that do not match the selections you have made on this page are not imported; they
are saved to a *.tmx file. The TMX file can be imported later if you want. Click
Browse to specify a location and name for the file.

If target segments differ - The source segments of some translation units for import
may be identical to those of the translation units in the translation memory although
the target segments differ. In this case, you can ask Trados Studio to:

® Add new translation units - Imports the new translation units as an addition to the
existing ones.

® Overwrite existing translation units - Imports the new translation units and
overwrites the existing translation units in the translation memory.

¢ Leave existing translation units unhanged - Keeps the existing translation units
and does not import the new ones. For server-based TMs, this option is only available
for translation memories created in Trados GroupShare SP2 and later.

® Keep most recent translation units - Keeps the most recently changed translation
units. Trados Studio imports a translation unit whose source segment is identical
to that of an existing translation unit only if the imported unit is newer than the
existing one. If the change date of the translation unit for import is older than the
change date of the existing one, Trados Studio does not replace the existing
translation unit. For server-based TMs, this option is only available for translation
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memories created in Trados GroupShare 2020 SR1 and later.

Existing translation units - Translation units that match both the source and target
segment of existing TUs, are not added as duplicates to the translation memory.
Instead, Trados Studio merges the system and custom fields available for the two
translation units. This ensures that the information about both translation units is
recorded in your translation memory.

Click Finish to display the Importing page. A progress bar is displayed as each task
is run.

7. When data has finished importing into the translation memory. Click Close.

Importing bilingual files to a legacy
translation memory and upgrading the
translation memory

This section describes how to import legacy Bilingual Rich Text Format (RTF) files created
when translating in Microsoft Word with SDL Trados Translator's Workbench to legacy SDL
Trados Translator's Workbench. Then upgrade the translation memory to Trados Studio
translation memory format *.sdltm using the Upgrade Translation Memories wizard in
Trados Studio.

Importing bilingual files to a legacy Translation
Memory and upgrade the Translation Memory

To import a bilingual file to a legacy translation memory and upgrade the translation
memory:

Procedure

1. Use the Clean Up command for your bilingual word document in SDL Trados Translator's
Workbench to remove hidden source text, restore the original coloring of your text and
to update the legacy translation memory.

Note: For more information, see the SDL Trados Translator's WorkBench User Guide.

2. Upgrade your translation memory using the Upgrade Translation Memories wizard. For
more information, see “Upgrading Legacy Translation Memories” on page 117.
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° Populating translation memories from alignment result files

Overview

This chapter describes how to populate Trados Studio translation memories from legacy
alignment result files. These are *. txt and . 1iad files, generated from SDL WinAlign and SDL
Align which have to be converted to the ».sd1tm formatin order to be used in Trados Studio
2009 - 2024.

Starting with Trados Studio 2015, a new integrated Alignment Tool is available which sends
the alignment result directly to an *.sdltm translation memory. However, if you have used
SDL WinAlign or SDL Align and you have legacy alignment results, you can use Trados
Studio 2024 to upgrade them to the Trados Studio format. This allows you to continue to
leverage matches from these files when you translate new documents in Trados Studio 2024.

Populating Translation Memories using SDL
Trados WinAlign alignment results

SDL Trados WinAlign is the legacy alignment solution in SDL Trados Studio 2011 and SDL
Trados 2007.

WinAlign allows you to create translation memory data from existing translated documents
but cannot send the segment pairs directly to an *.sdltm translation memory. Instead, it
produces an Alignment Results file in a . txt format which you have to manually convert
to the *.sd1tm format using the Upgrade Translation Memories wizard in Trados Studio.

Note:

® . tmx files exported from SDL Trados WinAlign can also populate Trados Studio
translation memories. However, RWS recommends that you only use * . tmx files from
SDL Trados WinAlign if you are working with Unicode only languages, such as Hindi and
Maltese.

Populating Translation Memories using SDLX
alignment results

SDL Align is the alignment solution for SDLX 2007. It enables you to harvest translations
from existing files and add them to an *.mdb translation memory in SDLX. You can upgrade
the *.mdpb translation memory to an Trados Studio translation memory format (*.sdltm)
using the Upgrade Translation Memories wizard in Trados Studio.

This means that valuable legacy files can be re-used, and consequently your efficiency and
productivity maximized.

For step-by-step instructions, see “Populating your Translation Memories from SDLX
Alignment Results” on page 178.
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Software required for upgrading alignment
result files

The SDL Alignment Tool available in Trados Studio 2014 SP1 and later sends the translation
units extracted from the aligned documents directly into an * . sd1tmtranslation memory. You
can then use *.sdltm translation memories in Trados Studio versions 2009 to 2024.

In contrast, legacy alignment tools like SDL Winalign and SDL Align which are available in
older versions of Trados Studio, send the extracted segment pairs to other translation
memory formats which then need to be upgraded to the *.sd1tm format.

To upgrade legacy alignment result files, make sure you have the application containing the
alignment tool and Trados Studio installed on your computer.

*.txt files (exported from SDL WinAlign or |Trados Studio 2024
WorkBench)

*.mdb translation memories which SDLX 2007 and any version of Trados Studio
contain the SDL Align results

Populating your Translation Memories from SDL Trados
WinAlign alignment results

This section describes how to populate your Trados Studio translation memories (*.sd1tm)
with SDL Trados WinAlign Export *. txt files.

You may want to do this if you have alignment result files created in WinAlign and you want
to use this translation data in Trados Studio 2024.

Upgrade SDL Trados WinAlign legacy files process

The following diagram shows the steps you need to take to populate your Trados Studio
translation memories with SDL Trados WinAlign Export * . txt files.
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Populating your Translation Memories from SDL
Trados WinAlign export TXT files

Procedure
1. Inthe Translation Memories view of Trados Studio, go to the Home tab and select
Upgrade Translation Memories.
2. Inthe Input Translation Memories page of the Upgrade Translation Memories wizard,
select your SDL Trados WinAlign export = . txt files:
® Select Add File-based TMs. In the Select Input Translation Memories dialog, select
the SDL Trados WinAlign export * . txt files and select Open.

® Inthe TXT Conversion dialog, select OK to convert your * . txt file to the intermediate
* . tmw format.
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r B
XT Conversion u

E To upgrade a Warkbench or WinAlign export file, it must first be converted to @ TMW file. This may take some

time.
Select the location for the converted TMW file.
Location: | D:UsershiproctorDocuments' My Received Files Browse

[ ok || cancel || Hep |

The files are displayed on the Input Translation Memories page as intermediate * . tmw
files.

3. The process of upgrading the intermediate *. tmw files to Trados Studio translation
memory format (*.sd1tm) is identical to upgrading process described in chapter 5. For
more information, see “How to Upgrade your Legacy Translation Memories " on page
128.

Populating your translation memories
from SDLX alignment results

This section describes how to populate your Trados Studio translation memories (*.sdltm)
with SDLX 2007 translation memories created from SDL Align (SDLX) alignment results.

Upgrade SDL Align legacy files process

The following diagram shows the steps you need to take to populate your translation
memories in Trados Studio using legacy SDL Align files.
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T¥T FilesExported
from SD0OLWinAlign

w
Upgrade Translation
Memaories Wizard in
S0OL Trados Studio

Input TXT Files

¥

Upgrade Custom Files

l

Mew Upgraded _
Translation Memoaories SDL Trados Studio SELTM
Forrnat
Created

Upgrade your translation memories to Trados Studio translation memory format (* . sdltm)
using the Upgrade Translation Memories wizard in Trados Studio. This process is identical to
upgrading process described in chapter 5. For more information, see “How to Upgrade

your Legacy Translation Memories” on page 129.
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@ Reuse translations from bilingual documents in PerfectMatch

Overview

This chapter gives instructions on how to extract translations from previously translated
bilingual documents from SDL Trados 2007 and SDLX 2007 and transfer them to Trados
Studio project files.

This is accomplished by applying PerfectMatch to your project in Trados Studio. It allows
you to leverage information from previous translations and apply them to new translations.
This chapter describes how to do this with the following bilingual formats:

® SDL Trados 2007 TTX
® SDLX 2007 ITD
® SDL Trados Studio SDL XLIFF

About PerfectMatch

A PerfectMatch is a form of context match that compares updated source files to a
corresponding set of existing bilingual documents rather than to a translation memory.

Segment matches, known as PerfectMatches, are checked for context, that is, the
surrounding entries are checked to ensure that they are the same. In addition, if your existing
bilingual document was segmented differently to the current document or had merged
segments, PerfectMatch can dynamically merge up to three consecutive segments in your
current document to improve your match results. The translations are then extracted from
the existing bilingual documents and transferred to the updated source files.

Because the PerfectMatch segment matching process includes a check for context and
segmentation, PerfectMatch units typically need no further translation or editing during
translation.

Note: Your license for Trados Studio may or may not include this feature. See the About
Editions and Licensing topic in the Trados Studio Help for information about your license
features.

Why use PerfectMatch?

You can extract context information from the bilingual documents because of the sequence
of the translation units.

Since the translations are inserted directly to the new project files as opposed to a translation
memory, it completely eliminates the requirement for in-context 100% match review and
requires no further editing.
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Scenarios

There are several scenarios where you might want to apply PerfectMatch:
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Pre-Project Scenario A:

At the start of a project, you can base a new project on an existing
Broject that has been fully reviewed. This will use the translated
ilingual files from the previous project for PerfectMatch.

For example, this could be useful if you are starting translation on a
technical manual for a second version of a product where the product
is almost the same as the first version.

Scenario B:

If you have two sets of previously translated files that you want to use
to apply PerfectMatch to the new project, you can do this by running
the PerfectMatch task twice.

To do this, select one set of translated files for PerfectMatch in the New
Project wizard and then PerfectMatch is automatically applied when
the project is created. After the project is created, run the Apply
PerfectMatch task and add the second set of translated files.

Note: To give first priority to the PerfectMatch translations and not
overwrite them when you pre-translate, you need to remove the
Pre-translate task from the Prepare/Prepare without Project TM
task sequence that is run as part of project creation. Then run the
Pre-translate task after you apply PerfectMatch for the second time.

Mid-Project Scenario A:

If you are part of the way through translating a project and you receive
a new set of source files that have been slightly modified, you can use
PerfectMatch to easily apply the work you %ave already translated to
the new set of documents.

This can be accomplished by creating a new project with the new set of
files and basing it on the project you are in the middle of translating.
PerfectMatch will then automatically apply all of your existing work to
the new set of files.

Scenario B: If you have already created a project and you receive some
previously translated files, you can use PerfectMatch to leverage the
translations from those files even though you have already started the
project.

This can be accomplished by running the Apply PerfectMatch task.
Scenario C:

If you have already created a project and applied PerfectMatch, and
then you receive additional files that need to be translated, you can
apply PerfectMatch to just those files.

This can be accomplished by running the Prepare/Prepare without

Project TM task sequence and selecting the previously translated files
for PerfectMatch.
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PerfectMatch process

This is one example of how PerfectMatch can be used when you create a project.

You can also apply PerfectMatch to an existing project. For more information, see “Applying
PerfectMatch " on page 190.

Existing Translation TM View in SDL Trados

Import Wizard

" Specify Status of
Translation Units to
be Imported

l

Apply Field Values Create a Filter

l

Successful Import

PerfectMatch options

There are several settings you can change to better make use of PerfectMatch.

You can tweak the way PerfectMatch leverages previous translation work by deciding if
formatting is taken into consideration or not.

If PerfectMatch renders poor result with heavily formatted documents, use the Ignore
formatting during PerfectMatch process option by opening the Options or the Project
settings dialogs and going to Editor > Language Pairs > All Language pairs > Batch
Processing > Perfect Match.

You can specify the translation origin and status that is used for translations taken from

previously translated bilingual files. This is specified on the PerfectMatch page in the New
Project wizard or the Batch Processing wizard.
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Apply PerfectMatch and lock

If you are applying PerfectMatch in the Pre-Project scenario where the translations were
taken from a previously reviewed project, you would typically want these to appear as a
PerfectMatch and be locked as there would be no need to edit those translations.

Only segments that have a status of Translated, Translation Approved and Signed Off will
be applied to the new project files.

Use the original translation origin and status

If you are applying PerfectMatch in the Mid-Project scenario where translations were taken
from bilingual files that have not yet been fully translated or reviewed, you would typically
want the translations to appear with the original origin, confirmation level and score.

For example, if it was a draft translation with a 95% match, you would not want that
translation to be locked as PerfectMatch but to be able to finish translating the segment
and confirm the translation

Note: If the files to which you are applying PerfectMatch already have confirmed or edited
translations, they will not be overwritten. PerfectMatch will only overwrite the target content
if:

® The target has a status of Not Translated.
® The target is a copy of the source and has not been edited manually or confirmed.

Selecting bilingual files

To apply PerfectMatch you need to pair the previously translated bilingual files with the new
project files. There are several different methods for doing this.

Selecting files when you have matching file names

If the files in your new project have the same file names and path location within the project
as the files in the previous project, you can select files using the following methods. This
ensures that the bilingual files are automatically paired with the new project files.

® Base your project on a previous project
® Automatically search a folder for bilingual files

Note: If you choose to select your bilingual files by automatically searching a folder, it will
only use the first type of bilingual file that it matches to the first project file in the list for all
of the project files. For the first project file it searches in this order: SDL XLIFF, TradosTag TTX
and then SDL Edit ITD. For example, if there is a matching SDL XLIFF file for the first project
file, it will only look for matching SDL XLIFF files for the remaining project files.
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Selecting files when you have different file names

If the file names in your new project are different to the file names in the previous project,
select the files using the following methods to pair the bilingual files with the new project
files.

® Manually add previous bilingual files
® Add files using a bilingual map file

About Map files

Map files are used when applying PerfectMatch to your project files. The map files allow you
to map files in the new project to the translated bilingual files in the previous project

This is useful if you have a large amount of files to which you want to apply PerfectMatch
and the file names have changed in the new project. Using map files avoids having to add
each previous bilingual file manually for every project file in the new project.

Map file format

Map files are tab delimited text files (TXT). A separate map file is required for each target
language in the project. Each line in the file is made up of two components.

Component 1:

The path relative to the new project folder and the file name of the file in the new project.
For example, if you created the folder structure shown below on the Project Files page of the
New Project wizard, the path would be the following:

o

Mewy Project

Project Files
Add project files or falders and venify that all file twpes are correcty identified.

) Add Files... | Add Folder.. = New Folder.. | | | (71 Merge Files.. | B CH
- Project .B ] Hame Size
[~ Froject 3 5]

@J SamplePhotoPrinter. doc 5 KR

If you did not create a folder structure under the project, then you would just put the file
name:
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P

ey F'ru:ujéu:i::

Project Files
Add project files or folders and werfy that all file types are comrectly identified.

) Add Files,., ; Add Folder.,  NewFalder. | [ 7 Merge Files..

..................... Name S|E

] SamplePhataPrinter. doc

Component 2:

The absolute path and file name of the bilingual translated file from the previous project:

Map file example

Map file creation

Bilingual map files can be created in any application that can produce tab delimited files,
such as Microsoft Excel or another text editor.

You can create the content of the files manually (by typing or copy/pasting the file paths) or
you may have another application or script that can automatically generate the content.

Applying PerfectMatch

PerfectMatch can be applied when a project is created or to files in an existing project. To
determine which procedure to follow, see “Why Use PerfectMatch? ” on page 184

® For information on how to create a new project and apply PerfectMatch, see “How to
Apply PerfectMatch to a New Project” on page 191.

® For information on how to apply PerfectMatch to an existing project, see “How to Apply
PerfectMatch to an Existing Project” on page 195.

Before you start

If you are using previously translated TradosTag (TTX) files, you should disable smart tag
pairing and use the compatibility mode to improve the leverage you get from the bilingual
files. For more information, see “Compatibility Setting for TT"” on page 221.
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About this task
To use the compatibility mode:
Procedure

1. Select File > options from the Ribbon. The Options dialog box is displayed. This is
where you can specify your default file type settings.

Note: If you are working with an existing project, you should do this in the Project
Settings dialog box.

2. Select File types > TRADOStag > Compatibility from the navigation tree. The
Compatibility settings are displayed on the right.

e = o=
b g Editor & | Compatibility
b B AutoSuggest Treat all inline tags as placeholders [dizable smart tag pairing)

4 E—‘e File Types

Generate Document Structure Information
b SDL=LIFF

A @ TRADDStag [ Canfirm all ranslated seaments with match value below 1005
Eompatl.blllty [T Include leading/trailing tags in segments
»-[#] SDL Edit

4 IE_] Microzoft Word 2000-2003
b [[T Microzoft Waord 2007-2013
b El Microgoft Waord 20072016
4 ﬂ;] Microzoft PowerPaint <P-2003
4 h:i] Microzoft PowerPoint 2007-2013
p-E3¢ Bilingual Excel
4 IT‘i] Microzoft Excel 2007-2013
4 @_] Microzoft Excel 2000-2003
4 E SDL Trados Translator's Workbench
»-[=) Rich Test Format (RTF)
bo-d@] WHTML 1.1
b HTMLS

b&] HTML 4

pged Adobe Framehdaker 813 MIF

b -"i Adobe InDesign CS2-C54 [Mx

b i Adobe InDesign CS4-CC DML

b m Adobe InCopy C54-CC ICML

p-F= OpenDocument Text Document (ODT)
b-Fa Openliocument Presentation [O0F)
»-f OpenDocument Spreadshest [0D5]
]
b

@ QuarksPress Export
M%) IFF r

o) (s ) [

3. Select the Treat all inline tags as placeholders option to use compatibility mode.
4. Click OK to close this dialog box.

Applying PerfectMatch to a new project

If you create a project where the project files are closely related files that have been
translated previously, for example previous versions of the same file, and you have the
bilingual files that were produced at that time, PerfectMatch can extract translations from
the bilingual files and apply them to the new project files.
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About this task
You can select these files by basing the project on a previous project on the Project Type

page or by explicitly selecting the files on the PerfectMatch page of the New Project wizard.
Step 1: Display the New Project wizard

Procedure
1. Click the New Project button. The New Project wizard is displayed.

2. Follow the on screen instructions to create the project and follow the instructions below
in steps 2 and 3 to set up PerfectMatch in the New Project wizard.

Step 2: Select the previously translated bilingual files

About this task

To apply PerfectMatch, you need to pair the previously translated bilingual files with the
new project files.

Selecting files when you have matching file names

If the files in your new project have the same file names and path location within the project
as the files in the previous project, you can select files using the following methods.

Method 1: Base your project on a previous project

Procedure

1. Start the Create a New Project wizard.
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&= Create a New Project — m] 4 —|
|
2 ] V] 5 6 7 8 g
|
i One Step General Translation Resources Termbases Trados GroupShare Perfect Match Batch Tasks Summary Preparation
| 1 of 9 completed
: Use Settings from Li) Source Language
| ww Sample Project (Sample project included with SDL Trados...) = Browse B [riglish (United States) -
Project Name Target Languages 3 Selected
Project 5 B German (Germany) I I French (France) | @ | Japanese {Japan)
| s
Location Path [¥] Autofil s
|

CA\Users\suricariv\Documents\Studio 2019\Projects\Samplesi\SamplePr | Browse

Project Files (0 total, O translatable, O reference) [ Include subfolders
BEMm % [ | Files in Selected Folder a Size | Usage File Type | File Type Identifier [5]
== Project3 (0)
|
|
|
|
|
|
|
|
Help Bac Mext Finisk Cancel |

2. Inthe Use settings from drop-down list, select the previous project.

Method 2: Automatically search a folder for bilingual files

Procedure
1. Go to the PerfectMatch page of the Create a New Project wizard.

2. Select the target language to which you want to add previous bilingual files, click Add
and then select Matching Previous Documents from Folder.

3. Browse to the required location, select the folder and click OK. The New Project wizard
searches the folder and all sub-folders for matching previous bilingual files automatically
and adds these to your project

Note:

® Even though you have selected a specific target language, the wizard will still add
any matching bilingual files that it finds for the other target languages in your folder.

® If the wizard finds other bilingual files that do not match the file names in your
project, it displays an error message stating the number of files it has been unable
to add out of the number of files found.
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Selecting files when you have different file names

If the file names in your new project are different to the file names in the previous project,
select the files using the following methods to pair the bilingual files with the new project
files.

Method 1: Manually add previous documents

Procedure
1. Display the PerfectMatch page of the New Project wizard.
2. Select the target language to which you want to add previous bilingual files.

3. Select the file under the Project File column for which you want to add a previous
bilingual file, click Add and then select Specific Previous Document.

4. Browse to the required location, select the previous bilingual file and click Open.

The previous bilingual file is displayed in the Previous Document column next to the
corresponding project file.

Method 2: Add previous documents using a map file

Procedure
1. Display the PerfectMatch page of the New Project wizard.

2. Select the target language to which you want to add previous bilingual files, click Add
and then select Previous Documents from Map.

3. Browse to the required location, select the map file and click Open.

The previous bilingual files are displayed in the Previous Document column next to the
corresponding project file.

Step 3: Select your PerfectMatch options

Decide what translation origin and status to use for the translations that are extracted from
the previously translated files and applied to the new project files.

Before you begin

For more information about these options and the scenarios in which you would use them,
see “Scenarios” on page 184.

Procedure

1. Display the PerfectMatch page of the New Project wizard.

2. Under Translation transfer options, select one of the following options:

® Apply PerfectMatch and lock: Use this option If you are applying PerfectMatch
from a project that has fully reviewed translations. This will mark all approved
translations as PerfectMatch with a status of Signed Off.

® Use the original translation origin and status: Use this option if you want to use
the same status and translation origin as the original document.
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The previously translated bilingual files are displayed in the Previously Translated
File column next to the corresponding project file.

Applying PerfectMatch to an existing project

If you have already created a project which has project files that are closely related files that
have been translated previously, for example previous versions of the same file, and you
have the bilingual files that were produced at that time, PerfectMatch can extract translations
from the bilingual files and apply them to the new project files.

Step 1: Display the batch processing wizard

Procedure

1. Select the project files to which you want to apply PerfectMatch in the Files view, and
rightclick and select Batch Tasks > Apply PerfectMatch. The Batch Processing wizard
is displayed.

2. Click Next to display the PerfectMatch page.

Step 2: Select the previously translated files

To apply PerfectMatch, pair the previously translated files with the new project files.

Selecting files when you have matching file names

If the files in your new project have the same file names and path location within the project
as the files in the previous project, you can select files by automatically searching for them.

Procedure

1. Onthe PerfectMatch page, select the target language to which you want to add previous
bilingual files, select Add Matching File and then select Matching Previous Documents
from Folder.

2. Browse to the required location, select the folder and click OK. The Batch Processing
wizard searches the folder and all sub-folders for matching previous bilingual files
automatically and adds these to your project.

Note:

® Even though you have selected a specific target language, the wizard will still add
any matching bilingual files that it finds for the other target languages in your folder.

¢ If the wizard finds other bilingual files that do not match the file names in your
project, it displays an error message stating the number of files it has been unable
to add out of the number of files found.
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Selecting files when you have different file names

If the file names in your new project are different to the file names in the previous project,
select the files by manually adding them.
Procedure

1. Onthe PerfectMatch page, select the target language to which you want to add previous
bilingual files.

2. Select the file under the Project File column for which you want to add a previous
bilingual file, click Add and then select Specific Previous Document.

3. Browse to the required location, select the previous bilingual file and click Open.

The previous bilingual file is displayed in the Previous Document column next to the
corresponding project file.

Step 3: Select your PerfectMatch options:

Decide what translation origin and status to use for the translations that are extracted from
the previously translated files and applied to the new project files. For more information
about these options and the scenarios in which you would use them, see Scenarios.
Procedure

1. Display the PerfectMatch page of the New Project wizard.

2. Under Translation transfer options, select one of the following options:

® Apply PerfectMatch and lock: Use this option If you are applying PerfectMatch
from a project that has fully reviewed translations. This will mark all approved
translations as PerfectMatch with a status of Signed Off.

® Use the original translation origin and status: Use this option if you want to use
the same status and translation origin as the original document.

The previously translated bilingual files are displayed in the Previous Document
column next to the corresponding project file.
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@ Migrating ING and INL tag settings files

Overview

This chapter describes how to migrate your SDL Trados INI and SDLX ANL files to Trados
Studio.

These files contain information about the elements and entities in the file, and how these
should be handled during the translation process. They enable Trados Studio to format
documents appropriately, separating tag content from translatable text, classifying tags as
inline or structure, and converting specified entities.

These tag and filter settings are migrated by importing the INI and ANL files into an existing
file type or a new file type in Trados Studio. The file type format used in Trados Studio is
* . sdlfiletype. This provides one consistent format for all tag and filter settings.

Why migrate your tag settings and analysis
files?

Migrating these settings will allow you to reuse the rules you previously had about
translatable and untranslatable content for your XML and HTML files.

What types of files can you migrate?

® Tag Settings Files (SDL Trados INI)

® SDLX Analysis Files (ANL) - (Only supported for migrating to XML and not HTML file
types)

Note:

® This chapter only describes how to migrate legacy tag settings and analysis files. For
information on general XML support including defining settings based on XSD, XML and
other files, refer to the online Help in Trados Studio .

The following table describes what versions of INI and ANL files are supported in Trados
Studio:

Trados 2007 Suite Yes n/a
Trados 2007 SP2 Yes n/a
Trados 2006 (7.x) Yes n/a
SDLX 2007 n/a Yes
SDLX 2006 n/a No
SDLX 2005 n/a No
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What is migrated?

The components that are imported from ANL and INI files can vary depending on if you are
importing to an XML file type or HTML file type. In addition, you cannot import ANL files to an

HTML file type.

Migrating INI and ANL Files for XML

When you migrate settings for XML files, RWS recommends creating a new file type and
then importing the INI or ANL file. The following table describes the individual components

that are imported from your ANL and INI files:

Parser Rules Yes Yes
Formatting No Yes
Customized Tag Toolbar No Yes
Settings

Root Elements and DOCTYPE |No Yes
Declarations for File

Detection

Entity Conversion Settings No No
Namespace Declarations No No
xml:lang Settings No Yes
UTF-8 BOM Settings No Yes

When you import a settings file for XML, the following settings are affected by the import:

® Parser rules - The parser rules specify the structure of XML files for Trados Studio. For
example, they determine what content is translatable text and what is non-translatable.
Trados Studio uses the parser rules to process XML files. Each XML file type has a
different set of parser rules.

® Writer settings - This specifies the META charset and the UTF-8 BOM handling in the

target file.

® File detection - When Trados Studio opens an XML file, it matches the file detection

settings and the file contents to determine the type of XML of the open file.

Migrating INI files for HTML

To migrate settings for HTML files, create a new HTML file type and import the settings to it.

You can only migrate settings from SDL Trados INI files.
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Note: The default HTML settings are the same as default settings defined in the INI files in
SDL Trados 2007. You only need to migrate these settings if you have made changes to them
in SDL Trados 2007.

The following table describes the individual components that are imported in your INI files:

Parser Rules Yes

Formatting No

Customized Tag Toolbar Settings | Yes

DOCTYPE Declarations for File Yes
Detection
Entity Conversion Settings Yes

¢ Element and attributes - Rules that manage how Trados Studio manages HTML
elements and attributes. It defines for each element, what sort of element it is, and
what attributes, if any, of the element are translatable.

® Entity conversion - This specifies how character entities are displayed during
translation. If a character entity is selected for conversion, Trados Studio displays the
character during translation, then re-encodes the character into its entity reference form,
which it inserts into the translated file. For example if the character entity is >, then the
translator sees the character >, and the translated character is encoded as entity >. If a
character entity is not selected for conversion, the entity reference, rather than the
character, is displayed as a placeholder tag.

® Writer - This specifies the META charset in the target file

® File detection - When Trados Studio opens an HTML file, it matches the file detection
settings and the file contents to determine the type of HTML of the open file.

Migrating INI and INL files for XML

This section describes how to migrate your SDL Trados INI files and SDLX ANL files to Trados
Studio for XML. You can migrate these settings by creating a new XML file type into which
you can then import the files containing the rules.

Use the Options dialog box to set up your default file type settings. These settings are used
every time you create a new project.

Note: You can also import INI and ANL settings to an existing XML file type. For more
information, refer to the online Help in Trados Studio .

200 Migration Guide


https://docs.rws.com/TradosStudio/

Migrating ING and INL tag settings files

How to migrate INI and ANL files for XML

To migrate INI and ANL files for XML you need to perform the following steps:

Procedure

1.

2
3.
4

“Step 1: Display the Options dialog box"” on page 201.
“Step 2: Create a new XML file type” on page 202.
“Step 3: Choose the file order ” on page 208.

“Step 4: Modify the Imported settings ” on page 209.

Step 1: Display the Options dialog box

Procedure

1.

Select File > options from the Ribbon. The Options dialog box is displayed.

2. Select File Types from the navigation tree. The File Types page is displayed on the right.

Options

b g Editor
l:’--EI AutoSuggest
b [E SOLHLIFF
4[] ML_Mew
- Detection
- Parzer
- Wfriter
- Entities
- Mameszpaces
- Whitezpace
Preview
- Walidation
- Embedded content
- Quickinzert
b@ TRADOStag
»-[#] SDLEdit
E._] Microzoft Wword 2000-2003
~fiw Micrasoft Word 2007-2013
El Microzoft Word 2007-2016
@ Microzoft PowerPaint x$P-2003
IT!_I] Microzoft PowerFoint 2007-2013
@ Bilingual Excel
@] Microzoft Excel 2007-2013
E._] Microzoft Excel 2000-2003
E SDL Trados Translator's Workbench
~[E=) Rich Text Format (RTF)
&] HHTML 1.1
- HTMLS
A HTMI 4

Reset to Defaults

T W T W W W W W W W

-

[E=5 (e =X
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SDL XLIFF = sdlxliff
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B HTMLS
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*.docx:" dotx;".docm;”. dotm
* docw” ot docm;”. dotm
* ppt.”.pps;” pot
* ppba:”. ppsx”. pot”. pptm;”. potm;”. ppem
" s

“ htrn;” kel shtml” jsp; . asp.”. aspe” a3
* bt kbl kbl jsp.” azp;” aspr”. as

m

+ Move Down

[ Import Settings... ] [ExportSeltings... ]

Ok

J[ Cancel ][ Help
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Step 2: Create a new XML file type

Procedure
1. Onthe File Types page, click New. The Select Type dialog box is displayed

CSelectType D =

Simple Delimited Text
HTHL
Feqular Expression Delimited T est

#ML [Embedded Content]
#ML [Legacy Embedded Content]

[ aF. ] [ Cancel

2. Select XML and click OK. The Create File Type wizard is displayed on the File Type
Information page.
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Create File Type
File Type Information

Set the information that identifies this file type _‘}f

A |

File type information

I

<> File type name: | 3<bL_Mew|
File type icon: @ azzembly/#SdlFileTypeSupport Mative Xmi_1_2/5dlFileTypeSupp

File type identifier:  Copy of xMLw 1.3.0.0

Filenames

Marne of individual document: =ML Template Document
Mame of document categony: ®ML Template Documents

File dialog wildcard expression:  *=ml

Drescription:
[Replace with a description of this file type]

Complete the File Type Information page.
® File type name - This is a mandatory setting. Change the file type name and enter a
suitable description.
® Optionally, complete the other settings on this page. For more information, refer to
the online Help in Trados Studio .

Click Next. The XML Settings Import page is displayed:
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Create File Type @

XML Settings Import
2

Impart gettings from an existing settings file or document.

#ML zettings import

Chooge whether you want to create an =ML file tpe based on default settings or bazed on settings from
an existing SOL settings file, ITS rule file, <KL file, DTD file or schema.

@ Create an ¥ML file ype bazed on the default settings
() Define settings based on IMI, ANL, #ML, S0, ITS ar DTD rule file:

| <Back | [ Met> Finish

5. Select your INI or ANL file to import:
® Select Define settings based on INI, ANL, XML, XSD, ITS or DTD rule file.
® Click Browse. The Import settings dialog box is displayed.

® Select the INI or ANL file and click Open. The XML Settings Import page is displayed
again with the settings file selected.

6. Click Next. The Parser Rules page is displayed. All of the rules from the imported INI or
ANL file are displayed on this page:
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-
Create File Type
Parser Rules
Define rules for reading transiatable content from the XML fie.
Parser
Search for; 4
Rula Translate Tagtype  Conbext Formatti_..
/Aogo Translatable (except ...
f Sweblink Translatable (except ...
! //address Translatable (except .
f //sgnature Translatable (except ..
¥ Feter Translatable jexcept ..
'l

7. Check the Parser Rules page to ensure your rules imported correctly.

® If you want to edit any of the rules, select the rule and click Edit. The Edit Rule dialog
box is displayed. You can modify the rules here.

Make the required changes and click OK to close the Edit Rule dialog box. The Parser
Rules page is displayed again.

Note: You can also modify rules after you create the XML file type.

In Trados Studio, structure tags are not visible to the translator. Therefore you need
to provide context information that allows translators to see where in a document

the text they are translating exists. For example, that a structure tag is a heading or
list item.

8. Specify the context information for your structure tag rules:
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[ Edit Rule |
Fule type: [Elummt 'l
Rule
Blement: leter -

| |

: Properties

Transiate: | Transiatable (out not n protected content) -]
Tag type: [hline '.l
Whitespace: | Inhert from Parent v
Fomatting: | Em. |
Structure info:

[ ok ][ cance |

® Select arule on the Parser Rules page that has a tag type of Structure and click Edit.
The Edit Rule dialog is displayed.

® C(Click the Edit button located next to the Structure info box. The Structure
Information Properties dialog box is displayed.
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-
Structure Information Properties liw

Name Code Description Document m

[} Dont inherit from Parert

® Click Add. The Add Structure Information dialog box is displayed:

Add Structure Information =
Standand: | Heading ~|
Pumpose: [ Match v]
Mame: Heading
Code: H

|dentifier: wim-heading

Description: | A heading
Set description from content of this relative XPath:

oo [
Formatting:

® From the Standard drop-down list, select the context of the structure tag. For
example, select Heading.

® Click OK three times to close the dialog boxes and return to the Parser Rules page
of the Create File Type dialog box.

9. Click Next. The File Detection page is displayed. The settings here determine what
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criteria is used for XML documents to be recognized as this file type.

-
Create File Type “
File Detection =

Provide information to identffy files that can be processed. = é'*.-
Detection

Enter the critera for XML documents to be recognized as this fie type. MNote: all settings are optional - a file only

has to match one of the settings to be recognized.

Ay of the following root elements:
¥

letter Add...
N -
¥  —
» .
¥
’ xsischemalocation declaration containing the fallowing LURI:
¥

DOCTYPE declaration with element name:

L]
¥ xmins: declaration with any of the followang URls: L
» Add...
) s
| Re fris =
L
L]
‘| Any of the following XPath nle matches:
Add. |
i

== o> ) ) e |

10. Edit the settings on this page as needed and click Next.

Note: For more information about the different settings, refer to the online Help in
Trados Studio .

Step 3: Choose the file order

On the File Types page the order of the files is important. Your new file type will be added to
the top of the page under SDL XLIFF.
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10)

About this task

When you add a file to a project or open a file for translation, Trados Studio searches this list
starting at the top, and working its way downwards. It processes a file as the first file of the
type which matches.

Procedure

1.

Click File Types on the navigation tree. Your new file type is displayed in the list on the
Files Types page on the right-hand side of the Options dialog box.

Select the new XML file type and use the Move Up and Move Down buttons to specify
where the file type should be located on the list.

File Types on the Navigation Tree

Filq Order on the File Types Page

IE_] bicrozoft \Word 2000-2003

|'[:" Microzoft Waord 2007-2013

@ tizrozoft Word 2007-2016

@ Microzoft PowerPoint »P-2003
El;] Microzoft PowerPoint 2007-2013
B Bilingual Excel

ﬁ Adobe InDesign C54-CC DML
m Adobe InCopy C54-CC ICML

= OpenDocument Text Document [ODT)

o B |

» OpenDocument Presentation (ODF)
5 OpenDocurment Spreadshest (O05)

@ QuarkiPress Expart
AR I

Fieset to Defaults

P W T W W YW T W W W W W W W W W W W W T

[iw Micrasoft ward 20072013

1 [l Microsaft Word 2007-2016

] Microsoft PowerPaint »P-2003
Eet] Microsoft PowerPaint 2007-2013
£ Bilingual Excel

E3] Microsoft Excel 20072013

%= OpenDocurnent Text Document (ODT) *
LS OpenDocument Presentation (ODF)
PEI OpenDocument Spreadshest [0D5)

/
owen: / S
b Editar / a | File Types /
St File Type E xtensions = New...
Bl FieTwes 1) SDL XLIFF = sdlxliff
bESU R emove
[2] ¥ML_Mew sl
b-[) XML_New [&] TRADOStag b
b [l THADD.Slag SDL Edit i
»|##] SDL Edit ] ] icrosoft word 2000-2003 * doc:”.dot

*.docw;”. dotw;”. docm;”. dotm

* docx;”. dob;”. docm;” dotrm

*.ppt*. pps.". pat

* ppts:”. ppsx”. pots:”. pptrn;”. potm;”. ppsm
ulsx

* s it wlsm

i3] Microsaft Excel 2007-2013 B Microsoft Excel 2000-2003 *als "l

B Microsoft Excel 2000-2003 E SDL Trados Translator's Workbench " doc;” docx

[®] SOL Trados Translator's workbench % :E?Jf:l 1Furmal [RTF) ::: . ™
=l Fi . htenl;” htm

E:j :;_T:Jf:t 1Format FTF) E HTHML S * bt bl whitml; . jsp; . asp;. aspe;” as
E HTML 5 @ HTML 4 * bt bl st jspc”. asp;” aspy” az
Ej HTML 4 \id Adobe Frametd aker 813 MIF * mif

= == Adobe InDesign C52054 INx *ins

Zzu tudobe Frameldsker 813 MIF i 4dobe InDesign C54-CC IDML * idrl

T3] Adabe InDesign C52.054 INX I &:dobe InCopy CS4-CC ICML *icml

odt;" ot odm

*.odp;".olp
“.ods;"ots

4 | i

| +

m

Move Down

[ Import Settings... ] [ExportSeltings... ]

ok ||

Cancel ] [

Help

Step 4: Modify the Imported settings

The settings you imported can be viewed on pages under the new file type on the navigation
tree:

Migration Guide 209



7T\
‘1\10/1‘ Migrating ING and INL tag settings files

About this task
opions =
b g Editar « File Types
4 |:§| A_UtDSUQQESt File Type E stensions |~ Hew,
+[Ed Fie ;}[') RS SDL XLIFF =_sdlxiff
b - [0 XML_New il
4 _ [& TRADOStag e
Detection 5DL Edi *id
\F:".fe' B Microsaft Ward 2000-2003 * doc;” dot
Enrtlit?;s IIT Microsoft Ward 2007-2013 * docx;” datx;” docm;”. datm
Namespaces [C] B Microsat word 2007-2016 * docw” date;” docm;” datm =
\Whitespace @ Microzoft PowerPaoint xP-2003 * ppt:”. ppz.”. pot
Preview Fi] Microzoft PowerPoint 2007-2013 * ppts”. ppsx”. pots;™. pptm;”. potm;”. ppsm
' alidation #as Bilingual Excel o
Erbedded corts §5] Microsoft Excel 2007-2013 * s bl
Sl ick neer E_] Microsoft Excel 2000-2003 "l il
b @ TRADOStag E SDL Trados Translator's Workbench " .doc” docs
»-[#] SDL Edit %) Rich Text Farmat [RTF)  1if T
b Microsoft Word 2000-2003 EIRHTML "l bt
b u:' icrozoft Wiord 20072013 [F HTHML G * bt html* kbl j2p;” asp;” aspe”. a3
b Microsoft Word 20072016 [V &I HTML 4 * htm;" html* shtml® jsp.” asp.” aspx.”. as
. ) 2 Adobe Frametaker 8-13 MIF * mif
b gj Hicroseft PowerPoint 47 2003 = Adobe InDesign C52.054 [NX inw
: _] :.:.cmsolftEF'owlerF'OInt 2z ﬁAdobe InDesign C54-CC DML *.idrnl
HEI’ M','"g“af E’m 500701 ] Wl 4dabe InCopy C54-CC ICML * ierml
’ |31_1 fcroso tEuce ) = DpenDocument Text Document (ODT] * odt” ott;* odm
4 —] Microsoft Excel 2000-2003 o OpenDocument Presentation [ODF)  “odp:".otp
4 E SPL Trados Translator's workbench PEI OpenDocument Spreadsheet [0DS] " ods"ots =
b} Rich Test Fomat (RTF) 3| = | v | [Movebewn]
be@] HHTHL 1.1
b HTMLS [ Import Settings... ] [ Expart Settings... ]
bod] HTHIL 4
Reset to Defauls ok || cancel | [ Hep

Procedure

1. Modify the imported settings on the following pages as needed:

® Detection - The imported settings on how Trados Studio identifies when a file is this

file type.

® Parser rules - The imported rules checks each XML element in the document against
the specified conditions to determine what content should be extracted for

translation.

® Writer - The imported settings on how Trados Studio saves the target XML file.

® Entities - The imported settings on how Trados Studio displays character entities to

translators.

® Namespaces - The imported namespace declarations for the XML file type.

® Whitespace - The imported settings on how Trados Studio handles the extra
whitespace characters found inside the XML elements.

® Preview - The imported settings on how Trados Studio handles adding style sheets
for previewing XML documents.

® Validation - The imported schemas and DTDs used for validation, and for specifying
when Trados Studio performs the validation (during the file detection stage, or
when the translator requests it).

® Embedded content - The imported settings for extracting and converting
embedded content into tags in the output document. These settings also specify

210 Migration Guide



Migrating ING and INL tag settings files

whether these tags are translatable or non-translatable.

® QuickInsert - The imported QuickInsert items available the XML file type. These
settings are only imported from INI files and not ANL files. On the QuickInsert page,
you can modify the QuickInsert group which is available in the Editor view. The
QuickInsert group contains buttons that you can use to quickly add formatting or
insert special characters, into the target XML documents.

Note:

® For more information on exactly what is imported, see “About Migrating INI
and ANL Files for XML " on page 199.

® For more information on what file type settings you can specify, refer to the
online Help in Trados Studio .

Migrating INI files for HTML

This section describes how to migrate your SDL Trados INI files to Trados Studio for HTML.
You can migrate these settings by creating a new HTML file type into which you can then
import the files containing the rules.

About this task

Use the Options dialog box to set up your default file type settings. These settings are used
every time you create a new project.

Note: The default HTML settings are the same as default settings defined in the INI files in
SDL Trados 2007. You only need to migrate these settings if you have made changes to them
in SDL Trados 2007.

How to migrate INI files for HTML

To migrate INI files for HTML you need to perform the following steps:

Procedure

1. "“Step 1: Display the Options dialog box” on page 212
2. "“Step 2: Create a new HTML file type " on page 212
3. "“Step 3: Choose the file order” on page 215

4, “Step 4: Modify the settings” on page 216
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Step 1: Display the Options dialog box

Procedure
1. Select File > options. The Options dialog box is displayed:

options fo e =
4 0’ Editor & | File Types
@ ?Tm_l_SUQQESt File Type Extensions il Hew...
b [E] SDLLIFF iﬂtjiﬁ x_':r:mh"
b [) XL_New [l TRADOStag ity
b [l TRADDStag [#]50L Edit itd
4 SDL Edit Microsaft word 2000-2003 * doc:”.dot
4 Microsaft Word 2000-2003 i Microsoft word 2007-2013 * docx;” dot;” docm;® dotm
b fiw Microsoft word 2007-2013 [T BE] Micrasaft Wword 2007-2016 * docx;” datx;". docm;” datm =
4 El Microsoft word 2007-2016 | Microzoft PawerPaint $P-2003 PPt pps”. pot
b Microzoft PowerPaint $P-2003 % Microzoft PowerPoint 2007-2013 * ppka:” ppax”. pots:”. pptm;”. potm;®. ppsm
b% Microzoft PowerPoint 2007-2013 £%5 Bilingual Excel " xlsx
,@ Bilingual Excel 5 Microsoft Excel 2007-2013 * s it s
b-430] Microsoft Excel 2007-2013 Microsoft Excel 2000-2003 sl
b Microsoft Excel 2000-2003 E SDL Trados Translator's Workbench " doc;” docx
DE SOL Tradaos Translator's Warkbench 5 Rich Text Fomat (RTF) :"tf . I
b-[E) Rich Test Fomat [RTF) @ #HTML 1.1 Chmlihm
b ] HHTML 1.1 [E HTMLE hiten:” hienl.” whitel: isp"asp” aspsas
. E HTML 5 @ HTHL 4 * bt html;” html;” j2p.". asp”. aspe” az
b@ HTHL 4 (2 Adobe Frameaker 813 MIF *.mif
- = Adobe InDesign C52-C54 [N *inw
bl Adobe Framebtaker 813 MIF ] Adobe InDesign C54-CC IDML il
b5l Adobe InDesign ES2-C54 I I dobe InCopy CS4-CCICML “icml
b‘ Adobe InDesign C54-CC IDML L= OpenDocument Text Document [ODT] . odt” ott;" odm
’Iﬂ #dobe InCopy C54-CCICML [7] s OpenDocument Presentation [ODF) " odp:™atp
D'E OpenDocument Text Document (ODT] %= OpenDocument Spreadshest (0DS)  *ods:" ot = e P
?---':‘o OpenDocument Presentation [ODF] T| —~ T | b Maove Down
K_’""EI OpenDocument Spreadshest [0D5]
b@ Quarki<Presz Export [ Import Settings... ] [ E=port Settings... ]
P LN [ e

o) (o)

Step 2: Create a new HTML file type

Procedure
1. On the File Types page, click New. The Select Type dialog box is displayed:

i - '
Select Type —— u

: — - -

Simple Delimited Text

Regular Expression Delimited Text
¥ML (Embedded Caortent)
¥ML {Legacy Embedded Contert)

| oK || Cancel

L|—~—-
2. Select HTML and click OK. The Create File Type wizard is displayed on the File Type
Information page:

— — — ¥
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Create File Type @

File Type Information e
Set the information that identifies thiz file tppe =}{
A

File type infarmation

HTHML

E Fil= type name:  Mew HTML

File type ican: E [none]

File type identifier:  Copy of Html File v 2.0.0.0

Filenames
Mame aof individual docurment:  HTRL Template Docurment
Mame of document category: HTHL Template Documents

File dialog wildcard expreszsion: . htm;™ html;™ jep;”. azp;" aspe;” azce,” inc;” php;” hhk,” hhc

Drezcription:

[Replace with a dezcription of thiz file type)

3. Complete the File Type Information page.

® File type name - This is a mandatory setting. Change the file type name and enter a
suitable description.

® Optionally, complete the other settings on this page. For more information, refer to
the online Help in Trados Studio .

4. Click Next. The HTML Elements Import page is displayed:

5. Select your INI file to import:

® Select Define HTML elements based on SGML, HTML, XML, XSD, DTD or INI rule
file.

® Click Browse. The Open dialog box is displayed.

® Select the INI file and click Open. The HTML Elements Import page is displayed
again with the settings file selected.
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6. Click Next. The Parser settings page is displayed with all the rules from the imported
INI file:

-
Create File Type -
Parser settings
Defines parser elemerts settings for reading translatable contert from the HTML file.
Parser
Search far: 4
Rule Condition Translate Tag type Cortet Fomatting =
| approval approval Translatable {but not...  Structure |E
f thead thead Translatable {but not...  Structure
1 callout_ref... callout_refer.. Translatable (but not...  Structure
chapter chapter Translatable (but not...  Structure
f topic topic Translatable (but not...  Structure
revision revision Translatable (but not...  Structure
change_d... change_des... Translatable (but not...  Structure
i oot Hoot Translatable (but not...  Structure
caption caption Translatable (but not...  Structure
: caution caution Translatable {but not...  Structure
danger danger Translatable {but not...  Structure
i step step Translatable (but not...  Structure
i Para Fara Translatable (but not...  Structure
[ notices naotices Translatable (but not...  Structure
heading heading Translatable (but not...  Inline
action action Translatable (but not...  Structure
lirkc lirkc Translatable {but not...  Inline i
f.I. .. S E—— - r
[ Add... ] [ Edit... ] [ Femove ] [ Copy ] [ Impart... ]

7. Check the Parser settings page to make sure your rules are imported correctly.

¢ If you want to edit any of the rules, select the rule and click Edit. The Edit Rule dialog

is displayed. You can modify the rules here.

® Make the required changes and click OK to close the Edit Rule dialog box. The Parser

settings page is displayed again.

Note: You can also modify rules after you create the HTML file type.

8. Click Next and edit the settings for the HTML file type on the pages of the Create File
Type Wizard as needed.

Note: For more information about the different settings, refer to the online Help for
Trados Studio .

9. Click Finish to create the new HTML file type with your migrated INI file.

214 Migration Guide


https://docs.sdl.com/813470/860842/trados-studio-2021-sr1/welcome-to-the-------------trados-studio-2021-sr1-documentation
https://docs.sdl.com/813470/860842/trados-studio-2021-sr1/welcome-to-the-------------trados-studio-2021-sr1-documentation

TN\
Migrating ING and INL tag settings files ‘1\10/1‘

The file type is added to the list of file types in the navigation tree in the Options dialog
box and list of files on the File Types page.

Step 3: Choose the file order

On the File Types page the order of the files is important. Your new file type will be added to
the top of the page under SDL XLIFF.

About this task

When you add a file to a project or open a file for translation, Trados Studio searches this list
starting at the top, and working its way downwards. It processes a file as the first file type
which matches. The new file type is added to the list

Procedure

1. Select your new HTML file type on the File Types page and use the Move Up and Move
Down buttons to specify the where the file type should be located on the list.

File Types on the Navigation Tree

File? Order on the File Types Page

/

Options /

b " Editor /
b [l tudbaSugnest

L FeToes D

e

b=
[ ML _Mew

[ TRaDOStag

SOL Edit

ILT'I_] Microzoft Word 2000-2003

|i:" Microzaft Word 2007-2013

@ Microzoft Word 2007-2016

@ Microsoft PowerPoint >P-2003

Ej Microzoft PowerPoint 2007-2013
B3 Bilingual Excel

I?‘i] Microzoft Excel 2007-2013

& Microsaft Excel 2000-2003

@ SDL Trados Translator's Waorkbench
%) Rich Test Fomat [RTF)

&) #HTML 11

& HTMLS

&) HTML 4

iy Adobe Framekdaker 8-13 MIF

-."_J Adobe InDesign CS2-C54 [Nk

ﬁ Adobe InDesign C54-CC (DML

m Adobe InCopy C54-CC ICML

= OpenDocument Text Document [ODT]

o Xm |

» OpenDocument Presentation [ODF)
= OpenDocument Spreadshest [OD5)

@ Quark:<Press Export
AT = o

Reset to Defaults

P T wT T Y T T WYY YW W T T W W W T W T W T

-

/ oo
File Types /
File Type Extensions j* New...
SDL XLIFF = sdluliff
[2] %ML_Mew * el
[ TRADOStag * thy
1[#]sDLEdit *itd
lﬂ__’] Microsoft Wwiord 2000-2003 *.doc;”.dot

iw Microsoft wiard 20072013

[Tl B Microsoft Word 2007-2015

] Microsoft PowerPoint XP-2003
‘;—j Microsoft PowerPoint 2007-2013
£ Bilingual Excel

‘?‘i] Microsoft Excel 20072013

B Microsoft Excel 2000-2003

E SDL Trados Translator's workbench
%) Rich Test Farmat (RTF)
E]RHTML 1.1

B HTMLS

EHTML 4

|2 dobe FrameMaker 813 MIF

* docx:” dobx:”. docm:”. dotm

*.docw;”. dotw;”. docm;”. dotm

* ppt:* pps:” pot

*.ppts;”. ppss;”. poty”. pptm; . patm; ™. ppsm
" s

* s wlb " wlsm

*xls wlt

*.doc;” docx

*itf

* htrl;” htm

* bt bl st jspc”. asp;” aspy” az
* htrn;". himnl; . xhtml” jzp;”. asp;”. aspx;” as
* mif

== Adobe InDesign C52-C54 IN< *inx
i 4dobe InDesign C54-CC IDML * idmi
M & dabe InCapy C54-CC 1CML * el
= DpenDacument Text Document (ODT) *.odt* att:* adm
s DpenDocument Fresentation [ODF) *odp;”.otp
PEI OpenDocument Spreadsheet (0DS]  “ods:ots

T| (1]

| b

m

Move Down

[ Impart Settings... ] [ExportSeltlngs... ]

(0] 3 ] [ Cancel

] [ Help
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Step 4: Modify the settings

The settings you imported can be viewed on pages under the new file type on the navigation
tree.:

About this task
Optons oo =
b 4 Ediar «  File type information
b @ AutaSuggest —
4+ [EL File Types E File type name:  Mew HTML
b SDL HLIFF _
4| Mew HTML File type icon: [E [none)
g::;t'm File lype identiier:  Capy of Himl File v 20,00
writer Filenames
Entities Lo
‘whitespace MName of individual document:  HTML Template Document
Preview Mame of document category: HTML Template Documents
Guicklnzert
3 @ wML_Mew File dialog wildoard expression: — “hitm;™ html;" jzp;". asp;” aspx:” ascs.” inc”. php;" hhk " hhc
b [ TRADOStag o
b SOL Edit Description:
b Micrasaft Wword 2000-2003 [Feplace with a description of this file type)

3 [[:' Microzaft 'wiord 2007-2013

4 @ Microzoft word 2007-2016

4 @ Microzoft PowerPaint x<P-2003

4 h:i] Microzoft PowerPoint 2007-2013
b-(54 Bilingual Excel

b I?‘i] Microsoft Eweel 2007-2013

b @_] ticrosoft Exeel 2000-2003

4 E SOL Trados Translator's Workbench
v} Rich Test Format (RTF

b @] HHTML 11

b HTMLE

b@&] HTML 4

blge Adobe Framebdaker 313 MIF

Ok, ][ Cancel ][ Help

Procedure
1. Modify the imported settings on the following pages as needed.

® Detection - The imported setting detects the documents to which Trados Studio
should apply the HTML file type settings.

® Parser - The imported settings check each HTML element in the document against
your specified conditions to determine what content should be extracted for
translation.

® Writer - The imported settings on how Trados Studio saves the target HTML file.

® Entities - The imported settings on how Trados Studio displays character entities
found inside HTML elements.

® Whitespace - The imported settings on how Trados Studio handles the extra
whitespace characters found inside the HTML elements.

® Preview - The imported settings on how Trados Studio handles adding style sheets
for previewing HTML documents.

® QuickInsert - The imported QuickInsert items available the HTML file type. On this
page, you can modify the QuickInsert group in the Editor view. The QuickInsert
group contains buttons that you can use to quickly add formatting or insert special
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characters, into the target HTML documents.

Note:

® For more information on exactly what is imported, see “About Migrating INI
Files for HTML " on page 199.

® For more information on what file type settings you can specify, refer to the
online Help in Trados Studio .
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Overview

This chapter provides information about the best practices to use in Trados Studio when
working with the legacy TradosTag (TTX) and bilingual RTF formats produced by previous SDL
Trados versions.

It explains the various scenarios that may occur and provides extensive information on how
to make use of the many new Trados Studio features whilst still being able to satisfy your
customer requirements by providing backward compatible TTX files and translation
memories for as long as these legacy formats are still required.

TTX files, bilingual Microsoft Word files vs. SDL
XLIFF files

SDL Trados 2007 featured two main ways of working:

® When pre-translating files in SDL Trados Translator's Workbench or SDL Trados Synergy,
or when opening files for translation in SDL Trados TagEditor, the file was converted to
a bilingual format for translation. This file format was referred to as TTX (TradosTag XML).

® When using SDL Trados Translator's Workbench with Microsoft Word, all files were
converted to bilingual Rich Text Format (RTF). If the file was in native Microsoft Word
* . doc format, this process happened behind the scenes.

When you open a document for translation or create a project in Trados Studio, files are
converted to SDL XLIFF, a new generation of a bilingual format that is more powerful, flexible
and standards-based than TTX. SDL XLIFF stands for SDL XML Localization Interchange File
Format. It is an XML-based bilingual file format, specially developed for use in localization.
SDL XLIFF files are compliant with version 1.2 of the XLIFF standard. For more information
on XLIFF files, refer to:

http://xml.coverpages.org/xliff.ntml

Before you start

Before you start working with TTX files in Trados Studio:

® Make sure that you have installed the Trados Compatibility and Migration Power
Pack before importing TTX files. You can access the RWS AppStore from the Add-Ins tab
in any view. For more information, see “Software required for upgrade ” on page 120.

® Specify Compatibility and Tag Verification Settings

220 Migration Guide


http://xml.coverpages.org/xliff.html

How to work with the translation supply chain with Trados Studio 2024 (TTX and

bilingual doc files)

Compatibility setting for TTX

Trados Studio 2024 can work with TTX using two modes:

® Smart tag pairing mode
® Compatibility mode

In smart tag pairing mode, Trados Studio attempts to convert tags in the TTX so that they
have an opening and closing tag in the TTX file and become a tag pair in Trados Studio. It also
attempts to preserve the semi-WYSIWYG formatting from TTX ( [Elbald ). In addition,
an opening tag in a TTX file may not have a closing tag in the same segment. This is no longer
supported in, so in these cases Trados Studio inserts an extra closing tag to ensure the
integrity of all tag pairs.

Bodd tag paw.doc.thy [Transkation sndl)S-deDEN * X
Ecid tg posr dociin - Bodd 1 poirdoc it -
: Thisis-a-sentence-with-a- ipbold EJ | Dies ist-gin-Satz-mit-einem-: pfett- P2
word, formatierten - Waort,
Bl tag peir dod i | Bl Lo padr doc x|

This smart tag pairing approach will work in most cases, providing for more user-friendly
translation of TTX files. However, occasionally in instances where you have used smart tag
pairing, the conversion back to TTX files may fail. If this happens, RWS recommends that you
activate the compatibility mode for TTX as shown below. In this mode, all tags from the

TTX files become placeholder tags ( 28l ) during translation in Trados Studio. Each tag in the
TTX file will correspond to exactly one tag in Trados Studio, with no extra tags inserted. In
addition, formatting from the source file will not be shown in Trados Studio. This approach
ensures the maximum possible tag integrity and maximum legacy support for TTX:

sentence docx t [Translation en-LUS-de- O] J AL
SERNCE JOXIX sentence JocXx
: This is a sentence with a (Jbold G word, |/ Dies ist ein Satz mit einem 2] po
fett formatierten (Jwort|
setence ok . sertence docxifx.

The TTX compatibility setting can also affect translation memory matching when tag pairs
start or end outside a segment. With smart tag pairing, a matching start or end tag is
included in the segment in Trados Studio. This results in better translation memory reuse
across file formats when using other Trados Studio file types, and also ensures safe tag pair
handling (a starting bold tag will always have a matching end bold tag). These matching
tags are not created in compatibility mode as the new safe tag pairing feature was not
available in SDL Trados Translator's Workbench and SDL Trados TagEditor. Choosing
compatibility mode may therefore result in better reuse with translation memories
originating from SDL Trados 2007.
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Determining what compatibility setting to select

Before you start work on TTX files, it is useful to test TTX compatibility to determine whether
to enable or disable smart tag pairing by doing a translation test of a representative TTX
file from your project. To do this:

Procedure

1. Click File > Open > Translate Single Document iN any view to open the TTX file in
Trados Studio.

2. Inthe Editor view, press [alt]+[shift]+[InsCopy] to copy all source segments to target
segments in Trados Studio.

3. Select File > save As Target. The Select File Type dialog box is displayed. Save the
target version in its native format (original file format) and a TRADOStag (TTX) file. This
works for all file formats that are supported in SDL Trados 2007, including customizable
file formats, such as XML or SGML. If you are working with SGML, you should import
the tag settings files (.INI) in SDL Trados 2007 to ensure a smooth translation.

Select File Type - sentence.docc.ttx E
Criginal Fle Format

I 0K | Cancel

If saving both output file formats is possible, you can use smart tag pairing mode. If
not, disable smart tag pairing and use compatibility mode. You can also open the
generated TTX file in SDL Trados TagEditor, use the Save Target As command to save it
in its original format and review the document to ensure it generated correctly.

Specifying your compatibility setting
To specify if you want to use the smart tag pairing mode or compatibility mode:

Procedure

1. Select File > options from the Ribbon. The Options dialog box is displayed. This is
where you can specify your default file type settings.

Note: If you want to specify these settings for the active project or active document
instead, select Home tab > Project Settings in any view.

2. Select File types > TRADOStag > Compatibility from the navigation tree. The
Compatibility settings are displayed on the right.
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HEE =N e =
b g Editar || Compatibility
b @ AutoSuggest Treat all inline tags a3 placeholders [disable smart tag pairing)

Fe E—‘e File Types

Generate Document Structure Information
b SDL=LIFF

4 [@ TRADOStag [T] Confirrn all translated segmerts with match value below 1005%
| Eompatibilty [ Include leading/trailing tags in segments

»-[#] SDL Edit

IE__] Microzoft word 2000-2003
[[:" Microzaft Word 2007-2013
El Microzoft word 2007-2016
ﬂ_j Microzoft PowerPaoint »P-2003

h:__'_lj Microzoft PowerPoint 2007-2013

-
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-

b-Ee Bilingual Excel

ED El_] Microzoft Excel 2007-2013

b@__] Microzoft Excel 2000-2003

DE SDL Trados Translator's Workbench
b} Rich Text Farmat [RTF)

b @] RHTML 1.1

b B HTMLS

b&] HTML 4

b3l Adobe FrameMaker 813 MIF

b‘i Adobe InDesign C52-C54 [N

bi Adobe InDesign C54-CC DML

bm Adobe InCopy C54-CC ICML

b OpenDocument Text Document [ODT)
,
-
b

my I |

» OpenDocument Presentation [ODF)
= OpenDocument Spreadsheet [OD5]

@ GuarkiPress Expart
FH ) IFE

o) o) (e

3. Select your mode:

® Select the Treat all inline tags as placeholders option to disable smart tag pairing
and use compatibility mode.

® Clear the option to enable smart tag pairing.
4. Click OK to close this dialog box.

Tag verification settings

You can fine-tune the way tags are checked in a TTX file

Specifying your tag verification settings

Procedure

1. Select File > Options > Verification > Tag Verifier > Common from the navigation
tree. The Tag Verification settings are displayed on the right.
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Optons ===~

b Editor Check far
> @ AucSugoest Togs added
b E File Types
b El Embedded Cortert Processors Tags deleted
- b[2 (& Checker 30

_ B Spacing around tags

b & Teminology Yerifier

<13 Translation Quality Assessment
- Language Pairs Ignore farmatting tags
- 4% Default Task Sequence
‘B Translation Memaries Yiew
- %) Colors

- F.eyboard Shortcuts

[ lgnore locked segments

[ lgnore diference between normal and non-breaking space

e

b (@ Automatic Updates
bed Welcome Yiew

o) (o)

2. Specify your tag verification settings and click OK to close this dialog box.

Scenarios

These scenarios provide information on how to plug into the SDL Trados 2007 (and earlier)
supply chain from Trados Studio by explaining how to provide TTX files and translation
memories to users of legacy SDL Trados product generations wherever required.

For information on which options to select before you start, see “Before You Start: Options
for TTX Support” on page 220.

Scenario 1: Client sends TTX files and wants TTX
files back

About this task
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Receivea TTX
file

# Select
compatibility
setting for
TTX

* Decide
whether to
openthe
document or
create a new
project using
the wizard

Translate the file
imStudio

* Take
advantage of
the new
features and
functionality

* Choose
whether to
savethe
target
document as
a TTXfile
and/orinits

native format

o

* Run Finalize if
you have
createda
project; not
necessary
when using
Open
Document

Install the Trados Compatibility and Migration Power Pack to add support for TTX files in
Trados Studio. This enables you to import TTX files and return TTX files sent to you after
translation in Trados Studio.

® Single-file translation (using the Translate Single Document command).

® Standard projects (using the New Project command). Use this if you want to work with
multiple TTX files in a bigger project. This also allows you to analyze and pre-translate
before working on the files in Trados Studio.

The basic workflow is as follows:

Procedure

1. Receive TTX files from customer.

2. InTrados Studio, decide if you want to use smart tag pairing or full compatibility mode
for TTX files and define the tag verification settings for TTX (see “Before You Start:
Options for TTX Support” on page 220).

3. InTrados Studio, do one of the following:

® Click File > Open > Translate Single Document to open a single TTX file for

translation.

® Click File > New > New Project if you want to use the project preparation options
available in Trados Studio and if you are dealing with several TTX files. This allows you
to use the project automation features, such as, analysis prior to translation and
pre-translation. All relevant project automation features are supported not only for
source files, but also bilingual input files in TTX format.

4. Translate the file(s) in the Editor view.
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Clean Up Files - en-us_de*dﬂm (United States)-German (Germany) ...

M-d | Remove m

Hlesto clean up:

CA\My Documents® SampleFresentation pphx tt
CoMy DocumentshSecond Sample docx thx

dal

C:\My Documents'.SamplePhotoPrinter.docx tt Optiong =
Help
L]
Changed translations
! _ Dont update () Dont clgan up
9 Lpdate TM ) Update document

" logFle | C:\Temploglog

[ 0%
| 0%
Segments Wonds
" Cleaned: 0 0
Cleaned and updated: 0 0
1 LI ’ Total: 0 0

= ———
5. After translation is finished, use one of the following:

® Select File > Save Target As if you want to generate the target translated document
for a single file. The Select File Type dialog box is displayed. You can select to save
it in its native (original) format, a TTX file or both.

i h
Select File Type - sentence.doc.ttx “

THRADOStag Documert
Criginal Fle Format

o) [ Gomen )

® If you are working with projects, select Projects view > Home tab > Batch Tasks >
Finalize. The Finalize task generates TTX files as target files and places them into the
target language folder of your project.

6. Deliver the translated TTX files back to your customer.
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Scenario 2: Client sends new source files and
wants translated files and TTX files back

About this task

In this scenario, you can use SDL TTX IT or SDL LegIt! to batch convert files to the TTX format,
then translate, save and finalize the files in Trados Studio.Leglt! is an OpenExchange App
that must be download from the RWS AppStore . TTX IT is an OpenExchange App that is
installed with your installation of Trados Studio 2024.

Convert file to TTX format in SDLTTXIT

Procedure
1. Receive new source files from customer.
2. Batch convert the files to TTX format in SDL TTX IT:
® Open TTXIT from the Start menu under SDL Trados Studio 2017 Apps > SDL TTX
IT.

_
SDL TTX It! - Batch convert source files to TTX - (=] E i)

| Bowseforfiets).. | [ Convert Source language- | English (United States) ~| [ Eiters | [ i Fies |
Clearfles st View folder

Source language st to: English (United States) [leid = 1033 | -
Selected 3 file(s) for conversion. b
Convedting C:\Users'\Administrator' Documents'\Studio 2014 Projects'\Samples’\Sample Project \en-US\Sample Photo Pinter.docx ..

Conversion successful  TTX -» C:\Usars \Administrator' Documents ' Studio 2014%Projects’ . Samples'.Sample Project \wan- US\SmplcPhduPnrlar.dncxlbt

Converting C:\Users'\Administrator’.Documents' Studio 2014'\Projects'Samples'Sample Projecten-U S\ Sample Presentation ppbx ..
Conversion successful_ TTX -> C\Users\Administrater' Documents'.Studio 2014\mes\SM\SWeHm\mUS\SMmemmm

Convesting C:\Users'\Administrator.Documents'\Studio 2014'Projects'\Samples\SampleProject\en-US\SecondSample docx ...

Clearlog Save log

® Select your source language from the Source language box.

® Select Browse for file(s) and select the files that you want to convert to TTX.

® Select Convert. The files are converted to TTX.

Note: Select View folder to see the files in that format.
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Convert files to TTX format or Bilingual DOC in SDL LegIt!

About this task
SDL Leqlt! allows you to converted to TTX or Bilingual DOC.

You can add custom ini files to ensure XML/SGML files for example are properly handled
as your client requires

You can add a Trados Translation Memory in TMW format and pretranslate 100%
matches only so they are already present in the Bilingual file that is created

If you don't have a Trados Translation Memory then a default version will be created in
the background and used to fully segment the Bilingual files. This means that the
Bilingual files created in this application are going to more closely match whatever your
client is using. So cleanup should always be successful, and conversion to the target
file should always be successful in the clients legacy Trados 2007 application.

Because these files are fully segmented it means they can only be translated in the
specified language pair (For TTX. Bilingual DOC doesn't care about languages). So if you
select en (US) to de(DE) then this is what the TTX file will be seen as.

Procedure

N oo uos

10.

11.

Receive new source files from customer.
Batch convert the files to TTX format or Bilingual DOC in SDL Leglt!:
Open Leglt! from Add-Ins tab > LegIt!.

Select your source language from the Source language box.
Select your target language from the Target language box.
Select Browse for file(s) and select the files that you want to convert.

Choose Convert to TTX or Convert to Bilingual DOC, depending to what you want to
convert the files.

Select Convert.
A message appears after the conversion is completed.

Note: Select View folder to see the files in that format.

In Trados Studio, decide if you want to use smart tag pairing or full compatibility mode
for TTX files and define the tag verification settings for TTX (see “Before You Start:
Options for TTX Support” on page 220.

In Trados Studio, do one of the following:

® Select File > Translate Single Document to open a single TTX file for translation.
Select the target language in the Translation Memory and Document Settings dialog.

® Select New Project option on the Home tab of the of Projects view you want to use
the project preparation options available in Trados Studio and if you are dealing
with several TTX files. This allows you to use the project automation features, such
as, analysis prior to translation and pre-translation. All relevant project automation
features are supported not only for source files, but also bilingual input files in TTX
format.

228 Migration Guide



How to work with the translation supply chain with Trados Studio 2024 (TTX and

bilingual doc files)

12. Translate the file(s) in the Editor view.

Clean Up Files - En-us_d&dLEEsh (United States)-German (Germany) ...

Add.. | Remove Clear

Hesto clean up:

CA\My Documents®SampleFPresentation pphx tt
CAMy DocumentsSecond Sample docx thx

dal’

iong
C My Documents' SamplePhoto Printer doco Optiong
Help
Changed translations
L ) Don't update () Dont clean up
@ Lpdate TM () Update document

|  logFle | CA\Tempoglog

[ 0%
| 0%
Segments Wonds
" Cleaned: 0 0
Cleaned and updated: 0 0
1 i | g Total: 0 0
| —

13. After translation is finished, use one of the following:

® Select File > Save Target As if you want to generate the target translated document
for a single file. The Select File Type dialog box is displayed. You can select to save
it in its native (original) format, a TTX file or both.

- ™
Select File Type - sentence.docx.ttx eS|

TRADOStag Documert
COriginal Fle Format

o) [Coms

® If you are working with projects, select Projects view > Home tab > Batch Tasks >
Finalize. The Finalize task generates TTX files as target files and places them into the
target language folder of your project.

® If you want to batch create native target documents from the TTX files, you can now
run a batch clean up in SDL Trados Translator's Workbench in SDL Trados 2007.
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Select Tools > Clean Up from the menu bar. If you select the Update TM option,
then any new translations you created in Trados Studio are also imported into your
legacy SDL Trados translation memories, effectively keeping both your new Trados
Studio and old SDL Trados translation memories up-to-date. For more information,
see “Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation
Memories Up-to-Date ” on page 238.

Clean Up Files - manuals_en-de - English [(United Kingdom)-German (Germany) E'

Filez to clean up:

Cancel

C:AMp DocumentshDocument. doc. ths
C:AMy Documents\Document2, doc. Optiang =
C: Ay Documentz\Docurment 3. kil b —

Help

il

Changed tranzlations

) Don't update () Don't clean up

() Update THM () Update document

LogFile - | |E:"~Dther |nfohTranslation Memu:-ries|

| 0% |
| 0% |
Segments Wiords
Cleaned: 1] 0
Cleaned and updated: ] 0
£ b Total 0 0

14. You can now deliver the translated TTX files and target files back to your customer.

Note: Scenario 2 can also be used when a client sends source files and wants to have
extra reassurance that the translation can be done successfully even if a translator
cannot complete the job and it has to be passed over to another translator to finish. In
such a scenario, TTX can be a used as a document format to work with as the translator
who finishes the job may not yet have Trados Studio and so can then work on the TTX
file in SDL Trados 2007.
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Scenario 3: Client wants bilingual TTX for review

About this task
Assign a review task Reviewer completes
to reviewer task
# Follow stepsin # Lze Studio tocreate * Reviewer uses review # Create final TTX
scenario 1 until vou andsenda project editing mode in Studio documents and/or
have draft translated package withthe TTX , then returns package translated documents
TTx files files toa reviewer Toyou in native format

This scenario is similar to scenarios 1 and 2 in that you can deliver TTX files for reviewing
purposes before converting the files back to their native format. However, if you choose to
review the files in legacy SDL Trados versions, the Trados Studio reviewing features are not
available. Reviewing TTX files in Trados Studio, works as well as reviewing new source files
that are converted to SDL XLIFF. Below are instructions about how to follow a Trados
Studio-based process for reviewing TTX files:

Procedure
1. Follow the steps in scenario 1 until you have fully translated TTX files.
2. InTrados Studio, create a project package:
® Click the Projects button in the navigation pane. The Projects view is displayed.

® Select your project, right-click and select Create Project Package from the shortcut
menu. The Create Project Package wizard is displayed.

Create Project Package 5|
Review Project Packages (,.
Fieview the project packages and rearange them as required. “»
FPackages:
(% TTX_Package (35 words) Marne: TT#_Package
Agsigh to: [F!alph_ Review V] [ Users... ]
Task: [Translate V] [ Tasks... ]
Duedate: [C]  EA1E/2015 E:00:00 Phd
Comment: -
Marne L  Reference File Sent Task words Status Pri
[ MNewSarmple. hirn. e scldiff ) O n'a 53 InTranslat..
[ 0ldSample.htm.tt sdlxliff ] O nia 36 Translated [
] 1 ] +
Add... Femove... Include subfolders Add Files... Femove Files Move to Package...
) (] [ o
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® Follow the on-screen instructions to create a package. On the Review Project
Packages page, select Review from the Task drop-down list.

® When the wizard is complete and the project package has been created, send the
package to the team member who will review the files.

3. The reviewer, can open the files for review from the project package in Trados Studio,
For more information, see “Open a File for Review " on page 99.

4. When the review is finished, the reviewer can create a return package with the completed
work and send it back to you.

5. When you receive the return package, open it and then use one of the following methods
to create your target documents:

® Select File > Save Target As if you want to generate the target translated document
for a single file. The Select File Type dialog box is displayed. You can select to save
it in its native (original) format, a TTX file or both.

i -
Select File Type - sentence.docx.ttx ﬁ

TRADOStag Document
COriginal Fle Format

F 0K [ camelg_ﬂ

® If you are working with projects, select Projects view > Home tab > Batch Tasks >
Finalize from the menu bar. The Finalize task generates TTX files as target files and
places them into the target language folder of your project.

¢ If you want to batch create native target documents from the TTX files, you can now
run a batch clean up in SDL Trados Translator's Workbench in SDL Trados 2007.
Select Tools > Clean Up from the menu bar. If you select the Update TM option, then
any new translations you created in Trados Studio are also imported into your
legacy SDL Trados translation memories, effectively keeping both your new Trados
Studio and old SDL Trados translation memories up-to-date. For more information,
see “Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation
Memories Up-to-Date ” on page 238.
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6. You can now deliver the translated TTX files and target files back to your customer.

Note: In Trados Studio, it is possible to work with project and return packages, as
described in steps 2 through 5 above. RWS recommends this way of working as it ensures
that all relevant settings and project resources (such as, documents, translation
memories, termbases and AutoSuggest dictionaries) can all be packaged up into one
single file, making it easy and safe to pass project work on to the next project participant.
However, similar to what was possible with TTX and ITD, it is also still possible to send
SDL XLIFF files without creating project packages first. These SDL XLIFF are self-sufficient
and can be opened in Trados Studio in the same way as any other document. However,
in this case, the project participant needs to manually open other resources belonging to
the project, such as the translation memory or termbase.

Tip: Use HTML-based bilingual preview for review purposes:

Even without using the package process described above, there are useful new review
features in Trados Studio which you can use to optimize the review process.
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About this task

For instance, if you want to review a translated document on paper, you can use the Print
Preview feature in Trados Studio to print the currently open document using your browser.
A wide range of options are available to fine-tune what will be printed and how. For more
information, see the Trados Studio Help .

File Edit View Favorites Tools Help

Getting Started Erste Schritte Shew saurss
Show tal
Finding a location for your photo printer Aufstellungsort fiir Thren Fotodrucker fii - w::m »
Place the photo printer on a flat, clean and dust-free surface, Platzieren Sie den Fotodrucker auf einer flach S :g
in a dry location, and out of direct sunlight. und staubfreien Oberflache, und stellen Sie ih [ Stenceficommen
trockenen Ort auf, der keinem direkten Sonne @ Shewt=xtanly
ausgesetzt ist. @ TETEES
Allow at least 12 cm clearance from the back of the photo [Apply Chenges |
printer for the paper to travel. When connecting power or B
USB cables, keep the cables clear of the paper path to the
front and rear of the photo printer.
For proper ventilation, make sure the top and back of the pa
photo printer are not blocked.
Allow enough space on all sides of the photo printer to let pa
you connect and disconnect cables, change the color -

Scenario 4: Client wants bilingual TTX files to
update their TM

This scenario is an extension to Scenario 2. See Scenario 2: Client Sends New Source Files
and Wants Translated Files and TTX Files Back on page 11-11 and Tip: Keeping Both Studio
(.sdltm) and Legacy SDL Trados (.tmw) Translation Memories Up-to-Date on page 11-23 for
more information on how to ensure that both Trados Studio and legacy SDL Trados
translation memories can be kept up-to-date.

Scenario 5: Client sends sources file in word
format (.doc) and wants bilingual .doc and
target.doc files back

About this task

Sawve and Finalizein
Studio

Receive Microsoft Translate files in Studio

Word Files

Cleanup thefilesin
Translator Workbench

* Generate the

» Batch convert the = Generate the target

» Lise the bilingual

source files toa .doc (SDL Trados bilingual docfiles .docfilesinTrados
bilingual .doc Translator's 2007

formatin Workbench) filter

Translator's inStudio

Waorkbench
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Procedure

1. Convert the files to bilingual word format using SDL Trados 2007. To do this, open SDL

Trados Translator's Workbench and do one of the following:

® Create a new translation memory with a source and target language that match the
language direction with which you want to convert the files.

® Select File > Open from the Ribbon to open an existing translation memory with a
matching language pair. This not only converts the files to TTX format but also

partially translates your files during batch conversion.
2. Select a workflow for bilingual word files:

® Select Options > Translation Memory Options from the menu bar. The Translation

Memory Options dialog box is displayed.

Translation Memory Options

General || Penalties || Substitution Localisation Cl:nnccurdance| Tools |

X]

General options

Strip unuzed fonts [] Strip T/ dwin styles

[ Move backup files

[ 5trip uruged styles I1ze zame log file for all Thz
[] TRADOS ag =ML workflow for wWorkbench | [] TRADOStag =L workfow for word
RTF files .doc files
C5% log file cell zeparator: ||-|SE spsterm default ) b |
Backup
¥.eep backup

Tag zettings files

@ Manage the tag ettings files list to customise settings for

waur MLAHTMLASGRML documents. T ag Sethings.. ]
Multiple ranslations
T
=
[ (u] 4 ] [ Zancel ] [ Help

® On the Tools tab, clear the check box next to the TRADOStag XML workflow for
Word .doc files option. This will ensure that documents are not converted to TTX
during the batch conversion. For more information on file type supportin SDL Trados
2007, refer to the SDL Trados File Formats Reference Guide shipped with SDL Trados

2007.

3. Select Tools > Translate from the menu bar. The Translate Files dialog box is displayed.
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Translate Files - manuals_en-de - English (United Kingdom)-German [Germany) E|

Add... Tranzlate

Files to tranzlate:

C: My DocumentzhDocument]. doc
C: My DocumentzhDocument?. doc Optionz =
C: My DocumentziDocument 3. kil
% or higher match value
[ ] Segment unknown sentences
Update changed tranzlations
(®1Dont () Update TH (" Update document
Tranzlate terms
® Dont () FReplace ) Inzert
[ Log File l |E:'\I'-1_I,I DocumentzMulog.log |
| 0% |
| 0% |
Segments: YWords
Ferfectt atch Count; 1] 1]
Tranzlated: 1] 1]
Ilpdated: 1] 1]
Total: 1] 1]
£ > Terms tranzlated: 1]

4. Select Segment unknown sentences to ensure the file is fully segmented even where
no match is found from the 2007 TM. If you do not select this option and use a new
translation memory, a clean TTX document that contains only the source document
converted to TTX is created.

Note: If you plan to keep both legacy translation memories from SDL Trados 2007 and
new translation memories in Trados Studio in sync (because you intend to work with both
product generations in the transition phase), RWS recommends that you ensure that
the segmentation rules of the SDL Trados 2007 translation memory match the settings
in the Trados Studio translation memory. This will ensure that you get the same or very
similar leverage from the translation memories in both products.

Click Add. The Files to Translate dialog box is displayed.
Select your files and click Open.

Click Translate. Your files are converted to a bilingual word format and the correct
source and target language is set for translation in Trados Studio later. If you have
applied a translation memory that contains data, your files are also pre-translated.
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8. Translate the files in Trados Studio. For more information about translating bilingual
word documents in Trados Studio, refer to the online help .

9. After translation is finished, use one of the following to convert the files back to the
bilingual .doc format:

® Select File > Save Target As if you want to generate the target translated document
for a single file. The Select File Type dialog box is displayed. You can select to save
it in its native (original) format, a bilingual file or both.

iy N
Select File Type - sentence.doc.ttx E

Original Fle Format

I 0K | Cancel

¢ If you are working with projects, select Projects view > Home tab > Batch Tasks >
Finalize from the menu bar. The Finalize task generates bilingual doc files as target
files and places them into the target language folder of your project.

10. Clean up the translated bilingual doc files in SDL Trados 2007. Select Tools > Clean Up
from the menu bar. The Clean Up Files dialog box is displayed.

Clean Up Files - TM - English (United States)-German (Germany)

Filaa to clean up:

ChDocuments and Settings AdmiristratorDes

Optiong -~
Help
Changed trandlations
(¥ Don't update ) Dont cleanup
) Update TM ) Update document

logFle - |C:"-:h:n:|_rnerds and Se‘l'ﬁngs"-A.cmhi|

| 0% |
| 0% |
Segmeris Words
Cleaned: o 0
Cleaned and updated: ] ]
< 2| Total: 0 0
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11. Click Add and select the translated bilingual .doc files.
12. Click Clean Up. When you do this, the following happens:

® A backup copy of the document is created that contains the source and translated
material (* . BaK).

® A copy of the target document with no source is created (the "clean" file - *.DOC).
® The translation memory is updated (* . TMw).

Note: For more information, see “Tip: Keeping Both Studio (.sdltm) and Legacy
SDL Trados (.tmw) Translation Memories Up-to-Date ” on page 238. This adds the
translations to your legacy translation memories for use in SDL Trados 2007.

Tip: Keeping both Studio (.sditm) and Legacy SDL Trados
(.tmw) Translation Memories up-to-date

The best approach to keeping both Trados Studio and legacy SDL Trados translation
memories up-to-date is to complete the following two steps:

Procedure

1. Trados Studio TM (.sdltm): Translate the TTX documents in Trados Studio and run the
Finalize batch task at the end of translation. This will ensure that the Trados Studio
translation memory will be kept up-to-date at all times.

Note: If you work with the master translation memory throughout the project lifecycle,
(this is the case if you do not use project translation memories or you work with single
document translation only using the Translate Single Document command rather
than the New Project command) then it is not necessary to run the Finalize task, as the
translation memory is already up-to-date based on your work in the Editor view in
Trados Studio.

2. SDL Trados Translator's Workbench TM (.tmw): After finalizing the files in Trados Studio,
the final version of the TTX files are automatically placed in the target language folder
of your project location in Trados Studio. In SDL Trados Translator's Workbench, open the
legacy translation memory you want to update.

® Select Tools > Clean Up from the menu bar. The Clean Up dialog box is displayed.
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Clean Up Files - manuals_en-de - English (United Kingdom)-German [Germany) E'

Add.. Clean Up

Filez to clean up:

Cancel

C:Aky Documentz\Document]. doc. b
C:\My Documents\Document2, doc. i Optians =
C:Aky Documentz\D ocument 3. kkml —

Help

Al

Changed tranzlations

() Don't update () Don't clean up
(%) Update TH () Update document

LogFile - | |E:"~Dther |nfohTranzlation Memu:uries|

| 0% |
| 0% |
Segments Words
Cleaned: 0 0
Cleaned and updated: ] ]
< > Tatal: 0 0

Click Add and select the final TTX files.
® Select the Update TM option.

Click Clean Up. SDL Trados Translator's Workbench updates the translation memory
based on the latest version of the TTX file and also produces the final target
language version.

Optionally, you can also run an analysis on the original (initial untranslated) files
using the SDL Trados 2007 translation memory and fix (re-translate) any segments
that do not match.

Note: If you plan to keep translation memories in both 2007 and 2024 in sync as
much as possible, use the mixed scenario option in the Upgrade Translation
Memories wizard when upgrading your translation memories from 2007 to 2024.
This will ensure that your 2024 translation memories are best suited for use with
both new (SDL XLIFF) and old (TTX or ITD) based projects.
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BB Upgrade Translation Memaries — 0 X
™ F e
L4 L4 3) -
Input Translation Memories Output Translation Memories ‘Qutput Translation Memaories Settings Upgrading Translation
Memories

3 of 4 completed

EN-US_DE-DE_en-US_de-DE

Qutput Translation Memories:
Settings Language Pairs Compatibility Fields  Language Resources

B EN-US_DE-DE_en-US_de-DE Location
- Please select the scenario that applies best to you:
EN-US_DE-DE tmx E PP ¥y
e} The upgraded TM will be primarily used with new, native source files or files processed only with SDL Trados
Studio

(O The upgraded TM will be primarily used with presegmented legacy SDL Trados ITD or TTX files

(® The upgraded TM will be primarily used in mixed scenarios
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Trados Studio includes open source or similar third-party software.

Autofac
Version: 4.8.1

Vendor: Autofac
Copyright: Copyright © 2015 Autofac Contributors
License type: MIT

License details: “https://github.com/autofac/Autofac/blob/v4.8.1/LICENSE" on page O

Azure.Core
Version: 1.38.0

Vendor: Microsoft, azure-sdk
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/Azure/azure-sdk-for-net/blob/main/LICENSE.txt" on
page 0

Azure.Identity
Version: 1.11.1

Vendor: Microsoft, azure-sdk
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/Azure/azure-sdk-for-net/blob/main/LICENSE.txt” on
page 0

CachedImage
Version: 1.0.1

Vendor: Hari Pachuveetil
Copyright: MIT © Haridas Pachuveetil 2014
License type: MIT

License details: “https://github.com/floydpink/CachedImage/blob/main/LICENSE" on
page 0

ControlzEx
Version: 4.4.0

Vendor: Jan Karger, Bastian Schmidt

Copyright: Copyright © 2015 - 2020 Jan Karger, Bastian Schmidt, James Willock
License type: MIT

License details: “https://github.com/ControlzEx/ControlzEx/blob/4.4.0/LICENSE"” on page
0
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Crc32.NET
Version: 1.2.0

Vendor: force
Copyright:
License type:

License details: “https://github.com/force-net/Crc32.NET/blob/develop/LICENSE” on
page 0

DocumentFormat.OpenXml
Version: 2.15.0

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/OfficeDev/Open-XML-SDK/blob/v2.15.0/LICENSE” on
page 0

Flee
Version: 1.2.2

Vendor: Muhammet Parlak
Copyright: Copyright 2017 Muhammet Parlak
License type: L-GPL

License details: “https://github.com/mparlak/Flee” on page 0

HtmlAgilityPack
Version: 1.11.16

Vendor: ZZZ Projects
Copyright: Copyright © ZZZ Projects Inc.
License type: MIT

License details: “https://github.com/zzzprojects/html-agility-pack/blob/v1.11.16/LICENSE"
on page 0

Hunspellx86
Version: 1.7.2

Vendor: Crawler-Lib
Copyright: Copyright (C) 2002-2017 Németh Laszl6
License type: L-GPL

License details: “https://github.com/hunspell/hunspell/blob/v1.7.2/license.hunspell” on
page 0
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ICSharpCode.Decompiler
Version: 7.1.0.6543

Vendor: Daniel Grunwald, Siegfried Pammer
Copyright: Copyright 2011-2021 AlphaSierraPapa

License type:

License details: “https://github.com/icsharpcode/ILSpy/blob/v7.1/doc/license.txt” on
page 0

icu.net
Version: 2.9.0

Vendor: SIL International
Copyright: Copyright © 2007-2019 SIL International
License type: MIT

License details: “https://github.com/sillsdev/icu-dotnet/blob/v2.9.0/LICENSE” on page 0

Icud4c.Win.Full.Lib
Version: 59.1.15

Vendor: SIL International

Copyright: Copyright (c) 2016-2017 SIL International
License type: ICU

License details: “https://github.com/unicode-org/icu/blob/release-59-1/icu4c/LICENSE”
on page 0

log4net
Version: 2.0.16

Vendor: Cincura.net, Apache.Logging
Copyright: Copyright 2004-2017 The Apache Software Foundation
License type: Apache 2.0

License details: “https://github.com/apache/logging-log4net/blob/rel/2.0.14/LICENSE"
on page 0

MahApps.Metro
Version: 2.4.10

Vendor: Jan Karger, Dennis Daume

Copyright: Copyright © 2021 .NET Foundation and Contributors. All rights reserved.
License type: MIT

License details: “https://github.com/MahApps/MahApps.Metro/blob/2.4.10/LICENSE” on
page 0
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Markdig.Signed
Version: 0.31.0

Vendor: Alexandre Mutel
Copyright: Copyright (c) 2018-2019, Alexandre Mutel.All rights reserved.
License type: BSD-2-Clause

License details: “https://github.com/xoofx/markdig/blob/master/license.txt” on page 0

MaterialDesignColors
Version: 3.0.0

Vendor: James Willock
Copyright: Copyright 2015 James Willock/Mulholland Software Ltd
License type: MIT

License details:

“https://github.com/MaterialDesignInXAML/MaterialDesignInXamlToolkit/blob/v4.3.0/LICENSE"
on page 0

MaterialDesignThemes
Version: 5.0.0

Vendor: James Willock
Copyright: Copyright 2015 James Willock/Mulholland Software Ltd
License type: MIT

License details:

“https://github.com/MaterialDesignInXAML/MaterialDesignInXamlToolkit/blob/v4.3.0/LICENSE”"
on page 0

MaterialDesignThemes.MahApps
Version: 1.0.0

Vendor: James Willock
Copyright: Copyright 2015 James Willock/Mulholland Software Ltd
License type: MIT

License details:

“https://github.com/MaterialDesignInXAML/MaterialDesignInXamlToolkit/blob/master/LICENSE”
on page 0

Microsoft.ApplicationInsights
Version: 2.22.0

Vendor: Microsoft
Copyright: Copyright (c) 2015 Microsoft
License type: MIT

License details:

“https://github.com/microsoft/ApplicationInsights-dotnet/blob/v2.2.0/LICENSE” on page
0
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Microsoft.AspNet.WebApi.Client
Version: 6.0.0

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: Apache 2.0

License details:

“https://www.nuget.org/packages/Microsoft. AspNet.WebApi.Client/6.0.0/License” on
page 0

Microsoft.AspNetCore.Connections.Abstractions
Version: 8.0.3

Vendor: Microsoft, aspnetcore
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt" on page
0

Microsoft.AspNetCore.Http.Connections.Client
Version: 8.0.3

Vendor: Microsoft, aspnet
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt" on page
0

Microsoft.AspNetCore.Http.Connections.Common
Version: 8.0.3

Vendor: Microsoft, aspnet
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt” on page
0

Microsoft.AspNetCore.JsonPatch
Version: 8.0.3

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MS-PL

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt” on page
0
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Microsoft.AspNetCore.SignalR.Client
Version: 8.0.3

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt” on page
0

Microsoft.AspNetCore.SignalR.Client.Core
Version: 8.0.3

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt" on page
0

Microsoft.AspNetCore.SignalR.Common
Version: 8.0.3

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt" on page
0

Microsoft.AspNetCore.SignalR.Protocols.Json
Version: 8.0.3

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt” on page
0

Microsoft.Bcl.AsyncInterfaces
Version: 8.0.0

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT” on page 0
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Microsoft.Bcl.HashCode
Version: 1.1.1.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/main/LICENSE.TXT” on page 0

Microsoft.Bcl.TimeProvider
Version: 8.0.1

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.1/LICENSE.TXT” on page 0

Microsoft.CSharp
Version: 4.7.0

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT" on page
0

Microsoft.Extensions.Configuration
Version: 8.0.0

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT" on page
0

Microsoft.Extensions.Configuration.Abstraction
Version: 8.0.0

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT" on page
0
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Microsoft.Extensions.Configuration.Binder
Version: 8.0.0

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT" on page
0

Microsoft.Extensions.DependencylInjection
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT” on page 0

Microsoft.Extensions.DependencylInjection.Abstractions
Version: 8.0.1

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.1/LICENSE.TXT” on page 0

Microsoft.Extensions.DependencyModel
Version: 7.0.0

Vendor: Microsoft, aspnet, dotnetframework
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/core/blob/v7.0.0/LICENSE.TXT” on page 0

Microsoft.Extensions.Features
Version: 8.0.3

Vendor: Microsoft
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt" on page
0

Microsoft.Extensions.Http
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.
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License type: MIT
License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT" on page 0

Microsoft.Extensions.Logging
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT” on page 0

Microsoft.Extensions.Logging.Abstractions
Version: 8.0.1

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.1/LICENSE.TXT” on page 0

Microsoft.Extensions.Options
Version: 8.0.2

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.2/LICENSE.TXT” on page 0

Microsoft.Extensions.Primitives
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT" on page 0

Microsoft.Identity.Client
Version: 4.60.3

Vendor: Microsoft, AzureAD
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details:

“https://github.com/AzureAD/microsoft-authentication-library-for-dotnet/blob/4.60.3/LICENSE"
on page 0
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Microsoft.Identity.Client.Extensions.Msal
Version: 4.60.3

Vendor: Microsoft, AzureAD
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details:

“https://github.com/AzureAD/microsoft-authentication-library-for-dotnet/blob/4.60.3/LICENSE"
on page0

Microsoft.Identity.Client.NativeInterop
Version: 0.16.0

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “" on page 0

Microsoft.IdentityModel.Abstractions
Version: 7.4.1

Vendor: Microsoft, AzureAD
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details:

“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/dev/LICENSE
on page 0

Microsoft.IdentityModel.JsonWebTokens
Version: 7.4.1

Vendor: Microsoft, AzureAD
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details:

“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/dev/LICENSE
on page 0

Microsoft.IdentityModel.Logging
Version: 7.4.1

Vendor: Microsoft, AzureAD
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details:

“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/dev/LICENSE
on page 0
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Microsoft.IdentityModel.Tokens
Version: 7.4.1

Vendor: Microsoft, AzureAD
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details:

“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/dev/LICENSE
on page0

Microsoft.Office.Interop.Outlook
Version: 15.0.4797.1004

Vendor: Camron Bute
Copyright:

License type:

License details: “" on page 0

Microsoft.Office.Interop.Word
Version: 15.0.4797.1004

Vendor: Camron Bute
Copyright:

License type:

License details: “* on page 0

Microsoft.Web.WebView2
Version: 1.0.2210.55

Vendor: Microsoft, webview
Copyright: © Microsoft Corporation. All rights reserved.
License type:

License details:

“https://www.nuget.org/packages/Microsoft. Web.WebView2/1.0.2210.55/License” on
page 0

Microsoft.Xaml.Behaviors.Wpf
Version: 1.1.77

Vendor: Microsoft, xamlexperiencesteam

Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/microsoft/Xam|BehaviorsWpf/blob/v1.1.77/LICENSE”
on page 0
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murmurhash-signed
Version: 1.0.2

Vendor: Darren Kopp

Copyright: Copyright © 2021 The Apache Software Foundation, Licensed under the Apache
License, Version 2.0.

License type: Apache 2.0

License details:
“https://github.com/darrenkopp/murmurhash-net/blob/master/LICENSE.md" on page 0

NETStandard.Library
Version: 2.0.3.0

Vendor: Microsoft, dotnetframework
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/standard/blob/v2.0.3/LICENSE.TXT” on page
0

Newtonsoft.Json
Version: 13.0.3

Vendor: James Newton-King
Copyright: Copyright (c) 2007 James Newton-King
License type: MIT

License details:

“https://raw.githubusercontent.com/JamesNK/Newtonsoft.Json/master/LICENSE.md"” on
page 0

Nlog
Version: 4.6.7

Vendor: Jarek Kowalski, Kim Christensen, Julian Verdurmen
Copyright: Copyright (c) 2004-2020 NLog Project - https://nlog-project.org/
License type: BSD-3-Clause

License details: “https://github.com/NLog/NLog/blob/v4.6.7/LICENSE.txt" on page 0

Sdl.MultiSelectComboBox
Version: 1.0.77

Vendor: RWS
Copyright: Copyright © RWS
License type: Apache 2.0

License details: “https://github.com/RWS/Multiselect-ComboBox/blob/master/LICENSE"
on page 0
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Sharpcompress
Version: 0.36.0

Vendor: Adam Hathcock
Copyright: Copyright (c) 2014 Adam Hathcock
License type: MIT

License details:
“https://github.com/adamhathcock/sharpcompress/blob/0.36.0/LICENSE.txt” on page 0

SharpZipLib
Version: 1.4.1.0

Vendor: ICSharpCode
Copyright: Copyright © 2000-2018 SharpZipLib Contributors
License type: MIT

License details: “https://github.com/icsharpcode/SharpZipLib/blob/v1.4.1/LICENSE.txt"
on page 0

Simplelnjector
Version: 5.4.4

Vendor: Simple Injector Contributors
Copyright: Simple Injector Contributors 2010 - 2020
License type: MIT

License details: “https://github.com/simpleinjector/Simplelnjector/blob/v5.4.4/LICENSE"
on page 0

SmartThreadPool
Version: 2.3.0

Vendor: Ami Bar
Copyright: Copyright © Ami Bar
License type: MS-PL

License details: “https://github.com/amibar/SmartThreadPool/blob/v2.3.0/LICENSE" on
page 0

System.Buffers
Version: 4.5.1

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/corefx/blob/master/LICENSE.TXT” on page 0
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System.Collections.Immutable
Version: 8.0.0

Vendor: Microsoft, dotnetframework
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT” on page 0

System.IdentityModel.Tokens.Jwt
Version: 7.4.1

Vendor: Microsoft, AzureAD
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details:

“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/7.4.1/LICEN
on page 0

System.IO.Abstractions
Version: 4.2.17

Vendor: Tatham Oddie
Copyright: Copyright © Tatham Oddie 2010
License type: MIT

License details:

“https://github.com/System-10-Abstractions/System.IO.Abstractions/blob/main/LICENSE”
on page 0

System.IO.Pipelines
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT" on page 0

System.Memory
Version: 4.5.5

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://dotnet.microsoft.com/en/dotnet_library_license.htm” on page 0
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System.Net.Http
Version: 4.3.4

Vendor: Microsoft
Copyright: Copyright © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://dotnet.microsoft.com/en-us/dotnet_library_license.htm” on
page 0

System.Numerics.Vectors
Version: 4.5.0

Vendor: Microsoft
Copyright: Copyright © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://dotnet.microsoft.com/en/dotnet_library_license.ntm” on page 0

System.Reactive
Version: 6.0.0

Vendor: .NET Foundation and Contributors
Copyright: Copyright (c) .NET Foundation and Contributors.
License type: MIT

License details: “https://github.com/dotnet/reactive/blob/rxnet-v6.0.0/LICENSE” on page
0

System.Reflection.Metadata
Version: 5.0.0

Vendor: Microsoft, dotnetframework
Copyright:
License type:

License details: “https://github.com/dotnet/runtime/blob/v5.0.0/LICENSE.TXT” on page 0

System.Reflection.TypeExtensions
Version: 4.7.0

Vendor: Microsoft, dotnetframework
Copyright: © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/corefx/blob/master/LICENSE.TXT” on page 0

System.Runtime.CompilerServices.Unsafe
Version: 6.0.0

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.
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License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT” on page
0

System.Text.Encoding.CodePages
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT” on page 0

System.Text.Encodings.Web
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT” on page 0

System.Text.Json
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT” on page 0

System.Threading.RateLimiting
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT" on page 0

System.Threading.Channels
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT” on page 0
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System.Threading.Tasks.Extensions
Version: 4.5.4

Vendor: Microsoft
Copyright: Copyright © Microsoft Corporation. All rights reserved.
License type: MIT

License details: “https://github.com/dotnet/corefx/blob/master/LICENSE.TXT” on page 0

YamliDotNet
Version: 8.1.0

Vendor: Antoine Aubry

Copyright: Copyright (c) 2008, 2009, 2010, 2011, 2012, 2013, 2014 Antoine Aubry and
contributors

License type: MIT

License details: “https://github.com/aaubry/YamIDotNet/blob/v8.1.0/LICENSE.txt" on
page 0

ZstdSharp.Port
Version: 0.7.4

Vendor: oleg-st

Copyright: Copyright Oleg Stepanischev 2024
License type: MIT

License details: “https://github.com/oleg-st/ZstdSharp/blob/0.7.4/LICENSE” on page 0
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