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Legal notice

Copyright and trademark information relating to this product release.

Copyright © 2000–2024 RWS Holdings plc. All rights reserved.

This legal notice applies to RWS Holdings plc and its subsidiaries and affiliates. All intellectual
property rights contained herein are the sole and exclusive rights of RWS. All references to
RWS shall mean RWS Holdings plc and its subsidiaries and affiliates details of which can be
obtained upon written request.

All rights reserved. Unless explicitly stated otherwise, all intellectual property rights including
those in copyright in the content of this website and documentation are owned by or
controlled for these purposes by RWS. Except as otherwise expressly permitted hereunder
or in accordance with copyright legislation, the content of this site, and/or the documentation
may not be copied, reproduced, republished, downloaded, posted, broadcast or transmitted
in any way without the express written permission of RWS.

Trados Studio is a registered trademark of RWS. All other trademarks are the property of
their respective owners. The names of other companies and products mentioned herein may
be the trademarks of their respective owners. Unless stated to the contrary, no association
with any other company or product is intended or should be inferred.

This product may include open source or similar third-party software, details of which can
be found by clicking the following link: “Acknowledgments ”  on page 161 .

Although RWS takes all reasonable measures to provide accurate and comprehensive
information about the product, this information is provided as-is and all warranties,
conditions or other terms concerning the documentation whether express or implied by
statute, common law or otherwise (including those relating to satisfactory quality and fitness
for purposes) are excluded to the extent permitted by law.

To the maximum extent permitted by law, RWS shall not be liable in contract, tort (including
negligence or breach of statutory duty) or otherwise for any loss, injury, claim liability or
damage of any kind or arising out of, or in connection with, the use or performance of the
Software Documentation even if such losses and/or damages were foreseen, foreseeable or
known, for: (a) loss of, damage to or corruption of data, (b) economic loss, (c) loss of actual
or anticipated profits, (d) loss of business revenue, (e) loss of anticipated savings, (f) loss of
business, (g) loss of opportunity, (h) loss of goodwill, or (i) any indirect, special, incidental or
consequential loss or damage howsoever caused.

All Third Party Software is licensed "as is." RWS makes no warranties, express, implied,
statutory or otherwise with respect to the Third Party Software, and expressly disclaims all
implied warranties of non-infringement, merchantability and fitness for a particular purpose.
In no event will Licensor be liable for any damages, including loss of data, lost profits,
cost of cover or other special, incidental, consequential, direct, actual, general or
indirect damages arising from the use of the Third Party Software or accompanying
materials, however caused and on any theory of liability. This limitation will apply even
if Licensor has been advised of the possibility of such damage. The parties acknowledge
that this is a reasonable allocation of risk.

Information in this documentation, including any URL and other Internet website references,
is subject to change without notice. Without limiting the rights under copyright, no part of
this may be reproduced, stored in or introduced into a retrieval system, or transmitted in any
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form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or
for any purpose, without the express written permission of RWS.
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1

About this Quick Start Guide



This guide is for translators and reviewers. It focuses on the how to translate local and cloud
projects, going through the whole translation workflow until review and sign-off.

Note: For information about on-premise server workflows using Trados GroupShare, see
to the videos and information in the Trados Studio Help available at:
https://docs.rws.com/TradosStudio 

How to use this guide

You can use the sample files to complete the exercises. Each exercise
builds on the last so if you are using the sample files you need to follow
through the instructions step-by-step.

This symbol indicates there are sample files available to complete the
exercise and their location. The paths specified are based on a Microsoft
Windows 10 or later operating system.

Note This indicates that there is a tip providing additional information on the
task you are performing.

Keyboard
Shortcuts

This indicates that there is an important piece of information you need to
know for the task you are performing. Any keys that you need to press on
your keyboard are displayed in the following font: Ctrl+Enter.

Cloud references
In this guide, the term "cloud" covers all product offerings powered by our cloud platform:

• Trados Studio's cloud capabilities (formerly known as Trados Live Essential).

• Trados Team

• Trados Accelerate

• Trados Enterprise

• Trados Terminology

All the examples illustrate working with cloud projects using a cloud account with a Trados
Studio's built in cloud capabilities subscription.

The cloud sections of this quick start guide assume you have read and completed the
"Cloud onboarding Quick StartGuide " or you already have an onboarded cloud account.

If you don't have an onboarded cloud account see " Onboarding your cloud account ".

1 About this Quick Start Guide
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Other information sources
Here are some other sources of information you can access:

• Trados Studio 2024 Help 

• Trados GroupShare 2020 SR1 Help 

• Trados GroupShare 2020 SR1 Installation Guide 

• Trados Studio 2024 Migration Guide 

• Project Management Quick Start Guide 

• Translation Memory Management Quick Start Guide 

• Trados Studio's built in cloud capabilities documentation 

• Trados Team documentation 

• Language Cloud Translation Management documentation 

1About this Quick Start Guide
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2

About Trados Studio



Trados Studio enables organizations to effectively manage all aspects of their translation
projects. Trados Studio incorporates project management and computer-aided translation
(CAT) tools for use by project managers, translators, editors, proofreaders and other
language professionals. These tools are provided through a highly customizable user
interface and it is easy to add on features from the RWS AppStore.

Trados Studio views
The features in Trados Studio are grouped together in thematic views. (e.g. there is a view
for managing translation projects and another one for performing the translation).

The view navigation buttons are located at the bottom of the navigation pane. To access a
certain view, select one of the view buttons.

2 About Trados Studio
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View Description

Welcome This is where you can:
• Access popular help videos and documentation
• Read the latest Trados Studio news
• Create a new project
• Translate a single document
• Open a package
• Open a Trados GroupShare project
• Access your Language Cloud account information and

manage subscriptions to Language Cloud machine translation
engines

Selecting any of these commands will switch you to the
appropriate view in Trados Studio or open another application
where you can perform the action.

Manager This is where you manage and work with your translation projects
and files. The Manager view offers you the best features of both
the Projects and Files view combined.

Projects This is where you view and work with projects. You can select a
project to view detailed project and file information and track
project and file status.

Files This is where you work with project files. From here you can:
• Open files for translation
• Open files for review
• Perform batch processing on files
• You can also view word counts and translation progress for

these files

Reports This is where you view project reports. The reports provide
detailed translation analysis figures which feed directly into the
project planning and budgeting process.

Editor This is where documents are translated and reviewed.

Translation
Memories

This is where you create and manage translation memories.

Alignment This is where you can align existing translated documents to
generate translation memory content. This view is only available
when you open an alignment result file (*.sdlalign).

2About Trados Studio
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3

Translation workflows



Local translation workflow for
single-files
Use the Translate Single Document command to initiate a translation and start working on
it quickly.

Starting a translation using this method bypasses the selections you make when using the
New Project wizard. For example, you do not specify settings for pre-translation. Using the
Translate Single Document command, you can create and save an*.sdlxliff file which
contains source language segments only and then, from this, create further *.sdlxliff files
which have a target language assigned to them. After you are done translating you can
quickly and easily generate the target files and finish the translation project.

The following diagram shows one potential way of translating in a single-file translation
workflow:

3 Translation workflows

10 Translating and Reviewing Documents



3Translation workflows

11Translating and Reviewing Documents



Project package translation workflow
A package is a file structure which contains all the files that need to be sent to a project team
member in order for them to work on the project. When translators or reviewers finish
their work, they send their work back to the person who assigned it to them, in return
packages.

Packages are used to send work to other team members when you are working in an offline
workflow.

Once the package is created, you can send it by email, post on an FTP site or use any other
method that you prefer to send it to the team member who will be working on the project
files. This eliminates the need to send multiple files or multiple emails and enables all
project information (files, translation memories (TMs), termbases (TBs) and AutoSuggest
dictionaries) to be sent with project files in a coherent structure.

The following diagram shows one potential way of translating in a project package workflow:

3 Translation workflows
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Cloud translation workflow
The following diagram shows the workflow for translating a cloud project file when using
Studio with its included cloud capabilities. Trados Team and Trados Enterprise subscriptions
give you access to more complex workflows and more account resources.

3Translation workflows
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Other online workflows
For information about online workflows, refer to the videos and information in the Trados
Studio 2024 Help .

3 Translation workflows
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4

Translating and Reviewing in
Trados Studio



Opening project files
This section provides an overview of the options Trados Studio provides to open resources
for translation.

Opening a single file for translation
Assume you want to translate the SamplePhotoPrinter.doc from English (United States) to
German (Germany). Follow these instructions to open the file and apply the settings you
previously defined in the Options dialog box.

Procedure
1. On the Welcome tab, drag the file or browse for it.

…Documents\Studio 2024\Projects\Samples\SampleProject\en-US\
SamplePhotoPrinter.doc

2. Select Translate single document.

3. In the Translation Memory and Document Settings dialog, you can see that the
translation memory you selected in the previous section is automatically displayed.
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Select Advanced to specify advanced settings. This will also display the termbase
and AutoSuggest dictionary that you selected in the Options dialog as well as other
settings related to the resources used during translation (such as, the minimum fuzzy
match value, what metadata to use when updating the TM and concordance search
settings).

4. Select OK:

• The translatable content of the source language document is identified, segmented
and placed in a bilingual *.sdlxliff file. The file is opened in the Editor window in
the Editor view for translating.

• Your default translation memories, termbases and AutoSuggest dictionaries that
you previously defined are automatically opened. Any other settings that you
specified in the Options dialog are also automatically applied.

5. Select File > Save:

• The Save As dialog is displayed. Trados Studio prompts you to save your document
as SamplePhotoPrinter.doc_en-US_de-DE.sdlxliff. Select Save to save your document
with this name.

• A project is automatically created with the same name as the document:
SamplePhotoPrinter.doc_en-US_de-DE.

Opening a local project file
The project associated with the project package you just opened becomes the active project.
You can now open the project files for translation.
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About this task
To follow along with this exercise in the application, use the Sample Project. If this project

is not the active (currently selected) project, display the Projects view and double-click on
Sample Project.

…Documents\Studio 2024\Projects\Samples\SampleProject\Sample Project.sdlproj

Procedure
1. Go to the Files view. This displays all files from the project package you have just opened.

2. Double-click the SamplePhotoPrinter. doc.sdlxliff file. The file is automatically opened
in the Editor view with the associated translation memories, termbases and AutoSuggest
dictionaries that were included in the project or project package.

Note: You can also right-click and select Open For Translation from the shortcut menu
to open the file.

Alternatively, you can open a project in the Manager view by clicking on the Add
Project button, selecting Open Project from the drop-list, and browsing to your
project's location.

Opening a file for translation from a local
project or project package
Assume you have received a project package from your customer that contains files that
need to be translated or reviewed. Follow these steps to open the package and start
translating its contents.
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Open a project package
Procedure
1. Select File > Open > Open Package.

If you want to follow along with this part of the exercise, ask another user of Trados
Studio to create a project package that you can use to open in Trados Studio.

2. In the Open Package dialog, browse for the package you've received and select Open.

3. In the Review Package Contents page, select Finish to import the package. The
Importing Package page is displayed.

4. If this is the first package for this project that you have ever opened, Trados Studio will,
by default, create a folder for this project under My Documents. This folder is labeled
with the name of the project to which the package is associated. You can choose to
save the project to a different folder, by selecting Browse in the Review Package Contents
window.

5. When the import is complete, select Close to close the Open Package wizard. A project
corresponding to the project details in the package has been created and opened in
Trados Studio.
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Local project settings

Options dialog
You can define default settings in the Options dialog.

When you start translating a local project, the default translation memories and termbases
are automatically opened and the default settings applied.

Language pair settings
Language pairs store settings relating to translation from a specific source language into a
specific target language. Resources and options are typically configured for use across all
language pairs to which they apply. Multilingual resources, such as termbases and
server-based translation memories, may apply to more than one language pair. Bilingual
resources, such as file-based translation memories, only apply to a specific language pair.

Typically you configure translation resources (even if they are bilingual) and edit settings at
the All Language Pairs level. The settings then apply to all language pairs and the translation
resources apply to the all language pairs to which they are relevant.

For example:

• If you select a multilingual server-based translation memory at the All Language Pairs
level that contains English to German and English to French language pairs, this
translation memory is used for translation for both language pairs.

• If you change the minimum match value to 65% at the All Language Pairs level, it will
apply to all language pairs.

Individual exceptions to these settings can be defined for each language pair. For example,
if you wanted the English to German language pair to have a different minimum match value,
you could change it at the individual language pair level.

4 Translating and Reviewing in Trados Studio

20 Translating and Reviewing Documents



Defining your default language pair settings
Before starting to translate local projects, you may want to set up default language pair
settings. This allows you to use the same settings and resources for all your local translations.
For example, you may want to specify which translation memory, termbase and other
resources to use to translate local projects from English to German.

About this task
Follow these instructions to set up your default translation memories, termbases and
AutoSuggest dictionaries for translating from English (United States) to German (Germany).

Note: These settings should be defined at the All Language Pairs level where possible.

You can follow the same procedure for setting up default resources for other language
pairs. In this example, you will use the sample project in Trados Studio. Once you are familiar
with these steps, you can then use them to specify your own default resources for all
language pairs with which you are working.

Procedure
1. Select File > Options from the Ribbon. The Options dialog is displayed.
2. Select Language Pairs > All Language Pairs > Translation Memory and Automated

Translation from the navigation tree.
3. On the Translation Memory and Automated Translation page, you can select file-based

and server-based translation memories. Select Use > File-based Translation Memory
and browse for the sample translation memory file.

…Documents\Studio 2024\Projects\Samples\SampleProject\TMs\English-German.
sdltm

• If your setup does not include any default options for the language pair English
(United States) - German (Germany), the Add Supported Language Pairs dialog is
displayed. Select the check box next to the language pair and click OK.
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4. Select Language Pairs > All Language Pairs > Termbases from the navigation tree.
5. On the Termbases page, you can select MultiTerm termbases. Select Use > File-based

MultiTerm Termbase and browse for the sample termbase file.
…Documents\Studio 2024\Projects\Samples\SampleProject\Termbase\

Printer.sdltb

6. Select Language Pairs > English (United States) - German (Germany) >
AutoSuggest Dictionaries from the navigation tree.

Note: AutoSuggest dictionaries can only be defined at the individual language pair
level.
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7. On the AutoSuggest Dictionaries page, you can select AutoSuggest dictionaries. Select
Add and browse for the sample AutoSuggest dictionary file.

…Documents\Studio 2024\Projects\Samples\SampleProject\AutoSuggest\
AutoSuggest_EN-US_DE-DE.bpm

8. Select OK to save your default settings.
These resources will now be used whenever you translate a document from English to
German.

Click through the tree structure under All Language Pairs to define additional
settings, such as minimum fuzzy match values and autosubstitution. Remember these
settings will apply to all of the language pairs. If you want to specify settings that are only
specific to the English to German language pair, do this under Language Pairs >
(English United States) - German (Germany).

Resources
You can select the following resources for a language pair:
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Resource Description

Translation
memories

The Trados Studio translation memory file-based format is
*.sdltm. You can use translation memories from any version of
Trados Studio 2009 and later. If you have a translation memory
from a previous version of SDL Trados or SDLX, refer to the Trados
Studio 2024 Migration Guide for details of how to upgrade the
translation memory to the current format.

You can also connect to server-based translation memories from
Trados GroupShare 2017-2020.

To connect to WorldServer 11.x and 10.4.5 Live TM, go to the
Add-instab >RWS AppStore and install the free WorldServer
Compatibility Pack for Studio.

Neural machine
translation providers

Trados Studio can connect to Language Weaver via Trados Team to
generate automated translations. You can access many other
Automated Translation providers, including Google Cloud
Translation and DeepL, from the RWS AppStore.

To find and install third-party AT providers, go to the Add-ins tab >
RWS AppStore and search for apps in the Automated Translation
category.

You can also add your own custom automated translation server.

Termbases Trados Studio 2024 is compatible with file-based termbases
created in MultiTerm 2017 and later. In addition, you can use the
following legacy termbase formats:
• MultiTerm 2007 (version 7.5) and previous 7.x releases
• MultiTerm iX (version 6.x).

When you open legacy termbases, they are automatically
upgraded to MultiTerm 2024, *.sdltb format. You can also
connect to server-based termbases in Trados GroupShare 2017
and later.

A convenient way of adding terminology assets to your project is
using termbases in your Trados Team account. If you have these
configured in your Trados Team account, you can use them just
like any other termbase.

AutoSuggest
dictionaries

AutoSuggest editing is an important feature which can be used to
speed up manual translation. AutoSuggest monitors what you are
typing. After you have typed the first few characters of a word,
AutoSuggest presents you with a list of suggested words and
phrases from the translation memory in the target language that
start with the same characters. You can use the following as
sources for AutoSuggest:
• AutoSuggest dictionaries - create a new or select an existing

AutoSuggest dictionary created by yourself or another user.
This dictionary contains words and phrases extracted from
translation memories (*.sdltm) or *.tmx files.

• A MultiTerm termbase selected in your project.
• AutoText entries - create a list of words and phrases manually

by typing them into Trados Studio.
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The AnyTM translation providers for local TMs, server-based TMs and machine translation
providers allow you to leverage translations from TMs with different source or target
language than the ones you have set in your project.

Changing your project settings
Change the settings that are applied to the file after you open it in the Project Settings
dialog. For cloud projects, Penalties, Filters and Field values can only be edited from your
cloud account.

About this task
When you change project settings, you typically change settings at the “All Language Pairs ” 
on page 20 level as you did when you set up your default settings in the Options dialog.

Assume you want to change your minimum match value for fuzzy matches to 65%. This is
the degree of match that must exist between a source document segment and a translation
memory segment in order for the segment translation to be offered as a match. The default
is 70%.

To change the minimum match value:

Procedure
1. Select Project Settings on the Ribbon, or under the kebab menu if you have the

Manager view active.
2. Select Language Pairs > All Language Pairs > Search from the navigation tree.
3. Change the Minimum match value under Translation to 70.

4. Select OK to apply your search settings to the document that is currently open.
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Note: For instructions on how to translate the document, see “A First Look at the
Translation Environment in Trados Studio ”  on page 26.

Translating documents in Trados Studio
This section describes how to translate the SamplePhotoPrinter.doc in the Sample Project
into German in Trados Studio. While this example uses a local file, very similar steps would
apply to the other ways of working, for example cloud workflows or GroupShare workflows.

About this task
First you open the sample file. See “Open a Project File ” on page 17 for details.

SamplePhotoPrinter.doc.sdlxliff in the Sample Project
…Documents\Studio 2024\Projects\Samples\SampleProject\Sample Project.sdlproj

A first look at the translation environment
in Trados Studio
In Trados Studio, documents are reviewed and translated in the Editor view. This view
contains the following components:

• Navigation pane, where you can see the documents that are currently open and navigate
between them.

• Ribbon tabs and groups containing editing tools.

• Editor window - this is where you perform translation or review (#3 in image below).

• Translation Results window - This window displays the results of translation memory
lookups and creates draft automated translations. From here you can apply one of the
results to the current segment if you are not happy with the result that is automatically
applied (#1 in image below).

• Term Recognition window - This window displays the results of the termbase lookups
(#2 in image below).
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A closer look at the Editor window
The Editor window in the Editor view is where you translate documents. The bilingual
*.sdlxliff document containing the text to be translated and the translation are displayed
side by side in the window. The source language text appears on the left and the target
language version on the right. The content of the document is broken down into segments
(typically sentences). The target language segments can be edited.

• The first column displays segment numbers. You can choose not to display segment
numbers. The source and target segments can also be worked with as two separate lists.

• Between the source and target segment columns is the segment status column. This
column is very important as it indicates the current translation status of the segment and
its translation origin. For example, if the translation is approved and if a 100% match
was found in the translation memory for this segment.

• To the right of the target language segments is the document structure column. It
displays a code that tells you where the segment text appears in the original document.
Hover over the code or click on the code in this column to display a description that
tells you where the segment appears in the source document.
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Context Matches
When you open the sample document, a lookup is automatically performed in the first
segment. In the example below:

About this task

• The results of the translation memory search are displayed in the Translation Results
window and the best result is placed in the target segment of the document.

• A context match has been found in the translation memory and automatically confirmed.
The match type is displayed in the segment status column and the symbol
indicates the segment is confirmed.

A context match is a 100% match that also has context, for example, it has the same
preceding segment in the translation memory as it does in the document. Context match in
this case means that this sentence has been translated at the beginning of a document
before. The context in the translation memory is assumed to be the same as in our example
where it is also the first sentence pair. No editing is required for a context match.
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Fuzzy Matches
Place your cursor in the target segment in segment 2.

About this task

• Two fuzzy matches (91% and 86%) are found in the translation memory and are displayed
in the Translation Results window.

• The fuzzy match of 91% is the best match and is automatically inserted into the target
segment of the document.

You can change the setting that automatically inserts the best fuzzy match into the
document from File > Options > Editor > Automation.

Termbases matches
When you placed your cursor in segment 2, a termbase lookup was also performed. Photo
printer was found in the termbase and is highlighted by a red bracket in the source segment.

The translation for the term, Fotodrucker, is displayed in the Term Recognition window.
This translation is already in the target segment as it was found in the translation memory.

Note: To insert a term translation, press Ctrl+Shift+L, click Insert term translation in the
Term Recognition window or go to Home tab > Terminology group > Show Translations in
the Editor view.
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Leveraging previously translated content with
upLIFT
As you get more advanced with using Trados Studio and your translation memories get
larger, you can take advantage of the upLIFT technology for TMs, which leverages previously
translated segment fragments to increase translation productivity and speed.

With TMs that have over 1000 translation units, Trados Studio can create a correspondence
between parts of source and target sentences and then suggests those fragments during
translation. Learn more about this in the Trados Studio 2024 Help .

Editing your translation
Edit the text in segment 2 to say Aufstellungsort für Ihren Fotodrucker finden. To do this, click
inside the target segment. You can use standard windows text editing functionality to edit the
segment and delete the word Geeigneten.

Spelling Errors
Spelling errors are displayed as a red wavy line underneath misspelled words. In segment 2,
the word Fotodrucker has a red wavy line underneath.
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About this task

Assume that Fotodrucker is the spelling that you want to use for this translation. Right-click
and select Add to Dictionary from the shortcut menu. The term is now added to your
custom dictionary and the wavy red line disappears.

To customize dictionaries and the words they contain, go to File > Options and click
Editor > Spelling > Custom Dictionary.

Confirming your translation
Now that your translation for segment 2 is complete, press Ctrl+Enter or click the Confirm
(Translated) button on the Home tab of the Editor view to confirm your translation.
This indicates that the translation is completely finished. When you confirm a translation:

About this task
The segment status is changed to Translated and the following icon is displayed in the
segment status column:

The translation is automatically added to the enabled translation memory. If you are using a
project translation memory, the translation is added to the project translation memory and
not the main translation memory.

Note:

For more information, see the About Updating a Translation Memory topic in the Trados
Studio 2024 Help .

Formatting Penalties
By default, when you confirmed your translation in the last step, your cursor was
automatically placed in the next unconfirmed segment. You can ask Trados Studio to jump
to a different segment from Home tab > Confirm.

About this task

4Translating and Reviewing in Trados Studio

31Translating and Reviewing Documents

https://docs.rws.com/TradosStudio2024
https://docs.rws.com/TradosStudio2024


Segment 3 has a 98% match in the translation memory. The text found in the translation
memory is the correct translation but because the new source segment in the document also
has formatting applied, a 2% penalty was applied in the translation memory because it
does not have the same formatting.

The symbol in the Translation Results window indicates that there is a formatting penalty.
Hover over the symbol to see the details of the penalty.

Note: By default, Trados Studio settings specify that recognized formatting tags (such as
bold and italics in this example) are hidden. The tags remain hidden when inserted and text
is instead formatted in the style shown in the Editor window.

Applying formatting
Source segment 3 contains some text formatted in bold, in a dry location, and some text
formatted in italics, direct sunlight. Use one of the following methods to apply formatting to
the text in the translation:

Method 1
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About this task
You can select the required formatting from the QuickPlace drop-down list. The QuickPlace
list is so-called because it allows you to quickly place elements from the source segment
into the target, for example formatting, numbers, dates and other types of placeables
(recognized tokens). For more information about placeables, see “Inserting placeables ”  on
page 36.

To apply formatting from a QuickPlace drop-down list:

• Select the text an einem trockenen Ortin the target segment and press Ctrl+,
(comma). A QuickPlace drop-down list of formatting options is displayed below the
target segment and the text with the formatting applied in the source segment is
highlighted in gold.

• Press Enter or Tab to select the first sample text on the list which is formatted in bold.

• Repeat the same steps above to apply italics formatting to keinem direkten Sonnenlicht.
This time select the sample text formatted in italics from the QuickPlace drop-down list.

Method 2
About this task
You can also select formatting from the QuickInsert group. This allows you to apply
formatting to the translation even if it does not exist in the source segment.

• Select the text an einem trockenen Ortin the target segment and click from the
QuickInsert group on the Home tab or press Ctrl+B.

• Select the text keinem direkten Sonnenlicht in the target segment and click from the
QuickInsert group on the Home tab or press Ctrl+I.

• Press Ctrl+Enter to confirm the translation.
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Performing verification
Trados Studio includes verification tools that check translated text for errors and
inconsistencies. Verification is automatically performed when you confirm the segment
translation and errors are displayed in the Messages window. The following verification
checks are includes in Trados Studio:

About this task

Verification Description

Tag Verification Tag verification compares the tag content of target text with the tag
content of the original source text and identifies any changes that
were made. Changes in the target text are acceptable provided that
the syntax of tags remains intact and that the translated document
can be converted back to its original format.

Tag verification helps to ensure that only acceptable changes are
made. The settings for this verifier are general, applicable to all files
type that you open in Trados Studio.

QA Check 3.0 QA Checker 3.0 incorporates a suite of quality assurance checks. The
checks are broken down into the following areas: Segment Verifica-
tion, Segments to Exclude, Punctuation, Numbers, Regular
Expressions, Word List, Inconsistencies, Trademark Check and
Advanced.

Starting with WorldServer 10.4, all WorldServer packages include the
QA Checker Profile configurations set in WorldServer. This ensures
that Studio uses the same quality settings for all the files belonging
to that WorldServer project.

Terminology
Verifier

Terminology Verifier checks your current document to ensure that
the target terms contained in the MultiTerm termbase have been
used during translation or to verify whether forbidden terms have
been used.

In segment 4 there is no match in the translation memory so the target segment remains
blank. For the purpose of this example, enter the following incorrect translation with a wrong
number, Lassen Sie 11 cm Abstand. and then press Ctrl+Enter to confirm the translation
and perform verification.

• An error has been found and the symbol is displayed in the segment status column.
Hover over the symbol to for a quick explanation of the error.
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The error indicates that a number from the source segment is missing in your translation.
Your translation has the number 11 cm when it should be the same as the source segment 12
cm.

To view detailed information about the error:

• Click on the Messages tab to display the Messages window.

• Right-click on the error message and select Show Message Details…
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The Problem Description box provides additional detail and a suggestion of how to fix the
problem by adapting the measurement.

• Click Close to return to the Editor and fix the problem in the example on the next page.

Verification can also be performed on the whole document by pressing F8. You can then
use the Verification Message Details dialog box to review and sometimes automatically fix
those errors. For more details, see the Trados Studio 2024 Help .

Inserting placeables
Placeables are source document content that has been recognized as content not requiring
translation and/or content which can be automatically localized by applying a translation
memory. Placeables are identified in the Editor window by a blue square-bracket underline.

About this task
Edit the translation in segment 4 and insert the correct placeables (12 cm):

• Delete the text from the target segment.

• Copy or type the following text into the target segment: Auf der Rückseite des
Fotodruckers sollte für problemlosen Papiertransport ein Abstand von mindestens.

• Press Ctrl+,(comma). The QuickPlace drop-down list is displayed. In an earlier example,
the QuickPlace drop-down list showed formatting; now it displays the number from
the source segment for you to place it into the target segment.
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• Press Enter or Tab to select 12 cm from the list.

• Copy or type the rest of the translation: gelassen werden.

• Press Ctrl+Enter to confirm the translation. This time there are no verification errors.

Using AutoSuggest
AutoSuggest editing monitors what you are typing and, after you have typed the first few
characters of a word, presents you with a list of suggested words and phrases from the
AutoSuggest sources in the target language that start with the same characters.
AutoSuggest uses the following sources:

About this task

• termbases

• AutoSuggest dictionaries (bilingual sentence fragments from TMs)

• AutoText entries

• translation memories, automated translation providers and concordance search
matches.

For more information, see “Resources”  on page 0.

Use AutoSuggest to translate segment 9:

• Place your cursor in segment 9. Type H. The AutoSuggest list is displayed below the
segment. It suggests using Hinweis. The symbol indicates that this suggestion comes
from the AutoSuggest Dictionary. Press Enter to insert the suggestion.

• Enter a colon: and press Ctrl+Enter to confirm the segment.
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Your cursor is automatically placed in segment 10. Translate the segment using AutoSuggest:

• Type the following translation using the suggested words displayed on the AutoSuggest
list (bold letters indicate words or fragments that you can insert from the AutoSuggest
list after typing the first letter): Verwenden Sie ausschließlich dasNetzteil, das im
Lieferumfang des Druckersenthalten ist.

• Type the F for Fotodrucker. The following suggestions are displayed. This list includes a
suggestion from a termbase and from a translation memory. The symbol indicates
that a suggestion comes from a termbase. In this case, you see Fotodrucker twice on
the suggestions list as it has been found both in the termbase and in the AutoSuggest
Dictionary. Finding a suggested translation in two sources can provide a more accurate
translation.

• Use your arrow keys to select either version of Fotodrucker and then press Enter to
insert the suggestion.

• Press Ctrl+Enter to confirm the segment.

Using AutoSuggest with machine translation
The AutoSuggest feature paired with a machine translation provider can prove a powerful
tool for those that just started to work with a small translation memory or termbase.

About this task
To make proper use of this feature, you must:

• enable Translation Memory and Automated Translation as a AutoSuggest provider in
File > Options > AutoSuggest.

• enable the Automated translations match type from File > Options > AutoSuggest >
Translation Memory and Automated Translation.

• disable the Apply automated translation when no TM match is found option from File
> Options > Editor > Automation.

You will now get real-time control over the translation process straight the Editor. You
preview the result from the machine translation (MT) provider in the Translation Results
window without it being inserted in your target segment so you can make an idea of what
the final translation might look like:
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In segment 11, when you start typing, you get suggestions from the MT provider and you
can choose to insert the ones you find appropriate.

You can also quickly edit translation fragments immediately after inserting them into the
target segment as opposed to post-editing an entire segment if you would have chosen to
insert the MT match entirely.

Using Language Cloud with Neural Machine
Translation Engines (NMT)
Language Weaver is a cloud-based machine translation solution for enterprise users.
Language Weaver can be accessed via a web browser with your cloud account. You can link
your Language Weaver account to your cloud account, to use the Language Weaver Neural
MT language pairs (also called NMT Models) during automated machine translation tasks.
NMT Models can also be used for interactive lookups while segments are translated in Online
Editor and in Trados Studio.

Before you begin
To use NMT models, enable the Apply automated translation when no TM match is
found option from File > Options > Editor > Automation.

For this example, we are using Language Cloud as an NMT provider, but you can choose
from the 60+ other NMT providers available in the App Store.

About this task
To configure the cloud resources provider:

Procedure
1. Go to Project Settings > Language Pairs > All Language Pairs > Translation

Memory and Automated Translation.
2. Select Use cloud-based resources.

If you are not already logged in, Trados Studio prompts you to log into your cloud
account.

3. Log in from a browser to check that your cloud account is linked to a Language Weaver
account with available NMT engines:

a. Click on your initials in the top right corner of your browser and select Manage
Account.

b. Under Language Weaver, add the credentials of your Machine Translation account
to bring your machine translation resources in your cloud account.

c. Click Resources > NMT Models tab and check the resources in your Machine
Translation account.

4. Go back to Trados Studio > Project Settings > Language Pairs > All Language Pairs >
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Translation Memory and Automated Translation select Language Cloud in the list of
providers and click Settings.

5. Add an available NMT engine for the English (United States) - German (Germany) language
pair.

6. Go to the Editor view and continue translating the project file. When not TM match is
available, Trados Studio applies the MT suggestion and you can further improve upon it:

Previewing your translation
You can preview the translations as you work. Real-time preview reflects the changes as you
type. The preview is updated every time you confirm a segment. This type of preview is
available for frequently used file formats, such as Microsoft Word and HTML.

About this task

Note: You can also preview documents in the application in which they were created or
print preview them as a bilingual document in your browser. For more information, see the
Trados Studio 2024 Help .

Preview your translation:

• Hover over the Preview tab on the right-hand side of the application. The Preview
window is displayed.
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Click the pin symbol to keep the window displayed. The preview window is docked on
the bottom right-hand side.
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In the Preview window, click the link Click here to generate initial preview. The document
is previewed in the Preview window.

The Preview window contains the content you have translated and confirmed. It also displays
the English content that has not yet been translated and confirmed. The segment you
currently have selected (Segment 11) is highlighted. This shows the English source text since
you have not yet translated the segment.

• Copy or type the following translation into segment 11 in the target segment, using
AutoSuggest as you go along (bold letters indicate words or fragments that you can
insert from the AutoSuggest list after typing the first letter):

Andere Adapter können Ihre Kamera, Fotodrucker bzw. Computer beschädigen.

• Press Ctrl+Enter to confirm the translation. The Preview window is updated with the
new translation.
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Translating with PerfectMatches
Assume that the SamplePhotoPrinter document that you translated in the previous example
was fully translated and reviewed. Version 2 of the photo printer is being released and
some additional text has been added to the document for this release.

About this task
Since the new document is primarily the same as the previous document, the project
manager applied PerfectMatch when pre-translating the file. This extracted the translations
from the previously translated document and transferred them to the new version of the
document as PerfectMatches.

Procedure
1. Click the Files button in the bottom left navigation pane to display the Files view.

Alternatively go to theView tab and clickFiles.
2. Right-click on the TryPerfectMatch. doc.sdlxliff file and select Open for Translation

from the shortcut menu. The file is automatically opened in the Editor view.

To follow along with this exercise in the application, use the Sample Project. If this
project is not the active (currently selected) project, display the Projects view and
double-click on Sample Project.

3. A PerfectMatch has been found for a majority of the segments in the document.
PerfectMatch translations:

• -Show a translation origin that indicates that the match type is PerfectMatch.

• - Have a segment status of Signed off. This means that the translation needs no
further translation or review.

• - Are locked to avoid accidentally editing them since no further work is needed.
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Translating the sample document with
PerfectMatch applied
A PerfectMatch is a form of context match that compares updated source files to a
corresponding set of existing bilingual documents rather than to a translation memory.

Segment matches, known as PerfectMatches, are checked for context, that is, the
surrounding entries are checked to ensure that they are the same. They are then extracted
from the existing bilingual documents and transferred to the updated source files. Because
the PerfectMatch segment matching process includes a check for context, PerfectMatch
units typically need no further translation or editing during translation.

Using the display filter to find new content
To find the new content in the document that has not been translated by PerfectMatch, you
can use a display filter:

Procedure
1. Go to the Display Filter group by selecting Review tab in the Editor view.

2. Select Not Translated from the Display drop-down list.
Segment 8 is displayed. This is the only new content that needs to be translated in this
document.

3. Enter the following translation Dies ist ein neuer Satz.

4. Press Ctrl+Enter to confirm the translation.

Results

You have now finished translating this document. Click Save to keep your changes and
then close the document.

The reviewer now only needs to review the new content in segment 8 since all of the
PerfectMatches have already been through the review process.

Advanced Display Filter 2.0
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If you need more powerful search criteria for filtering in the Editor view, open the Advanced
Display Filter 2.0 pane:

For information on working with the Advanced Display Filter, see Editing with Advanced
Display Filter 2.0 in the Trados Studio online Help.

Reviewing in Trados Studio
After translating both documents, you or a dedicated reviewer may want to review the
translations. If you still have the document open from the previous section, save and close
the document now.
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Note: If you have a reviewer that does not have Trados Studio, for example a subject matter
expert, you can also export for external review in Word. For more information, see the
Trados Studio 2024 Help .

Opening and reviewing the sample file
To follow along with this exercise in the application, use the Sample Project. If this project

is not the active (currently selected) project, display the Projects view and double-click on
Sample Project.

About this task

Procedure
1. Click the Files button in the views navigation pane to display the Files view.
2. Right-click on the SamplePhotoPrinter. doc.sdlxliff file and select Open for Review

from the shortcut menu. The file is automatically opened in the Editor view.

When you open a file for review, the screen layout in the Editor view changes to the
review layout and the list of statuses available to apply to segments changes to show
review statuses only.
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Approving Translations
When you have finished reviewing a segment, you should confirm the segment to indicate
that the translation is approved or reject the translation.

Procedure
1. Place your cursor in the target translation in segment 1 and press Ctrl+Enter or click

the Confirm (Translation Approved) button in the Segment Actions group on the
Home tab of the Editor view.
When you approve a translation:

• The segment status is changed to Approved and the following icon is displayed in
the segment status column:

• Segment verification is also performed. Segment verification errors are displayed in
the Messages window.

Rejecting translations using tracking changes
The Track Changes feature allows you to see any changes that you make to the translated
text alongside the original text. This allows your suggestions to be compared to the original
text. This feature is automatically turned on when you choose the Open for Review
command with a document for the first time.

4Translating and Reviewing in Trados Studio

47Translating and Reviewing Documents



About this task
The current translation for photo printer in segment 2 is Fotodrucker. Assume the customer
has asked you to change the translation to Drucker instead. Use the Track Changes feature to
suggest the replacement word for Fotodrucker.

Procedure
1. When you approved the translation in the last step, your cursor was automatically

placed in the next unapproved segment which is segment 2. Delete the term Fotodrucker
and then type the replacement term, Drucker. When you do this:

• Fotodrucker is displayed in red with a line through it to indicate that you have deleted
this word. Drucker is now displayed in purple with a line underneath to show that
you inserted this word. When the document is sent back to the translator they can
right-click on each suggestion and accept or reject your changes.

• The segment status is changed to Rejected and the following icon is displayed in
the segment status column:

Rejecting translation using comments
Adding comments allows you to explain what is wrong with a translation. You can add a
comment to the current target segment, selected text in the target segment or the whole
document.

About this task
Add a comment to explain why you replaced the term Fotodrucker with Drucker in segment
2.

Procedure
1. In the translation in segment 2, select Fotodrucker Drucker by highlighting it and then

press Ctrl+Shift+N or right-click and select Add Comment from the shortcut menu.
Complete the dialog box as shown below and click OK to add the comment:
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The comment now appears in the Comments window. When you added this comment:

• The text to which you attached the comment is highlighted in pale red, which
indicates the severity level of the comment is an Error.

• If the segment is not already rejected, the segment status is changed to Rejected
and the following icon is displayed in the segment status column: .

• Text with an attached comment can also be highlighted in pale yellow if it has a
For your information severity level or pale orange if it has a warning severity level.

Rejecting translations manually
You can also choose to manually reject segments. Since you inserted a comment above to
indicate that you want to use the term Drucker instead of Fotodrucker, reject any other
translations that are using the term.

Procedure
1. Place your cursor in segment 3, press Ctrl+Shift+Enter or click the Reject

(Translation Rejected) button on button in the Segment Actions group on the Home
tab of the Editor view.

2. The segment status is changed to Rejected and the Reject icon is displayed in the
segment status column.
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Rejecting translation using TQA
As a more advanced review mode, you also have the possibility to use the Translation Quality
Assurance (TQA) to measure the quality of the translation using custom quality criteria.

About this task
Set up quality metrics that matter to you, weigh their importance and set up a TQA
framework. This framework guides the reviewers when evaluating translations and enables
Trados Studio to determine the quality of a translation automatically.

For more information, see How to work with TQA .

Approving remaining segments
Assume you have finished reviewing the entire document and that you have not rejected
any of the other translations. You can approve all of the remaining segments at the same
time.

Procedure
1. To approve all translations that have not already been rejected or approved:

• Click .

• A prompt is displayed. Review the message and then click Yes.

• Any translations that do not have a status of Translation Approved or Translation
Rejected are now changed to Translation Approved and the document is saved and
closed.

Entering corrections
When you are reviewing a document or entering corrections for a document that has been
reviewed, you can use the display filters to filter out the translations that still need to be
reviewed or to find translations that need corrections.

Segment review display filters
About this task
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Trados Studio includes filters that allow you to only display the translations that you want to
review and filter out the rest. When you are reviewing a document or entering corrections
based on reviewer feedback, there are two key categories.

Review Filter
Categories

Description

Segment Review
Statuses

Use this to view translations based on the segment status. For
example, you can choose to only display segments with a status of
Translation rejected. This would allow you to review all segments
with this status that have corrections that need to be made.

Segment Review Use this to view translations that have:
• Comments with feedback
• Tracked changes
• Messages with details of verification errors

You can apply these filters using the Display Filter group available on the Review tab in the
Editor view.
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Using the display filters
Assume that you have received corrections back from the reviewer. Use display filters to find
the translations that need corrections.

About this task
If you still have the document open from the previous section, save and close the document
now.

To follow along with this exercise in the application, use the Sample Project. If this project
is not the active (currently selected) project, display the Projects view and double-click on
Sample Project.

…Documents\Studio 2024\Projects\Samples\SampleProject\Sample Project.sdlproj

Procedure
1. In the Files view, right-click on the SamplePhotoPrinter. doc.sdlxliff file and select

Open for Translation from shortcut menu. The file is automatically opened in the Editor
view.

2. To display any content that needs corrections; filter to only show translations with a
status of Translation Rejected.

• Click Translation rejected in the Display Filter group on the Review tab.

Segments 2 and 3 are displayed. These were both rejected by the reviewer in the
last exercise because the customer wants to use the term Drucker instead of
Fotodrucker.

3. If you need to filter segments by additional criteria, go to the View tab > Advanced
Display Filter 2.0 > Filter Attributes and combine the filters Translation Rejected and
Translation Approved with other available criteria.

Accepting suggested changes (Track Changes)
Accept the suggested changes:

Procedure
1. Place your cursor in the middle of the term Fotodrucker and press Ctrl+Shift+F9 or

right-click and select Accept Change. The word is removed from the translation.
2. Perform the same action with the other tracked change Drucker.

Press Ctrl+Enter to confirm the translation.
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Generating the translated document
Assume you have completed the translation of the sample document. Generate the final
version of the translated document.

Procedure
1. If you have closed the SamplePhotoPrinter. doc.sdlxliff file, open the file again in the

Editor view.
2. Select File > Save Target As.

Save the final word document, for instance as SamplePhotoPrinter-Translated.doc.
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Return packages
Assume you have completed the translation of all files sent to you in a package and now
want to return your work to your customer (typically your project manager). To do this, return
your work in a return package. Once the package is created, you can send it by email, post
on an FTP site or use any other method.

Note: Returning work in return packages is only used if you have received files for translation
in a project package.

WorldServer return packages
WorldServer return packages can be uploaded directly from WorldServer. To work with
WorldServer packages in WorldServer, you first need to install the WorldServer
Compatibility Pack for Studio . To add this app, go to the Add-Ins tab > RWS AppStore.

Creating a return package
Procedure
1. In the Project view, select Home tab > Packages group > Create Return Package. The

Create Return Package wizard is displayed on the Select Files page. All files in the
project are included in the list apart from reference files.

The option to create a return package is not available in the Sample Project because
you have not originally received any files in a project package.

2. Select or clear the check boxes next to the file names on the Select Files page to include
or exclude them from the package. If you have previously included any of the files
displayed in another return package, those files will not be selected by default.

3. Click Next to go to the Return Package Options page.
4. Click Browse to open the Save Return Package dialog box. Browse to the location where

you want to save the return package, enter Sample Project Return as the return
package name for the return package in the File name box and click Save.

Note: If you have installed the WorldServer Compatibility Pack for Studio are returning
an WorldServer package, you can choose the Server option on the Return Package
Options page to upload the package directly to WorldServer.

5. If you want to add a comment to the return package, enter it in the Comment box.
6. Click Finish to create the package and go to the Creating Return Package page.
7. Once the package creation is complete, the status next to the package name changes to

Completed.
8. You can choose to send the return package by email to the appropriate team member

by clicking Send Packages by Email.
9. Alternatively, to send the package by a different method such as placing it on a FTP site,

click Open Target Folder to open the folder where your return package is saved.
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10. Click the Close button to close the Create Return Package wizard.
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5

Working with Online Editor



Online Editor is an online tool that you can use to translate and review files online. Online
Editor is a scalable, cost-effective component that combines the core capabilities of a modern
desktop translation tool with a friendly interface designed to boost productivity and to
ensure a positive user experience.

Navigating the Online Editor user
interface
The Online Editor user interface consists of multiple elements designed to help you focus
on your work and make each interaction meaningful.

These elements include tabs, groups, the ribbon, the workspace, and the status bar, as
shown in the following image:

The number of words displayed in the status bar is the total number of words in the source
text. On the other hand, the number of characters refers to the total number of characters in
the segment that you are currently editing; this can be the source segment or the target
segment. If you select only a part of the source or the target segment, the number of
characters in the selected text is displayed.

The Online Editor interface is context-sensitive. Therefore, when you resize the page, its
elements are adjusted automatically to the new height and width. If the buttons on the
ribbon do not fit on the entire width of the page, only part of them are displayed and you can
access the rest by selecting .
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Modifying the layout of the workspace
The way segments are displayed during translation helps you focus on your task differently.
In Online Editor, you can choose between two layout options: vertical (the source and target
segments are displayed in two columns, one next to the other) or horizontal (each target
segment is displayed under its corresponding source segment).

Procedure
1. Open the appropriate file in Online Editor.
2. On the View tab, in the Layout group, do one of the following:

• To have the source and target segments displayed in two separate columns, one
next to the other, select Vertical.

• To have each target segment in the workspace displayed under its corresponding
source segment, select Horizontal.

Modifying the layout of the ribbon
Maximize your workspace and focus more on what matters by choosing the right Online
Editor ribbon layout for you.

Procedure
1. Open the appropriate file in Online Editor.
2. In the top-right corner of the ribbon, select , and then do the following:

• Choose whether you want to use the classic ribbon layout or the simple, minimalistic
one.

• Choose whether you want the ribbon to be displayed all the time or to be hidden
automatically when you are not using it.
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Tip: If you select Automatically hide, the ribbon will still show up whenever you
place your cursor in the row where the tab names are displayed.

Detaching the side panel
Detaching the side panel in Online Editor means opening it in a different window. This can
be particularly useful if you are working with two monitors, because it makes the translation
area larger and it separates the actual translation of content from other operations, such
as working with revisions, lookups, or comments.

Procedure
1. Open the appropriate file in Online Editor.
2. Select Detach Panel , and then do one of the following:

• Select Detach All to move all the side panels from the workspace to a separate
browser window. From here, you can switch between panels as you would in the
workspace.

• Select Detach Active Panel to move only the currently selected side panel to a
separate browser window. In this case, all the other panels are still available in the
workspace. From the newly opened window, you can switch between panels by
selecting Detach Panel, and then selecting the icon corresponding to the
appropriate panel.
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Note: You can only open one panel at a time. When you switch to a new panel, the
previous one is no longer displayed.

Viewing navigation information about a file
Navigation information consists in the name and path of the file, as well as in details about
whether the segment you are working on is part of a header, a footer, or a paragraph, for
example.

Procedure
1. Open the appropriate file in Online Editor.
2. On the View tab, in the Navigation group, select Show Navigation.

Viewing information about the structure of a
file
This information indicates where each segment is located in the structure of the source file;
for example, in a paragraph or in a header or footer.
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Procedure
1. Open the appropriate file in Online Editor.
2. Do one of the following:

• To view the document structure in a column on the right side of the workspace, on
the View tab, in the Navigation group, select Show Document Structure. Then, in
the newly displayed column, select the cell corresponding to the segment about
which you want to view information.
The available information about the location of the segment and about the meaning
of the code is displayed in the Document Structure Information box.

• To view the document structure in a separate panel, on the right side of the screen,
select Show Document Structure Information Panel .

Tip: If you choose to view information about the document structure in this way,
you can also select Detach Panel to open the panel in a separate window and
move it to another part of your screen or to another screen.

Consulting cloud project details
If you have a file open in the browser, you can easily check what project it belongs to and
what its location is. This is particularly useful when you work on multiple files at the same
time.

Procedure
1. Open the appropriate file in Online Editor.
2. On the header, in the top right-hand corner, hover over the information icon. Check the

project name and its location.

Details about segments and translations
These details consist in: the current status of the translation, information about the results
of verification actions (if applicable), information about whether each segment is locked or
not, as well as the percentage of the translation memory match applied to the translation.

They are displayed in the last few columns of the workspace:
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If you point to the status column, the Translation details box is displayed, containing
information about the status, origin, and score of the translation:

Verification
The icons in the verification column indicate the results of the latest verification actions
performed for each segment:

Icon Description

(none) The segment has not been verified.

No issues were found for this segment.

An issue with the Note severity was found
as part of the verification.

An issue with the Warning severity was
found as part of the verification.

An issue with the Error severity was found
as part of the verification.

Multiple issues were found for this segment.

You can find specific details about each verification message by expanding the Verification
side panel.
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Status
The translation status expresses the progress made with each segment:

Status Icon Description

Not Translated The segment has not been
translated at all.

Draft Scenario 1: Someone has
started translating the
segment. It is still a work in
progress.
Scenario 2: A translation
memory match was applied
to the segment at first, but
the translation has been
modified since.

Translated The segment has been
translated and confirmed.

Translation Rejected A reviewer has rejected the
translation of this segment.

Translation Approved A reviewer has approved the
translation of this segment.

Sign-off Rejected The translation of this
segment has been rejected
during the sign-off process.

Signed Off The translation of this
segment has been approved
and signed off.

Locked The segment is locked.

Origin
The translation origin expresses the way in which each segment has been translated:
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Origin Icon This segment has been
translated by...

Interactive None. Typing text in the target
area.

Copied from Source None. Copying the source content
to the target area
(Ctrl+Insert).

100% Match Applying a translation unit
(100% match) from the
translation memory.

Context Match Applying a translation unit
(context match) from the
translation memory.

Perfect Match The surrounding text is also
checked to ensure that it is
the same as in the bilingual
file.

Auto-propagated Auto-propagation—after
someone modified and
confirmed another segment
that was identical with the
current one.

TM with Rejected changes Matches originating from
segments that have been
translated and saved to the
TM, but whose changes were
rejected later on by a
linguistic reviewer.

Automated Translation Applying a translation unit
from an automated
translation server.

Fuzzy Match Applying a translation unit
(fuzzy match) from the
translation memory.

Neural Machine Translation NMT This target segment has
been changed by applying a
TU from

Machine Translation.

Score
The translation score expresses the translation memory leverage of each segment:
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Score Icon Description

100%

,

,

The segment has been
retrieved from a translation
memory (100% match or
context match) or
auto-propagated.

Less than 100% The segment has been
retrieved from a translation
memory (fuzzy match).

0%

or none at all.

The target segment has the
Draft status or the
Automated Translation
origin. No score is displayed
in the score column and 0%
is displayed as a score in the
Translation details box.

If a translation was applied from a translation memory, information about the system
(translation provider) is also displayed in the Translation details box:

Adapting the contrast of colored text
If the file you are working on contains text formatted with very light colors, you can change
the way in which it is displayed without affecting its formatting in the output.

Procedure
1. Open the appropriate file in Online Editor.
2. On the View tab, in the Fonts group, select Adapt Colors.
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Making text larger or smaller
Adjust the size of the text in the Online Editor workspace by making it larger or smaller. You
can do this either temporarily, by zooming in or out, or permanently, by configuring a
minimum and a maximum font size. In either case, the adjustments only have to do with
the way the text is displayed in Online Editor. They do not affect the size of the text in the
output.

Procedure
1. Open the appropriate file in Online Editor.
2. On the View tab, do one of the following:

• To zoom in or out, select Enable Text Zoom, and then select Smaller or Larger as
many times as necessary.

Tip: After zooming in or out, you can go back to default text size by selecting Enable
Text Zoom again.

• To configure a minimum and a maximum font size for segments, select Options,
and then, under Font Adaptation, specify a minimum and a maximum value. Select
the Adapt font sizes checkbox for the settings to be applied immediately after
saving, and then select Save.

Note: When you configure a minimum and a maximum font size, any segment
whose font size is smaller than the minimum value or larger than the maximum
value will be adapted to fit the values you configured. Segments whose font size falls
in between the minimum and the maximum values will not be affected.

Once you save your configuration, these values are linked to your account and will
be applied every time you open a file in Online Editor.

Navigation themes
Navigation themes are a series of accessibility options developed in accordance with the
Web Content Accessibility Guidelines (WCAG) standard. There are three navigation themes
available on the Online Editor user interface: Light, Warm, and Dark. You can find them on the
View tab, in the Theme group.

The Light theme is the one displayed by default.
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The Warm theme includes warmer colors for the workspace and darker colors for the
elements on the ribbon.

The Dark theme includes darker colors for both the workspace and the elements on the
ribbon.

Navigating between segments
You can navigate between segments either one by one (forwards or backwards) or by going
directly to specific segments, according to their number.
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Procedure
1. Open the appropriate file in Online Editor.
2. On the Home tab, in the Navigation group, do one of the following:

• To return to the previous segment, select Previous.

• To move on to the next segment, select Next.

• To navigate to a specific segment, enter the number of the segment in the Go To
box, and then select Enter.

Tip: If you want to navigate to a specific segment while a segment filter is applied, you
can only do so if the segment matches the criteria specified through that filter. For
example, if you apply a filter to see only segments with the Translated status and the
segment to which you want to navigate has a different status, the Invalid segment
number message is displayed. In such a situation, you have to remove the filter to
navigate to that segment.

Cutting, copying, and pasting text
You can select fragments of text and copy them somewhere else in the file or move them
there altogether.

Before you begin
Before you cut text from a source segment or paste text to a source segment, you need to
enable source editing (Other Actions > Edit Source). However, you do not have to do this if
you only want to copy text from a segment or to paste text to a target segment.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the text that you want to cut or copy.
3. On the Home tab, in the Clipboard group, select Cut or Copy, depending on what you

want to do.
4. Click the exact place where you want to paste the text.
5. Select Ctrl+V.

Tip: You can also select Paste on the Online Editor user interface, but some browsers
do not support this action.
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Support for right-to-left scripts
If you select a display language that uses a right-to-left script (for example, Arabic) before
opening a file in Online Editor, the options on the Online Editor user interface will be
displayed in that language from right to left.

Dictation in Online Editor
Use your voice to translate and review content in Online Editor.

Activating dictation in Online Editor
Make sure that your browser has access to your microphone and that dictation is available
for the target language of the file you are working on.

About this task
At the moment, dictation is available for the following target languages, as well as their
language variants:

• Chinese (Simplified)

• Czech

• English

• French

• German

• Italian

• Japanese

• Romanian

• Spanish

Note: Make sure you block out any background noise while you dictate. Position your
microphone or your device close to your mouth and utter the commands clearly. Do not
forget to stop the dictation when you are finished.

Also, dictation is not available when opening Online Editor with Firefox, regardless of the
target language of the file; use Google Chrome or Microsoft Edge instead.
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Procedure
1. Open the appropriate file in Online Editor.
2. On the Home tab, select Dictation.

A red circle is displayed as part of the tab in which Online Editor is open. This indicates
that your microphone is in use.

3. Use the available commands to dictate.
A message is displayed each time Online Editor recognizes a command.

Inserting commands as plain text
By default, Online Editor executes commands as soon as you dictate them. However, in
some situations, you might need to spell out these commands.

For example, in the following sentence, you want the term space to be spelled out instead of
being executed as a command: A satellite was launched into outer space. To achieve
this in English, say literal before the actual command. For example:

Prompt Text added to the active segment

space (space character)

literal space space

question mark ?

literal question mark question mark

Tip: This example applies to English. In Italian, for example, you would use spazio and
letterale spazio. For more details, see the Special commands section of the command
list corresponding to your target language of choice.
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Dictation commands for Chinese (Simplified)
A list of commands that you can use for dictation when working with files whose target
language is set to Chinese (Simplified).

Area Action Command

Turn off dictation 停止听写

Punctuation Insert a period (.) 句号

Insert a comma (,) 逗号

Insert an exclamation mark
(!)

感叹号

Insert a question mark (?) 问号

Insert a hyphen (-) 连字符

Insert an em dash (—) 长破折号

Insert an en dash (–) 短破折号

Insert a colon (:) 冒号

Insert a semicolon (;) 分号

Special characters Insert a pair of single
quotation marks (‘’)

单引号

Insert a new line 换行符

Insert a tab 制表符

Insert a space 空格符

Insert a non-breaking
hyphen

不间断连字符

Insert an optional hyphen 可选连字符

Insert a non-breaking space 不间断空格

Insert a copyright symbol (©) 版权符号

Insert a registered symbol
(®)

注册符号

Insert a trademark symbol
(™)

商标符号

Insert a euro symbol (€) 欧元符号

Insert a pound symbol (£) 英镑符号

Insert a pair of German
quotation marks („“)

德语引号

Insert a pair of English
quotation marks (“”)

英语引号
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Insert a pair of angular
quotation marks («  »)

角引号

Insert an apostrophe (') 撇号

Insert a micro symbol (µ) 微符号

Insert an approximation
symbol (≈)

近似符号

Insert a tilde (~) 波浪符号

Insert a not equal symbol
(≠)

不等号

Insert a degree symbol (°) 度数符号

Insert a less than or equal
symbol (≤)

小于等于号

Insert a greater than or
equal symbol (≥)

大于等于号

Insert a lowercase alpha
symbol (α)

小写阿尔法符号

Insert a lowercase beta
symbol (β)

小写贝塔符号

Insert a capital delta symbol
(Δ)

大写德尔塔符号

Insert a lowercase gamma
symbol (γ)

小写伽马符号

Insert a lowercase pi symbol
(π)

小写派符号

Insert a plus or minus
symbol (±)

加减号

Insert a sum symbol (∑) 求和符号

Insert a multiplication
symbol (×)

乘号

Insert an infinite symbol (∞) 无限符号

Insert a slash (/) 斜杠

Insert a backslash (\) 反斜杠

Insert an at sign (@) 艾特符号

Insert a percentage
character (%)

百分比符号

Insert a round opening
bracket

左括号

Insert a round closing
bracket

右括号
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Insert an opening square
bracket ([)

左方括号

Insert a closing square
bracket (])

右方括号

Insert an opening angle
bracket (<)

左尖括号

Insert a closing angle
bracket (>)

右尖括号

Insert an underscore symbol
(_)

下划线

Insert an equal sign (=) 等号

Insert an asterisk (*) 星号

Selection and segment
editing

Select the content of the
entire segment

全选

Select the word after the
caret

选择下一个单词

Select the word before the
caret

选择上一个单词

Select the character after the
caret

选择下一个

Select the character before
the caret

选择上一个

Remove the selection by
using backspace

退格

Remove the selection by
using delete

删除所选

Clear (unselect) any selected
characters or text

取消选择

Remove the character before
the caret (when no text is
selected)

退格

Remove the character after
the caret (when no text is
selected)

删除所选

Navigation Move the caret to the start of
the segment

转到句段开头

Move the caret to the end of
the segment

转到句段末尾

Go to the next segment 转到下一个句段

Return to the previous
segment

转到上一个句段
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Move the caret forwards by
one character

向前移动

Move the caret backwards by
one character

向后移动

Scroll up the workspace 向上滚动

Scroll down the workspace 向下滚动

Select the Page up key 上一页

Select the Page down key 下一页

Select the Home key 起始

Select the End key 结束

Copying and pasting Copy the currently selected
content

复制

Paste the currently selected
content to the clipboard

粘贴

Cut the currently selected
content

剪切

Formatting Apply bold formatting 应用粗体

Apply italic formatting 应用斜体

Apply underline formatting 应用下划线

Apply strikethrough
formatting

应用删除线

Apply subscript formatting 应用下标

Apply superscript formatting 应用上标

Apply small caps formatting 应用小型大写字母

Show whitespace characters 显示空格符

Hide whitespace characters 隐藏空格符

Remove all the tags from the
current selection

清除格式

Remove all the tags from the
entire segment

清除所有格式

Undo and redo Undo the last action 撤消

Redo the last action 恢复

Segment actions and
confirmation

Clear the content of the
active target segment

清除译文

Copy the source content to
the active target segment

复制原文

Lock the active segment 锁定句段
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Unlock the active segment 解锁句段

Confirm the active segment
and move to the next
unconfirmed segment

确认

Confirm the active segment
and move to the next
segment, regardless of its
status

确认并转到下一句段

Confirm the active segment
and do not move to the next
segment

确认并停留在当前句段

Add the active segment as a
new translation unit into the
translation memory

作为新翻译单元添加

Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

拒绝句段

Smart actions Open the smart actions
menu

显示智能操作

Select the insert tags action
in the smart actions menu

显示标记菜单

Select the terminology action
in the smart actions menu

显示术语菜单

Select the fragment matches
action in the smart actions
menu

显示片段菜单

Select the placeables action
in the smart actions menu

显示占位符菜单

Select the TQA action in the
smart actions menu

选择质量评估菜单

Select the comments action
in the smart actions menu

显示备注菜单

Sidebar interaction Collapse the side panel 折叠侧面板

Expand the Verification
panel

展开验证面板

Expand the Revisions panel 展开修订面板

Expand the TQA panel 展开质量评估面板

Expand the Filters panel 展开筛选器面板

Expand the Lookups panel 展开搜索面板

Expand the Comments
panel

展开备注面板
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Expand the Navigation
panel with the Find tab
selected

展开查找面板

Expand the Navigation
panel with the Replace tab
selected

展开替换面板

Track Changes Enable the Track Changes
functionality

启用跟踪修订

Disable the Track Changes
functionality

禁用跟踪修订

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

接受所有修订

Reject all the revisions in the
current document

拒绝所有修订

Move to the next revision 下一个修订

Return to the previous
revision

上一个修订

Accept the currently selected
revision

接受此修订

Reject the currently selected
revision

拒绝此修订

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

下一条消息

Return to the previous
verification message

上一条消息

Ignore the active verification
message

忽略此消息

Comments (only if the
Comments panel is
expanded)

Move to the next comment 下一条备注

Return to the previous
comment

上一条备注

Delete the currently selected
comment

删除此备注

Edit the currently selected
comment

编辑此备注
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Command Description

文字 Use before another command to insert that
command as text instead of executing it

Dictation commands for Czech
A list of commands that you can use for dictation when working with files whose target
language is set to Czech.

Area Action Command

Turn off dictation konec diktování

Select the last text inserted
by using dictation

vyber poslední

Punctuation Insert a period (.) tečka

Insert a comma (,) čárka

Insert an exclamation mark
(!)

vykřičník

Insert a question mark (?) otazník

Insert a hyphen (-) pomlčka

Insert an em dash (—) em pomlčka

Insert an en dash (–) en pomlčka

Insert a colon (:) dvojtečka

Insert a semicolon (;) středník

Special characters Insert a pair of single
quotation marks (‘’)

jednoduché uvozovky

Insert a new line nový řádek

Insert a tab tabulátor

Insert a space mezera

Insert a non-breaking
hyphen

pevný rozdělovník

Insert an optional hyphen volitelný rozdělovník

Insert a non-breaking space pevná mezera

Insert a copyright symbol (©) znak copyright

Insert a registered symbol
(®)

znak registrováno
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Insert a trademark symbol
(™)

znak značka

Insert a euro symbol (€) znak euro

Insert a pound symbol (£) znak libra

Insert a pair of German
quotation marks („“)

uvozovky

Insert a pair of English
quotation marks (“”)

uvozovky anglické

Insert a pair of angular
quotation marks («  »)

uvozovky francouzské

Insert an apostrophe (') apostrof

Insert a micro symbol (µ) znak mikro

Insert an approximation
symbol (≈)

znak zhruba

Insert a tilde (~) znak vlnovka

Insert a not equal symbol
(≠)

znak nerovná se

Insert a degree symbol (°) znak stupeň

Insert a less than or equal
symbol (≤)

znak menší nebo rovno

Insert a greater than or
equal symbol (≥)

znak vetší nebo stejný

Insert a lowercase alpha
symbol (α)

znak alfa

Insert a lowercase beta
symbol (β)

znak beta

Insert a capital delta symbol
(Δ)

znak delta

Insert a lowercase gamma
symbol (γ)

znak gama

Insert a lowercase pi symbol
(π)

znak Pí

Insert a plus or minus
symbol (±)

znak plus mínus

Insert a sum symbol (∑) znak suma

Insert a multiplication
symbol (×)

znak krát

Insert an infinite symbol (∞) znak nekonečno

Insert a slash (/) lomítko
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Insert a backslash (\) zpětné lomítko

Insert an at sign (@) zavináč

Insert a percentage
character (%)

procento

Insert a round opening
bracket

otevírací závorka

Insert a round closing
bracket

uzavírací závorka

Insert an opening square
bracket ([)

otevírací hranatá závorka

Insert a closing square
bracket (])

uzavírací hranatá závorka

Insert an opening angle
bracket (<)

menší než

Insert a closing angle
bracket (>)

větší než

Insert an underscore symbol
(_)

podtržítko

Insert an equal sign (=) rovná se

Insert an asterisk (*) hvězdička

Selection and segment
editing

Select the content of the
entire segment

označ(it) vše

Select the word after the
caret

označ(it) nasledující slovo

Select the word before the
caret

označ(it) předcházející slovo

Select the character after the
caret

označ(it) další

Select the character before
the caret

označ(it) předcházející

Remove the selection by
using backspace

backspace

Remove the selection by
using delete

smaž

Clear (unselect) any selected
characters or text

zrušit výběr

Remove the character before
the caret (when no text is
selected)

backspace

Remove the character after
the caret (when no text is
selected)

smaž
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Navigation Move the caret to the start of
the segment

jdi na začátek

Move the caret to the end of
the segment

jdi na konec

Go to the next segment jdi do dalšího segmentu

Return to the previous
segment

jdi do předcházejícího
segmentu

Move the caret forwards by
one character

posuň dopředu

Move the caret backwards by
one character

posuň dozadu

Scroll up the workspace posuň nahoru

Scroll down the workspace posuň dolů

Select the Page up key strana nahoru

Select the Page down key strana dolů

Select the Home key domů

Select the End key konec

Copying and pasting Copy the currently selected
content

zkopíruj to

Paste the cut or copied
content

vlož to

Cut the currently selected
content

vyjmi to

Formatting Apply bold formatting formátuj tučné

Apply italic formatting formátuj kurzíva

Apply underline formatting formátuj podtrženě

Apply strikethrough
formatting

formátuj dvojté podtržení

Apply subscript formatting formátuj dolní index

Apply superscript formatting formátuj horní index

Apply small caps formatting formátuj velká písmena

Show whitespace characters aktivuj neviditené znaky

Hide whitespace characters deaktivuj neviditené znaky

Remove all the tags from the
current selection

zruš formátování

Remove all the tags from the
entire segment

zruš všechno formátování
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Undo and redo Undo the last action zpět

Redo the last action znovu

Segment actions and
confirmation

Clear the content of the
active target segment

vymaž překlad

Copy the source content to
the active target segment

zkopíruj zdroj

Lock the active segment zamkni segment

Unlock the active segment odemkni segment

Confirm the active segment
and move to the next
unconfirmed segment

potvrď

Confirm the active segment
and move to the next
segment, regardless of its
status

potvrď a další

Confirm the active segment
and do not move to the next
segment

potvrď a zůstaň

Add the active segment as a
new translation unit into the
translation memory

nový překlad

Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

zamítnout segment

Smart actions Open the smart actions
menu

ukaž akce

Select the insert tags action
in the smart actions menu

tagy

Select the terminology action
in the smart actions menu

pojmy

Select the fragment matches
action in the smart actions
menu

části

Select the placeables action
in the smart actions menu

rozeznané

Select the TQA action in the
smart actions menu

vyhodnocení

Select the comments action
in the smart actions menu

komentář

Panel interaction Collapse the side panel zavři boční panel

Expand the Verification
panel

ukaž panel kontroly
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Expand the Revisions panel ukaž revizí

Expand the TQA panel ukaž panel vyhodnocení

Expand the Filters panel ukaž panel filtrů

Expand the Lookups panel ukaž panel překladů

Expand the Comments
panel

ukaž panel komentářů

Expand the Navigation
panel with the Find tab
selected

ukaž panel hledání

Expand the Navigation
panel with the Replace tab
selected

ukaž panel nahrazování

Track Changes Enable the Track Changes
functionality

zapni revize

Disable the Track Changes
functionality

vypni revize

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

potvrdit všechny revize

Reject all the revisions in the
current document

zamítnout všechny revize

Move to the next revision další revize

Return to the previous
revision

předchozí revize

Accept the currently selected
revision

potvrď

Reject the currently selected
revision

zamítni

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

další chyba

Return to the previous
verification message

předchozí chyba

Ignore the active verification
message

ignoruj

Comments (only if the
Comments panel is
expanded)

Move to the next comment další komentář

Return to the previous
comment

předchozí komentář

Delete the currently selected
comment

vymaž to
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Edit the currently selected
comment

uprav to

Special commands

Command Description

doslova Use before another command to insert that
command as text instead of executing it

Dictation commands for English
A list of commands that you can use for dictation when working with files whose target
language is set to English.

Area Action Command

Turn off dictation stop dictation

Select the last text inserted
by using dictation

select last

Punctuation Insert a period (.) period

Insert a comma (,) comma

Insert an exclamation mark
(!)

exclamation mark

Insert a question mark (?) question mark

Insert a hyphen (-) hyphen

Insert an em dash (—) em dash

Insert an en dash (–) en dash

Insert a colon (:) colon

Insert a semicolon (;) semicolon

Special characters Insert a pair of single
quotation marks (‘’)

single quote

Insert a new line new line

Insert a tab tab

Insert a space space

Insert a non-breaking
hyphen

non-breaking hyphen

Insert an optional hyphen optional hyphen
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Insert a non-breaking space non-breaking space

Insert a copyright symbol (©) copyright symbol

Insert a registered symbol
(®)

registered symbol

Insert a trademark symbol
(™)

trademark symbol

Insert a euro symbol (€) euro symbol

Insert a pound symbol (£) pound symbol

Insert a pair of German
quotation marks („“)

German quotation marks

Insert a pair of English
quotation marks (“”)

English quotation marks

Insert a pair of angular
quotation marks («  »)

angle quotation marks

Insert an apostrophe (') apostrophe

Insert a micro symbol (µ) micro symbol

Insert an approximation
symbol (≈)

approximately symbol

Insert a tilde (~) tilde symbol

Insert a not equal symbol
(≠)

not equal symbol

Insert a degree symbol (°) degree symbol

Insert a less than or equal
symbol (≤)

less than or equal symbol

Insert a greater than or
equal symbol (≥)

greater than or equal symbol

Insert a lowercase alpha
symbol (α)

lowercase alpha symbol

Insert a lowercase beta
symbol (β)

lowercase beta symbol

Insert a capital delta symbol
(Δ)

capital delta symbol

Insert a lowercase gamma
symbol (γ)

lowercase gamma symbol

Insert a lowercase pi symbol
(π)

lowercase pi symbol

Insert a plus or minus
symbol (±)

plus or minus symbol

Insert a sum symbol (∑) sum symbol
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Insert a multiplication
symbol (×)

multiplication symbol

Insert an infinite symbol (∞) infinite symbol

Insert a slash (/) slash

Insert a backslash (\) backward slash

Insert an at sign (@) at sign

Insert a percentage
character (%)

percent

Insert a round opening
bracket

open bracket

Insert a round closing
bracket

close bracket

Insert an opening square
bracket ([)

open square bracket

Insert a closing square
bracket (])

close square bracket

Insert an opening angle
bracket (<)

open angle bracket

Insert a closing angle
bracket (>)

close angle bracket

Insert an underscore symbol
(_)

underscore

Insert an equal sign (=) equal

Insert an asterisk (*) asterisk

Selection and segment
editing

Select the content of the
entire segment

select all

Select the word after the
caret

select next word

Select the word before the
caret

select previous word

Select the character after the
caret

select next

Select the character before
the caret

select previous

Remove the selection by
using backspace

backspace

Remove the selection by
using delete

delete

Clear (unselect) any selected
characters or text

clear selection
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Remove the character before
the caret (when no text is
selected)

backspace

Remove the character after
the caret (when no text is
selected)

delete

Navigation Move the caret to the start of
the segment

go to the beginning

Move the caret to the end of
the segment

go to the end

Go to the next segment go to next segment

Return to the previous
segment

go to previous segment

Move the caret forwards by
one character

move forward

Move the caret backwards by
one character

move back

Scroll up the workspace scroll up

Scroll down the workspace scroll down

Select the Page up key page up

Select the Page down key page down

Select the Home key home

Select the End key end

Copying and pasting Copy the currently selected
content

copy that

Paste the currently selected
content to the clipboard

paste that

Cut the currently selected
content

cut that

Formatting Apply bold formatting apply bold

Apply italic formatting apply italic

Apply underline formatting apply underline

Apply strikethrough
formatting

apply strikethrough

Apply subscript formatting apply subscript

Apply superscript formatting apply superscript

Apply small caps formatting apply small caps

Show whitespace characters show whitespaces
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Hide whitespace characters hide whitespaces

Remove all the tags from the
current selection

clear formatting

Remove all the tags from the
entire segment

clear all formatting

Undo and redo Undo the last action undo that

Redo the last action redo that

Segment actions and
confirmation

Clear the content of the
active target segment

clear target

Copy the source content to
the active target segment

copy source

Lock the active segment lock segment

Unlock the active segment unlock segment

Confirm the active segment
and move to the next
unconfirmed segment

confirm

Confirm the active segment
and move to the next
segment, regardless of its
status

confirm and next

Confirm the active segment
and do not move to the next
segment

confirm and stay

Add the active segment as a
new translation unit into the
translation memory

new translation unit

Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

reject segment

Smart actions Open the smart actions
menu

show smart actions

Select the insert tags action
in the smart actions menu

show tags menu

Select the terminology action
in the smart actions menu

show terms menu

Select the fragment matches
action in the smart actions
menu

show fragments menu

Select the placeables action
in the smart actions menu

show placeables menu

Select the TQA action in the
smart actions menu

show quality assessment
menu
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Select the comments action
in the smart actions menu

show comments menu

Panel interaction Collapse the side panel collapse side panel

Expand the Verification
panel

expand verification panel

Expand the Revisions panel expand revisions panel

Expand the TQA panel expand quality assessment
panel

Expand the Filters panel expand filters panel

Expand the Lookups panel expand lookups panel

Expand the Comments
panel

expand comments panel

Expand the Navigation
panel with the Find tab
selected

expand find panel

Expand the Navigation
panel with the Replace tab
selected

expand replace panel

Track Changes Enable the Track Changes
functionality

enable track changes

Disable the Track Changes
functionality

disable track changes

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

accept all revisions

Reject all the revisions in the
current document

reject all revisions

Move to the next revision next revision

Return to the previous
revision

previous revision

Accept the currently selected
revision

accept this

Reject the currently selected
revision

reject this

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

next message

Return to the previous
verification message

previous message

Ignore the active verification
message

ignore this
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Comments (only if the
Comments panel is
expanded)

Move to the next comment next comment

Return to the previous
comment

previous comment

Delete the currently selected
comment

delete this

Edit the currently selected
comment

edit this

Special commands

Command Description

literal Use before another command to insert that
command as text instead of executing it

Dictation commands for French
A list of commands that you can use for dictation when working with files whose target
language is set to French.

Area Action Command

Turn off dictation arrêter la dictée

Select the last text inserted
by using dictation

sélectionner en dernier

Punctuation Insert a period (.) point

Insert a comma (,) virgule

Insert an exclamation mark
(!)

point d'exclamation

Insert a question mark (?) point d'interrogation

Insert a hyphen (-) trait d'union

Insert an em dash (—) tiret cadratin

Insert an en dash (–) tiret demi-cadratin

Insert a colon (:) deux points

Insert a semicolon (;) point virgule

Special characters Insert a pair of single
quotation marks (‘’)

guillemet simple
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Insert a new line nouvelle ligne

Insert a tab espace

Insert a space tabulation

Insert a non-breaking
hyphen

trait d'union insécable

Insert an optional hyphen trait d'union conditionnel

Insert a non-breaking space espace insécable

Insert a copyright symbol (©) symbole copyright

Insert a registered symbol
(®)

symbole marque déposée

Insert a trademark symbol
(™)

symbole marque de
commerce

Insert a euro symbol (€) symbole euro

Insert a pound symbol (£) symbole livre sterling

Insert a pair of German
quotation marks („“)

guillemets allemands

Insert a pair of English
quotation marks (“”)

guillemets anglais

Insert a pair of angular
quotation marks («  »)

guillemets chevrons

Insert an apostrophe (') apostrophe

Insert a micro symbol (µ) symbole micro

Insert an approximation
symbol (≈)

symbole environ

Insert a tilde (~) symbole tilde

Insert a not equal symbol
(≠)

symbole pas égal à

Insert a degree symbol (°) symbole degré

Insert a less than or equal
symbol (≤)

symbole inférieur ou égal à

Insert a greater than or
equal symbol (≥)

symbole supérieur ou égal à

Insert a lowercase alpha
symbol (α)

symbole alpha minuscule

Insert a lowercase beta
symbol (β)

symbole bêta minuscule

Insert a capital delta symbol
(Δ)

symbole delta majuscule
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Insert a lowercase gamma
symbol (γ)

symbole gamma minuscule

Insert a lowercase pi symbol
(π)

symbole pi minuscule

Insert a plus or minus
symbol (±)

symbole plus ou moins

Insert a sum symbol (∑) symbole somme

Insert a multiplication
symbol (×)

symbole multiplication

Insert an infinite symbol (∞) symbole infini

Insert a slash (/) barre oblique

Insert a backslash (\) barre oblique inversée

Insert an at sign (@) arobase

Insert a percentage
character (%)

pourcentage

Insert a round opening
bracket

parenthèse ouvrante

Insert a round closing
bracket

parenthèse fermante

Insert an opening square
bracket ([)

crochet ouvrant

Insert a closing square
bracket (])

crochet fermant

Insert an opening angle
bracket (<)

chevron ouvrant

Insert a closing angle
bracket (>)

chevron fermant

Insert an underscore symbol
(_)

tiret du bas

Insert an equal sign (=) égal

Insert an asterisk (*) astérisque

Selection and segment
editing

Select the content of the
entire segment

tout sélectionner

Select the word after the
caret

sélectionner le mot suivant

Select the word before the
caret

sélectionner le mot
précédent

Select the character after the
caret

sélectionner le caractère
suivant
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Select the character before
the caret

sélectionner le caractère
précédent

Remove the selection by
using backspace

retour arrière

Remove the selection by
using delete

annuler

Clear (unselect) any selected
characters or text

annuler la sélection

Remove the character before
the caret (when no text is
selected)

retour arrière

Remove the character after
the caret (when no text is
selected)

supprimer

Navigation Move the caret to the start of
the segment

aller au début

Move the caret to the end of
the segment

aller à la fin

Go to the next segment aller au segment suivant

Return to the previous
segment

aller au segment précédent

Move the caret forwards by
one character

avancer

Move the caret backwards by
one character

reculer

Scroll up the workspace faire défiler vers le haut

Scroll down the workspace faire défiler vers le bas

Select the Page up key page précédente

Select the Page down key page suivante

Select the Home key début

Select the End key fin

Copying and pasting Copy the currently selected
content

copier

Paste the cut or copied
content

coller

Cut the currently selected
content

couper

Formatting Apply bold formatting mettre en gras

Apply italic formatting mettre en italique

Apply underline formatting souligner
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Apply strikethrough
formatting

barrer

Apply subscript formatting mettre en indice

Apply superscript formatting mettre en exposant

Apply small caps formatting utiliser des petites
majuscules

Show whitespace characters afficher les espaces blancs

Hide whitespace characters masquer les espaces blancs

Remove all the tags from the
current selection

effacer le formatage

Remove all the tags from the
entire segment

effacer tout le formatage

Undo and redo Undo the last action annuler

Redo the last action rétablir

Segment actions and
confirmation

Clear the content of the
active target segment

effacer la cible

Copy the source content to
the active target segment

copier la source

Lock the active segment verrouiller le segment

Unlock the active segment déverrouiller le segment

Confirm the active segment
and move to the next
unconfirmed segment

confirmer

Confirm the active segment
and move to the next
segment, regardless of its
status

confirmer et passer au
suivant

Confirm the active segment
and do not move to the next
segment

confirmer sans passer au
suivant

Add the active segment as a
new translation unit into the
translation memory

nouvelle unité de traduction

Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

rejeter le segment

Smart actions Open the smart actions
menu

afficher les actions
intelligentes

Select the insert tags action
in the smart actions menu

afficher le menu des balises
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Select the terminology action
in the smart actions menu

afficher le menu des termes

Select the fragment matches
action in the smart actions
menu

afficher le menu des
fragments

Select the placeables action
in the smart actions menu

afficher le menu des
éléments transposables

Select the TQA action in the
smart actions menu

afficher le menu d'évaluation
de la qualité

Select the comments action
in the smart actions menu

afficher le menu des
commentaires

Panel interaction Collapse the side panel réduire le volet latéral

Expand the Verification
panel

développer le volet des
vérifications

Expand the Revisions panel développer le volet des
révisions

Expand the TQA panel développer le volet de
l'évaluation de la qualité

Expand the Filters panel développer le volet des filtres

Expand the Lookups panel développer le volet des
concordances

Expand the Comments
panel

développer le volet des
commentaires

Expand the Navigation
panel with the Find tab
selected

développer le volet
Rechercher *

Expand the Navigation
panel with the Replace tab
selected

développer le volet
Remplacer

Track Changes Enable the Track Changes
functionality

activer le suivi des
modifications

Disable the Track Changes
functionality

désactiver le suivi des
modifications

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

accepter toutes les révisions

Reject all the revisions in the
current document

rejeter toutes les révisions

Move to the next revision révision suivante

Return to the previous
revision

révision précédente

Accept the currently selected
revision

accepter
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Reject the currently selected
revision

rejeter

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

message suivant

Return to the previous
verification message

message précédent

Ignore the active verification
message

ignorer

Comments (only if the
Comments panel is
expanded)

Move to the next comment commentaire suivant

Return to the previous
comment

commentaire précédent

Delete the currently selected
comment

supprimer

Edit the currently selected
comment

modifier

Special commands

Command Description

littéral Use before another command to insert that
command as text instead of executing it

Dictation commands for German
A list of commands that you can use for dictation when working with files whose target
language is set to German.

Area Action Command

Turn off dictation Diktieren beenden

Select the last text inserted
by using dictation

zuletzt auswählen

Punctuation Insert a period (.) Punkt

Insert a comma (,) Komma

Insert an exclamation mark
(!)

Ausrufezeichen

Insert a question mark (?) Fragezeichen
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Area Action Command

Insert a hyphen (-) Bindestrich

Insert an em dash (—) Geviertzeichen

Insert an en dash (–) Halbgeviertzeichen

Insert a colon (:) Doppelpunkt

Insert a semicolon (;) Semikolon

Special characters Insert a pair of single
quotation marks (‘’)

Einfaches
Anführungszeichen

Insert a new line Neue Zeile

Insert a tab Tabulator

Insert a space Leerzeichen

Insert a non-breaking
hyphen

Geschützter Bindestrich

Insert an optional hyphen Optionaler Bindestrich

Insert a non-breaking space Geschütztes Leerzeichen

Insert a copyright symbol (©) Copyrightzeichen

Insert a registered symbol
(®)

Zeichen für eingetragene
Marke

Insert a trademark symbol
(™)

Warenzeichen

Insert a euro symbol (€) Eurozeichen

Insert a pound symbol (£) Pfundzeichen

Insert a pair of German
quotation marks („“)

deutsche Anführungszeichen

Insert a pair of English
quotation marks (“”)

englische
Anführungszeichen

Insert a pair of angular
quotation marks («  »)

Chevron Anführungszeichen

Insert an apostrophe (') Apostroph

Insert a micro symbol (µ) Mikro Zeichen

Insert an approximation
symbol (≈)

Ungefähr Zeichen

Insert a tilde (~) Tilde

Insert a not equal symbol
(≠)

Ungleich

Insert a degree symbol (°) Gradzeichen

Insert a less than or equal
symbol (≤)

Kleiner gleich Zeichen
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Area Action Command

Insert a greater than or
equal symbol (≥)

Größer gleich Zeichen

Insert a lowercase alpha
symbol (α)

Kleines Alpha Zeichen

Insert a lowercase beta
symbol (β)

Kleines Beta Zeichen

Insert a capital delta symbol
(Δ)

Großes Delta Zeichen

Insert a lowercase gamma
symbol (γ)

Kleines Gamma Zeichen

Insert a lowercase pi symbol
(π)

Kleines pi Zeichen

Insert a plus or minus
symbol (±)

Plusminus zeichen

Insert a sum symbol (∑) Summenzeichen

Insert a multiplication
symbol (×)

Multiplikationszeichen

Insert an infinite symbol (∞) Unendlich Zeichen

Insert a slash (/) Schrägstrich

Insert a backslash (\) Umgekehrter Schrägstrich

Insert an at sign (@) At Zeichen

Insert a percentage
character (%)

Prozent

Insert a round opening
bracket

Klammer auf

Insert a round closing
bracket

Klammer zu

Insert an opening square
bracket ([)

Eckige Klammer auf

Insert a closing square
bracket (])

Eckige Klammer zu

Insert an opening angle
bracket (<)

Spitze Klammer auf

Insert a closing angle
bracket (>)

Spitze Klammer zu

Insert an underscore symbol
(_)

Unterstrich

Insert an equal sign (=) Gleich

Insert an asterisk (*) Sternchen
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Selection and segment
editing

Select the content of the
entire segment

Alles auswählen

Select the word after the
caret

Nächstes Wort auswählen

Select the word before the
caret

Vorheriges Wort auswählen

Select the character after the
caret

Nächstes auswählen

Select the character before
the caret

Vorheriges auswählen

Remove the selection by
using backspace

Rücktaste

Remove the selection by
using delete

entfernen

Clear (unselect) any selected
characters or text

auswahl aufheben

Remove the character before
the caret (when no text is
selected)

Rücktaste

Remove the character after
the caret (when no text is
selected)

entfernen

Navigation Move the caret to the start of
the segment

Gehe zum Anfang

Move the caret to the end of
the segment

Gehe zum Ende

Go to the next segment Gehe zum nächsten Segment

Return to the previous
segment

Gehe zum vorherigen
Segment

Move the caret forwards by
one character

Vorwärts

Move the caret backwards by
one character

Zurück

Scroll up the workspace Nach oben scrollen

Scroll down the workspace Nach unten scrollen

Select the Page up key Bild auf

Select the Page down key Bild ab

Select the Home key Pos1

Select the End key Ende

Copying and pasting Copy the currently selected
content

Kopiere das

5Working with Online Editor

99Translating and Reviewing Documents



Area Action Command

Paste the cut or copied
content

Füge das ein

Cut the currently selected
content

Schneide das aus

Formatting Apply bold formatting Fett formatieren

Apply italic formatting Kursiv formatieren

Apply underline formatting Unterstrichen formatieren

Apply strikethrough
formatting

Durchgestrichen formatieren

Apply subscript formatting Tiefgestellt formatieren

Apply superscript formatting Hochgestellt formatieren

Apply small caps formatting Kapitälchen formatieren

Show whitespace characters Leerzeichen anzeigen

Hide whitespace characters leerzeichen ausblenden

Remove all the tags from the
current selection

Formatierung löschen

Remove all the tags from the
entire segment

Alle Formatierungen löschen

Undo and redo Undo the last action Mache das rückgängig

Redo the last action Wiederhole das

Segment actions and
confirmation

Clear the content of the
active target segment

Zielsegment löschen

Copy the source content to
the active target segment

Ausgangssatz kopieren

Lock the active segment Segment sperren

Unlock the active segment Segment entsperren

Confirm the active segment
and move to the next
unconfirmed segment

Bestätigen

Confirm the active segment
and move to the next
segment, regardless of its
status

Bestätigen und nächstes
Segment

Confirm the active segment
and do not move to the next
segment

Bestätigen und hierbleiben

Add the active segment as a
new translation unit into the
translation memory

Neue Übersetzungseinheit
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Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

Segment ablehnen

Smart actions Open the smart actions
menu

Smart Actions anzeigen

Select the insert tags action
in the smart actions menu

Menü Tags anzeigen

Select the terminology action
in the smart actions menu

Term Menü anzeigen

Select the fragment matches
action in the smart actions
menu

Menü Fragmente anzeigen

Select the placeables action
in the smart actions menu

Menü für platzierbare
Elemente anzeigen

Select the TQA action in the
smart actions menu

Menü Qualitätsbewertung
anzeigen

Select the comments action
in the smart actions menu

Kommentarmenü anzeigen

Panel interaction Collapse the side panel Seitenbereich ausblenden

Expand the Verification
panel

Überprüfungsmeldungen
einblenden

Expand the Revisions panel Nachverfolgte Änderungen
einblenden

Expand the TQA panel Qualitätsbewertungen
einblenden

Expand the Filters panel Filter einblenden

Expand the Lookups panel Suchergebnisse einblenden

Expand the Comments
panel

Kommentare einblenden

Expand the Navigation
panel with the Find tab
selected

Suche einblenden

Expand the Navigation
panel with the Replace tab
selected

Ersetzen einblenden

Track Changes Enable the Track Changes
functionality

Änderungsnachverfolgung
an

Disable the Track Changes
functionality

Änderungsnachverfolgung
aus

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

Alle nachverfolgten
Änderungen annehmen
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Area Action Command

Reject all the revisions in the
current document

Alle nachverfolgten
Änderungen ablehnen

Move to the next revision Nächste nachverfolgte
Änderung

Return to the previous
revision

Vorherige nachverfolgte
Änderung

Accept the currently selected
revision

Nehme das an

Reject the currently selected
revision

Lehne das ab

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

Nächste Meldung

Return to the previous
verification message

Vorherige Meldung

Ignore the active verification
message

Ignoriere das

Comments (only if the
Comments panel is
expanded)

Move to the next comment Nächster Kommentar

Return to the previous
comment

Vorheriger Kommentar

Delete the currently selected
comment

Lösche das

Edit the currently selected
comment

Bearbeite das

Special commands

Command Description

Literalwort Use before another command to insert that
command as text instead of executing it

Dictation commands for Italian
A list of commands that you can use for dictation when working with files whose target
language is set to Italian.
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Turn off dictation sospendi dettato

Select the last text inserted
by using dictation

selezionare ultimo

Punctuation Insert a period (.) punto

Insert a comma (,) virgola

Insert an exclamation mark
(!)

punto esclamativo

Insert a question mark (?) punto interrogativo

Insert a hyphen (-) segno meno

Insert an em dash (—) lineetta

Insert an en dash (–) trattino

Insert a colon (:) due punti

Insert a semicolon (;) punto e virgola

Special characters Insert a pair of single
quotation marks (‘’)

virgoletta singola

Insert a new line a capo/nuova riga

Insert a tab tabulazione

Insert a space spazio

Insert a non-breaking
hyphen

trattino unificatore/trattino
d'unione

Insert an optional hyphen segno meno facoltativo

Insert a non-breaking space spazio unificatore

Insert a copyright symbol (©) simbolo di copyright

Insert a registered symbol
(®)

simbolo registrato

Insert a trademark symbol
(™)

simbolo di marchio

Insert a euro symbol (€) simbolo di euro

Insert a pound symbol (£) simbolo di sterlina

Insert a pair of German
quotation marks („“)

virgolette tedesche

Insert a pair of English
quotation marks (“”)

virgolette inglesi

Insert a pair of angular
quotation marks («  »)

virgolette francesi

Insert an apostrophe (') apostrofo
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Area Action Command

Insert a micro symbol (µ) simbolo di micro

Insert an approximation
symbol (≈)

simbolo di circa

Insert a tilde (~) tilde

Insert a not equal symbol
(≠)

diverso da

Insert a degree symbol (°) simbolo di grado

minore o uguale a Insert a less than or equal
symbol (≤)

minore o uguale a

Insert a greater than or
equal symbol (≥)

maggiore o uguale a

Insert a lowercase alpha
symbol (α)

alfa minuscolo

Insert a lowercase beta
symbol (β)

beta minuscolo

Insert a capital delta symbol
(Δ)

delta maiuscolo

Insert a lowercase gamma
symbol (γ)

gamma minuscolo

Insert a lowercase pi symbol
(π)

pi minuscolo

Insert a plus or minus
symbol (±)

simbolo più o meno

Insert a sum symbol (∑) simbolo di somma

Insert a multiplication
symbol (×)

simbolo di moltiplicazione

Insert an infinite symbol (∞) simbolo di infinito

Insert a slash (/) barra

Insert a backslash (\) barra rovesciata

Insert an at sign (@) chiocciola

Insert a percentage
character (%)

percentuale

Insert a round opening
bracket

parentesi aperta

Insert a round closing
bracket

parentesi chiusa

Insert an opening square
bracket ([)

apri parentesi quadra

Insert a closing square
bracket (])

chiudi parentesi quadra
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Area Action Command

Insert an opening angle
bracket (<)

apri angolata

Insert a closing angle
bracket (>)

chiudi angolata

Insert an underscore symbol
(_)

trattino basso/underscore

Insert an equal sign (=) uguale a

Insert an asterisk (*) asterisco

Selection and segment
editing

Select the content of the
entire segment

seleziona tutto

Select the word after the
caret

seleziona parola successiva

Select the word before the
caret

seleziona parola precedente

Select the character after the
caret

seleziona successivo

Select the character before
the caret

seleziona precedente

Remove the selection by
using backspace

backspace

Remove the selection by
using delete

cancella

Clear (unselect) any selected
characters or text

cancella selezione

Remove the character before
the caret (when no text is
selected)

backspace

Remove the character after
the caret (when no text is
selected)

cancella

Navigation Move the caret to the start of
the segment

inizio segmento

Move the caret to the end of
the segment

fine segmento

Go to the next segment segmento successivo

Return to the previous
segment

segmento precedente

Move the caret forwards by
one character

avanti di uno

Move the caret backwards by
one character

cursore indietro di uno

Scroll up the workspace scorri verso l'alto
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Area Action Command

Scroll down the workspace scorri verso il basso

Select the Page up key pagina precedente

Select the Page down key pagina successiva

Select the Home key tasto Inizio

Select the End key tasto Fine

Copying and pasting Copy the currently selected
content

copia negli appunti

Paste the cut or copied
content

incolla dagli appunti

Cut the currently selected
content

taglia negli appunti

Formatting Apply bold formatting grassetto

Apply italic formatting corsivo

Apply underline formatting sottolinea

Apply strikethrough
formatting

Apply subscript formatting pedice

Apply superscript formatting apice

Apply small caps formatting maiuscoletto

Show whitespace characters mostra spaziatura

Hide whitespace characters nascondi spaziatura

Remove all the tags from the
current selection

cancella formattazione
selezione

Remove all the tags from the
entire segment

cancella formattazione

Undo and redo Undo the last action annulla

Redo the last action ripeti

Segment actions and
confirmation

Clear the content of the
active target segment

cancella destinazione

Copy the source content to
the active target segment

copia origine

Lock the active segment blocca segmento

Unlock the active segment sblocca segmento

Confirm the active segment
and move to the next
unconfirmed segment

conferma
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Area Action Command

Confirm the active segment
and move to the next
segment, regardless of its
status

conferma e successivo

Confirm the active segment
and do not move to the next
segment

conferma e rimani

Add the active segment as a
new translation unit into the
translation memory

nuova unità di traduzione

Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

rifiuta segmento

Smart actions Open the smart actions
menu

mostra azioni smart

Select the insert tags action
in the smart actions menu

mostra menu tag

Select the terminology action
in the smart actions menu

mostra menu termini

Select the fragment matches
action in the smart actions
menu

mostra menu frammenti

Select the placeables action
in the smart actions menu

mostra menu posizionabili

Select the TQA action in the
smart actions menu

mostra menu tqa

Select the comments action
in the smart actions menu

mostra menu commenti

Panel interaction Collapse the side panel comprimi riquadro

Expand the Verification
panel

amplia riquadro verifica

Expand the Revisions panel amplia riquadro revisioni

Expand the TQA panel amplia riquadro tqa

Expand the Filters panel amplia riquadro filtri

Expand the Lookups panel amplia riquadro ricerca

Expand the Comments
panel

amplia riquadro commenti

Expand the Navigation
panel with the Find tab
selected

amplia riquadro trova
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Area Action Command

Expand the Navigation
panel with the Replace tab
selected

amplia riquadro sostituisci

Track Changes Enable the Track Changes
functionality

abilita revisioni

Disable the Track Changes
functionality

disabilita revisioni

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

accetta tutte le revisioni

Reject all the revisions in the
current document

rifiuta tutte le revisioni

Move to the next revision revisione successiva

Return to the previous
revision

revisione precedente

Accept the currently selected
revision

accetta

Reject the currently selected
revision

rifiuta

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

messaggio successivo

Return to the previous
verification message

messaggio precedente

Ignore the active verification
message

ignora

Comments (only if the
Comments panel is
expanded)

Move to the next comment commento successivo

Return to the previous
comment

commento precedente

Delete the currently selected
comment

elimina commento

Edit the currently selected
comment

modifica commento

Special commands

Command Description

letterale Use before another command to insert that
command as text instead of executing it

5 Working with Online Editor

108 Translating and Reviewing Documents



Dictation commands for Japanese
A list of commands that you can use for dictation when working with files whose target
language is set to Japanese.

Area Action Command

Turn off dictation ディクテーションを停止

Punctuation Insert a period (.) ピリオド

Insert a comma (,) コンマ

Insert an exclamation mark
(!)

感嘆符

Insert a question mark (?) 疑問符

Insert a hyphen (-) ハイフン

Insert an em dash (—) エムダッシュ

Insert an en dash (–) エヌダッシュ

Insert a colon (:) コロン

Insert a semicolon (;) セミコロン

Special characters Insert a pair of single
quotation marks (‘’)

一重引用符

Insert a new line 改行

Insert a tab タブ

Insert a space スペース

Insert a non-breaking
hyphen

固定ハイフン

Insert an optional hyphen 任意指定のハイフン

Insert a non-breaking space 固定スペース

Insert a copyright symbol (©) 著作権記号

Insert a registered symbol
(®)

登録商標記号

Insert a trademark symbol
(™)

商標記号

Insert a euro symbol (€) ユーロ記号

Insert a pound symbol (£) ポンド記号

Insert a pair of German
quotation marks („“)

ドイツ語の引用符

Insert a pair of English
quotation marks (“”)

英語の引用符
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Insert a pair of angular
quotation marks («  »)

フランス語の引用符

Insert an apostrophe (') アポストロフィ

Insert a micro symbol (µ) マイクロ記号

Insert an approximation
symbol (≈)

アプロクシメトリ

Insert a tilde (~) チルダ

Insert a not equal symbol
(≠)

ノットイコール

Insert a degree symbol (°) 度記号

Insert a less than or equal
symbol (≤)

小なりイコール

Insert a greater than or
equal symbol (≥)

大なりイコール

Insert a lowercase alpha
symbol (α)

小文字アルファ記号

Insert a lowercase beta
symbol (β)

小文字ベータ記号

Insert a capital delta symbol
(Δ)

大文字デルタ記号

Insert a lowercase gamma
symbol (γ)

小文字ガンマ記号

Insert a lowercase pi symbol
(π)

小文字パイ記号

Insert a plus or minus
symbol (±)

プラマイ記号

Insert a sum symbol (∑) シグマ記号

Insert a multiplication
symbol (×)

かける記号

Insert an infinite symbol (∞) 無限大記号

Insert a slash (/) スラッシュ

Insert a backslash (\) バックスラッシュ

Insert an at sign (@) アットマーク

Insert a percentage
character (%)

パーセント記号

Insert a round opening
bracket

かっこ開く

Insert a round closing
bracket

かっこ閉じる
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Insert an opening square
bracket ([)

角かっこ開く

Insert a closing square
bracket (])

角かっこ閉じる

Insert an opening angle
bracket (<)

山かっこ開く

Insert a closing angle
bracket (>)

山かっこ閉じる

Insert an underscore symbol
(_)

アンダースコア

Insert an equal sign (=) イコール記号

Insert an asterisk (*) アスタリスク

Selection and segment
editing

Select the content of the
entire segment

すべて選択

Select the word after the
caret

次の単語を選択

Select the word before the
caret

前の単語を選択

Select the character after the
caret

次の文字を選択

Select the character before
the caret

前の文字を選択

Remove the selection by
using backspace

バックスペース

Remove the selection by
using delete

削除

Clear (unselect) any selected
characters or text

選択をクリア

Remove the character before
the caret (when no text is
selected)

バックスペース

Remove the character after
the caret (when no text is
selected)

削除

Navigation Move the caret to the start of
the segment

最初に移動

Move the caret to the end of
the segment

最後に移動

Go to the next segment 次の分節に移動

Return to the previous
segment

前の分節に移動

5Working with Online Editor

111Translating and Reviewing Documents



Area Action Command

Move the caret forwards by
one character

ひと文字前に移動

Move the caret backwards by
one character

ひと文字後ろに移動

Scroll up the workspace 上にスクロール

Scroll down the workspace 下にスクロール

Select the Page up key 前のページ

Select the Page down key 次のページ

Select the Home key ホームキー

Select the End key エンドキー

Copying and pasting Copy the currently selected
content

それをコピー

Paste the cut or copied
content

それを貼り付け

Cut the currently selected
content

それを切り取り

Formatting Apply bold formatting 太字の適用

Apply italic formatting 斜体の適用

Apply underline formatting 下線の適用

Apply strikethrough
formatting

取り消し線の適用

Apply subscript formatting 下付き文字の適用

Apply superscript formatting 上付き文字の適用

Apply small caps formatting 小文字の適用

Show whitespace characters 空白文字を表示

Hide whitespace characters 空白文字を非表示

Remove all the tags from the
current selection

書式をクリア

Remove all the tags from the
entire segment

すべての書式をクリア

Undo and redo Undo the last action それを元に戻す

Redo the last action それをやり直す

Segment actions and
confirmation

Clear the content of the
active target segment

分節のクリア

Copy the source content to
the active target segment

原文をコピー

Lock the active segment 分節のロック
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Area Action Command

Unlock the active segment 分節のロック解除

Confirm the active segment
and move to the next
unconfirmed segment

確定

Confirm the active segment
and move to the next
segment, regardless of its
status

確定して次

Confirm the active segment
and do not move to the next
segment

確定して移動しない

Add the active segment as a
new translation unit into the
translation memory

新しい翻訳単位

Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

リリース却下

Smart actions Open the smart actions
menu

スマートアクションを表示

Select the insert tags action
in the smart actions menu

タグメニューを表示

Select the terminology action
in the smart actions menu

用語メニューを表示

Select the fragment matches
action in the smart actions
menu

フラグメントメニューを表示

Select the placeables action
in the smart actions menu

固定要素メニューを表示

Select the TQA action in the
smart actions menu

品質評価メニューを表示

Select the comments action
in the smart actions menu

コメントメニューを表示

Panel interaction Collapse the side panel サイドパネルを非表示

Expand the Verification
panel

検証パネルを表示

Expand the Revisions panel 変更履歴パネルを表示

Expand the TQA panel 品質評価パネルを表示

Expand the Filters panel フィルタパネルを表示

Expand the Lookups panel ルックアップパネルを表示

Expand the Comments
panel

コメントパネルを表示
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Area Action Command

Expand the Navigation
panel with the Find tab
selected

検索パネルを表示

Expand the Navigation
panel with the Replace tab
selected

置換パネルを表示

Track Changes Enable the Track Changes
functionality

変更履歴有効

Disable the Track Changes
functionality

変更履歴無効

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

変更をすべて反映

Reject all the revisions in the
current document

変更をすべて拒否

Move to the next revision 次の変更

Return to the previous
revision

前の変更

Accept the currently selected
revision

これを反映

Reject the currently selected
revision

これを拒否

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

次のメッセージ

Return to the previous
verification message

前のメッセージ

Ignore the active verification
message

これを無視

Comments (only if the
Comments panel is
expanded)

Move to the next comment 次のコメント

Return to the previous
comment

前のコメント

Delete the currently selected
comment

これを削除

Edit the currently selected
comment

これを編集
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Special commands

Command Description

リテラル Use before another command to insert that
command as text instead of executing it

Dictation commands for Romanian
A list of commands that you can use for dictation when working with files whose target
language is set to Romanian.

Area Action Command

Turn off dictation opreste dictarea

Select the last text inserted
by using dictation

selectează ultimul text

Punctuation Insert a period (.) punct

Insert a comma (,) virgulă

Insert an exclamation mark
(!)

semnul exclamării

Insert a question mark (?) semnul întrebării

Insert a hyphen (-) cratimă

Insert an em dash (—) linie de dialog

Insert an en dash (–) linie de pauză

Insert a colon (:) două puncte

Insert a semicolon (;) punct si virgulă

Special characters Insert a pair of single
quotation marks (‘’)

ghilimele simple

Insert a new line linie nouă

Insert a tab tab

Insert a space spatiu

Insert a non-breaking
hyphen

cratimă fără pauză

Insert an optional hyphen cratimă optională

Insert a non-breaking space spatiu fără pauză

Insert a copyright symbol (©) simbol drepturile de autor

Insert a registered symbol
(®)

simbol marcă înregistrată
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Area Action Command

Insert a trademark symbol
(™)

simbol marcă comercială

Insert a euro symbol (€) simbol euro

Insert a pound symbol (£) simbol liră

Insert a pair of German
quotation marks („“)

ghilimele germane

Insert a pair of English
quotation marks (“”)

ghilimele englezesti

Insert a pair of angular
quotation marks («  »)

ghilimele frantuzesti

Insert an apostrophe (') apostrof

Insert a micro symbol (µ) simbol micro

Insert an approximation
symbol (≈)

simbol aproximativ

Insert a tilde (~) simbol tildă

Insert a not equal symbol
(≠)

simbol diferit

Insert a degree symbol (°) simbol grad

Insert a less than or equal
symbol (≤)

simbol mai mic sau egal

Insert a greater than or
equal symbol (≥)

simbol mai mare sau egal

Insert a lowercase alpha
symbol (α)

simbol alfa

Insert a lowercase beta
symbol (β)

simbol beta

Insert a capital delta symbol
(Δ)

simbol delta

Insert a lowercase gamma
symbol (γ)

simbol gama

Insert a lowercase pi symbol
(π)

simbol pi

Insert a plus or minus
symbol (±)

simbol plus sau minus

Insert a sum symbol (∑) simbol sumă

Insert a multiplication
symbol (×)

simbol înmultire

Insert an infinite symbol (∞) simbol infinit

Insert a slash (/) slash
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Area Action Command

Insert a backslash (\) backslash

Insert an at sign (@) a rond

Insert a percentage
character (%)

procent

Insert a round opening
bracket

paranteză deschisă

Insert a round closing
bracket

paranteză închisă

Insert an opening square
bracket ([)

paranteză dreaptă deschisă

Insert a closing square
bracket (])

paranteză dreaptă închisă

Insert an opening angle
bracket (<)

paranteză unghiulară
deschisă

Insert a closing angle
bracket (>)

paranteză unghiulară închisă

Insert an underscore symbol
(_)

bară jos

Insert an equal sign (=) egal

Insert an asterisk (*) asterisc

Selection and segment
editing

Select the content of the
entire segment

selectează tot

Select the word after the
caret

selectează cuvântul următor

Select the word before the
caret

selectează cuvântul
precedent

Select the character after the
caret

selectează caracterul
următor

Select the character before
the caret

selectează caracterul
precedent

Remove the selection by
using backspace

backspace

Remove the selection by
using delete

sterge

Clear (unselect) any selected
characters or text

sterge selectia

Remove the character before
the caret (when no text is
selected)

backspace

Remove the character after
the caret (when no text is
selected)

sterge
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Area Action Command

Navigation Move the caret to the start of
the segment

mergi la început

Move the caret to the end of
the segment

mergi la final

Go to the next segment mergi la segmentul următor

Return to the previous
segment

mergi la segmentul
precedent

Move the caret forwards by
one character

mergi înainte

Move the caret backwards by
one character

mergi înapoi

Scroll up the workspace derulează în sus

Scroll down the workspace derulează în jos

Select the Page up key pagină sus

Select the Page down key pagină jos

Select the Home key acasă

Select the End key final

Copying and pasting Copy the currently selected
content

copiază

Paste the cut or copied
content

lipeste

Cut the currently selected
content

taie

Formatting Apply bold formatting aplică bold

Apply italic formatting aplică italic

Apply underline formatting aplică subliniere

Apply strikethrough
formatting

aplică tăiere text

Apply subscript formatting aplică indice

Apply superscript formatting aplică exponent

Apply small caps formatting aplică litere mici

Show whitespace characters arată spatiile libere

Hide whitespace characters ascunde spatiile libere

Remove all the tags from the
current selection

sterge formatarea

Remove all the tags from the
entire segment

sterge toată formatarea
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Area Action Command

Undo and redo Undo the last action anulează

Redo the last action reface

Segment actions and
confirmation

Clear the content of the
active target segment

sterge segmentul

Copy the source content to
the active target segment

copiază sursa

Lock the active segment blochează segmentul

Unlock the active segment deblochează segmentul

Confirm the active segment
and move to the next
unconfirmed segment

confirmă

Confirm the active segment
and move to the next
segment, regardless of its
status

confirmă si mergi la
următorul

Confirm the active segment
and do not move to the next
segment

confirmă si stai

Add the active segment as a
new translation unit into the
translation memory

memorează segmentul

Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

refuză segmentul

Smart actions Open the smart actions
menu

arată actiuni inteligente

Select the insert tags action
in the smart actions menu

afisează meniul de etichete

Select the terminology action
in the smart actions menu

afisează meniul de termeni

Select the fragment matches
action in the smart actions
menu

afisează meniul de
fragmente

Select the placeables action
in the smart actions menu

afisează meniul de optiuni

Select the TQA action in the
smart actions menu

afisează meniul de evaluare
a calitătii

Select the comments action
in the smart actions menu

afisează meniul de
comentarii

Panel interaction Collapse the side panel închide panoul lateral

Expand the Verification
panel

deschide panoul de verificare
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Area Action Command

Expand the Revisions panel deschide panoul de revizie

Expand the TQA panel deschide panoul de evaluare
a calitătii

Expand the Filters panel deschide panoul de filtre

Expand the Lookups panel deschide panoul de căutări

Expand the Comments
panel

deschide panoul de
comentarii

Expand the Navigation
panel with the Find tab
selected

deschide panoul de căutare

Expand the Navigation
panel with the Replace tab
selected

deschide panoul de înlocuire

Track Changes Enable the Track Changes
functionality

activează track changes

Disable the Track Changes
functionality

dezactivează track changes

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

acceptă toate modificările

Reject all the revisions in the
current document

refuză toate modificările

Move to the next revision modificarea următoare

Return to the previous
revision

modificarea precedentă

Accept the currently selected
revision

acceptă modificarea

Reject the currently selected
revision

refuză modificarea

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

mesajul următor

Return to the previous
verification message

mesajul precedent

Ignore the active verification
message

ignoră mesajul

Comments (only if the
Comments panel is
expanded)

Move to the next comment comentariul următor

Return to the previous
comment

comentariul precedent

Delete the currently selected
comment

sterge comentariul
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Area Action Command

Edit the currently selected
comment

editează comentariul

Special commands

Command Description

literal Use before another command to insert that
command as text instead of executing it

Dictation commands for Spanish
A list of commands that you can use for dictation when working with files whose target
language is set to Spanish.

Area Action Command

Turn off dictation parar dictado

Select the last text inserted
by using dictation

seleccione el último

Punctuation Insert a period (.) punto

Insert a comma (,) coma

Insert an exclamation mark
(!)

signo de exclamación

Insert a question mark (?) signo de interrogación

Insert a hyphen (-) guion

Insert an em dash (—) guion largo

Insert an en dash (–) guion corto

Insert a colon (:) dos puntos

Insert a semicolon (;) punto y coma

Special characters Insert a pair of single
quotation marks (‘’)

comilla simple

Insert a new line nueva línea

Insert a tab tabulación

Insert a space espacio

Insert a non-breaking
hyphen

guion sin salto

Insert an optional hyphen guion opcional
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Area Action Command

Insert a non-breaking space espacio sin salto

Insert a copyright symbol (©) símbolo copyright

Insert a registered symbol
(®)

símbolo registrado

Insert a trademark symbol
(™)

símbolo marca registrada

Insert a euro symbol (€) símbolo euro

Insert a pound symbol (£) símbolo libra

Insert a pair of German
quotation marks („“)

comillas alemanas

Insert a pair of English
quotation marks (“”)

comillas inglesas

Insert a pair of angular
quotation marks («  »)

comillas españolas

Insert an apostrophe (') apóstrofo

Insert a micro symbol (µ) símbolo micro

Insert an approximation
symbol (≈)

símbolo aproximadamente

Insert a tilde (~) símbolo tilde

Insert a not equal symbol
(≠)

símbolo no igual

Insert a degree symbol (°) símbolo grado

Insert a less than or equal
symbol (≤)

símbolo menor o igual que

Insert a greater than or
equal symbol (≥)

símbolo mayor o igual que

Insert a lowercase alpha
symbol (α)

símbolo alfa minúscula

Insert a lowercase beta
symbol (β)

símbolo beta minúscula

Insert a capital delta symbol
(Δ)

símbolo delta mayúscula

Insert a lowercase gamma
symbol (γ)

símbolo gamma minúscula

Insert a lowercase pi symbol
(π)

símbolo pi minúscula

Insert a plus or minus
symbol (±)

símbolo más menos

Insert a sum symbol (∑) símbolo suma
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Area Action Command

Insert a multiplication
symbol (×)

símbolo multiplicación

Insert an infinite symbol (∞) símbolo infinito

Insert inverted question
mark (¿). Spanish only.

signo de interrogación de
apertura

Insert inverted exclamation
mark (¡). Spanish only.

signo de exclamación de
apertura

Insert a slash (/) barra diagonal

Insert a backslash (\) barra diagonal inversa

Insert an at sign (@) arroba

Insert a percentage
character (%)

porcentaje

Insert a round opening
bracket

abrir paréntesis

Insert a round closing
bracket

cerrar paréntesis

Insert an opening square
bracket ([)

abrir corchete

Insert a closing square
bracket (])

cerrar corchete

Insert an opening angle
bracket (<)

abrir corchete angular

Insert a closing angle
bracket (>)

cerrar corchete angular

Insert an underscore symbol
(_)

guion bajo

Insert an equal sign (=) igual

Insert an asterisk (*) asterisco

Selection and segment
editing

Select the content of the
entire segment

seleccionar todo

Select the word after the
caret

seleccionar la palabra
siguiente

Select the word before the
caret

seleccionar la palabra
anterior

Select the character after the
caret

seleccionar siguiente

Select the character before
the caret

seleccionar anterior

Remove the selection by
using backspace

retroceso
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Area Action Command

Remove the selection by
using delete

eliminar

Clear (unselect) any selected
characters or text

borrar selección

Remove the character before
the caret (when no text is
selected)

retroceso

Remove the character after
the caret (when no text is
selected)

eliminar

Navigation Move the caret to the start of
the segment

ir al principio

Move the caret to the end of
the segment

ir al final

Go to the next segment ir al segmento siguiente

Return to the previous
segment

ir al segmento anterior

Move the caret forwards by
one character

avanzar

Move the caret backwards by
one character

retroceder

Scroll up the workspace desplazar hacia arriba

Scroll down the workspace desplazar hacia abajo

Select the Page up key retroceder página

Select the Page down key avanzar página

Select the Home key inicio

Select the End key fin

Copying and pasting Copy the currently selected
content

copiar eso

Paste the cut or copied
content

pegar eso

Cut the currently selected
content

cortar eso

Formatting Apply bold formatting aplicar negrita

Apply italic formatting aplicar cursiva

Apply underline formatting aplicar subrayado

Apply strikethrough
formatting

aplicar tachado

Apply subscript formatting aplicar subíndice
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Area Action Command

Apply superscript formatting aplicar superíndice

Apply small caps formatting aplicar versales

Show whitespace characters mostras espacios en blanco

Hide whitespace characters ocultar espacios en blanco

Remove all the tags from the
current selection

borrar formato

Remove all the tags from the
entire segment

borrar todo el formato

Undo and redo Undo the last action deshacer eso

Redo the last action rehacer eso

Segment actions and
confirmation

Clear the content of the
active target segment

borrar texto de destino

Copy the source content to
the active target segment

copiar texto de origen

Lock the active segment bloquear segmento

Unlock the active segment desbloquear segmento

Confirm the active segment
and move to the next
unconfirmed segment

confirmar

Confirm the active segment
and move to the next
segment, regardless of its
status

confirmar y siguiente

Confirm the active segment
and do not move to the next
segment

confirmar y quedarse

Add the active segment as a
new translation unit into the
translation memory

nueva unidad de traducción

Set the status of the active
segment to Sign-off
Rejected. Only available to
certain users.

rechazar segmento

Smart actions Open the smart actions
menu

mostrar acciones
inteligentes

Select the insert tags action
in the smart actions menu

mostrar menú de etiquetas

Select the terminology action
in the smart actions menu

mostrar menú de términos

Select the fragment matches
action in the smart actions
menu

mostrar menú de
fragmentos
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Area Action Command

Select the placeables action
in the smart actions menu

mostrar menú de variables

Select the TQA action in the
smart actions menu

mostrar menú de evaluación
de calidad

Select the comments action
in the smart actions menu

mostrar menú de
comentarios

Panel interaction Collapse the side panel contraer panel lateral

Expand the Verification
panel

expandir panel de
verificación

Expand the Revisions panel expandir panel de revisiones

Expand the TQA panel expandir panel de evaluación
de calidad

Expand the Filters panel expandir panel de filtros

Expand the Lookups panel expandir panel de
búsquedas

Expand the Comments
panel

expandir panel de
comentarios

Expand the Navigation
panel with the Find tab
selected

expandir panel buscar

Expand the Navigation
panel with the Replace tab
selected

expandir panel reemplazar

Track Changes Enable the Track Changes
functionality

activar control de cambios

Disable the Track Changes
functionality

desactivar control de
cambios

Revisions (only if the
Revisions panel is expanded)

Accept all the revisions in the
current document

aceptar todas las revisiones

Reject all the revisions in the
current document

rechazar todas las revisiones

Move to the next revision revisión siguiente

Return to the previous
revision

revisión anterior

Accept the currently selected
revision

aceptar esto

Reject the currently selected
revision

rechazar esto

Verification messages (only
if the Verification panel is
expanded)

Move to the next verification
message

mensaje siguiente
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Area Action Command

Return to the previous
verification message

mensaje anterior

Ignore the active verification
message

ignorar esto

Comments (only if the
Comments panel is
expanded)

Move to the next comment comentario siguiente

Return to the previous
comment

comentario anterior

Delete the currently selected
comment

eliminar esto

Edit the currently selected
comment

editar esto

Special commands

Command Description

literal Use before another command to insert that
command as text instead of executing it

Translating content
You can translate content in Online Editor using the translation resources (TMs, terminology,
MT) originating in the application Online Editor integrates with.

Online Editor can integrate with: Trados Studio, Trados GroupShare, Managed Translation,
WorldServer, cloud products (Trados Enterprise, Trados Team, Trados Studio cloud
capabilities).

Copying source content to target segments
If a source segment contains long numbers or other characters which are easily mistyped,
you can copy the entire content of a source segment into the target segment and translate
around those characters. Do the same if the segment translation is the same in both the
source and in the target language.
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About this task
You can copy a source segment or all the source content.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target segment to which you want to copy source content.
3. On the Home tab, in the Segments group, do one of the following:

• To copy source content only to that particular target segment, select Copy Source
to Target > Copy Source to Target.

Note: If the segment already contains some content, the source content overwrites
the current content in the target segment. If the segment has already been
confirmed, the source content also overwrites the current content and the status of
the segment is changed to Draft.

• To copy all the content in the source segments to all the target segments, select
Copy Source to Target > Copy All Source to Target.

Note: When copying all the source content, the content is added only to empty
segments that have the Draft or the Not Translated status and that are not locked.

Source content copying for segments with revisions
Several changes are made to the information in target segments if you copy source content
to target segments that already contain revisions made with Track Changes.
In target segments, when copying source content:

• All the revisions (insertions and deletions) are accepted and the resulting text is displayed
as a deleted revision.

• The source content is copied as an inserted revision.

• The revisions made to the source content are accepted and displayed as plain text.

• The comments inserted in the source content are displayed as plain text.

• The deleted comments (from the source content) is not displayed at all.

Modifying source segments
If some of the source segments you are working on contain mistakes, you can modify them
and correct the mistakes.
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About this task
Modify source segments only after you get confirmation from your customer.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target area of the source segment that you want to modify.
3. On the Home tab, in the Segments group, select Other Actions > Edit Source.
4. Make the necessary changes in the source segment, and then select another target

row.

Results

Your changes are saved automatically.

Copying content in target segments
If copying content to and from source segments is disabled, you can still copy external
content to target segments.

Splitting segments
If the initial segmentation of a file contains source segments that are too long (perhaps as a
result of improper formatting in the source text) and that should be split, you can correct
the segmentation and split the segments.

Before you begin
The project which the file belongs to must have the Allow editing of source text in
segments setting enabled.

About this task
Changing the initial segmentation of a file may affect the matches delivered by a translation
memory, because the segmentation in the translation memory might become different
from the one in the file. You can revert to the initial segmentation of a split segment by
merging it.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target area of the segment that you want to split.
3. On the Home tab, in the Segments group, select Other Actions > Edit Source.
4. In the source segment, click in front of the word that should start the next segment.
5. Select Other Actions > Split Segment.
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Results

The segment is split. If the segment already has a translation, that translation is now placed
in the first split segment.

Merging segments
If the initial segmentation of a file contains source segments that were split unnaturally
(perhaps as a result of improper formatting in the source text) and that should be merged,
you can correct the segmentation and merge the segments.

Before you begin
The project which the file belongs to must have the Allow editing of source text in
segments setting enabled.

About this task
You can only merge consecutive segments that are part of the same paragraph.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target area of the segment that you want to merge.
3. On the Home tab, in the Segments group, select Other Actions > Edit Source.
4. Click inside the first source segment you want merged with a consecutive segment.
5. On the Home tab, in the Segments group, select Other Actions > Merge Segments.

Results

The two segments are merged, along with their translations (if available).

Formatting segments
When working with segments, you can perform multiple actions to make sure that the
formatting in your target text is consistent with the one in the source text.

These actions include:

• Viewing white spaces in both the source and the target text

• Viewing formatting tags in both the source and the target text

• Copying formatting from the source text to the target text

• Copying tag pairs

• Changing the capitalization of a selected fragment

• Clearing the formatting of a selected fragment or of the entire target text
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Viewing white spaces and other non-printing characters
Viewing white spaces is particularly useful if you want to remove unnecessary non-printing
characters from your text.

Procedure
1. Open the appropriate file in Online Editor.
2. On the Home tab, in the Formatting group, select Show Whitespaces.

Viewing formatting tags
By viewing formatting tags, you can see information about how source segments are
formatted. This is also useful if you want to copy tag pairs from the source segment to the
target segment.

Procedure
1. Open the appropriate file in Online Editor.
2. On the View tab, in the Tags group, select Show Formatting Tags.

Options for displaying tags
In Online Editor, you can choose between multiple ways of having tags displayed.
The following options are available on the View tab, in the Tags group, in the Show Tag
Details list:

• No Tag Text – If you choose this option, no text is displayed within tags. To see the
entire content of a tag, place the cursor over it.

• Partial Tag Text – If you choose this option, text is displayed only partially within tags.
To see the entire content of a tag, place the cursor over it.

• Full Tag Text – If you choose this option, all the available content is displayed within
tags.

• Tag Id – If you choose this option, only IDs are displayed within tags. Tag IDs are unique
identifiers assigned automatically to each tag pair and placeholder tag in the asset. To
see the entire content of a tag, place the cursor over it.

Copying formatting from the source text to the target text
If you prefer to format segments only after you have translated them, you can do so more
quickly by copying formatting from the source text directly to fragments of the target text.
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Procedure
1. Open the appropriate file in Online Editor.
2. In a target segment of your choice, select the text to which you want to copy source

formatting.
3. On the Home tab, in the Formatting group, select Apply Formatting.
4. In the source text, select the formatting you want to apply to the selected target text.

Copying tag pairs
If you prefer to format target segments before you translate them, copying tag pairs from
the source text to the target text helps you to be more efficient.

Procedure
1. Open the appropriate file in Online Editor.
2. In a target segment of your choice, click the place where you want to copy a tag pair.
3. Select Ctrl+Comma, and then, in the list, select the tag pair that you want to add.

What to do next
Write the appropriate content inside the newly copied tag pair.

Clearing segment formatting
You can remove the formatting from an entire target segment or only from a part of it if
that target segment no longer needs to contain the same formatting tags as its
corresponding source segment.

Procedure
1. Open the appropriate file in Online Editor.
2. Do one of the following:

• To clear the formatting of a certain part of a target segment, select the part whose
formatting you want to clear, and then, on the Home tab, in the Formatting group,
select Clear Formatting > Clear Formatting.

• To clear all the formatting of an entire target segment, select the segment whose
formatting you want to clear, and then, on the Home tab, in the Formatting group,
select Clear Formatting > Clear All Formatting.

Inserting symbols and special characters
If your translation needs to contain symbols and special characters, you can insert them
directly from the Online Editor user interface. These include em dashes (—), en dashes (–),
copyright (©) and trademark (™) symbols, as well as various types of quotation marks.
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Procedure
1. Open the appropriate file in Online Editor.
2. In the target segment, click the place where you want to add a symbol or a special

character.
3. On the Home tab, in the Insert characters group, select the symbol or the special

character that you want to add. Select Insert Symbols to access even more symbols.

Overwriting content in segments
If you copy the content of source segments to target segments, you do not need to delete
all the copied content when you start translating; you can simply overwrite it.

Enable Overwrite mode
To turn on content overwriting, click the segment whose content you want to overwrite and
press Insert.

What does Overwrite mode do?

• Overwrite writes over existing text when you start typing.

• Overwrite inserts revisions if Track Changes is enabled.

What doesn't Overwrite do?

• Overwrite does not affect locked content.

• Overwrite does not affect revision content if Track Changes is disabled.

Clearing the content of target segments
You can remove the entire content of a target segment, regardless of whether it contains
revisions or not, and then start translating again from scratch.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target segment whose content you want to clear.
3. On the Home tab, in the Segments group, do one of the following:

• To clear the content of that particular segment, select Clear Target > Clear Target
or Alt+Delete.

• To clear the content of all the segments having the Draft status, select Clear Target
> Clear Draft Segments or Alt+Shift+Delete.

The TU status changes to Not Translated.
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Working with translation memories and
terminology
Keeping previously translated content in translation memories and enforcing terminology
are best practices for reusing content and reducing translation costs.

Performing concordance searches in the translation memory
When you perform a concordance search, you search through a translation memory (TM) for
words or fragments within translation units (TUs).

About this task

Procedure
1. Open the appropriate file in Online Editor.

If you have the required permissions, the Lookups panel is displayed on the right
side of the screen.

2. Select the target area of the segment for which you want to find translations and press
F3.

The translations available for that segment are displayed in the Lookups panel, along
with their corresponding scores.

Tip: In the lower part of each entry, you can view details such as the date and time
when they were added to the translation memory.

3. In the search box, enter a word, and select whether you want to search for it in the
source text or in the target text. Press Enter.

Note: To get the best results, make sure that you enter the entire word that you want
to search for, not just a part of it. For example, enter office instead of offic.

You can also clear your search history by selecting Clear search in the list:

5 Working with Online Editor

134 Translating and Reviewing Documents



Results
The results are displayed in the Lookups panel.

Viewing differences between translation memory matches
In Online Editor, you can use the Alternative view to see the differences between source
segments and their fuzzy matches from the translation memory. These differences have to
do with words or characters that are either included in source segments, but missing from
their matches or vice versa.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target row of the segment for which you want to view differences between

matches.
3. On the View tab, in the Lookups group, select Alternative view.

Results
The differences between the source segment and its matches in the translation memory are
highlighted in the Lookups pane.

Consulting details for translation memory lookups
You can consult the details of a translation memory (TM) lookup in the Lookups panel: the
content, the match percentage, the TM it is part of, the fields, the person who added the
translation unit (TU) and the time it was added.

Procedure
1. Open the appropriate file in Online Editor.
2. Select a segment.
3. In the Lookups panel, consult the available matches. Each match (TU) consists of:

• the actual text

• the match percentage

• the TM it is part of

• the fields

• the person who added the TU

• the time the TU was added

Blurring or hiding unfiltered translations
If you start translating a segment and you want to see whether there are translations in the
translation memory that start with the text you entered, you can do so by blurring or hiding
the translations that do not match that text.
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Procedure
1. Open the appropriate file in Online Editor.
2. Enter some text in the target segment of your choice.
3. While searching for translation memory matches, on the View tab, in the Lookups

group, do one of the following:

• To blur the translations that do not start with that text, select Filter Lookups > Blur
mismatches.

• To hide the translations that do not start with that text, select Filter Lookups >
Hide mismatches.

• To see all the available translations for that segment, select Filter Lookups > Show
All.

Applying translations
You can apply the results retrieved from the TMs (translation memories) included in your
project to the target segment. Context matches, 100% matches, and fuzzy matches are
applied automatically to target segments when you select these target segments.

About this task
The TM, terminology, and MT (if applicable) results are available in the Lookups panel.

If your TM contains multiple translations for the same segment, you can choose which one
to apply.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target segment to which you want to apply an existing translation. The

available translations are automatically displayed in the Lookups panel.
3. Do one of the following:

• Select the segment you want to edit. From the Lookups panel, double-click the
translation you want to apply or press Ctrl+Shift+A. Note that fragment matches are
highlighted in yellow.

Tip: Suggestions can include full matches, fragment matches or terms. Fragment
matches are marked with a vertical yellow line, while terms are marked with a vertical
red line.

Tip: Alternatively, you can press Ctrl+<digit>, where <digit> represents the order of
that particular translation in the Lookups panel. For example, press Ctrl+1 to apply
the first translation from the Lookups panel or Ctrl+9 to apply the ninth one.

• Edit the target segment. When AutoSuggest detects already translated content, a
box is displayed below the segment you are editing. Use the key arrows to navigate
the suggestions. Choose a suggestion and either press Enter or double-click it.
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Results
The translation is applied to the target segment. Until you confirm it, the target segment
has the Draft status.

Applying terminology
You can apply the existing terminology to translate segments in the current file consistently.

About this task
The TM, terminology, and MT (if applicable) results are available in the Lookups panel.

If your terminology includes fields, you can check them in the Lookups panel, below the
actual term.

Procedure
1. Open the appropriate file in Online Editor.

In the workspace, recognized terms are marked with a red line above their
corresponding words. Also, if you have the required permissions, the Lookups ( )
panel is displayed on the right side of the screen.

2. Select a term and check its translated versions in the Lookups panel, under Terms. At
this point, you can:

• Select the icon next to a term to open that term in the terminology editor. Thus,
you can edit the term and make changes to the termbase directly from Online Editor.

• Apply the most suitable entry by double-clicking it in the Lookups pane.

Tip: When AutoSuggest detects existing terminology, a box is displayed below the
segment you are editing. Use the key arrows to navigate the suggestions. Choose a
suggestion and either press Enter or double-click it.

Note: Terms marked as Forbidden are not available as part of smart actions. Forbidden
terms can only be consulted in the Lookups pane for reference purposes.

Results
The terminology is applied to the target segment. Until you confirm it, the target segment
has the Draft status.

Using smart actions
Smart actions are actions designed to boost your productivity while updating target segment
in Online Editor. These actions include adding terms to a termbase and inserting tags,
placeables, terms, or fragment matches.
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About this task
Placeables are elements which can be copied from the source segment to the target segment
exactly as they are – for example, a phone number or the year in which a book was written.
Insert tags and placeables directly from the source text to make sure they are rendered
correctly in the final translation.

Fragment matches are parts of previously translated segments that are analyzed and
suggested as possible translations in certain parts of the target text.

Procedure
1. Open the appropriate file in Online Editor.
2. Select a target segment.

If its corresponding source segment contains any tags, placeables, terms, or fragment
matches, their corresponding symbols are displayed.

3. Do one of the following:

• To add a term to a termbase, select the term that you want to add, and then select
Add term . In the quick add dialog box, choose the termbase where you want to
add the term and whether or not you want to create the term based on an existing
entry template. Then, select the rectangle next to the other language and select
the equivalent of the term in the other language. Finally, select Add term to add the
term directly or Add and edit term to edit fields related to that term after adding
it to the termbase.

Note: If the term you are trying to add already exists in the termbase, you have
the following options:

• To create a duplicate entry, select Edit Term, and then select Create duplicate
entry > Finish.

• To merge it with an existing entry, select Edit Term, and then select Merge
with existing entry. Choose the entry you want to merge it with. On the preview
screen, consult the details of the merged entry and remove any attributes or
attribute values that you do not want to be a part of the merged entry. When
finished, select Finish.

• To stop adding it, select Cancel. Termbase entries added from Online Editor
automatically receive the Draft system status in Trados Enterprise.

• To insert a tag into the target segment, select Insert Tag , and then select the
appropriate tag or tag pair.

5 Working with Online Editor

138 Translating and Reviewing Documents



Tip: Tags and tag pairs are displayed in the order of their relevance based on your
position within the source segment. For example, if a term in the target segment is
written in bold and you select its correspondent in the source segment, the bold tag
pair will be displayed first. Also, tags and tag pairs which have already been used
are displayed last; however, you can select them again if necessary.

Also, you can move tags around in the target segment by using drag-and-drop.

• To insert a placeable into the target segment, select Insert Placeables , and
then select the appropriate placeable.

Note: Terms marked as Forbidden are not available as part of smart actions.
Forbidden terms can only be consulted in the Lookups pane for reference purposes.

In the source segment, placeables are underlined in blue.

• To insert a term into the target segment, select Terms , and then select the
appropriate term.
In the source segment, terms have a red line above them.

• To insert a fragment match into the target segment, select Fragment Matches ,
and then select the appropriate match.

You can bring up the smart action menu at any time by selecting Ctrl + Comma.

Interpreting translation unit matches and penalties
When you perform translation memory (TM) lookups, the resulting translation units (TUs)
are displayed in the Lookups panel together with details such as: match percentage, fields,
the person who added the TU to the TM, the date when the TU was added. The match
percentage is influenced by the penalty values specified in the main application using Online
Editor.

About this task
Match percentages reflect the translation origin of the TU. Matches can have one of the
following values:

• 100% Match - This target segment has been changed by applying a TU, with 100%
match, from a TM.

• Context Match - This target segment has been changed by applying a TU, with context
match, from a TM (the preceding source and target segments are identical).

• Fuzzy Match - This target segment was translated by applying a TM match ranging
from 1%-99%, and then by editing and confirming the translation. The match is below
100% because one or more penalties were applied.
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Procedure
1. Open the appropriate file in Online Editor.
2. Select the target segment to which you want to apply an existing translation. The

available translations are automatically displayed in the Lookups panel.
3. Check the TU details: fields, the person who added the TU to the TM, the date when the

TU was added.
4. Check the TU match percentage and the applied penalties:

• Missing formatting

• Different formatting

• Multiple translations

• Auto-localization

• Text replacement

• Alignment

• Character-width difference

Updating existing translation units
While translating, you may find that some translation units (TUs) in your translation memory
(TM) contain mistakes. In such cases, you can update the existing TUs in the TM.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target segment whose translation you want to update.
3. Search for TUs and apply the appropriate translation.
4. Make the necessary changes directly in the target segment.
5. Confirm the translation.

Results
The TU is updated in the TM. These updates are also reflected in the Lookups panel.

Adding translation units
If you confirm a segment, you can add it as a new translation unit (TU) in your TM.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target segment and edit it.
3. Select Confirm > Add as new Translation Unit or press Ctrl+Shift+U.

5 Working with Online Editor

140 Translating and Reviewing Documents



Results
The translation unit is updated in the translation memory. These updates are also reflected
in the Lookups panel.

Changing segment statuses
You can change the status of a segment if you want to mark a confirmed segment as Draft
or if you want to approve, reject, or sign off translated segments during the review process.

About this task
The available translation statuses are: Not Translated, Draft, Translated, Translation
Rejected, Translation Approved, Sign-off Rejected, Signed Off. The translation status is
indicated by the icon displayed in the Segment Status column. When changing the segment
status, a new translation origin is created.

The segment statuses do not change in Online Editor in several situations:

• The segment status does not change when you merge segments in Online Editor. The
status of the new segment keeps the status of the first segment.

• The segment status does not change when you accept revisions in Online Editor.

• The segment status does not change when you reject revisions in Online Editor.

• The segment status does not change when you add comments to segments in Online
Editor.

• The segment status does not change when you update the comments made on
segments in Online Editor.

• The segment status does not change when you delete the comments made on segments
in Online Editor.

• The segment status does not change when you lock or unlock segments in Online
Editor.

• When you clear a target segment, the system automatically marks the segment as
having Draft status.

Procedure
1. Open the appropriate file in Online Editor.
2. Select the target segment whose status you want to change.
3. On the Home tab, in the Segments group, select Change Segment Status, and then

select a new status for the target segment.

Reviewing translated content
You can review translations in Online Editor by managing comments, tracking changes, and
using other advanced options.

Reviewing content increases the quality of your translated content.
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Revision modes
Whether you are reviewing a translation or integrating reviews in your translation, there are
multiple ways in which you can view the revisions made with tracked changes.

Revision modes are especially useful for previewing purposes and have no impact on the
actual content of the revisions. For example, if you choose a revision mode that displays
changes as accepted, this does not mean that the changes are accepted in the target
document, only that they are displayed as such.

You can choose between the following revision modes:

• Original: The file is displayed in the workspace with all the revisions rejected.

• Final: The file is displayed in the workspace with all the revisions accepted.

• All Markup: All the revisions are displayed in the workspace. This mode is selected by
default when you enable change tracking.

To choose how revisions are displayed, on the Review tab, select Revision Mode, and then
select the mode of your choice.

Reviewing content with Track Changes
You can track all the changes you make to a text, which is useful especially when reviewing
translations.

About this task
Reviewing content increases the quality of your translated content.

Procedure
1. Open the appropriate file in Online Editor.
2. On the Review tab, in the Tracking group, select Track Changes.
3. Edit the segments. If you add something, the word Inserted is placed after the user

who made the change. If you delete something, the word Deleted is placed after the user
who made the change.

Results

All the changes you make from this point on are tracked.
You can view all of your changes by selecting the Revisions panel on the right side of the
screen. When the file you are working on contains revisions, a small dot is displayed on
the Revisions button.

Username for tracked changes

If you are logged into cloud, this username is taken from your cloud account name. The
cloud account name is generated from the First Name and the Last Name information
available on your cloud user profile.

If you are not logged into cloud, Trados Studio uses your Windows username instead. You
first set this ID after installing Trados Studio and you can change it at any time from File >
Setup > Users.
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Moving from one revision to another
When you receive a reviewed translation, you can move from one revision to another to
make sure that you cover all the revisions before submitting the final translation.

Procedure
1. Open the appropriate file in Online Editor.
2. On the Review tab, do one of the following:

• To filter through the available revisions, choose one of the available options: All
Revisions, Source Revisions, Target Revisions, Current Segment Revisions.

• To move to the next segment containing revisions, select Next. If you applied a
filter, you can navigate only through the filtered content.

• To move to the previous segment containing revisions, select Previous. If you applied
a filter, you can navigate only through the filtered content.

Tip: If you select Next and Previous without any segments being displayed, it means
that the file you are working on no longer contains revisions. If your asset still contains
revisions, a small dot is displayed next to the Revisions Panel button on the right side of
the screen:

Accepting revisions
After you receive a reviewed file, you can directly accept the revisions you agree with.

Procedure
1. Open the appropriate file in Online Editor.
2. Find the revision that you want to accept and select it.
3. On the Review tab, in the Tracking group, select Accept.
4. Optional: To accept all the revisions at once, on the right side of the screen, select the

Revisions panel, and then select Accept All.

Modifying revisions
You can modify your revisions if they are no longer relevant. To modify other users' revisions,
you must enable Track Changes first.
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Procedure
1. Open the appropriate file in Online Editor.
2. Select the Revisions panel.
3. Find the revision that you want to modify.

• If it is your revision (edited in the current session), edit it.

• If it is a revision added by another user, go to the Review tab, select Track Changes
to enable it, and then edit the revision. In the Revisions panel, check each revision.
If you add something, the word Inserted is placed after the user who made the
change. If you delete something, the word Deleted is placed after the user who
made the change.

Rejecting revisions
After you receive a reviewed file, you can directly reject the revisions you do not agree with.

Procedure
1. Open the appropriate file in Online Editor.
2. Find the revision that you want to reject and select it.
3. On the Review tab, in the Tracking group, select Reject.
4. Optional: To reject all the revisions at once, on the right side of the screen, select the

Revisions panel, and then select Reject All.

Revision color markup
When multiple users review files collaboratively, the system automatically assigns a color to
individual users, so that they can differentiate their comments from the ones introduced
by other users.

When users open a file, the system randomly assigns colors to individual users. All revisions
made by the same user are marked with the same color.

Working with comments
Comments enable you to offer more context for the changes or revisions you apply to target
segments.

Viewing comments
You can view the comments added by all users to a specific file, segment, or selection. When
you open a file, segments or selections that have comments are highlighted in yellow.
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Procedure
1. Open the appropriate file in Online Editor.
2. On the right side of the screen, select Comments .

Results
All the comments are displayed for that file. You can view the specific segment or selection
to which each comment applies by selecting the text of the comment. To further filter
comments, expand the Show All menu, and select the comments of interest according to
the available criteria: Current Segment, Segment, Selection, File.

Tip: When the file you are working on contains comments, a small dot is displayed on the
Comments button.

Also, segment-level comments are marked with an icon next to the segment number. For
example, in the following image, there is a segment-level comment on segment 22:

Adding comments
By adding comments, you can make suggestions to translators and reviewers and help
improve the overall quality of the translation. You can add comments only to target
segments.

Procedure
1. Open the appropriate file in Online Editor.
2. On the right side of the screen, select Comments .

The Comments panel is displayed.
3. In the Comments panel, in the text box, enter your comment.
4. Do one of the following:

Scope Action

Add a comment to the current selection,
to the current segment, or to the entire
file.

Select a fragment of text in the target
segment. You cannot add comments over
locked segments. If a segment contains a
combination of locked and non-locked
content, you can add comments over the
latter.
After you select a fragment of text, under
Applies to select one of the options:
Current Selection, Current Segment, or
File.

Add a comment to the current segment or
to the entire file.

Click anywhere inside a target segment
that has text in it, and under Applies to
select either Current Segment or File.
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Scope Action

Add a comment to the entire file. Click anywhere inside an empty target
segment, and under Applies to select File.

5. In the Severity list, select the severity level (or importance) of your comment:
Information, Warning, Error.

6. Select Add.

Results
If you added a comment to a selection or to a segment, that selection or segment is
highlighted. If you select a segment with comments, you can see all the users who added
comments for that segment.

Tip: When the file you are working on contains comments, a small dot is displayed on the
Comments button.

Also, segment-level comments are marked with an icon next to the segment number. For
example, in the following image, there is a segment-level comment on segment 22:

Modifying comments
You can modify previously added comments if you feel that they are not clear enough or if
you forgot to make an important point about something. You can also modify the severity
levels of comments.

Procedure
1. Open the appropriate file in Online Editor.
2. On the right side of the screen, select Comments .
3. In the Comments panel, find the comment that you want to modify.
4. Select the current text of the comment.
5. Make changes to the text or to the severity level of the comment.
6. Select an area outside the comment to save your changes.

Deleting comments
You can delete comments after their corresponding issues have been solved or if the
information in them is no longer relevant.
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Procedure
1. Open the appropriate file in Online Editor.
2. On the right side of the screen, select Comments .
3. In the Comments panel, find the comment that you want to delete.
4. Place your cursor on the comment, go to the end of the comment row, hover over ,

and then select Delete Comment.

Filtering segments
Filtering segments is particularly useful, for example, in making sure that there are no
untranslated segments left in a file.

Procedure
1. Open the appropriate file in Online Editor.
2. On the right side of the screen, select Filters .
3. In the Filters panel, select the Enable Filters checkbox.
4. Do one or more of the following:

• To filter segments according to their status, origin, or origin before adaptation, expand
the Segment Attributes node and select the appropriate attributes in the Status,
Origin, and Origin Before Adaptation lists.

Tip: The origin of a segment refers to the way in which it was populated—whether
by typing a translation manually, copying it from the source segment, or applying a
translation unit from a translation memory or from an automated translation server.
On the other hand, the origin before adaptation applies to segments which have
been changed multiple times and refers to the previous origin of the segment. For
example, if a segment was machine-translated initially, but you made a few
corrections later on, its current origin is Interactive (you performed the last change
by typing a translation manually) and its origin before adaptation is Automatic
Translation (the origin before the last change).

The distinction between origin and origin before adaptation is helpful because a
new translation origin is created when you change the segment status.

• To filter segments according to the changes suggested during the review phase,
expand the Review node and select the appropriate check boxes or provide the
relevant information:

• Segments with track changes

• Segments with verification messages

• Segments with comments

• Segments with TQA (quality assessments)

• Revisions mismatch - This filter displays segments that contain revision
mismatches between source and target. More specifically, the filter makes a
comparison between the deleted and inserted characters in a segment's source
and target. In order for these segments to be displayed in the list, there have
to be differences like: the source has two inserted characters and the target one
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inserted character, or the source contains a revision and the target does not.

• Revisions from - Specify a start date and an end date.

• Revisions added by - From the list, select the user who performed the revisions.

• To filter locked or unlocked segments, expand the Segment Locking node and
select the appropriate checkbox.

The filters are applied as soon as you select them and the number of segments that
match the filtering attributes is displayed at the top of the Filters pane, in a form such
as Filtered 16 of 184 segments. If the file you are working on contains segments with
comments, only the comments of the segments that match the filtering attributes are
displayed in the Comments pane. Similarly, if the file you are working on contains
segments with revisions, only the revisions of the segments that match the filtering
attributes are displayed in the Revisions pane.

Results
When you filter segments, a small dot is displayed on the Filters button. This is helpful
especially if you collapse the Filters panel, because it helps you remember that you are
working with a filtered list of segments, not with all the segments in the text.

Using Smart Review
Trados Copilot Smart Review (further referred to as Smart Review) provides an AI-based
translation quality review to guide linguists in their activity. Smart Review rates translated
segments on a scale of 0 to 100.

Before you begin

To work with the Smart Review feature, make sure you “setup an LLM model correctly in
Azure OpenAI”  on page 0. Smart Review is an optional functionality which must be enabled
on your account based on a contractual agreement.

About this task
You can use Smart Review to assess active segments automatically or manually.
To generate an assessment of your translation, Smart Review uses Azure OpenAI LLMs,
while at the same time considering, as point of reference, confirmed translations from the
current document or similar Translation Memory matches. If there are no confirmed
translations, Smart Review uses the LLM as initial point of reference, and gradually
improves, as translated segments are confirmed.
The assessment provided by Smart Review consists of:
1. A score and an explanation for the score

• Segments are marked Green if they score between 67-100.

• Segments are marked Amber if they score between 34-66.

• Segments are marked Red if they score between 0-33.
2. Translation suggestions
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Procedure
1. Open the appropriate file in Online Editor.
2. On the right side of the screen, select Smart Review ( ).

The Smart Review panel is displayed.
3. To have active segments evaluated automatically, keep Always evaluate active

segment toggled on. For each active segment, check the evaluation score and the
suggestions. Change the content and then select Evaluate again until you are satisfied
with the result of your translation.

4. To have active segments evaluated manually, toggle off Always evaluate active
segment. Select a segment to make it the active segment, and then select Evaluate
segment. For each active segment, check the evaluation score and the suggestions.
Change the content and then select Evaluate again until you are satisfied with the result
of your translation. Do this for all segments of interest.

Undoing or redoing actions
You can undo or redo actions to make sure that the asset you submit does not contain any
errors.

Procedure
1. Open the appropriate file in Online Editor.
2. On the Home tab, in the History group, do one of the following:

• To undo your last action, select Undo.

• If you undid your last action and you decide to redo it, select Redo.

Note: Replace or Replace All operations cannot be undone.

Performing batch operations on
segments
You can perform several batch operations if you select multiple segments.

Procedure
1. Open the appropriate file in Online Editor.
2. Select multiple segments by pressing Ctrl+Click (on the segment number) or Shift+Click

(on the segment number).
3. Perform one of the allowed batch actions:
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No.Operation Enabled / Disabled

1. Clear formatting

2. Change case

3. Copy source to target

4. Clear target segment

5. Lock segment

6. Change segment status

7. Undo / Redo

8. Copy / Paste / Cut

9. Apply formatting

10.Insert symbols and special characters

11.Apply translation

12.Confirm translation (all options)

13.Copy all to target

14.Clear draft segments

15.Segment actions (various)
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No.Operation Enabled / Disabled

16.Quality Assessment options

17.Accept revision

18.Reject revision

19.Verify translations

Finding and replacing text
Search for words, strings, or expressions in source or target segments and replace existing
occurrences with up-to-date text.

Procedure
1. Open the appropriate file in Online Editor.
2. Do one of the following:

• On the Home tab, in the Navigation group, select Find.

• Select Show Find and Replace Panel .
The Navigation panel is displayed and the Find tab is selected by default.

3. In the Search box, enter the text you want to search for and select the appropriate
search options.
The available options are:

• In source – Search in the source segments of the file.

• In target – Search in the target segments of the file.

• Text in tags – Search for text within tags in the source segments, in the target
segments, or in both. For this option to work, select either one or both of the In
source and In target options.

• Match case – Search for text that has the exact letter case as the text you entered
in the Search box.

• Whole word – Search for an entire word.

• Regular expression – Search for regular expressions.
The search results are displayed automatically.

4. To replace the text you entered with a different text, select the Replace tab.

Note: Replace or Replace All operations cannot be undone.
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5. In the Replace with box, enter the text that will replace the existing text, and then do
one of the following:

• If you want to replace the text in one occurrence at a time, select the occurrence
where you want to replace the text, and then select Replace.

• If you want to replace the text in all occurrences at the same time, select Replace
All.

Tip: If you are in TQA mode and you want to replace all the occurrences of the same
text, a new dialog box is displayed when you select Replace All. Enter a comment and
select the appropriate category, subcategory, and severity before selecting Replace All
again.

When you view the translation quality assessments, the first occurrence of the replaced
text has the severity that you selected earlier. However, all other occurrences of the
replaced text will have the Repeated severity.

Configuring user settings in Online
Editor
Configure Online Editor settings related to font adaptation, auto-propagation, and lookups.

About this task
Auto-propagation is the process whereby the confirmed translation from one segment is
copied to other segments within the same file that have identical source content. By default,
when you confirm a segment that has the Not Translated or Draft status, its translation is
copied automatically to all the other segments with identical source content in the file you are
working on.

Procedure
1. Open the appropriate file in Online Editor.
2. On the View tab, under Settings, select Options.
3. To configure a minimum and a maximum font size for segments, expand the Font

Adaptation section, and then specify a minimum and a maximum value. Select the
Adapt font sizes checkbox for the settings to be applied immediately after saving.

Note: When you configure a minimum and a maximum font size, any segment whose
font size is smaller than the minimum value or larger than the maximum value will be
adapted to fit the values you configured. Segments whose font size falls in between the
minimum and the maximum values will not be affected.

4. To configure auto-propagation behavior, expand the Auto-propagation section, and
then do the following:
a. Select the Auto-propagate exact matches to confirmed segments checkbox if

you want previously confirmed translations to be updated whenever you confirm a
newer translation of a segment that has the same source content. If you clear this
checkbox, the newly confirmed translation will only be auto-propagated to
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same-source segments that have the Not Translated or Draft status; it will not be
auto-propagated to previously confirmed translations.

b. Select the Confirm segment after auto-propagating an exact match checkbox if
you want auto-propagated translations to also be confirmed automatically for all the
segments with an exact match.

c. To control where you would like auto-propagation to start, in the Start propagation
from list, select one of the available options: Start of document or Next segment.
Start of document means that auto-propagation will take place throughout the
entire file (same-source segments both before and after the confirmed segment).
On the other hand, Next segment means that auto-propagation will only affect
same-source segments after the confirmed segment; in this case, the segments
before the confirmed one will not be affected.

5. To configure lookup settings, expand the Lookups section, and then do the following:
a. Under Minimum match value, specify the minimum threshold for suggested

translation memory matches. The default value is 70%. Lowering the value under
70% can have a negative impact on translation memory performance.

b. Under Maximum number of hits, specify the maximum number of suggested
translation memory matches. The default value is 5.

6. When finished, select Save

Timeout interval in Online Editor
Online Editor times out after 30 minutes of inactivity.

Saving behaviour in Online Editor
Your edits are saved permanently as you progress through the file and there is no need to
save your changes explicitly.

Known issues in Online Editor
Consult the list of known issues and limitations.

• Opening a file for review with Track Changes on via Google Chrome results in Google
Chrome overriding the revision formatting performed in Online Editor. Consult this KB
article to learn how to troubleshoot this behavior.
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6

Switching environments



Switching to the Online Editor
About this task
Because your work is synced to the cloud, you can move seamlessly between Trados Studio
and the Online Editor.
To switch to the Online Editor, click Open in Online Editor in the Files view and continue
translating and reviewing the selected file from your browser.
If you make changes to the file in the Online Editor and then move back to Trados Studio,
Trados Studio detects the file updates you made in the cloud. Before opening the updated
project file, Trados Studio asks you whether you want to overwrite the existing local version
of the file with the latest file version available in the cloud. This ensures that projects are
in sync, wherever you work from.

Switching to Trados Studio
About this task
If you need to work offline, translate your cloud file in the Editor view and sync your offline
changes to the cloud as soon as you get back online.
To switch to Trados Studio for translating in the Editor view:

Procedure
1. Go back to the project tab and click Open in Studio.
2. Confirm that you want to switch application in the prompt that is displayed.
3. Once Trados Studio finishes preparing the file tasks, click Start work in the Notifications

panel to open the file in the Editor view.

Working offline in Trados Studio

If you need to work offline, translate your cloud file in the Editor view and sync your offline
changes to the cloud as soon as you get back online.

For information on translating in the Editor view, see the previous chapter “Translating the
sample file in the Editor view ”  on page 26.

Synchronizing changes and version
conflicts
The changes you make to cloud project files in Trados Studio are automatically synced to
the cloud when you save your file changes. In the Online Editor, changes are automatically
saves and synchronized to the cloud.

Trados Studio detects if a downloaded cloud file does not match the version stored in the
cloud. This can happen when you are trying to open a cloud file which is already available in
Trados Studio and contains unsaved changes. In this case, you are prompted to syncronize
your local changes to the cloud or replace the local version with the cloud version.
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How Studio displays cloud resources
inside Translation Engines
The offline and online way of working in Trados Studio is different when it comes to how
cloud linguistic resources are displayed in the UI. Note that the way cloud linguistic resources
are displayed in the Trados Studio UI does not impact the way lookups are retrieved.

Cloud translation packages manually uploaded to Studio always list the individual TMs and
termbases inside the translation engine. Conversely, projects opened from the cloud using
the Open in Studio option only show the name of the translation engine available for the
project. To check the termbases and translation memories inside a translation engine,
open your cloud account in a browser and check the resources attached to the translation
engine from the Resources tab.
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7

End of Quick Start Guide



Now you know how to translate and review documents in Trados Studio. For additional
information, see the Trados Studio 2024 Help . You can access this help system by selecting
Help tab > Help Topics in any view of inside Trados Studio.

7 End of Quick Start Guide
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Autofac
Version: 4.8.1

Vendor: Autofac

Copyright: Copyright © 2015 Autofac Contributors

License type: MIT

License details: “https://github.com/autofac/Autofac/blob/v4.8.1/LICENSE”  on page 0
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Version: 1.0.1

Vendor: Hari Pachuveetil
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License type: MIT
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Version: 4.4.0

Vendor: Jan Karger, Bastian Schmidt

Copyright: Copyright © 2015 - 2020 Jan Karger, Bastian Schmidt, James Willock

License type: MIT
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Crc32.NET
Version: 1.2.0

Vendor: force

Copyright:

License type:

License details: “https://github.com/force-net/Crc32.NET/blob/develop/LICENSE”  on
page 0

DocumentFormat.OpenXml
Version: 2.15.0

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/OfficeDev/Open-XML-SDK/blob/v2.15.0/LICENSE”  on
page 0

Flee
Version: 1.2.2

Vendor: Muhammet Parlak

Copyright: Copyright 2017 Muhammet Parlak

License type: L-GPL

License details: “https://github.com/mparlak/Flee”  on page 0

HtmlAgilityPack
Version: 1.11.16

Vendor: ZZZ Projects

Copyright: Copyright © ZZZ Projects Inc.

License type: MIT

License details: “https://github.com/zzzprojects/html-agility-pack/blob/v1.11.16/LICENSE”
 on page 0

Hunspellx86
Version: 1.7.2

Vendor: Crawler-Lib

Copyright: Copyright (C) 2002-2017 Németh László

License type: L-GPL

License details: “https://github.com/hunspell/hunspell/blob/v1.7.2/license.hunspell”  on
page 0
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ICSharpCode.Decompiler
Version: 7.1.0.6543

Vendor: Daniel Grunwald, Siegfried Pammer

Copyright: Copyright 2011-2021 AlphaSierraPapa

License type:

License details: “https://github.com/icsharpcode/ILSpy/blob/v7.1/doc/license.txt”  on
page 0

icu.net
Version: 2.9.0

Vendor: SIL International

Copyright: Copyright © 2007-2019 SIL International

License type: MIT

License details: “https://github.com/sillsdev/icu-dotnet/blob/v2.9.0/LICENSE”  on page 0

Icu4c.Win.Full.Lib
Version: 59.1.15

Vendor: SIL International

Copyright: Copyright (c) 2016-2017 SIL International

License type: ICU

License details: “https://github.com/unicode-org/icu/blob/release-59-1/icu4c/LICENSE” 
on page 0

log4net
Version: 2.0.16

Vendor: Cincura.net, Apache.Logging

Copyright: Copyright 2004-2017 The Apache Software Foundation

License type: Apache 2.0

License details: “https://github.com/apache/logging-log4net/blob/rel/2.0.14/LICENSE”  on
page 0

MahApps.Metro
Version: 2.4.10

Vendor: Jan Karger, Dennis Daume

Copyright: Copyright © 2021 .NET Foundation and Contributors. All rights reserved.

License type: MIT

License details: “https://github.com/MahApps/MahApps.Metro/blob/2.4.10/LICENSE”  on
page 0
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Markdig.Signed
Version: 0.31.0

Vendor: Alexandre Mutel

Copyright: Copyright (c) 2018-2019, Alexandre Mutel.All rights reserved.

License type: BSD-2-Clause

License details: “https://github.com/xoofx/markdig/blob/master/license.txt”  on page 0

MaterialDesignColors
Version: 3.0.0

Vendor: James Willock

Copyright: Copyright 2015 James Willock/Mulholland Software Ltd

License type: MIT

License details:
“https://github.com/MaterialDesignInXAML/MaterialDesignInXamlToolkit/blob/v4.3.0/LICENSE”
 on page 0

MaterialDesignThemes
Version: 5.0.0

Vendor: James Willock

Copyright: Copyright 2015 James Willock/Mulholland Software Ltd

License type: MIT

License details:
“https://github.com/MaterialDesignInXAML/MaterialDesignInXamlToolkit/blob/v4.3.0/LICENSE”
 on page 0

MaterialDesignThemes.MahApps
Version: 1.0.0

Vendor: James Willock

Copyright: Copyright 2015 James Willock/Mulholland Software Ltd

License type: MIT

License details:
“https://github.com/MaterialDesignInXAML/MaterialDesignInXamlToolkit/blob/master/LICENSE”
 on page 0

Microsoft.ApplicationInsights
Version: 2.22.0

Vendor: Microsoft

Copyright: Copyright (c) 2015 Microsoft

License type: MIT

License details:
“https://github.com/microsoft/ApplicationInsights-dotnet/blob/v2.2.0/LICENSE”  on page
0
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Microsoft.AspNet.WebApi.Client
Version: 6.0.0

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: Apache 2.0

License details:
“https://www.nuget.org/packages/Microsoft.AspNet.WebApi.Client/6.0.0/License”  on
page 0

Microsoft.AspNetCore.Connections.Abstractions
Version: 8.0.3

Vendor: Microsoft, aspnetcore

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0

Microsoft.AspNetCore.Http.Connections.Client
Version: 8.0.3

Vendor: Microsoft, aspnet

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0

Microsoft.AspNetCore.Http.Connections.Common
Version: 8.0.3

Vendor: Microsoft, aspnet

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0

Microsoft.AspNetCore.JsonPatch
Version: 8.0.3

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MS-PL

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0
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Microsoft.AspNetCore.SignalR.Client
Version: 8.0.3

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0

Microsoft.AspNetCore.SignalR.Client.Core
Version: 8.0.3

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0

Microsoft.AspNetCore.SignalR.Common
Version: 8.0.3

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0

Microsoft.AspNetCore.SignalR.Protocols.Json
Version: 8.0.3

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0

Microsoft.Bcl.AsyncInterfaces
Version: 8.0.0

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0
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Microsoft.Bcl.HashCode
Version: 1.1.1.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/main/LICENSE.TXT”  on page 0

Microsoft.Bcl.TimeProvider
Version: 8.0.1

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.1/LICENSE.TXT”  on page 0

Microsoft.CSharp
Version: 4.7.0

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT”  on page
0

Microsoft.Extensions.Configuration
Version: 8.0.0

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT”  on page
0

Microsoft.Extensions.Configuration.Abstraction
Version: 8.0.0

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT”  on page
0
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Microsoft.Extensions.Configuration.Binder
Version: 8.0.0

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT”  on page
0

Microsoft.Extensions.DependencyInjection
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

Microsoft.Extensions.DependencyInjection.Abstractions
Version: 8.0.1

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.1/LICENSE.TXT”  on page 0

Microsoft.Extensions.DependencyModel
Version: 7.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/core/blob/v7.0.0/LICENSE.TXT”  on page 0

Microsoft.Extensions.Features
Version: 8.0.3

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/aspnetcore/blob/v8.0.3/LICENSE.txt”  on page
0

Microsoft.Extensions.Http
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.
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License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

Microsoft.Extensions.Logging
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

Microsoft.Extensions.Logging.Abstractions
Version: 8.0.1

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.1/LICENSE.TXT”  on page 0

Microsoft.Extensions.Options
Version: 8.0.2

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.2/LICENSE.TXT”  on page 0

Microsoft.Extensions.Primitives
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

Microsoft.Identity.Client
Version: 4.60.3

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details:
“https://github.com/AzureAD/microsoft-authentication-library-for-dotnet/blob/4.60.3/LICENSE”
 on page 0
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Microsoft.Identity.Client.Extensions.Msal
Version: 4.60.3

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details:
“https://github.com/AzureAD/microsoft-authentication-library-for-dotnet/blob/4.60.3/LICENSE”
 on page 0

Microsoft.Identity.Client.NativeInterop
Version: 0.16.0

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “”  on page 0

Microsoft.IdentityModel.Abstractions
Version: 7.4.1

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details:
“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/dev/LICENSE.txt”
 on page 0

Microsoft.IdentityModel.JsonWebTokens
Version: 7.4.1

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details:
“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/dev/LICENSE.txt”
 on page 0

Microsoft.IdentityModel.Logging
Version: 7.4.1

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details:
“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/dev/LICENSE.txt”
 on page 0
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Microsoft.IdentityModel.Tokens
Version: 7.4.1

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details:
“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/dev/LICENSE.txt”
 on page 0

Microsoft.Office.Interop.Outlook
Version: 15.0.4797.1004

Vendor: Camron Bute

Copyright:

License type:

License details: “”  on page 0

Microsoft.Office.Interop.Word
Version: 15.0.4797.1004

Vendor: Camron Bute

Copyright:

License type:

License details: “”  on page 0

Microsoft.Web.WebView2
Version: 1.0.2210.55

Vendor: Microsoft, webview

Copyright: © Microsoft Corporation. All rights reserved.

License type:

License details:
“https://www.nuget.org/packages/Microsoft.Web.WebView2/1.0.2210.55/License”  on
page 0

Microsoft.Xaml.Behaviors.Wpf
Version: 1.1.77

Vendor: Microsoft, xamlexperiencesteam

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/microsoft/XamlBehaviorsWpf/blob/v1.1.77/LICENSE” 
on page 0
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murmurhash-signed
Version: 1.0.2

Vendor: Darren Kopp

Copyright: Copyright © 2021 The Apache Software Foundation, Licensed under the Apache
License, Version 2.0.

License type: Apache 2.0

License details:
“https://github.com/darrenkopp/murmurhash-net/blob/master/LICENSE.md”  on page 0

NETStandard.Library
Version: 2.0.3.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/standard/blob/v2.0.3/LICENSE.TXT”  on page
0

Newtonsoft.Json
Version: 13.0.3

Vendor: James Newton-King

Copyright: Copyright (c) 2007 James Newton-King

License type: MIT

License details:
“https://raw.githubusercontent.com/JamesNK/Newtonsoft.Json/master/LICENSE.md”  on
page 0

Nlog
Version: 4.6.7

Vendor: Jarek Kowalski, Kim Christensen, Julian Verdurmen

Copyright: Copyright (c) 2004-2020 NLog Project - https://nlog-project.org/

License type: BSD-3-Clause

License details: “https://github.com/NLog/NLog/blob/v4.6.7/LICENSE.txt”  on page 0

Sdl.MultiSelectComboBox
Version: 1.0.77

Vendor: RWS

Copyright: Copyright © RWS

License type: Apache 2.0

License details: “https://github.com/RWS/Multiselect-ComboBox/blob/master/LICENSE” 
on page 0
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Sharpcompress
Version: 0.36.0

Vendor: Adam Hathcock

Copyright: Copyright (c) 2014 Adam Hathcock

License type: MIT

License details:
“https://github.com/adamhathcock/sharpcompress/blob/0.36.0/LICENSE.txt”  on page 0

SharpZipLib
Version: 1.4.1.0

Vendor: ICSharpCode

Copyright: Copyright © 2000-2018 SharpZipLib Contributors

License type: MIT

License details: “https://github.com/icsharpcode/SharpZipLib/blob/v1.4.1/LICENSE.txt” 
on page 0

SimpleInjector
Version: 5.4.4

Vendor: Simple Injector Contributors

Copyright: Simple Injector Contributors 2010 - 2020

License type: MIT

License details: “https://github.com/simpleinjector/SimpleInjector/blob/v5.4.4/LICENSE” 
on page 0

SmartThreadPool
Version: 2.3.0

Vendor: Ami Bar

Copyright: Copyright © Ami Bar

License type: MS-PL

License details: “https://github.com/amibar/SmartThreadPool/blob/v2.3.0/LICENSE”  on
page 0

System.Buffers
Version: 4.5.1

Vendor: Microsoft

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/corefx/blob/master/LICENSE.TXT”  on page 0
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System.Collections.Immutable
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.IdentityModel.Tokens.Jwt
Version: 7.4.1

Vendor: Microsoft, AzureAD

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details:
“https://github.com/AzureAD/azure-activedirectory-identitymodel-extensions-for-dotnet/blob/7.4.1/LICENSE.txt”
 on page 0

System.IO.Abstractions
Version: 4.2.17

Vendor: Tatham Oddie

Copyright: Copyright © Tatham Oddie 2010

License type: MIT

License details:
“https://github.com/System-IO-Abstractions/System.IO.Abstractions/blob/main/LICENSE”
 on page 0

System.IO.Pipelines
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Memory
Version: 4.5.5

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://dotnet.microsoft.com/en/dotnet_library_license.htm”  on page 0
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System.Net.Http
Version: 4.3.4

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://dotnet.microsoft.com/en-us/dotnet_library_license.htm”  on page
0

System.Numerics.Vectors
Version: 4.5.0

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://dotnet.microsoft.com/en/dotnet_library_license.htm”  on page 0

System.Reactive
Version: 6.0.0

Vendor: .NET Foundation and Contributors

Copyright: Copyright (c) .NET Foundation and Contributors.

License type: MIT

License details: “https://github.com/dotnet/reactive/blob/rxnet-v6.0.0/LICENSE”  on page
0

System.Reflection.Metadata
Version: 5.0.0

Vendor: Microsoft, dotnetframework

Copyright:

License type:

License details: “https://github.com/dotnet/runtime/blob/v5.0.0/LICENSE.TXT”  on page 0

System.Reflection.TypeExtensions
Version: 4.7.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/corefx/blob/master/LICENSE.TXT”  on page 0

System.Runtime.CompilerServices.Unsafe
Version: 6.0.0

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.
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License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT”  on page
0

System.Text.Encoding.CodePages
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Text.Encodings.Web
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Text.Json
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Threading.RateLimiting
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Threading.Channels
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0
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System.Threading.Tasks.Extensions
Version: 4.5.4

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/corefx/blob/master/LICENSE.TXT”  on page 0

YamlDotNet
Version: 8.1.0

Vendor: Antoine Aubry

Copyright: Copyright (c) 2008, 2009, 2010, 2011, 2012, 2013, 2014 Antoine Aubry and
contributors

License type: MIT

License details: “https://github.com/aaubry/YamlDotNet/blob/v8.1.0/LICENSE.txt”  on
page 0

ZstdSharp.Port
Version: 0.7.4

Vendor: oleg-st

Copyright: Copyright Oleg Stepanischev 2024

License type: MIT

License details: “https://github.com/oleg-st/ZstdSharp/blob/0.7.4/LICENSE”  on page 0
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