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About this Quick Start Guide



Who is this guide for and what does it cover?
This guide is for project managers and translators alike. It focuses on creating and
maintaining a translation memory both in Trados Studio and the cloud.

Note: For information about online workflows using Trados GroupShare, see to the videos
and information in the Trados Studio Help available at: Trados Studio Help .

How to use this guide

You can use the sample files to complete the exercises. Each exercise builds
on the last so if you are using the sample files you need to follow through the
instructions step-by-step.

This symbol indicates there are sample files available to complete the
exercise and their location. The paths specified are based on a Microsoft
Windows 10 or later operating system.

Note This symbol indicates that there is a tip providing additional information on
the task you are performing.

Keyboard
Shortcuts

This symbol indicates that there is an important piece of information you
need to know for the task you are performing. Any keys that you need to
press on your keyboard are displayed in the following font: Ctrl+Enter.

Other information sources
Here are some other sources of information you can access:

• Trados Studio Help 

• Trados GroupShare Help 

• Trados GroupShare Installation Guide 

• Trados Studio Migration Guide 

• Translating and Reviewing Documents Quick Start Guide 

• Project Management Quick Start Guide 

1 About this Quick Start Guide
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About Trados Studio



Trados Studio enables organizations to effectively manage all aspects of their translation
projects. Trados Studio incorporates project management and computer-aided translation
(CAT) tools for use by project managers, translators, editors, proofreaders and other
language professionals. These tools are provided through a highly customizable user
interface and it is easy to add on features from the RWS AppStore.

2 About Trados Studio
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Working with Translation
Memories locally



About the Translation Memories view
Translation memories are created and maintained in the Translation Memories view in Trados
Studio. Depending on your level of access, you can perform the following tasks in the
Translation Memories view:

• Create a translation memory

• Open a translation memory

• Migrate local translation memories to cloud 

• Migrate local termbases to cloud 

• Edit and delete translation units in the translation memory

• Assign custom field values to translation units

• Search and filter the translation memory data

• Import content from .SDLTM files into an existing translation memory

• Export content from a translation memory

• Create language resource templates

Additional functionality provided via add-on Trados
Compatibility and Migration Power Pack
Install the Trados Compatibility and Migration Power Pack app to add the infrastructure
required to work with the following legacy files in Trados Studio 2021 and later: S-tagger,
Bilingual Workbench, *.TMW, *.MDB, *.ITD, *.TTX, *.TMX.

The app also adds the Upgrade Migration Wizard to the Translation Memories view. This
wizard was available out-of-the box in Trados Studio 2019 and earlier, but has moved to this
dedicated app in order to declutter the Trados Studio user interface.

The powerful Upgrade Migration Wizard enables the following batch-oriented use cases:

• Combine multiple Trados Studio translation memories (TMs) into one

• Upgrade Translator's Workbench and SDLX TMs to Trados Studio translation memory
format: .TMW and .MDB format to .SDLTM

• Migrate TMs from TMX to Trados Studio format in batch mode

• Migrate file-based to server-based TMs in Trados GroupShare and vice versa

To add this app to Trados Studio 2021, go to the Add-Ins tab > RWS AppStore and search
for Trados Compatibility and Migration Power Pack in the RWS AppStore.

The import functionality is enabled for any Trados Studio license. However, the Upgrade
Migration Wizard is only enabled if you have an active Trados Studio subscription or a
perpetual license for the Professional, Freelance or Express edition.

3 Working with Translation Memories locally
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A first look at the Translation Memory view in
Trados Studio
The Translation Memories view contains the following components:

1. Ribbon tabs and groups containing maintenance tools.
2. Navigation pane, where you can see the file-based and server-based translation

memories that are currently open and navigate between them. You can also see
language resource templates.

3. Search Details window, where you create and apply filters to your translation memories.
4. TM side-by-side editor window, where you perform maintenance on your translation

memories.
5. Field Values window, where you view and edit field values for the selected translation

unit.

Creating and maintaining translation
memories
You can create both file-based (local) and server-based translation memories in the
Translation Memories view. Assume you want to create a file-based English-German
translation memory in this exercise.

Note: For detailed information on server-based translation memories, refer to the Trados
Studio Help and the Trados GroupShare Online Help .

3Working with Translation Memories locally
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Creating a file-based translation memory
To create your English-German file-based translation memory:

Procedure
1. Click Translation Memories in the views navigation pane to display the Translation

Memories view.
2. Press Alt+Shift+N or click New in the Tasks group on the Home tab. The New

Translation Memory wizard is displayed on the General page.

3. Complete the General page:

• In the Name box, enter the name, Sample EN-DE.

• Check and if necessary, select English (United States) and German (Germany).

• Click Next.
You can also base the new translation memory on an existing translation memory

by clicking the Browse button next to the Create From box. This can be useful
when you want to copy the setup form the other translation memory (for example,
custom fields and segmentation rules).
The Fields page is displayed. This page is used to create custom fields and values.
These allow you to further describe the translation units (TU) that are stored in your
translation memory

3 Working with Translation Memories locally

8 Translation Memory Management



4. Create a text field called Project. This will allow you to specify which project a translation
unit is associated with.

• Place your cursor in the Name column and type Project.

• Hover over the Type field and an arrow is displayed. Click the arrow to display the
drop-down list and select List. This allows you to specify more than one project to
which a translation unit can be associated.

You can also create Text, Text (Multiple), Date/Time, List (Multiple) and Number
fields.

5. Click Next.
The Language Resources page is displayed. This is where you can create or modify lists
of language resources. These lists are used in conjunction with the segmentation rules in
translation memory processing to identify and localize untranslatable content. The
default language resource settings are automatically applied.
The Settings section on the Language Resources page dictate how Trados Studio
identifies and localizes elements that do not change during translation.

3Working with Translation Memories locally
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• In the Recognize section, enable all the elements that Trados Studio identifies as
placeables (recognized tokens).

• In the Count as one if words section, set how the word count engine reports words
that are separated by hyphens, dashes, formatting tags or apostrophes for your
translation memory

• In source language of the table, specify the formats Trados Studio identifies as
placeables. For example, "15.2 in" may not be recognized as a measurement, but
a numbered followed by a word. In the target language of the table, specify the
formats that Trados Studio uses for auto-localizing placeables. For example, change
the default French localization of numbers from standard "x xxx,x" to custom
"x'xxx.x".

• Prioritize your own patterns so that Trados Studio can use them when generating
QuickPlace and Automatic Translation (AT) suggestions and when auto-substituting
values in TM matches.
You can display the QuickPlace drop-down list during translation, select placeables
from the current source segment and insert them into the target translation. This
list is called QuickPlace because it allows you to quickly place elements from the
source segment such as the formatting, acronyms, numbers, dates and other types
of placeables into the target.
Assume that you want all acronyms to be spelled out in the translation rather than
transferred using QuickPlace. In this case you would clear the check box next to
Recognize acronyms so that they are not recognized as placeables during
translation.

6. Assume this translation memory will be used for translating the content of the RWS

3 Working with Translation Memories locally
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website into German. Since you do not want the company name to be translated, enter
RWS as a variable.
a. Double-click on Variable List for the source language. The Variables dialog is

displayed. The default variable list does not contain any values.
b. Double-click on the first line and type RWS.
c. Click the Add icon , then click OK to close the dialog.

Note: If you based your new translation memory on an existing translation memory,
the language resources in the selected translation memory are applied to the new
translation memory.

You can also select language resources templates that you created prior to creating
this translation memory. For more information on language resources, see the Trados
Studio Online Help .

7. Click Finish to create the translation memory. The Creating page is displayed.
8. When the status of the items on the Creating page changes to Completed, click Close

to save the newly created translation memory.

The translation memory is saved with an *.sdltm extension to the following default
location:
Documents\Studio 2024\Translation Memories

The translation memory is added to the navigation pane in the Translation Memories
folder.

Creating a translation memory from alignment
results
You can also create translation memories for importing the translation units generated
after aligning the source and target files of an existing translation.

For more information, see this chapter in the Trados Studio Online Help .

3Working with Translation Memories locally
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Editing translation memory settings
Assume you now want to edit the translation memory settings to create a field that specifies
whether the translation unit is used in publications that you print or in online publications.
You can edit the translation memory in the Translation Memory Settings dialog box.

About this task
Use the Sample EN-DE translation memory that you created in the last exercise.

Procedure
1. To edit translation memory settings, the translation memory must be closed in the TM

side-by-side editor. If your translation memory is still open for maintenance, click the X
in the top right corner of the TM side-by-side editor to close the current maintenance
session. The translation memory is closed in TM Side-by-side editor but remains on the
navigation pane.

2. Select the Sample EN-DE translation memory (the translation memory that you created
in the last exercise) in the navigation tree under Translation Memories and click
Settings in the Tasks group on the Home tab.
The Translation Memory Settings dialog is displayed.

3. Create a list field called Output Type:

• Select the Fields page.

• Place your cursor in the first empty field under the Name column and type Output
Type.

3 Working with Translation Memories locally
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• Hover over the Type field and an arrow is displayed. Click the arrow to display the
drop-down list and select List.

• Hover over the Values field and an arrow is displayed. Click the arrow to display the
box where you can add the two field values: Print and Online.

• Press Enter to apply the new settings.

Note: You can also specify settings on the following pages:

• [TM Name] - This is where you can view general details of the translation memory.

• Language Resources - This is where you can modify language resource lists in your
translation memory. These lists are used in conjunction with the segmentation
rules in translation memory processing to identify and localize untranslatable
content.

• Access Rights - This is where you can protect file-based translation memories by
defining passwords that are linked to translation memory maintenance or user
rights.

• Performance and Tuning - This is where you can use different tools to improve the
performance of server-based translation memory searches. This does not apply to
file-based translation memories.

• Fragment Alignment - This is where you can enable and set up upLIFT Fragment
Recall to leverage previously translated segment fragments into your translations..

3Working with Translation Memories locally
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Managing translation memory data
Translation memory data is managed in the Translation Memories view. All translation
memories that are currently available for editing appear in the navigation tree in the
Translation Memories view.

Maintenance options
Assume that you want to make the following changes to your translation memory to ensure
that when the translation memory is used during translation, the translator receives quality
matches.

…Documents\Studio 2024\Projects\Samples\SampleProject\TMs\English-German.
sdltm

• Search for source segments that contain incorrect spellings and correct them.

• Save changes to edited translation units.

• Create filters to find all translations added by a particular user so that you can review
the translations.

• Use batch editing to modify the spelling in more than one translation at the same time.

• Import translation units from previously translated bilingual documents so that you can
use them in future translations of updated content.

You can also perform additional maintenance on a translation memory, for example,
assigning or changing custom field values, exporting and importing filters, and exporting
translation memory data.

3 Working with Translation Memories locally
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Opening a translation memory
Assume you want to perform the maintenance options listed above on the sample translation
memory. To do this, open the translation memory for maintenance in the TM side-by-side
editor.

Procedure
1. In the Translation Memories view, click Open in the Tasks group on the Home tab.

The Open File-based Translation Memory dialog box is displayed.
2. Select the English-German.sdltm sample translation memory that is provided with

Trados Studio.

…Documents\Studio 2024\Projects\Samples\SampleProject\TMs\English-German.
sdltm

If the translation memory is already in the navigation tree, double-click the translation
memory or right-click the translation memory and select Open from the shortcut menu.
The translation memory is opened for editing in the TM side-by-side editor window
and becomes the active translation memory. When you select a row, any system and
custom field values that are assigned to that translation unit are displayed in the Field
Values window.

3Working with Translation Memories locally
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A closer look at the TM side-by-side editor
You can use the TM Side-by-Side Editor to display search results and edit translation units.

Columns

• The translation unit status column indicates the status of the translation unit. For
example, if it is marked for deletion or has been edited. This is also indicated by the
color in which the translation unit is highlighted.

• To the right of the target language segments is the document structure column. It
displays a code that tells you where the segment text appeared in the source document
from which it was extracted. For example, TC = table cell and H1 = header 1.

• The final column, custom field values, displays any field values assigned to the translation
unit. This column is only displayed if there are custom field values assigned to the
translation units.

Colors
This color indicates that the column is currently selected.

This color indicates that the translation unit has been modified and that changes to the
translation unit are pending and have not yet been committed (saved).

This color indicates that the translation unit is marked for deletion and that this deletion
has not yet been committed (saved).

3 Working with Translation Memories locally
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Searching, editing and saving changes in the
translation memory

…Documents\Studio 2024\Projects\Samples\SampleProject\TMs\English-German.
sdltm

Searching the translation memory
About this task
Assume that you just imported translation units into this translation memory that were
from an English (United Kingdom) - German (Germany) bilingual document. However, your
translation memory is an English (United States) - German (Germany) translation memory.

You want the imported source text in this translation memory to use United States spelling.
Search for the English spelling of organisation in the source text and change it to the United
States spelling organization.

Procedure
1. Search for organization:

• Enter organisation in the Source Text box in the Search Details window.

• Clear the Case sensitive check box.

• Click Perform Search.
One translation unit has been found containing organisation and is displayed in the
TM side-by-side editor.

3Working with Translation Memories locally
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Editing a translation unit
Now that you have located the United Kingdom spelling of the word organisation, change it
to the United States spelling organization.

Procedure
1. Click in the source segment and type or paste the United States spelling of Organization.

The color of the translation unit changes to dark yellow and the following icon is
displayed in the translation unit status column. The icon indicates that the translation
unit has pending changes that have not yet been saved.

You can also edit translation units in the following ways:

To Do the following

Mark a translation unit for
deletion,

Click

in the Save group on the Home tab.

Assign custom field values to
the translation unit,

Use the Field Values window.

Saving pending changes

3 Working with Translation Memories locally
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About this task
Once you have corrected the text in the translation unit, you next need to save your changes.

Procedure
1. Click the Commit Changes button in the Save group on the Home tab. The

translation unit is now saved with the new spelling.

Filters and batch editing
About this task

…Documents\Studio 2024\Projects\Samples\SampleProject\TMs\English-German.
sdltm

Batch editing translation units
In Carol-Ann's translations that were displayed when you applied the filter in the last section,
there are several words that use the old German spelling which contains the character ß.
Assume you want to change those translations to the new spelling ss. To do this, batch edit
a group of translations at the same time.

About this task

Note: There are some German spellings that still contain this character ß. Assume for the
purposes of this example though, that the new spelling applies to all Germans words
containing ß.

Procedure
1. Right-click on the English-German translation memory in the navigation tree and select

Batch Edit from the shortcut menu. The Batch Edit wizard is displayed on the Batch Edit
Script page.

2. Click Add and select Find and Replace Text from the drop-down list.

• Find what: ß (You can copy and paste this character into the box or press Alt +
0223 (on the numeric keypad)).

• Replace with: ss (Enter these as lowercase letters)

• If necessary, change the additional settings to match the dialog box below.

3Working with Translation Memories locally
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3. Click OK to add the edit action to the list in the Actions box.
4. Click Finish. The Applying batch edit script page is displayed.

3 Working with Translation Memories locally
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5. Click Close to close the wizard.

Note: Changes made by a batch edit are automatically committed and cannot be
canceled.

The words in translation unit 14 and translation unit 15 now have the new German
spelling.

3Working with Translation Memories locally
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Creating and applying a filter
As well as being able to search the source and target text, you can also use filters in
combination with the search feature or by themselves to find certain translation units. This
filters out the translation units that do not match the conditions of the filter. Assume you only
want to view all translations modified by Carol-Ann to ensure the translations are correct.

About this task

Note: If you still have search criteria in the Source Text box, delete it now.

Procedure
1. Select Add on the Filters group in the Ribbon to add a filter.
2. Enter the name of the filter, Carol, in the Filter Name box. The new name is automatically

displayed in the TM Filter box with an * asterisk next to it to indicate this filter is not
saved.

3. Select Add in the Search Details window to add a new condition to the filter and open
the Add Condition dialog.

4. Fill in the settings below and select OK to add the condition.

5. Select Save to save the filter. The filter is now saved with the translation memory.
6. Select Perform Search. The translation units that were last updated during translation

by Carol-Ann are displayed.

Importing data into a translation memory
Import translation units and their associated data into a translation memory. The translation
units are always imported but the associated data that is imported varies depending on
the file type from which it was extracted. Trados Studio offers out-of-the box support for
importing TM data in .TMX and SDLXLIFF in .SDLALIGN files. To import TM data from ITD, TTX
and BilingualWorkbench files, first install the Trados Legacy Compatibility Pack app.

3 Working with Translation Memories locally
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Import types supported out-of-the box
About this task
By default, Trados Studio supports importing TM data from the following file types, in
addition to TMX:

• SDL XLIFF Bilingual Documents (*.sdlxliff)

• Alignment Files (*.sdlalign)

Importing a sample bilingual file

Assume a customer has asked you to prepare a translation memory for a project. The project
is an update to previously translated documents. They do not have a translation memory
from the project, but they do have the bilingual translated files. Import the data into your
sample translation memory so that the content can be leveraged for translating the updated
documents.

Procedure
1. Open the Sample EN-DE.sdltm translation memory.

...Documents\Studio 2024\Translation Memories\Sample EN-DE.sdltm (This is the
sample translation memory you created in an earlier exercise.)

2. Right-click on the Sample EN-DE translation memory in the navigation tree and select
Import from the shortcut menu. The Import wizard is displayed on the Import Files page.

3. Click Add Files and select the SecondSample. doc.sdlxliff.

…Documents\Studio 2024\Projects\Samples\Sample Project\de-DE\SecondSample.
doc.sdlxliff
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4. Click Next. The Bilingual Document Import Options page is displayed.
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This page identifies the segments you want to import by their confirmation level (status).
The currently selected statuses indicate that the imported translations must have one
of these statuses.

• Translated - This translation has been confirmed as complete.

• Translation approved - The translation has been approved by the reviewer.

• Signed off - The translation has been signed off. This is another level of approval by
a reviewer.

5. Accept the defaults on this page and click Next.

The General Import Options page is displayed.
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6. Add a field value that indicates that the imported translation units are for the Road
Safety project. The value will be assigned to all imported translation units.

• Click Edit. The Field Values box is displayed. The Project field and Output Type
field that you created earlier are listed.

• Enter Road Safety in box next to Project in the Value column.
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• Click OK to close the Field Values dialog box and display again the General Import
Options page.

7. Click Finish. The Importing page is displayed.

This page displays each file being imported and indicates the status of each import.
When the import has finished, the items on this page are listed as Complete. The results
of the import indicate:

• Read 43: This indicates that 43 segments were read in the bilingual file during the
import.

• Imported 4: This indicates that out of the 43 translation units that were read, only
four of them were imported. This is because only four of the translations have a
status of Translated, Translation Approved or Signed off.

• Invalid 0: This indicates that there were no errors during the import.

Note: If you have modified the sample file that you imported, your results may be
different to these.

8. When the import is complete, the Close button becomes available. Click Close to close
the wizard.

The results of the import are displayed in the TM side-by-side editor. Even though four
translation units were imported, only three appear in the translation memory. This is
because two of the imported translation units had the exact same source text and
translation. Therefore, they were merged into one translation unit.
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Importing alignment result files (*.sdlalign)

.SDLALIGN files are alignment result files that contain translation units generated after
aligning the source with the target file of an existing translation.

When you import *.sdlalign data, you can tell Trados Studio to triage only the translation
units that meet a certain quality value threshold. You can also add custom field values to the
imported translation units and specify other TM import options.

Additional imports support via add-on app
About this task
Install the Trados Compatibility and Migration Power Pack from the RWS AppStore to
add support for importing the following additional types of files:

• Translation Memory Exchange Documents (*.tmx, *. tmz.gz)

• TRADOStag Documents (*.ttx)

• SDL Edit Documents (*.itd)

These are legacy file types created SDLX, Trados 2007 and Translator'sWorkbench. Starting
with the 2021 release, Trados Studio supports these file types only via the Trados Legacy
Compatibility Pack app.

To install the Trados Compatibility and Migration Power Pack:

Procedure
1. Open the Add-ins tab Trados Studio and select RWS AppStore.

This opens the RWS AppStore on the Installed Plug-ins page.
2. Type Trados Compatibility and Migration Power Pack in the search box and press

Enter.
3. Select the app and click the Download icon in the app description on the right-hand

side of the RWS AppStore page.
4. When Trados Studio finishes downloading the app, the following confirmation message

is displayed: Download complete. Restart Trados Studio to finish installing
the plug-ins. Click this confirmation message to go to your specified Downloads
location and run the app installer.

5. Double-click on the downloaded Trados Compatibility and Migration Power Pack app
and run the installer.
The following message is displayed when the app is successfully installed:

6. Restart Trados Studio after closing all active sessions.
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7. Go to the Translation Memories view check that the Upgrade Translation Memories
option has been added to the Tools group. You can now also start opening and importing
the following legacy file types:

• SDL Edit Documents (.ITD)

• TRADOStag Documents (.TTX)

• Translation Memory Exchange Documents (.TMX, .TMX.GZ)

• S-tagger

• Bilingual Workbench

• .TMW

• .MDB

Importing TM data from legacy files

.TMX files

The following data can be imported from a .TMX file after installing the Trados Compatibility
and Migration Power Pack:

• Translation units

• Custom fields and their values

• System fields

.TTX and .ITD files

The following data can be imported from legacy bilingual files:

• Translation units

• Context information (bilingual files contain a sequence of translation units that is used
for creating context matches in the translation memory based on this sequence)

Note: If you are importing data from SDL Trados 2007 and SDLX 2007, it is often better to
import bilingual files instead of TMX files so that you can import the information needed to
create context matches. For detailed information on how to upgrade your SDL Trados 2007
and SDLX 2007 translation memories, see the Trados Studio Migration Guide .
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4

Working with Translation
Memories in the cloud



This section guides you through the procedures of managing your translation memories
from a browser. It assumes all the scenarios from the previous chapter. To follow along with
the procedures you have to be logged in to your cloud account from a browser. Each
procedure assumes the starting point is the cloud Dashboard.

Migrate local Translation Memories to
cloud
This section describes how to migrate local TMs to cloud and convert them to cloud TMs to
use them in your translation engines. This allows you to share your TMs with your team in
cloud projects, for example. You can also merge multiple local TMs into cloud TMs during
the conversion wizard. This procedure covers the dedicated migration functionality in Studio.
You can also migrate/import data in the browser.

Before you begin

Before you begin, make sure that you are logged in to your cloud account from within
Studio.

About this task
To migrate your local TMs to cloud:

Procedure
1. In the Translation Memories view, click Migrate to Cloud > Migrate Local Translation

Memories to Cloud drop-down menu on the ribbon. This displays the conversion
wizard.

2. On the first page of the wizard, first add your desired local TMs to the conversion list.
You can either:

• Click Add File-based TMs to browse your local storage and choose a TM file.

• Click Add File-based TMs from Folder and select a folder containing multiple TM
files. This will add all of them to the conversion list

• Drag-and-drop your TM files to the list.

• Remove any of the added termbases by selecting them and clicking Remove Files.
3. Configure how the wizard will process the TMs you selected for conversion by choosing

one of the following options:

• Create a single cloud translation memory containing all file-based translation
memories - merges all the TMs in the conversion list into a single cloud TM.

• Create Create cloud translation memory for each language pair - creates cloud
TMs based on matching language pairs. This means that TMs that have the same
language pairs will get merged into a single cloud TM.

• Create cloud translation memory for each file-based translation memory -
creates a cloud TM for each local TM you added to the list.
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4. Click Next to proceed to the next page of the wizard and configure the following
properties and settings for your cloud TMs:

• If you want, you can edit the name of the resulting cloud TMs by clicking on the
icon next to their name.

• In the Location field, select the location in the cloud account where you want to
save your cloud TM. If you are logged in with an Administrator account, you can also
click New customer to create a new location in your cloud account.

• Choose a Field Template for each cloud TM. Field templates allow you to work
consistently across your TMs and create TMs that share the same fields faster. TM
fields hold descriptive data for each Translation Unit (TU) in a TM. You can also select
New Field Template to create a new one.

• Select Language Processing Rules for your cloud TMs. Language processing rules
contain information about the following elements in a TM: compounds treated as
one word, segmentation rules and placeables. If you don't have one, you can create
it by selecting New Language Processing Rule.
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5. Configure your Import Settings by clicking on the icon:

• Choose a Description and Copyright for your cloud TMs. Note that these fields are
optional and they will be populated with the description and copyright of the first
listed TM, if available.

• Check the box under Import if you want to import TUs as plain text.

• Choose how the wizard should process TUs if the target segments differ.
6. Click Save then Finish to complete the wizard.

Creating a translation memory in the
cloud
Create TMs to store your translated content and reuse it.

When you create TMs, you use the following component resources created beforehand:
language processing rules, field templates. For this example we will use the default resources
that are already available.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Click New Translation Memory
4. Enter the following details:

a. Enter a name for your TM.
b. (Optional) Enter a copyright.
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c. Select a location for your TM.
d. (Optional) Enter a description detailing the context where your TM is used or any

other relevant information.
5. Under Languages:

a. Select the source language column and choose a language from the list. Select the
target language column and choose a language from the list.

b. In the Language Processing Rules box, select the default language processing
rule.

c. In the Field Template box, select the default field template.

6. Click Create.

Deleting translation memories in the
cloud
You can delete TMs if they are not used in a project which is in progress.

1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the checkbox corresponding to the TM you want to delete.

4. Click Delete.
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Editing cloud translation memory
settings
You can edit TM settings any time, but be aware that the changes you make to an existing
TM affect both the current and the future projects which reference the TM.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the TM you want to change and click Edit.

4. In the [translation memory name] dialog, make the necessary changes in terms of
details, languages, language processing rule, field template.

5. To re-index the TM in terms of speed, click Re-Index. Click Re-Compute Statistics to
get an overview of the total number of TUs the TM contains, and consult whether the TUs
are aligned.

6. Click Save.
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Applying filters to find cloud
translation memories faster
If you configured several translation memories (TMs) and would like to quickly identify a
particular one, filter your TM list.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. On the left-hand side of the page, expand the Filter menu ( ) .

4. Apply one or all of the available filters: source language, target language, location.
When you expand the Location list, the folder structure of your account is displayed.
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Importing translation memory content
You can import TM content from other TMs. In some scenarios you might want to simply
save a local TM to cloud but for this example we will go through the importing process.

Before you begin

• Ensure that the TM content you want to import is stored in *.tmx, *.sdltm, *.zip, *.tmx.gz,
*.sdlxliff format.

• Ensure that the *.zip consists only of *.tmx files.

• Ensure that each file you import has a maximum size of 1 GB, if you upload individual
files. If you upload a *.zip archive, the individual files inside the archive can exceed 1 GB,
but the *.zip archive must not exceed 1 GB.

About this task
Usage:
You can import TM content in a TM even if the TM is currently in use in a started project.
Process:
TMs are applied on the source files of projects automatically during the Preprocessingstage
of a workflow, and more specifically during the Translation Memory Matching task. If the
project is started and you imported content in a TM which that project uses:

• The newly updated TM is applied on the source files if the project has not reached the
Translation Memory Matching task yet.

• The newly updated TM is not applied on the source files if the project has already moved
beyond the Translation Memory Matching task. However, the newly imported content
will be returned during lookup or concordance search.

Restrictions:
Importing a *.tmx file into a cloud TM - The *.tmx is imported correctly if it has the same
source-target languages as the destination TM. If there are source-target language
mismatches, the import completes, but the mismatched language pairs are not imported.
This, however does not apply to language families. For example, if you are importing a TMX
that has en-GB into a TM that has en-US, the import will succeed because it can recognize
language families.
Importing an *.sdlxliff file or an *.sdltm file into a cloud TM - The *.sdlxliff and the *.sdltm
files are imported correctly only if they have the same source-target languages as the TM.

Procedure
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to import content to.
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4. Click Import.
5. On the Import into [TM name] page:
6. Under General Options:

a. Click Browse to upload the files you want to import.
b. In the Language Direction box, check that the language pair is correct.
c. Under Options, select or clear the check boxes: Import translation units as plain

text, Export invalid translation units, Recompute fuzzy index statistics.
d. Under If target segments differ, select one of the available options: Add new

translation units, Overwrite existing translation units, Leave existing
translation units unchanged, Keep most recent translation units.

7. Under Advanced Options:
a. If you import content from a *.TMX file, decide how you want unknown fields to be

handled. From the Unknown Fields box, choose an option: Add to translation
memory, Ignore, Skip translation unit,Fail translation unit import.

b. If you import content from an *.XLIFF file, decide which units will be imported based
on their status: Translated, Translation approved, Signed-off, Draft, Translation
rejected, Sign-off rejected.

8. Click Finish.
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Exporting translation memory content
When you export your TM content, you download it as an*.TMX.GZ which you can store locally
or re-import into another TM later on.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the checkbox corresponding to the TM you want to delete.
4. Select Export > Translation Memory > [language pair].

5. Check the progress of your TM download in the upper right-hand corner of the page
and select the Click here to download link when prompted.

6. Save the*.TMX.GZ file.

Tip: Depending on the browser you are using, the file is saved in a location specified by you
or it is automatically saved in the Downloads folder.

Maintaining translation memory
content
You can search and edit translation units (TUs) in the TM Maintenance Editor. You can edit
TUs at any time except during TM import. The editor is shaped after the Studio editor to
facilitate easy editing of TMs.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair fir which you want to

perform maintenance operations.
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5. In the TM Maintenance Editor, you can perform any of the following:

• Check the TM details on the banner: the TM name (and its language directions if
you hover over the TM name), and the TM location, creation date, and reindex date
(if you hover over the information icon)

• Specify a theme - Go to the View tab and choose one of the options: Light (default),
Warm, Dark.

• Navigate the content - Select a TU, go to the Home tab, and use the Next and
Previous options.

• Overwrite TU content - Press the Insert key and enter your new content.

• Manage tag pairs - To insert a tag from the source TU to the target TU, hold the Ctrl
key and then select the source tag.

• Edit TU - Select a TU and:

• Insert characters or symbols - Go to the Home tab, and use the options in the
Insert Characters group.

• Copy content

• Delete content

• Change display formatting - Go to the Home tab, and use the Show
Whitespaces and Change Case menus.

• Zoom in on content - Go to the View tab, and in the Fonts group select Enable
Text Zoom. Select Larger or Smaller.
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• Change TU status - Select a segment, go to the Home tab, expand the Status list
and select a value: Not Translated, Draft, Translated, Translation Approved,
Translation Rejected, Sign-off Rejected, Signed Off.

• View and edit TU fields.

• Delete TUs - Select a TU, go the Home tab, and select Delete.

• Undo or redo any operation.
6. When finished with all your changes, check your TUs for this symbol . These segments

were edited or their status was changed, but these segments are not confirmed yet. To
confirm a segment, select it and then select Confirm changes. If you do not select
Confirm changes, the segments are not updated in the TM with the latest changes.

7. Close the TM Maintenance Editor.
8. In the [translation memory name] dialog, select Save.

Shortcuts in TM Maintenance Editor
You can use several built-in shortcuts for more productivity when working with the TM
Maintenance Editor.

Command Windows Shortcut Mac Shortcut

Navigate to the previous
translation unit.

Ctrl+Up Arrow Command+Up Arrow

Navigate to the next translation
unit.

Ctrl+Down Arrow Command+Down
Arrow

Delete the next word. Ctrl+Delete Control+Fn+Backspace

Delete the previous word. Ctrl+Backspace Control+Backspace

Undo your last action. Ctrl+ Z Command+Z or
Control+Z

Redo your last action (if you
undid it).

Ctrl+Y Command+Y or
Control+Y

Change the casing of a selected
translation unit or text.

Shift+F3 Shift+Fn+F3

Select the entire content of the
current translation unit.

Ctrl+A Command+A or
Control+A

Reload the current translation
unit.

Ctrl+R Control+R

Clear all translation unit. Ctrl+Alt+Space Control+Option+Space

Move to first translation unit in
the translation memory.

Ctrl+Home Command+Fn+Left
Arrow

Move one page up. PageUp Command+Fn+Up
Arrow

Move one page down. PageDown Command+Fn+Down
Arrow
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Command Windows Shortcut Mac Shortcut

Move cursor to next word. Ctrl+Right Arrow Command+Right
Arrow

Move cursor to previous word. Ctrl+Left Arrow Command+Left Arrow

Select the word after the cursor,
including the whitespace after it.

Ctrl+Shift+Right Arrow Command+Shift+Right
Arrow

Select the word before the
cursor.

Ctrl+Shift+Left Arrow Command+Shift+Left
Arrow

Delete the previous character. Backspace Backspace

Delete the next character. Delete Fn+Backspace

Add a soft break to the current
translation unit.

Shift+Enter Shift+Enter

Add German quotation marks to
the current translation unit.

Ctrl+Shift+4 Control+Shift+4

Add English quotation marks to
the current translation unit.

Ctrl+Shift+5 Control+Shift+5

Add angular (French) quotation
marks («») to the current
translation unit.

Ctrl+Shift+6 Control+Shift+6

Add a non-breaking space to the
current translation unit.

Ctrl+Shift+Space Command+Shift+Space

Add the euro symbol (€) to the
current translation unit.

Ctrl+Shift+E Command+Shift+E

Add the copyright symbol (©) to
the current translation unit.

Ctrl+Shift+C Command+Shift+C

Add the registered symbol (®) to
the current translation unit.

Ctrl+Alt+R Control+Option+R

Add the trademark symbol (™) to
the current translation unit.

Ctrl+Alt+T Control+Option+T

Add an em dash (—) to the
current translation unit.

Ctrl+Alt+Minus Sign Control+Option+Minus
Sign

Add an en dash (–) to the current
translation unit.

Ctrl+Minus Sign Command+Minus Sign
or Control+Minus Sign

Add the pound symbol (£) to the
current translation unit.

Ctrl+Shift+P Command+P or
Control+P

Show the Home tab. Alt+H (Not available on Mac)

Show the View tab. Alt+V (Not available on Mac)
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Viewing translation unit count
You can check the number of total TUs in your TM. The count is updated automatically when
TUs are added or deleted. The language pair is displayed next to the TU count.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair for which you want to

perform maintenance operations.
5. Check the TU count in the lower left corner.

Navigating TM content
You can navigate TM content using the ribbon options, the arrow keys or the available
shortcuts.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair fir which you want to

perform maintenance operations.
5. In the TM Maintenance Editor, do one or more of the following:

• Select a segment, select the Home tab, and use the Next and Previous options.

• Select a segment and use the Up and Down arrows.

• Select a segment and use the shortcuts: Ctrl+Up arrow (for the previous segment),
Ctrl+Down arrow (for the next segment).

6. Close the TM Maintenance Editor.
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Searching for segments
You can search for TM segments or words in both the source and the target.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair for which you want to

perform maintenance operations.
5. From the right-hand side pane, select .
6. Toggle the filter on if not already so.
7. Expand the Basic menu.
8. Do one of the following:

• To search for segments or words in the source, type your text in the Source Text
field.

• To search for segments or words in the target, type your text in the Target Text
field.

• To search for segments or words via regular expressions, select the Use regular
expression check box. Then, enter your regular expression in the Source Text field,
the Target Text field, or both.

9. Click Apply.
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Editing segments
When you edit TM content, you can change segments and their content in various ways.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. If your TM is multilingual, expand the TM Maintenance menu and select the language

pair for which you want to perform maintenance operations.
5. In the TM Maintenance Editor, select a segment and edit it:

• Edit content- Select some source or target content and edit it.

• Copy content- Select some source text, copy it, and paste it the target or select
some target text, copy it, and paste it in the target.

• Delete content - Delete word forward using Ctrl+Delete or delete word backwards
using Ctrl+Backspace.

• Tags - To insert a tag from the source segment to the target segment, hold the Ctrl
key, and then select the source tag. You can delete the entire tag pair or only one of
the tags (either the end or the start tag). When you delete one tag, the other tag
pair is automatically deleted.

• Formatting and case - Select a TU, go to the Home tab, and in the Formatting
group use the Show Whitespaces and Change Case menus. You can also change
case by selecting a segment and pressing Shift+F3.

• Characters or symbols - Select a TU, go to the Home tab, and use the options in the
Insert Characters group.

• Whitespaces - Go to Home, and in the Formatting group select Show Whitespaces.
6. When finished with all your changes, check your segments for this symbol . These

segments were edited or their status was changed, but these segments are not
confirmed yet. To confirm a segment, select it and then select Confirm changes. If you
do not select Confirm changes, the segments are not updated in the TM with the latest
changes.

7. Close the TM Maintenance Editor.
8. In the [translation memory name] dialog, click Save.

Concurrent editing
Multiple users are able to open and edit the same translation memory (TM) at the same
time, for maintenance purposes.

The rules for concurrent editing are:

• When more users open the same TM and position themselves on the same segment, a
tooltip informs them that the segment is being edited by another user.

• A segment can be edited by one user at a time, namely by the user who positions
themselves on that segment first. The rest of the users who subsequently select that
segment cannot edit it, because the segment is locked for editing. All edit actions in the
ribbon and the
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Fields panel are disabled for locked segments.

Editing translation unit fields
Translation units have metadata attached to them. There are 2 types of segment fields:
system fields (generated automatically by the application) and custom fields (defined by you)
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair fir which you want to

perform maintenance operations.
5. Select a segment, select , and:

• Consult the system fields: Created by, Created on, Last modified by, Last modified
on, Last used by, Last used on, Usage count. System fields are not editable.

• Edit the custom fields if necessary. You can have custom fields of the following
types:

• Text (maximum 255 characters)

• Multiple text (multiple text strings)

• Number

• Data and time

• Single picklist (choose one option out of all the available options)

• Multiple picklist (choose several options out of all the available options)
6. When finished with all your changes, check your segments for this symbol . These

segments were edited or their status was changed, but these segments are not
confirmed yet. To confirm a segment, select it and then select Confirm changes. If you
do not select Confirm changes, the segments are not updated in the TM with the latest
changes.

7. Close the TM Maintenance Editor.
8. In the [translation memory name] dialog, click Save.

Enabling Overwrite mode
When Overwrite mode is enabled, you can write text over existing text.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair fir which you want to

perform maintenance operations.
5. In the TM Maintenance Editor, press the Insert key and make your changes.
6. When finished with all your changes, check your segments for this symbol . These

segments were edited or their status was changed, but these segments are not
confirmed yet. To confirm a segment, select it and then select Confirm changes. If you

4Working with Translation Memories in the cloud

47Translation Memory Management



do not select Confirm changes, the segments are not updated in the TM with the latest
changes.

7. Close the TM Maintenance Editor.
8. In the [translation memory name] dialog, click Save.

Batch editing translation units
When you batch edit TUs you delete their tags or field values, change their field values, or
replace text. You cannot revert any batch edit action.

Before you can batch edit TUs, you must filter them. Only filtered segments can be batch
edited. See “Applying filters”  on page 0

For this example we're going to edit a German TM so let's create a filter.

If you don't have a cloud TM with the "de-DE" language pair you can import or save to cloud
one of the sample TMs that ship with Studio.

..\Documents\Studio 2024\Projects\Samples\SampleProject\TMs\English-German.sdltm
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair for which you want to

perform maintenance operations.
5. Go to Filters > Advanced and click the filter icon next to the Advanced filter condition

textbox.
6. Set the filter settings as shown below:

7. You can copy and paste this character into the textbox: "ß", then click Apply.
You should now see the segments filtered.
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8. In the Batch Actions wizard:
a. Under Choose Operation, choose Edit translation units.
b. Under Operation Details expand the Find and replace text section:

• In the Find what texbox paste the "ß" character.

• In the Replace with textbox enter "ss".

• Set the Search in parameter to Target.

c. Under Confirmation, clear the Reset current filter for Translation Memory check
box, and then select Confirm.

All occurrences of "ß" should now be replaced by "ss".
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Changing translation statuses
You can change the translation unit status by choosing one of the available values.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair fir which you want to

perform maintenance operations.
5. In the TM Maintenance Editor, select a segment, go to the Home tab, expand the

Status list and select a value: Not Translated, Draft, Translated, Translation Approved,
Translation Rejected, Sign-off Rejected, Signed Off.

Translation statuses
A source segment and a target segment unit form a translation unit (TU). TUs are displayed
on one row in the Online Editor. Each TU has a translation status depending on how
complete the translation is.

TUs can have one of the following translation statuses at a time:

• Not Translated ( ) - This target segment has not been translated or edited yet.

• Draft ( ) - This target segment may have been changed, but it is not yet considered
fully translated, or a translation memory (TM) match was applied to the segment but the
segment text has since been edited.

• Translated( ) - This target segment translation has been confirmed.

• Locked ( ) - This target segment translation is locked.

• Translation Rejected( ) - This target segment translation was rejected by the
reviewer.
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• Translation Approved ( ) - This target segment translation was approved by the
reviewer.

• Sign-off Rejected ( ) - This translation has been rejected during the sign-off process.

• Signed Off ( ) - The translation has been approved and signed-off. This translation is
ready to be released to the customer.

Deleting translation units
You can delete TUs if they are no longer necessary.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair for which you want to

perform maintenance operations.
5. Select a TU, go to the Home tab, and select Delete. TU deletion is not reversible and it is

immediately reflected in the TU count.

Batch deleting translation units
You can batch delete the TUs you no longer need. You cannot revert any batch delete action.

Before you can batch delete segments TUs, you must filter them. Only filtered segments
can be batch deleted. Therefore, create a filter and apply it before you follow the procedure
below.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. In the TM Maintenance Editor, go to the Home view, and in the Tasks group select

Batch Actions.
4. In the Batch Actions wizard:

a. Select Choose Operation, and then Delete translation units.
b. Select Operation Details and consult the message informing you that all the filtered

segments will be deleted after you confirm the operation.
c. Select Confirmation, clear the Reset current filter for Translation Memory check

box, and then select Confirm.

Filters
TM Maintenance filters help you search through your source and target segments, and
perform batch operations on segments.
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Creating filters
You can create filters to quickly identify all the segments which have the same metadata in
common.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair for which you want to

perform maintenance operations.
5. From the right-hand side pane, select .
6. Toggle the filter on if not already so.
7. Expand the Advanced menu.
8. Enter a filter name.
9. Expand the Advanced filter condition pane, select your criteria (segment status,

creation date and so on), and if several criteria apply, link these via operators.

10. Click Save.
11. Expand the right-hand side menu of the Saved filters field, and click Create.
12. Click Apply.

Editing filters
You can edit your filter details if no longer necessary.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair for which you want to

perform maintenance operations.
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5. From the right-hand side pane, select .
6. Toggle the filter on if not already so.
7. Expand the Advanced menu.
8. Under Saved filters, select a filter.
9. Expand the Advanced filter condition pane and modify the criteria.
10. Expand the right-hand side menu of the Saved filters field, and click Update.
11. Click Apply.

Deleting filters
You can delete filters if no longer necessary.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair for which you want to

perform maintenance operations.
5. From the right-hand side pane, select .
6. Toggle the filter on if not already so.
7. Expand the Advanced menu.
8. Under Saved filters, select a filter you want to delete.
9. Expand the right-hand side menu of the Saved filters field, and click Delete.

Deleting translation units via filters
Once you create a filter for the quick retrieval of a set of translation units, you can batch
delete these translation units.
1. Go to the Resources view.
2. Select the Translation Memories tab.
3. Select the check box corresponding to the TM you want to maintain.
4. Expand the TM Maintenance menu and select the language pair for which you want to

perform maintenance operations.
5. From the right-hand side pane, select .
6. Toggle the filter on if not already so.
7. Expand the Advanced menu.
8. Enter a filter name.
9. Expand the Advanced filter condition pane, select your criteria (segment status,

creation date and so on), and if several criteria apply, link these via operators. Click
Save.

10. Expand the right-hand side menu of the Saved filters field, and click Create.
11. From the ribbon, select Batch Actions.
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12. On the Choose Operation page, select Delete translation units.
13. On the Operation Details page, read about the effects of the batch delete you are

about to perform.
14. Select Confirmation, and then Confirm.
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5

End of Quick Start Guide



Now you know how to create and manage your translation memories in Trados Studio. For
additional information about translation memories in Trados Studio, see:

• Trados Studio Online Help - This provides additional information about translation
memories. You can access this help system by selecting Help Topics from the Online
Help group on the Help tab in the Trados Studio application.

• Trados Studio 2024 Migration Guide - This provides information about converting or
upgrading existing translation resources from SDL Trados 2007 and SDLX so that you can
work with them in Trados Studio.

• Trados GroupShare Installation Guide - This provides information about upgrading server
-based translation memories from SDL TM Server 2009 to SDL TM Server 2020.

• Trados GroupShare Help - This provides information on how to manage your server
-based translation memories in TM Server. You can access this help system by clicking
Help from the GroupShare application.
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License type:
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License details: “https://github.com/dotnet/corefx/blob/master/LICENSE.TXT”  on page 0

System.Runtime.CompilerServices.Unsafe
Version: 6.0.0

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.
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License type: MIT

License details: “https://github.com/dotnet/runtime/blob/master/LICENSE.TXT”  on page
0

System.Text.Encoding.CodePages
Version: 8.0.0

Vendor: Microsoft, aspnet, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Text.Encodings.Web
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Text.Json
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Threading.RateLimiting
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0

System.Threading.Channels
Version: 8.0.0

Vendor: Microsoft, dotnetframework

Copyright: © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/runtime/blob/v8.0.0/LICENSE.TXT”  on page 0
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System.Threading.Tasks.Extensions
Version: 4.5.4

Vendor: Microsoft

Copyright: Copyright © Microsoft Corporation. All rights reserved.

License type: MIT

License details: “https://github.com/dotnet/corefx/blob/master/LICENSE.TXT”  on page 0

YamlDotNet
Version: 8.1.0

Vendor: Antoine Aubry

Copyright: Copyright (c) 2008, 2009, 2010, 2011, 2012, 2013, 2014 Antoine Aubry and
contributors

License type: MIT

License details: “https://github.com/aaubry/YamlDotNet/blob/v8.1.0/LICENSE.txt”  on
page 0

ZstdSharp.Port
Version: 0.7.4

Vendor: oleg-st

Copyright: Copyright Oleg Stepanischev 2024

License type: MIT

License details: “https://github.com/oleg-st/ZstdSharp/blob/0.7.4/LICENSE”  on page 0
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